Ubuntu

pidgin not showing up

Reported by RedMirtle on 2011-10-22
338
This bug affects 113 people
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Undecided
Unassigned
pidgin (Unity Linux)
New
Undecided
Unassigned

Bug Description

Pidgin is just not visible. It shows on the message menu, it whos on Unity and it even shows on the global Menu, it's just... not on screen. This problem is happening often but i don't know as a result of what, since it works upon launching, but may not upon relaunching. After Pidgin put together the information for thisre port, the window shoed up again but disappeared from Unity, although currently working.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: pidgin 1:2.10.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Sat Oct 22 17:03:25 2011
ExecutablePath: /usr/bin/pidgin
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
SourcePackage: pidgin
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (6 days ago)

RedMirtle (faceman8) wrote :
Dmitry Kann (yktooo) wrote :

RedMirte, is it not a duplicate of bug 879960?

RedMirtle (faceman8) wrote :

I'm not actually sure. The behaviour is very similar, but Pidgin is not listed in the startup Applications and this happens after oppening it at any given point, not necessairly after opening it on startup.

Niether have i tried that right button click solution or tested the eprsistence of the bug upon restart, I will as soon as the bug repeats itself and get back to you :D

Either way, I think it's the same Bug, just mine is a little more extended (happening also when not in the startup Applications).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pidgin (Ubuntu):
status: New → Confirmed
Mossroy (mossroy) wrote :

I still have this bug on Ubuntu 12.04 beta 2.
It does not happen every time, though.

It's a big issue as it makes Pidgin unusable with this Ubuntu version...

In the duplicate https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/879960 , the importance had been set to High : why is it still "Undecided" in this one?

Dmitry Kann (yktooo) wrote :

I've found a simple solution on this: I've quit using Pidgin. Unity in general has a whole bunch of similar issues with windows not showing up, launcher context menu not showing etc. No one seems to care.

I'm using Gtalk on the webpage now. Works perfectly.

Mossroy (mossroy) wrote :

It did not happen to me any more the last times I launched Pidgin.
Do you still face this issue?

RedMirtle (faceman8) wrote :

No, I'd say it's stopped happening in LTS (12.04), i think it stopped happening in Narwhal. So... pretty cool! :D

Sparhawk (sparhawkthesecond) wrote :

Strange, because for me it only *started* after I upgraded from 11.10 to 12.04. Having said that, I haven't come across it in the last few days, so perhaps an upgrade fixed it.

mhz (marc-heinz) wrote :

Still 100% reproducible after an upgrade to 12.04.

Workaround:
1) Launch pidgin and close it immediately (eg. using right-click on its icon in the unity bar)
2) Launch it again, and cycle through window (ctrl-tab) to reach the buddy list.

A do that for a year now... Pidgin is used by a *lot* of people and this bug is as old as Unity itself, a fix would be great.

Mossroy (mossroy) wrote :

I confirm I still face the issue. I had just been lucky for a few days...

Still getting this in 12.04, has been present from at least 11.10..

I have the same issue as described by previous posters, in fact I use the same work-around as marc-heinz. This bug must have come from a long negligence since it truly is as old as Unity itself.
It occured to me when using 11.04 (clean install), 11.10 (both clean and upgrade) and 12.04 (clean install).
It's hard to provide a log of some kind since this is more of a GUI defect.

Sergio Benjamim (sergio-br2) wrote :

I'm using Ubuntu 12.04 with Unity 5.12.0, and it still happens.

Sergio Benjamim (sergio-br2) wrote :

It seems to be a problem with Popsups Libnotify plugin, take a look in this video:

http://www.youtube.com/watch?v=987uuyJTDxw&feature=youtu.be

dmarks (markstedt) wrote :

In addition to Pidgin, this happens with Update Manager for me once in a while as well.

12.04

Ali Najafi (alinajafi) wrote :

Whenever I shut down, I make sure window of Pidgin is open; In the next startup, Pidgin won’t have any problem!

Alfredo Matos (alfmatos) wrote :

The fact that this bug is such a big problem, affects all Ubuntu pidgin users, and still isn't fixed, after almost a year, completely baffles me. No, I will not change to empathy because it's simply daunting from a functional perspective. If that was the intended underlying motivation to not fix this, it's just plain awkward.

Since at the pace of things, this isn't going away any time soon (yey for quality control), I accept suggestions on a non-QT instant messenger that has a decent behavior on Ubuntu. Or perhaps some indication as to whether this happens on other distros, since a fresh change might be the way to go.

Sergio Benjamim (sergio-br2) wrote :

I reported this problem at https://developer.pidgin.im/ticket/15384 , Pidgin Official site. Let's see if something happens.

Ali Najafi (alinajafi) wrote :

Hi guys,
Do you still have the problem with Pidgin? I think I’ve found the solution; it’s simple:

Go to Pidgin Preferences -> Interface -> System Tray Icon, and choose ALWAYS for “Show system tray icon”.
Now if you can set Pidgin as a startup application, there will be no problem with opening the buddy list. In this situation, I recommend you to UNCHECK “Use status from last exit at startup” in Preferences -> Status/Idle and preferably set it to offline.

(If you don’t set Pidgin as a startup application, you should click on the icon once to start the application – which shows a triangle beside the icon in the messaging menu – and click again to open the window.)

I tried more than 5 times on 12.04 and the window is shown every time without any problem.

TomasHnyk (sup) wrote :

No, I have the settings as yo udescribed and sometimes (not very often) Pidgin still does not show up.

piratemurray (mez-pahlan) wrote :

I don't get this any more with 12.10 and the latest Pidgin in the repository.

The workaround mentioned in #20 is well known but means you have a redundant entry in the tray. Workaround, but not a fix.

Anyway, can't say I've noticed this in 12.10.

Eamonn Comerford (eamonn-r-c) wrote :

I still run into this issue almost every time I start 12.04. My workaround is to quit and relaunch Pidgin.

With all due respect, Ali Najafi, your proposal is not a solution, it's a workaround. Launching Pidgin on startup or showing a system tray icon are not considered desirable behaviors by many users. If they work for you, that's fantastic, but this workaround ignores the primary use case:

1) Turn on computer
2) Log in
3) Click Pidgin icon on Dash (or launch from Application Lens)

Any solution must cover the primary use case.

Ali Najafi (alinajafi) wrote :

You’re absolutely right about solution and workaround. Account this for my weak English.

Moreover, I must add about “system tray icon” that no icons will be displayed in 12.04 menu, but you won’t need to quit it. I myself did’t set it as startup, just since I’ve enabled tray icon which changed nothing in appearance, I don’t need to quit anymore; however sometimes I need to relaunch (without quitting).

This is great for me, because I lost some offline messages when quitting to relaunch.

Silvan (silvan-0) wrote :

Almost 2 years now, and no fix.

This problem still exists in Ubuntu 12.04.

Chase Sandmann (csandmann) wrote :

This seriously needs to be fixed ASAP. It is ridiculous the hoops that users of this software have to go through in order for it to function basically. If a user logs in and is sent a message, clicking on the tray icon only flips the message and there is no way to even access the Tools > Preferences menu. Only the conversation menu is accessible which only has Conversation and Options (neither of which supplies any help in opening the Buddy Menu)

Manuel J. Garrido (mgarrido) wrote :

Still happening in xubuntu 13.04.

Works fine when libnotify plugin is disabled.

Ketil Malde (ketil-ii) wrote :

Pidgin has been working for me (with the env variable workaround for MS servers), but now suddenly it fails to display a window. Debug (-d) and strace seem to indicate the program is otherwise working. When I Ctrl-C, the window appears to flicker on screen before terminating. While it is running, the window also shows up in xlsclients. I'm not using Unity (just a simple XMonad setup), so if this is indeed the same problem, it's proabably not Unity-related. Ubuntu 13.04.

Ketil Malde (ketil-ii) wrote :

Removing .purple/prefs.xml "fixed" it for me.

Ketil Malde (ketil-ii) wrote :

Or, just changing the

<prefs name='blist'> [...]
<pref name='list_visible' type='bool' value='0'/>

from '0' to '1' also brought the window back. I guess this is a Gnomism, Pidgin isn't expected to work without some supporting things running alongside it, panels or whatever, so it starts up "minimized", with no way of opening the running applicaiton without a panel or dock or something.

TomasHnyk (sup) wrote :

Ketil Malde: I already had then et to 1, I gues yours was a different issue then.

Heiko Selber (heiko-selber) wrote :

I have the same problem (pidgin 2.10.3 on mint 13 with unity and backport). I can also make pidgin show up when I remove .purple/prefs.xml.

But then, the window frame (title bar with minimize, maximize and close icons, drag corners) behaves as if it weren't there.

E.g. I can't drag the pidgin window because when I click the frame, the click goes through to the window below it, or to the desktop if there is no such window.

But I can use the contents of the pidgin window as usual.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.