relocation error with latest wxwidgets2.8

Bug #610975 reported by Thomas Bechtold on 2010-07-28
392
This bug affects 104 people
Affects Status Importance Assigned to Milestone
CodeLite
Invalid
Undecided
Unassigned
KiCad
Undecided
Unassigned
Ubuntu Server papercuts
High
Unassigned
codelite (Ubuntu)
High
Unassigned
Lucid
High
Unassigned
Maverick
High
Unassigned
filezilla (Ubuntu)
Undecided
Unassigned
Lucid
High
Adrien Cunin
Maverick
Undecided
Unassigned
kicad (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
High
Unassigned
pgadmin3 (Debian)
Fix Released
Unknown
pgadmin3 (Ubuntu)
High
Unassigned
Lucid
High
Unassigned
Maverick
High
Unassigned
poedit (Ubuntu)
High
Unassigned
Lucid
High
Unassigned
Maverick
High
Unassigned
wxwidgets2.8 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: pgadmin3

I tried to start pgadmin3 with this result:

$ pgadmin3
pgadmin3: relocation error: pgadmin3: symbol _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference

Binary package hint: codelite

I try to run codelite from terminal i get this error:

codelite: relocation error: /usr/lib/codelite/libpluginu.so: symbol _ZN13wxAuiNotebook7SetFontERK6wxFont, version WXU_2.8 not defined in file libwx_gtk2u_aui-2.8.so.0 with link time reference

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: pgadmin3 1.10.3-1
ProcVersionSignature: Ubuntu 2.6.35-11.16-generic 2.6.35-rc5
Uname: Linux 2.6.35-11-generic i686
Architecture: i386
Date: Wed Jul 28 19:33:06 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427.1)
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: pgadmin3

Thomas Bechtold (toabctl) wrote :
perriman (chuchiperriman) wrote :

Looking for a solution, I find:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=540060

As you can see, recompiling the pgadmin against the new wxgtk version should work.

It is very important solve this bug!!!!!

Sapsan (sergiy-bagnak) wrote :

I have the same problem.
# uname -a
Linux 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:20:59 UTC 2010 x86_64 GNU/Linux
It's happened after yesterday system updates.

Clint Byrum (clint-fewbar) wrote :

Marking the bug as high importance and triaged, as it appears we just need a noop rebuild.

Changed in pgadmin3 (Ubuntu):
importance: Undecided → High
status: New → Triaged
frankvielma (frankvielma) wrote :

I have a similar problem

# uname -a
Linux crux 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:22:14 UTC 2010 i686 GNU/Linux

pgadmin3: relocation error: pgadmin3: symbol _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference

There is a problem with the libwxbase2.8-0 version (2.8.11.0-1ubuntu1) because before the last system updates (with the 2.8.10.1-0ubuntu1) I don't had this problem with pgadmin3.

Clint Byrum (clint-fewbar) wrote :

Release managers, please disregard my nomination for lucid, I thought it was lucid because the "Intallation Media" portion of the original bug report said Lucid.

Can any of the reporters/verifiers of the bug confirm that this is on maverick, and post the exact version of libwxbase2.8-0 that you have?

Thanks.

yurx cherio (cherio) wrote :

I am running Lucid 64bit and I just got this message. I remember a week ago (or so) I could still run pgadmin3.
The message is exactly the same as in the original post.

$ uname -a
Linux jiggins 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:20:59 UTC 2010 x86_64 GNU/Linux

Kamil Murawski (k-murawski-1) wrote :

Hi everyone!

I have the same issue and I really want to get rid of it. I also remember that the day before yesterday I could still run pgadmin3. Does anyone know how to manually downgrade the libwxbase ??

$uname -a
Linux kmurawski 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:22:14 UTC 2010 i686 GNU/Linux

meux (reinhard-moser) wrote :

Hi,

  i have same problems on lucid i386. I now recompiled package and pgadmin3 works.

apt-get source pgadmin3
sudo apt-get install debhelper libpq-dev libwxgtk2.8-dev libxml2-dev libxslt1-dev autotools-dev
cd pgadmin3-1.10.2
dpkg-buildpackage
sudo dpkg -i ../pgadmin3_1.10.2-1_i386.deb

and pgadmin3 works again.

Cheers

Kamil Murawski (k-murawski-1) wrote :

Hi,

Perfect solution. Thank you meux :)

Yuriy Padlyak (gneeot) wrote :

Above solution works, but I also had to sudo apt-get install devscripts.
thanks!

Garrett Blits (garrett) wrote :

Solution from meux worked for me (thanks meux) however I had to install devscripts just as Yuriy Padlyak mentioned.

Since the rebuild from source seems to work for people could someone please rebuild the lucid version of pgadmin3 in lucid-proposed since afaict it is the libwxgtk2.8-0 from there which causes this problem on lucid.

apt-cache policy libwxgtk2.8-0
libwxgtk2.8-0:
  Installed: 2.8.10.1-0ubuntu1.1
  Candidate: 2.8.10.1-0ubuntu1.1
  Version table:
 *** 2.8.10.1-0ubuntu1.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid-proposed/universe Packages
        100 /var/lib/dpkg/status
     2.8.10.1-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid/universe Packages

tags: added: lucid
alfabravoteam (alfabravoteam) wrote :

As long as the rebuilded pgAdmin makes its way to the updates, the instructions given by meux does work considering that one must have the devscripts package installed. Other than that, the sequence is pretty straightforward. Thanks for the advice!

Yuval (yuvilio) wrote :

The dpkg-buildpackage instructions worked for me as well. Two additional things to note for us non-build-masters in training:

- To make sure I had all the packages to build pgadmin per the dpkg-buildpackage instructions above i ran this command which should be more catchall than guessing which packages are needed to build it:

sudo apt-get build-dep pgadmin3

-your resulting pgadmin package(s) may be different. Simply list them first and then run the dpkg -i command:

ls ../pgadmin*deb

Thierry Carrez (ttx) on 2010-08-03
Changed in server-papercuts:
importance: Undecided → High
milestone: none → maverick-beta
status: New → Confirmed
Andrew Cowie (afcowie) on 2010-08-03
Changed in pgadmin3 (Ubuntu Lucid):
status: New → Confirmed
Andrew Cowie (afcowie) wrote :

Definitely hitting people with lucid-proposed; the upgrade of libwxgtk2.8-0 broke ABI, causing [in this case] pgadmin3 being unable to resolve symbols.

While it's unfortunate that this has occured, I doubt wxwidgets is going to get rolled back, so if someone could kick off a rebuild pgadmin3 (and say make it depend on the newer libwxgtk2.8-0 2.8.10.1-0ubuntu1.1, giving us apgadmin > 1.10.2-1) and upload it to lucid-proposed, it sounds like we'd be sorted.

AfC

Abhijit Navale (abhi-navale) wrote :

Thank you.

durammx (durammx) wrote :

Hi! I done the rebuild and it worked. Also attach the rebuild debs. Can someone upload to the server.

olinews (olinews) wrote :

Thank you so much durammx for your package. It solved my problem i a second.

quiricada (raraland) wrote :

same here, thanks durammx.

ggiardina (ggiardina) wrote :

Also for me there is a problem for this tool. I do the steps signed above (thanks to the others users, I can't figure it out):
sudo apt-get source pgadmin3
sudo apt-get install debhelper libpq-dev libwxgtk2.8-dev libxml2-dev libxslt1-dev autotools-dev
sudo apt-get install devscripts
cd pgadmin3-1.10.2
dpkg-buildpackage

It worked for me, and there is the package for the 64 bit version.

I hope that this can help.
Regards.

ggiardina (ggiardina) wrote :

Sorry, seems that the upload does not work.
Try again.

ggiardina (ggiardina) wrote :

I try for the last time, then, if this doesn't work, I quit.

tags: added: patch
Clint Byrum (clint-fewbar) wrote :

ggiardina, those are all the components of the source package, not binaries.

I've gone ahead and setup a PPA for this, though I don't have a lucid system that was affected by the problem so its hard for me to test.

https://launchpad.net/~clint-fewbar/+archive/pgadmin3

I'd suggest people use those binaries, (i386 and amd64 available) rather than the unsigned binaries attached to the bug.

I'll go ahead and rattle some developers' cages a bit and see if we can't get them to upload a noop rebuild.

Micah Gersten (micahg) wrote :

Marking high since the app is reported unusable in Lucid as well.

Changed in pgadmin3 (Ubuntu Lucid):
importance: Undecided → High
status: Confirmed → Triaged
citylights (shaun-methodmaker) wrote :

I also get the following error when running pgadmin3
pgadmin3: relocation error: pgadmin3: symbol _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvmS2_, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference

Sergios (linuxmangr) wrote :

After this command pgadmin3 work .
sudo apt-get build-dep pgadmin3 && sudo apt-get -b source pgadmin3 && sudo dpkg -i pgadmin3 deb package

Yorirou (yorirou) wrote :

I am using Lucid, and I accidentally discovered that the wxwidgets2.8 package is installed from a PPA. I removed the PPA and downgraded the package to the original lucid version and now pgadmin3 works.

Guillermo_Cristancho (sw2band) wrote :

A solution [1] for codelite (build from source):

Make sure the following are installed on your Ubuntu:

Code: Select all
    sudo apt-get install build-essential
    sudo apt-get install libwxgtk2.8-dev
    sudo apt-get install libgtk2.0-dev
    sudo apt-get install subversion

Next, checkout the sources:

Code: Select all
    svn co https://codelite.svn.sourceforge.net/svnroot/codelite/trunk codelite

Followed by:

    cd codelite/
    ./configure && make
    sudo make install

And works...

[1 ]http://www.codelite.org/forum/viewtopic.php?f=3&t=986&p=4420&hilit=libwx#p4420

summary: - Can not start pgadmin3
+ Can not start pgadmin3 and codelite
description: updated

I'm closing the codelite project task and opened an Ubuntu codelite one instead.

Changed in codelite:
status: New → Invalid
Changed in codelite (Ubuntu Lucid):
importance: Undecided → High
status: New → Triaged
Changed in codelite (Ubuntu Maverick):
importance: Undecided → High
status: New → Triaged
Changed in poedit (Ubuntu Lucid):
importance: Undecided → High
status: New → Triaged
Changed in poedit (Ubuntu Maverick):
importance: Undecided → High
status: New → Triaged
tags: added: regression-proposed
summary: - Can not start pgadmin3 and codelite
+ relocation error with latest wxwidgets2.8

Fixed in maverick

Changed in codelite (Ubuntu Maverick):
status: Triaged → Fix Released

pgadmin3 relocation error fixed in maverick

Changed in pgadmin3 (Ubuntu Maverick):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package poedit - 1.4.2-5build1

---------------
poedit (1.4.2-5build1) maverick; urgency=low

  * No-change upload to rebuild against current wxwidgets2.8, which
    involuntarily changed ABI due to a binutils change (see Debian #540060
    for details). (LP: #610975)
 -- Martin Pitt <email address hidden> Tue, 24 Aug 2010 15:02:24 +0200

Changed in poedit (Ubuntu Maverick):
status: Triaged → Fix Released

Accepted poedit into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in poedit (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted codelite into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in codelite (Ubuntu Lucid):
status: Triaged → Fix Committed
Changed in pgadmin3 (Ubuntu Lucid):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Accepted pgadmin3 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Thierry Carrez (ttx) on 2010-08-24
Changed in server-papercuts:
status: Confirmed → Fix Released
Carlos Briosso (photon) wrote :

Changed in pgadmin3 (Ubuntu Lucid):
summary: - Can not update from lucid-proposed
                 + Depends: pgadmin3-data (= 1.10.2-1build1) but 1.10.2-1 is to be installed

You should wait until -data packages reach the repository.

SRU verification for Lucid:
I have reproduced the problem with poedit 1.4.2-5 in lucid and have verified that the version of poedit 1.4.2-5build0.1 in -proposed fixes the issue.

SRU verification for Lucid:
I have reproduced the problem with pgadmin3 1.10.2-1 in lucid and have verified that the version of pgadmin3 1.10.2-1build1 in -proposed (downloaded from LP) fixes the issue.

SRU verification for Lucid:
I have reproduced the problem with codelite 2.5.2.4031~dfsg-1 in lucid and have verified that the version of codelite 2.5.2.4031~dfsg-1build1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pgadmin3 - 1.10.2-1build1

---------------
pgadmin3 (1.10.2-1build1) lucid-proposed; urgency=low

  * No-change upload to rebuild against current wxwidgets2.8, which
    involuntarily changed ABI due to a binutils change (see Debian #540060
    for details). (LP: #610975)
 -- Martin Pitt <email address hidden> Tue, 24 Aug 2010 15:08:53 +0200

Changed in pgadmin3 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package codelite - 2.5.2.4031~dfsg-1build1

---------------
codelite (2.5.2.4031~dfsg-1build1) lucid-proposed; urgency=low

  * No-change upload to rebuild against current wxwidgets2.8, which
    involuntarily changed ABI due to a binutils change (see Debian #540060
    for details). (LP: #610975)
 -- Martin Pitt <email address hidden> Tue, 24 Aug 2010 15:10:22 +0200

Changed in codelite (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package poedit - 1.4.2-5build0.1

---------------
poedit (1.4.2-5build0.1) lucid-proposed; urgency=low

  * No-change upload to rebuild against current wxwidgets2.8, which
    involuntarily changed ABI due to a binutils change (see Debian #540060
    for details). (LP: #610975)
 -- Martin Pitt <email address hidden> Tue, 24 Aug 2010 15:02:24 +0200

Changed in poedit (Ubuntu Lucid):
status: Fix Committed → Fix Released
Abhijit Navale (abhi-navale) wrote :

This worked for me for postgres.
http://ubuntuforums.org/showthread.php?t=1542391

Though i need that libgtk file for other softwares too so i ended up in reinstalling ubuntu.

Steve Langasek (vorlon) wrote :

From the description, I think this fix is as yet incomplete; the new, binary-incompatible wxwidgets2.8 package should also declare a Breaks: against the versions of the packages that are broken by this, so that pulling in the SRU of wxwidgets2.8 without (for whatever reason) also pulling in the other SRUs doesn't leave users with silently-broken applications.

Changed in wxwidgets2.8 (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Triaged
Steve Langasek (vorlon) on 2010-08-24
Changed in wxwidgets2.8 (Ubuntu Maverick):
importance: Undecided → Medium
status: New → Triaged
Changed in codeblocks (Ubuntu Maverick):
status: New → Fix Released
Changed in codeblocks (Ubuntu Lucid):
status: New → Invalid
Changed in codeblocks (Ubuntu Maverick):
status: Fix Released → Invalid
eval- (eval-) wrote :

When will opennx be fixed for the new version?

@eval, opennx is not part of the official ubuntu repository. You must ask to the maintainer of the package to rebuild it against the current version of wxwidget2.8 available in lucid. Thanks.

Ken Norris (ken-norris) wrote :

In Ubuntu lucid.
Using Synaptic to install the package pgadmin3 - 1.10.2-1build1 with/after install of postgresql generates the error message but is fixed with manual (using Synaptic) selection and installation of all libwxgtk2.8 bits and pieces.

Adrien Cunin (adri2000) on 2010-10-04
Changed in filezilla (Ubuntu Maverick):
status: New → Invalid
Changed in filezilla (Ubuntu Lucid):
assignee: nobody → Adrien Cunin (adri2000)
importance: Undecided → High
status: New → In Progress
Adrien Cunin (adri2000) wrote :

= SRU for filezilla =

In lucid, the impact this wxwidgets2.8 update has on filezilla is that opening a new tab now crashes the program.
(It doesn't seem to affect the maverick package at all.)

I've prepared a no-change rebuild which solves the problem, as for the other impacted packages.

TEST CASE:
Open the program, and hit Ctrl+T or open a new tab through the File menu. If it doesn't crash, then it's ok.

I'm uploading to lucid-proposed right now.

Thanks,

Accepted filezilla into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in filezilla (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: removed: verification-done
Adrien Cunin (adri2000) wrote :

(Oops, I realized afterwards I didn't use the correct ubuntu1.1 versioning, but well it doesn't create any versioning conflict in this case.)

Anyway, I've just tested on an i386 computer and can confirm it works now (opening a tab doesn't crash the program anymore).

tags: added: verification-done
removed: verification-needed
Jonathan Mercier-Ganady (jmgr) wrote :

I tested Adrien's package here and it fixed the crash problem. Nice work !

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package filezilla - 3.3.1-1ubuntu2

---------------
filezilla (3.3.1-1ubuntu2) lucid-proposed; urgency=low

  * Rebuild against latest wxwidgets2.8 which introduced some unwanted ABI
    change, fixes crash when opening a new tab (LP: #610975)
 -- Adrien Cunin <email address hidden> Mon, 04 Oct 2010 22:19:21 +0200

Changed in filezilla (Ubuntu Lucid):
status: Fix Committed → Fix Released
Stefano Rivera (stefanor) wrote :

Uploaded to maverick-proposed. Can be pocket-copied up to natty.

Changed in kicad (Ubuntu Maverick):
importance: Undecided → High
status: New → Fix Committed
Changed in kicad (Ubuntu Lucid):
status: New → Invalid
Martin Pitt (pitti) wrote :

Accepted kicad into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
David Planella (dpm) wrote :

The latest kicad upload fixes the problem for me. Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kicad - 0.0.20100314-1build0.1

---------------
kicad (0.0.20100314-1build0.1) maverick-proposed; urgency=low

  * No-change upload to rebuild against current wxwidgets2.8, which
    involuntarily changed ABI due to a binutils change (see Debian #540060 for
    details). (LP: #610975)
 -- Stefano Rivera <email address hidden> Sun, 17 Oct 2010 12:59:49 +0200

Changed in kicad (Ubuntu Maverick):
status: Fix Committed → Fix Released
Daniel T Chen (crimsun) wrote :

Resolved in current development branch already, marking completed

Changed in kicad (Ubuntu):
status: New → Fix Released
Changed in pgadmin3 (Debian):
status: Unknown → Fix Released
Changed in kicad:
status: New → Invalid
Adolfo Jayme (fitojb) on 2013-07-06
no longer affects: codeblocks (Ubuntu)
no longer affects: codeblocks (Ubuntu Lucid)
no longer affects: codeblocks (Ubuntu Maverick)
no longer affects: wxwidgets2.8 (Ubuntu Lucid)
no longer affects: wxwidgets2.8 (Ubuntu Maverick)
PeterPall (peterpall) wrote :

This bug - or at least a bug with the same symptoms has appeared on current ubuntu saucy again. See https://bugs.launchpad.net/wxwidgets/+bug/1226035 for details.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.