package initramfs-tools 0.98.8ubuntu2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #741832 reported by Brian Murray on 2011-03-24
100
This bug affects 12 people
Affects Status Importance Assigned to Milestone
pango1.0 (Ubuntu)
High
Steve Langasek
Natty
High
Steve Langasek
plymouth (Ubuntu)
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: initramfs-tools

This happened during an upgrade.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: initramfs-tools 0.98.8ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-7.38-server 2.6.38
Uname: Linux 2.6.38-7-server x86_64
Architecture: amd64
Date: Wed Mar 23 16:19:07 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
SourcePackage: initramfs-tools
Title: package initramfs-tools 0.98.8ubuntu2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to natty on 2011-03-09 (15 days ago)

Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :

From DpkgTerminalLog:

update-initramfs: Generating /boot/initrd.img-2.6.38-7-server
cryptsetup: WARNING: failed to detect canonical device of /dev/sdb2
cp: cannot stat `/usr/lib/pango/1.6.0/module-files.d/libpango1.0-0.modules': No such file or directory
cp: cannot stat `/usr/lib/pango/1.6.0/modules/pango-basic-fc.so': No such file or directory
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-2.6.38-7-server
dpkg: error processing initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 1

Steve Langasek (vorlon) wrote :

Caused by having the new pango1.0 installed, but not the new plymouth. I think we want pango1.0 to declare Breaks: plymouth (<< $fixedver) to ensure smooth upgrades.

affects: initramfs-tools (Ubuntu) → pango1.0 (Ubuntu)
Changed in pango1.0 (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-1
status: New → Confirmed
comrobo (j-alfarop) wrote :

i copied pango folder from "/usr/lib/i386-linux-gnu" to "/usr/lib/" and no more errors.

Steve Langasek (vorlon) wrote :

Yes, but that's a wrong fix. You should upgrade the plymouth package to the current version instead.

Changed in pango1.0 (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pango1.0 - 1.28.3-4ubuntu4

---------------
pango1.0 (1.28.3-4ubuntu4) natty; urgency=low

  * Declare a Breaks: on the pre-multiarch version of plymouth, so users
    don't get initramfs generation errors on upgrade from maverick.
    LP: #741832.
 -- Steve Langasek <email address hidden> Fri, 25 Mar 2011 12:51:37 -0700

Changed in pango1.0 (Ubuntu Natty):
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

The original bug is now fixed, but a converse bug is present that if plymouth is upgraded before pango, plymouth is looking for these modules in the *new* path and fails for the same reason.

I think in this direction a more subtle fix is needed than a Breaks, since there are cases where plymouth can be configured not to use the graphical themes /at all/, in which case plymouth-label may not be installed and there may be nothing else that ensures the presence of pango on the system.

Changed in plymouth (Ubuntu Natty):
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-1
status: New → Triaged
Colin Watson (cjwatson) on 2011-03-28
Changed in plymouth (Ubuntu Natty):
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.2-2ubuntu21

---------------
plymouth (0.8.2-2ubuntu21) natty; urgency=low

  * Tolerate pre-multiarch versions of pango (LP: #741832).
 -- Colin Watson <email address hidden> Mon, 28 Mar 2011 11:07:14 +0100

Changed in plymouth (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers