Ubuntu

Comment 4 for bug 879938

You can use "pkcon refresh" to refresh the cache. If you execute this
in a terminal, do you get the same error messages AND does Apper still
complain about an unrefreshed cache? (If yes, this is a issue in the
aptcc backend)

2011/11/18 Sergio Callegari <email address hidden>:
> apt-get gives an error message, but that's all... then everything works
> just fine.
>
> Apper gives the error message and then keeps complaining that the
> package cache was not refreshed.
>
> As an aside: apper is really too picky about the package cache not being refreshed.
> If I refresh the cache using apt-get, apper should realize that the cache was in fact refreshed. However to have apper see a cache refresh, you need to refresh the cache from apper.  Why cannot it just look at cache files access times?
>
> --
> You received this bug notification because you are subscribed to apper
> in Ubuntu.
> https://bugs.launchpad.net/bugs/879938
>
> Title:
>  Things that should be mere warnings block apper
>
> Status in “apper” package in Ubuntu:
>  New
>
> Bug description:
>  If you have something wrong in your package list, apper stops with an
>  error. This makes upper keep saying that the package list was not
>  refreshed.
>
>  To reproduce
>
>  1) Put in your /etc/apt/sources.list.d something that is still not up there.
>  In my case, I have a ppa repo for which nothing has been published yet for oneiric. But I like to have the ppa there, so as soon as packages are ported to oneiric I can realize it.
>  2) Try refreshing the package list with synaptic and apper.
>
>  For synaptic, there are just some warnings, which is perfectly fine.
>  Apper exits with an error.
>
>  BTW, if the package list is refreshed with synaptic, there is no
>  reason why apper should say it has not been refreshed for a long time.
>  Particularly because in spite of this, apper can correctly detect if
>  there are packages to be updated.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.10
>  Package: apper 0.7.0~20111008-0ubuntu1
>  ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
>  Uname: Linux 3.0.0-12-generic x86_64
>  ApportVersion: 1.23-0ubuntu3
>  Architecture: amd64
>  Date: Sat Oct 22 16:40:00 2011
>  InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
>  SourcePackage: apper
>  UpgradeStatus: Upgraded to oneiric on 2011-10-16 (6 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/apper/+bug/879938/+subscriptions
>