Things that should be mere warnings block apper

Bug #879938 reported by Sergio Callegari on 2011-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
packagekit (Ubuntu)
Low
Matthias Klumpp
Nominated for Quantal by Matthias Klumpp

Bug Description

If you have something wrong in your package list, apper stops with an error. This makes upper keep saying that the package list was not refreshed.

To reproduce

1) Put in your /etc/apt/sources.list.d something that is still not up there.
In my case, I have a ppa repo for which nothing has been published yet for oneiric. But I like to have the ppa there, so as soon as packages are ported to oneiric I can realize it.
2) Try refreshing the package list with synaptic and apper.

For synaptic, there are just some warnings, which is perfectly fine. Apper exits with an error.

BTW, if the package list is refreshed with synaptic, there is no reason why apper should say it has not been refreshed for a long time. Particularly because in spite of this, apper can correctly detect if there are packages to be updated.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: apper 0.7.0~20111008-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Sat Oct 22 16:40:00 2011
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
SourcePackage: apper
UpgradeStatus: Upgraded to oneiric on 2011-10-16 (6 days ago)

Sergio Callegari (callegar) wrote :
Daniel Nicoletti (dantti) wrote :

Right, well the aptcc backend says the refresh cache failed if any error appears, if you do apt-get update what messages do you see at the end?
It's unlikely the problem is with the repo being empty but something is giving you an error, if it was an warning this should not be a problem.

Sergio Callegari (callegar) wrote :

apt-get gives an error message, but that's all... then everything works just fine.

Apper gives the error message and then keeps complaining that the package cache was not refreshed.

As an aside: apper is really too picky about the package cache not being refreshed.
If I refresh the cache using apt-get, apper should realize that the cache was in fact refreshed. However to have apper see a cache refresh, you need to refresh the cache from apper. Why cannot it just look at cache files access times?

You can use "pkcon refresh" to refresh the cache. If you execute this
in a terminal, do you get the same error messages AND does Apper still
complain about an unrefreshed cache? (If yes, this is a issue in the
aptcc backend)

2011/11/18 Sergio Callegari <email address hidden>:
> apt-get gives an error message, but that's all... then everything works
> just fine.
>
> Apper gives the error message and then keeps complaining that the
> package cache was not refreshed.
>
> As an aside: apper is really too picky about the package cache not being refreshed.
> If I refresh the cache using apt-get, apper should realize that the cache was in fact refreshed. However to have apper see a cache refresh, you need to refresh the cache from apper.  Why cannot it just look at cache files access times?
>
> --
> You received this bug notification because you are subscribed to apper
> in Ubuntu.
> https://bugs.launchpad.net/bugs/879938
>
> Title:
>  Things that should be mere warnings block apper
>
> Status in “apper” package in Ubuntu:
>  New
>
> Bug description:
>  If you have something wrong in your package list, apper stops with an
>  error. This makes upper keep saying that the package list was not
>  refreshed.
>
>  To reproduce
>
>  1) Put in your /etc/apt/sources.list.d something that is still not up there.
>  In my case, I have a ppa repo for which nothing has been published yet for oneiric. But I like to have the ppa there, so as soon as packages are ported to oneiric I can realize it.
>  2) Try refreshing the package list with synaptic and apper.
>
>  For synaptic, there are just some warnings, which is perfectly fine.
>  Apper exits with an error.
>
>  BTW, if the package list is refreshed with synaptic, there is no
>  reason why apper should say it has not been refreshed for a long time.
>  Particularly because in spite of this, apper can correctly detect if
>  there are packages to be updated.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.10
>  Package: apper 0.7.0~20111008-0ubuntu1
>  ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
>  Uname: Linux 3.0.0-12-generic x86_64
>  ApportVersion: 1.23-0ubuntu3
>  Architecture: amd64
>  Date: Sat Oct 22 16:40:00 2011
>  InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
>  SourcePackage: apper
>  UpgradeStatus: Upgraded to oneiric on 2011-10-16 (6 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/apper/+bug/879938/+subscriptions
>

Daniel Nicoletti (dantti) wrote :

Please what is the error apt-get shows, it does not matter if you run apt-get, or refresh the cache with apper, the backend sees an error an understand everything failed where maybe just one mirror failed to refresh.
I`m not convinced this is the best way but it is the way PackageKit threats error messages, if you can provide which error is being issued at the end of apt-get we can think of what is best for this use case.
Best.

Sergio Callegari (callegar) wrote :

Thank you for the explanation.

Still I do not understand why:

1) If i apt-get update, package kit does not see that the package info got updated and I need to also run the pkcon refresh tool manually. Wouldn't package kit be better off by looking at package file access times? If some package lists got rewritten in the last hour, package kit should not think that the package cache had not been refreshed for, say, 11 days, should it?

2) Why should package kit think that everything had failed if it sees files having been accessed for write later than the time it thinks is the latest access time?

Matthias Klumpp (ximion) wrote :

I'll take a look at this. Maybe we can identify these messages and demote them to warnings/messages.

Changed in apper (Ubuntu):
assignee: nobody → Matthias Klumpp (ximion)
status: New → In Progress
Matthias Klumpp (ximion) on 2012-03-14
Changed in apper (Ubuntu):
importance: Undecided → Low
Matthias Klumpp (ximion) wrote :

Behaviour will be changed with the next version of PackageKit (PK 0.7.4)

affects: apper (Ubuntu) → packagekit (Ubuntu)
Changed in packagekit (Ubuntu):
status: In Progress → Fix Committed
Matthias Klumpp (ximion) on 2012-04-23
Changed in packagekit (Ubuntu):
milestone: none → later
Matthias Klumpp (ximion) on 2012-04-24
Changed in packagekit (Ubuntu):
milestone: later → none
Matthias Klumpp (ximion) on 2012-04-29
Changed in packagekit (Ubuntu):
milestone: none → quantal-alpha-1
Matthias Klumpp (ximion) on 2012-05-02
Changed in packagekit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers