random apps crash to strcmp () after ORBit call

Bug #67361 reported by arjanhs on 2006-10-21
414
Affects Status Importance Assigned to Milestone
orbit2
Fix Released
Critical
orbit2 (Ubuntu)
High
Ubuntu Desktop Bugs
Edgy
Undecided
Unassigned

Bug Description

Orbit has a race condition on shutdown causing crashes in applications using it.

Edit: No more crash files are needed. Thanks

arjanhs (arjan-advance) wrote :
arjanhs (arjan-advance) wrote :
Sebastien Bacher (seb128) wrote :

Marking as confirmed, that seems to be a frequent crasher on edgy. The crash seems to happen when stopping the computer, people notice it on startup with the apport notification

Changed in gaim:
importance: Undecided → High
status: Unconfirmed → Confirmed
Siegfried Gevatter (rainct) wrote :
Olivier Anh (twen) wrote :

This happens with gaim and skype 1.3 for me.....

Neil (nnkx00) wrote :

Another crash on startup dump.

Some days ago I started bug report #70473, I don't know if this is the same.

Kevin Kubasik (kkubasik) wrote :
m.abouzaid (m-abouzaid) wrote :

Gaim crashes

sonny (sonnycrack) wrote :

Another report of Gaim crashing at startup:

ShinjiLeery (shinjileery) wrote :
archi02 (jo-chibois) wrote :

Another crash after startup

and another, look ones above

My backtrace

Hoagie (andreasabu) wrote :

I can confirm this crash, Gaim crashed twice up till now.

Valentin Rocher (bishiboosh) wrote :

Same thing here

Alex Maguran (amaguran) wrote :

First time

Jens Einar Vaskinn (vaskinn) wrote :

Crashes every strart up.

Melchior (m-tsp) wrote :

Another crash

dunno if you need yet another crash report, but here is mine.

might be useful for launchpad to indicate that crash data is no longer needed for a given bug.

Tiziano Sartori (crackedboy) wrote :
Sebastien Bacher (seb128) wrote :

We probably have enough crash files for that bug you can stop adding new ones to it

That bug lists different crashes, better to open a new bug if you are not sure you are facing the same problem than the bug described on a page

Saquib (saquib-h) wrote :

GAIM crashed for me as well... running with Beryl on XGL on Edgy!

logan (liam-liamjdavison) wrote :

crashes for me when i log on to a hotmail.co.uk account, but it is ok when i log on to a hotmail.com account.

Sebastien Bacher (seb128) wrote :

Could people read the bug before commenting? Previous comments state that we have enough crash file for that bug and that there is no need to keep attaching your files to that page

Nicholas Kourtzis (kourtzis) wrote :

Same happened to me just now...

AdON (d-launchpad) wrote :

another dump.
happens quite regularly. after reboot I got the bomb :)

Valentin Rocher (bishiboosh) wrote :

Hey guys, just read the messages above ? "No more crash files".

Sebastien Bacher (seb128) wrote :

Look like an ORBit problem rather than a gaim one

I think it is easy to reproduce.

Steps(from a clean gaim)
1) Delete you ./gaim directory
2) Open gaim an add a yahoo account. This should work fine and can connect to yahoo servers.
3) Add any bogus irc account. Click on Ok to accept the account. You should notice that it is trying to connect. Mine does not connect because I am behind a corporate firewall.
4) While it is trying to connect to an IRC server delete the account. Should be able to see the crash here.

Sebastien Bacher (seb128) wrote :

The steps described are probably for a different crasher

Paweł (paff) wrote :

I'm not sure, if it's the same problem here, but my gaim show me information about crash at startup, but tray icons is available all the time, and gaim is working while showing this message,

Changed in orbit:
assignee: nobody → desktop-bugs
viyyer (viyyer) wrote :

restarted from the menu and on starting gnome . I get this error

Sebastien Bacher (seb128) wrote :

there is no patch available at the moment and the bug can be annoying but is not really important since the application just crash when being closed which makes no difference to the user

Changed in orbit2:
status: Unconfirmed → Rejected
Changed in orbit2:
status: Unknown → Unconfirmed
Sergio Uribe (sergiouribe) wrote :

This happen very randomly when I log out and the log in. I think maybe is a bug with the gnome-panel, since it happen during the load of the panel. Anyway, here is my bug info

Paul Ivanov (pivanov) wrote :

same team as the above

Sebastien Bacher (seb128) wrote :

Paul, thank you for your interest for that bug. If you look at the page before sending though you would notice that there is already plently of crash files attached, no need of a new one

description: updated
description: updated
description: updated
Sebastien Bacher (seb128) wrote :

no recent feisty duplicate, dropping the milestone

Ivlev Kirill (webster-spb) wrote :

i confirm this bug in feisty...

Sebastien Bacher (seb128) wrote :

no recent duplicate, marking fixed, feel free to reopen if you get the bug again on gutsy

Changed in orbit2:
status: Confirmed → Fix Released
Changed in orbit2:
status: New → Fix Released
Changed in orbit2:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.