Add missing OFED packages for Ubuntu 14.04.3

Bug #1414818 reported by bugproxy on 2015-01-26
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dapl (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
ibutils (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
Vivid
Undecided
Unassigned
infiniband-diags (Debian)
Fix Released
Unknown
infiniband-diags (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
mstflint (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
Vivid
Undecided
Unassigned
opensm (Debian)
Fix Released
Unknown
opensm (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
perftest (Debian)
Fix Released
Unknown
perftest (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
Vivid
Undecided
Unassigned
rds-tools (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[ SRU Justification ]
These SRUs enable building a number of packages on arm64, ppc64el, and (sometimes) armhf where they weren't previously built.

[ Regression Potential ]
Other than one isolated arm64 porting patch, none of these uploads touch code at all, so the regression potential is pretty much zero.

[ Test Case ]
Check to see if the packages built. If they have testsuites, see that they passed, if not, smoketest a few commands on the command line and make sure they run.

[ Original Report ]
This feature is to track the inclusion of some packages that we requested for Ubuntu 14.10 for OFED that are not present in Ubuntu 14.04.2. The list is
perftest
infiniband-diags
opensm
dapl
dapl2-utils
libdapl2
rds-tools
mstflint
ibutils

bugproxy (bugproxy) on 2015-01-26
tags: added: architecture-ppc64le bugnameltc-120796 severity-high targetmilestone-inin1410
Luciano Chavez (lnx1138) on 2015-01-26
Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1414818/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Michael Hohnbaum (hohnbaum) wrote :

This request has arrived too late for 14.04.02. Will put it on the queue for 14.04.03

Steve Langasek (vorlon) wrote :

Hi Luciano,

To get this set of packages into 14.04 as SRUs, we will need more information for each package:

 - the specific version of the software component that you are requesting inclusion of
 - the specific way in which the versions currently in 14.04 don't meet your needs

We can then evaluate each package for SRU appropriateness.

The best way forward is for you to open a separate bug report for each of these packages, so that we can keep the SRU information for each package clearly separated.

------- Comment From <email address hidden> 2015-02-12 02:10 EDT-------
Re-posting reply from Carol Soto:

Some of those packages made it to Ubuntu 14.10, we can use those in Ubuntu 14.04.2?

bugproxy (bugproxy) on 2015-04-28
tags: added: targetmilestone-inin14043
removed: targetmilestone-inin1410

Rephrasing Carol. The version of the packages are the same as the same packages in 14.10.

Steve Langasek (vorlon) wrote :

What's missing is:

 - the specific way in which the versions currently in 14.04 don't meet your needs

Uplift to a new upstream version of a package during the development cycle, as was done for 14.10, is straightforward. Introducing new upstream versions of packages into a 14.04 point release, as you are asking for here, requires specific rationale under the stable release update process, owing to the risk of introducing a regression in a stable release that will affect other use cases for the software.

------- Comment From <email address hidden> 2015-05-27 14:08 EDT-------
Hi
14.04 stream does not have these packages. We were able to make them available for the Ubuntu 14.10 stream.
Mentioned the 14.10 packages because at least the code in those packages were able to run ok.

Ah, thanks for clarifying. I had overlooked that these packages were not built for ppc64el in 14.04.

Changed in ubuntu:
assignee: Taco Screen team (taco-screen-team) → Adam Conrad (adconrad)
importance: Undecided → High
Adam Conrad (adconrad) on 2015-06-15
Changed in ubuntu:
milestone: none → ubuntu-14.04.3
Breno Leitão (breno-leitao) wrote :

Hi Adam, any ETA for having these packages availabe in LTS?

Adam Conrad (adconrad) on 2015-07-09
affects: ubuntu → opensm (Ubuntu)
Adam Conrad (adconrad) on 2015-07-10
summary: - Add missing OFED packages for Ubuntu 14.04.2
+ Add missing OFED packages for Ubuntu 14.04.3
Changed in rds-tools (Ubuntu):
status: New → Invalid
Changed in rds-tools (Ubuntu Utopic):
status: New → Invalid
Changed in rds-tools (Ubuntu Vivid):
status: New → Invalid
Changed in dapl (Ubuntu Trusty):
status: New → Invalid
Changed in dapl (Ubuntu Utopic):
status: New → Invalid
Adam Conrad (adconrad) wrote :

dapl didn't exist in 14.04 or 14.10, only in 15.04 and beyond, so if there's a need/desire for that one, we'd have to backport the vivid version to trusty and utopic.

------- Comment From <email address hidden> 2015-07-14 14:21 EDT-------
yes probably for 14.04.3 will be great. Let us know if you need help.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2015-07-14 19:17 EDT-------
For the other packages like perftest, opensm, etc do you know when we will have it available for 14.0.4.3?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mstflint - 3.7.0+1.18.gcdb9f80-3.1ubuntu1

---------------
mstflint (3.7.0+1.18.gcdb9f80-3.1ubuntu1) wily; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)
  * Update config.{sub,guess} correctly with dh_autotools-dev

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 08:28:32 -0600

Changed in mstflint (Ubuntu):
status: New → Fix Released
Adam Conrad (adconrad) wrote :

dapl already exists on vivid and wily for all !arm architectures, and porting it to armhf/arm64 would require porting their horrific locking primitives, which I have no intention of doing for this SRU, so marking the dapl tasks invalid.

Changed in dapl (Ubuntu):
status: New → Invalid
Changed in dapl (Ubuntu Vivid):
status: New → Invalid
Changed in opensm (Ubuntu):
status: New → Invalid
Changed in opensm (Ubuntu Utopic):
status: New → Invalid
Changed in opensm (Ubuntu Vivid):
status: New → Invalid
Adam Conrad (adconrad) on 2015-07-15
description: updated
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2015-07-15 16:16 EDT-------
what about the other packages?
I have ubuntu 14..04.3 and I still can not get perftest, and the other packages

uname -a
Linux powerio-le13 3.19.0-23-generic #24~14.04.1-Ubuntu SMP Wed Jul 8 11:17:19 UTC 2015 ppc64le ppc64le ppc64le GNU/Linux
root@powerio-le13:~# apt-get install perftest
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package perftest
root@powerio-le13:~# apt-get install mstflint
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package mstflint

Hello bugproxy, or anyone else affected,

Accepted ibutils into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ibutils/1.5.7-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ibutils (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Changed in ibutils (Ubuntu Vivid):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted ibutils into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ibutils/1.5.7-3ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ibutils (Ubuntu Utopic):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted ibutils into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ibutils/1.5.7-3ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mstflint (Ubuntu Trusty):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted mstflint into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mstflint/1.4-OFED-1.4.2-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mstflint (Ubuntu Utopic):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted mstflint into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mstflint/3.7.0-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mstflint (Ubuntu Vivid):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted mstflint into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mstflint/3.7.0+1.18.gcdb9f80-3ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in opensm (Ubuntu Trusty):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted opensm into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/opensm/3.3.15-2ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted perftest into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/perftest/1.2-OFED-1.4.2-2ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in perftest (Ubuntu Trusty):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted perftest into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/perftest/2.3+0.12.gcb5b746-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in perftest (Ubuntu Utopic):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted rds-tools into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rds-tools/1.4.1-OFED-1.4.2-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in rds-tools (Ubuntu Trusty):
status: New → Fix Committed
Changed in perftest (Ubuntu Vivid):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibutils - 1.5.7-3ubuntu2

---------------
ibutils (1.5.7-3ubuntu2) vivid; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 12:35:19 -0600

Changed in ibutils (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package perftest - 2.3+0.12.gcb5b746-1ubuntu1

---------------
perftest (2.3+0.12.gcb5b746-1ubuntu1) utopic; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818, #1470160)

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 08:08:55 -0600

Changed in perftest (Ubuntu):
status: New → Fix Released

------- Comment From <email address hidden> 2015-07-16 12:08 EDT-------
*** Bug 127671 has been marked as a duplicate of this bug. ***

bugproxy (bugproxy) wrote :
Download full text (9.1 KiB)

------- Comment From <email address hidden> 2015-07-16 16:07 EDT-------
here is the verification
Perftest:
root@powerio-le13:~# uname -a
Linux powerio-le13 3.19.0-23-generic #24~14.04.1-Ubuntu SMP Wed Jul 8 11:17:19 UTC 2015 ppc64le ppc64le ppc64le GNU/Linux
root@powerio-le13:~# dpkg --list | grep perftest
ii perftest 1.2-OFED-1.4.2-2ubuntu1 ppc64el Infiniband verbs performance tests
root@powerio-le13:~# ib_send_bw 10.10.10.10
------------------------------------------------------------------
Send BW Test
Connection type : RC
Inline data is used up to 400 bytes message
local address: LID 0x02, QPN 0x002d, PSN 0x20dbd6
remote address: LID 0x02, QPN 0x002c, PSN 0xc3a9bf
Mtu : 2048
------------------------------------------------------------------
#bytes #iterations BW peak[MB/sec] BW average[MB/sec]
Warning: measured timestamp frequency 511.325 differs from nominal 3458 MHz
65536 1000 10695.39 10600.86
------------------------------------------------------------------

So perftest package is available and running.

Opensm
Having issues to find it
apt-get install opensm/trusty-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Release 'trusty-proposed' for 'opensm' was not found

ibutils
root@powerio-le13:~# dpkg --list | grep ibutils
ii ibutils 1.5.7-1ubuntu2 ppc64el InfiniBand network utilities
root@powerio-le13:~# ibdiagnet
Loading IBDIAGNET from: /usr/lib/powerpc64le-linux-gnu/ibdiagnet1.5.7
-W- Topology file is not specified.
Reports regarding cluster links will use direct routes.
Loading IBDM from: /usr/lib/powerpc64le-linux-gnu/ibdm1.5.7
-W- A few ports of local device are up.
Since port-num was not specified (-p option), port 1 of device 1 will be
used as the local port.
-I- Discovering ... 2 nodes (0 Switches & 2 CA-s) discovered.

-I---------------------------------------------------
-I- Bad Guids/LIDs Info
-I---------------------------------------------------
-I- No bad Guids were found

-I---------------------------------------------------
-I- Links With Logical State = INIT
-I---------------------------------------------------
-I- No bad Links (with logical state = INIT) were found

-I---------------------------------------------------
-I- General Device Info
-I---------------------------------------------------

-I---------------------------------------------------
-I- PM Counters Info
-I---------------------------------------------------
-I- No illegal PM counters values were found

-I---------------------------------------------------
-I- Fabric Partitions Report (see ibdiagnet.pkey for a full hosts list)
-I---------------------------------------------------
-I- PKey:0x7fff Hosts:2 full:2 limited:0

-I---------------------------------------------------
-I- IPoIB Subnets Check
-I---------------------------------------------------
-I- Subnet: IPv4 PKey:0x7fff QKey:0x00000b1b MTU:2048Byte rate:10Gbps SL:0x00
-W- Suboptimal rate for group. Lowest member rate:40Gbps > group-rate:10Gbps

-I---------------------------------------------------
-I- Bad Links Inf...

Read more...

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2015-07-16 17:01 EDT-------
I double checked that with ubuntu 15.04 mstflint and in this one the tool works for the cards that it was failing for the mstflint for 14.04.3

uname
Linux powerio-le13 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:13 UTC 2015 ppc64le ppc64le ppc64le GNU/Linux
root@powerio-le13:~# dpkg --list | grep mstflint
ii mstflint 3.7.0+1.18.gcdb9f80-3ubuntu1 ppc64el Mellanox firmware burning application
root@powerio-le13:~# mstflint -d mlx4_0 q
Image type: FS2
FW Version: 2.34.5000
FW Release Date: 12.5.2015
Rom Info: type=FCODE version=0.0.130 devid=4099 proto=ETH
Device ID: 4099
Description: Node Port1 Port2 Sys image
GUIDs: ffffffffffffffff ffffffffffffffff ffffffffffffffff ffffffffffffffff
MACs: 0002c9b76090 0002c9b76091
VSD:
PSID: IBM1560110023

mstflint -d mlx5_0 q
Image type: FS3
FW Version: 10.100.6440
FW Release Date: 2.6.2015
Description: UID GuidsNumber Step
Base GUID1: f452140300273730 8 1
Base GUID2: f452140300273738 8 1
Base MAC1: 0000f45214273730 8 1
Base MAC2: 0000f45214273738 8 1
Image VSD:
Device VSD:
PSID: IBM1210111019
Orig PSID: IBM1210110019

Adam Conrad (adconrad) wrote :

Oops. I missed the opensm binary itself in the architecture changes, despite building the libraries. Fixing that now.

Adam Conrad (adconrad) wrote :

The mstflint bug with newer cards is bug #1470167, which is not covered by this SRU. So, if mstflint is built and working with older cards, that satisfies this bug, and you can move your newer cards complaint to the other bug. ;)

Adam Conrad (adconrad) wrote :

As for infiniband-diags, I completely missed that it was requested in the original bug report. Checking on that now.

Adam Conrad (adconrad) on 2015-07-17
Changed in infiniband-diags (Ubuntu):
status: New → Invalid
Changed in infiniband-diags (Ubuntu Utopic):
status: New → Invalid
Changed in infiniband-diags (Ubuntu Vivid):
status: New → Invalid
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2015-07-17 16:33 EDT-------
(In reply to comment #34)
Oops. I missed
> the opensm binary itself in the architecture changes, despite building the
> libraries. Fixing that now.

------- Comment From adconrad 2015-07-17
> 21:31:44 UTC-------
The mstflint bug with newer cards is bug #1470167, which
> is not covered by this SRU. So, if mstflint is built and working with older
> cards, that satisfies this bug, and you can move your newer cards complaint
> to the other bug. ;)

that is ok, Do you think you can add me to the cc list that bug #1470167? not sure how to do it from my end.

Hello bugproxy, or anyone else affected,

Accepted infiniband-diags into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/infiniband-diags/1.6.1-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in infiniband-diags (Ubuntu Trusty):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted infiniband-diags into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/infiniband-diags/1.6.1-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Adam Conrad (adconrad) wrote :

Steve missed spamming the bug, but he also accepted a new opensm version that should have the opensm binary package built this time.

As for subscribing you to other bugs, if you have a launchpad account and are logged in, you'll see a link on the right hand side of the bug page, which will take you to:

https://bugs.launchpad.net/ubuntu/+source/mstflint/+bug/1470167/+subscribe

------- Comment From <email address hidden> 2015-07-17 19:56 EDT-------
Infiniband-diags
dpkg --list | grep infiniband
ii infiniband-diags 1.6.1-1ubuntu2 ppc64el InfiniBand diagnostic programs
root@powerio-le13:~# ibstatus
Infiniband device 'mlx5_0' port 1 status:
default gid: fe80:0000:0000:0000:f452:1403:0027:3730
base lid: 0x1
sm lid: 0x1
state: 4: ACTIVE
phys state: 5: LinkUp
rate: 56 Gb/sec (4X FDR)
link_layer: InfiniBand

Infiniband device 'mlx5_0' port 2 status:
default gid: fe80:0000:0000:0000:f452:1403:0027:3738
base lid: 0x3
sm lid: 0x3
state: 4: ACTIVE
phys state: 5: LinkUp
rate: 56 Gb/sec (4X FDR)
link_layer: InfiniBand

working

opensm
dpkg --list | grep opensm
ii libopensm5 3.3.15-2ubuntu2 ppc64el InfiniBand subnet manager libraries
ii opensm 3.3.15-2ubuntu2 ppc64el InfiniBand subnet manager
root@powerio-le13:~# ps -ef | grep opensm
root 2893 1 0 14:24 ? 00:00:00 /usr/sbin/opensm -g 0xf452140300273730 -f /var/log/opensm.0xf452140300273730.log
root 2896 1 0 14:24 ? 00:00:00 /usr/sbin/opensm -g 0xf452140300273738 -f /var/log/opensm.0xf452140300273738.log
root 3054 1358 0 14:55 hvc0 00:00:00 grep --color=auto opensm
working

------- Comment From <email address hidden> 2015-07-17 19:56 EDT-------
(In reply to comment #39)
Steve missed
> spamming the bug, but he also accepted a new opensm version that should have
> the opensm binary package built this time.

As for subscribing you to other
> bugs, if you have a launchpad account and are logged in, you'll see a link
> on the right hand side of the bug page, which will take you to:
> https://bugs.launchpad.net/ubuntu/+source/mstflint/+bug/1470167/+subscribe

Thanks for the link I was able to subscribe.

bugproxy (bugproxy) on 2015-07-17
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibutils - 1.5.7-3ubuntu0.1

---------------
ibutils (1.5.7-3ubuntu0.1) utopic; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 09:46:57 -0600

Changed in ibutils (Ubuntu Utopic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ibutils has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mstflint - 3.7.0-1ubuntu2

---------------
mstflint (3.7.0-1ubuntu2) utopic; urgency=medium

  * debian/patches/uninitialized-variables-O3.patch: Steal patch
    from vivid/wily to fix build failure with -O3 on ppc64el.

mstflint (3.7.0-1ubuntu1) utopic; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)
  * Update config.{sub,guess} correctly with dh_autotools-dev

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 10:21:50 -0600

Changed in mstflint (Ubuntu Utopic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package perftest - 2.3+0.12.gcb5b746-1ubuntu1

---------------
perftest (2.3+0.12.gcb5b746-1ubuntu1) utopic; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818, #1470160)

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 08:08:55 -0600

Changed in perftest (Ubuntu Utopic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibutils - 1.5.7-3ubuntu2

---------------
ibutils (1.5.7-3ubuntu2) vivid; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 12:35:19 -0600

Changed in ibutils (Ubuntu Vivid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mstflint - 3.7.0+1.18.gcdb9f80-3ubuntu2

---------------
mstflint (3.7.0+1.18.gcdb9f80-3ubuntu2) vivid; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)
  * Update config.{sub,guess} correctly with dh_autotools-dev

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 08:35:34 -0600

Changed in mstflint (Ubuntu Vivid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package perftest - 2.3+0.12.gcb5b746-1ubuntu1

---------------
perftest (2.3+0.12.gcb5b746-1ubuntu1) utopic; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818, #1470160)

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 08:08:55 -0600

Changed in perftest (Ubuntu Vivid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibutils - 1.5.7-1ubuntu2

---------------
ibutils (1.5.7-1ubuntu2) trusty; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)

 -- Adam Conrad <email address hidden> Thu, 09 Jul 2015 08:11:11 -0600

Changed in ibutils (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mstflint - 1.4-OFED-1.4.2-1ubuntu1

---------------
mstflint (1.4-OFED-1.4.2-1ubuntu1) trusty; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)
  * Update config.{sub,guess} correctly with dh_autotools-dev

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 06:08:16 -0600

Changed in mstflint (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package perftest - 1.2-OFED-1.4.2-2ubuntu1

---------------
perftest (1.2-OFED-1.4.2-2ubuntu1) trusty; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)
  * Backport commit a589682e90aefaa2c9ab03a3e1426b0f7c1a5eb2
    from upstream to sort the build on aarch64 (LP: #1470160)

 -- Adam Conrad <email address hidden> Wed, 15 Jul 2015 07:12:32 -0600

Changed in perftest (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rds-tools - 1.4.1-OFED-1.4.2-1ubuntu1

---------------
rds-tools (1.4.1-OFED-1.4.2-1ubuntu1) trusty; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)

 -- Adam Conrad <email address hidden> Fri, 10 Jul 2015 09:26:49 -0600

Changed in rds-tools (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package opensm - 3.3.15-2ubuntu2

---------------
opensm (3.3.15-2ubuntu2) trusty; urgency=medium

  * Fix missing linux-any Architecture change for the opensm binary.

opensm (3.3.15-2ubuntu1) trusty; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)

 -- Adam Conrad <email address hidden> Fri, 17 Jul 2015 10:21:51 -0600

Changed in opensm (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package infiniband-diags - 1.6.1-1ubuntu2

---------------
infiniband-diags (1.6.1-1ubuntu2) trusty; urgency=medium

  * Cherry-pick --with-ibpath_override from utopic (LP: #1450896)

infiniband-diags (1.6.1-1ubuntu1) trusty; urgency=medium

  * Enable building on all Linux architectures (LP: #1414818)

 -- Adam Conrad <email address hidden> Fri, 17 Jul 2015 11:14:35 -0600

Changed in infiniband-diags (Ubuntu Trusty):
status: Fix Committed → Fix Released
Adam Conrad (adconrad) on 2015-07-30
Changed in dapl (Ubuntu Trusty):
status: Invalid → Confirmed
Adam Conrad (adconrad) on 2015-07-30
Changed in dapl (Ubuntu Trusty):
status: Confirmed → Invalid
Adam Conrad (adconrad) on 2015-07-31
Changed in opensm (Ubuntu):
milestone: ubuntu-14.04.3 → none
Changed in perftest (Debian):
status: Unknown → Fix Released
Changed in opensm (Debian):
status: Unknown → Fix Released
Changed in infiniband-diags (Debian):
status: Unknown → Fix Released
Changed in opensm (Ubuntu):
assignee: Adam Conrad (adconrad) → nobody
importance: High → Undecided
status: Invalid → Fix Released
no longer affects: opensm (Ubuntu Utopic)
no longer affects: opensm (Ubuntu Vivid)
Changed in rds-tools (Ubuntu Utopic):
status: Invalid → Won't Fix
no longer affects: rds-tools (Ubuntu Utopic)
no longer affects: rds-tools (Ubuntu Vivid)
Changed in infiniband-diags (Ubuntu):
status: Invalid → Fix Released
no longer affects: infiniband-diags (Ubuntu Utopic)
no longer affects: infiniband-diags (Ubuntu Vivid)
no longer affects: dapl (Ubuntu Vivid)
no longer affects: dapl (Ubuntu Utopic)
Changed in dapl (Ubuntu):
status: Invalid → Fix Released
Changed in dapl (Ubuntu Trusty):
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.