[MASTER] package openoffice.org-common 2.2.1-5ubuntu2 failed to install/upgrade: subprocess post-installation script returned error exit status 1

Bug #125400 reported by Pedro Fragoso on 2007-07-12
820
This bug affects 15 people
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
High
Chris Cheney
Nominated for Jaunty by andreadawn

Bug Description

Binary package hint: openoffice.org

Setting up openoffice.org-style-human (2.2.1-5ubuntu2) ...
Setting up openoffice.org-common (2.2.1-5ubuntu2) ...
Updating OpenOffice.org's dictionary list... done.
No theme index file in '/usr/share/icons/locolor'.
If you really want to create an icon cache here, use --ignore-theme-index.
dpkg: error processing openoffice.org-common (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of openoffice.org-java-common:
 openoffice.org-java-common depends on openoffice.org-common; however:
  Package openoffice.org-common is not configured yet.
dpkg: error processing openoffice.org-java-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openoffice.org-filter-mobiledev:
 openoffice.org-filter-mobiledev depends on openoffice.org-java-common (>> 2.2.0-4); however:
  Package openoffice.org-java-common is not configured yet.
dpkg: error processing openoffice.org-filter-mobiledev (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 openoffice.org-common
 openoffice.org-java-common
 openoffice.org-filter-mobiledev
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up openoffice.org-common (2.2.1-5ubuntu2) ...
Updating OpenOffice.org's dictionary list... done.
No theme index file in '/usr/share/icons/locolor'.
If you really want to create an icon cache here, use --ignore-theme-index.
dpkg: error processing openoffice.org-common (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of openoffice.org-java-common:
 openoffice.org-java-common depends on openoffice.org-common; however:
  Package openoffice.org-common is not configured yet.
dpkg: error processing openoffice.org-java-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openoffice.org-filter-mobiledev:
 openoffice.org-filter-mobiledev depends on openoffice.org-java-common (>> 2.2.0-4); however:
  Package openoffice.org-java-common is not configured yet.
dpkg: error processing openoffice.org-filter-mobiledev (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 openoffice.org-common
 openoffice.org-java-common
 openoffice.org-filter-mobiledev

ProblemType: Package
Architecture: i386
Date: Thu Jul 12 05:11:17 2007
ErrorMessage: subprocess post-installation script returned error exit status 1
Package: openoffice.org-common 2.2.1-5ubuntu2
SourcePackage: openoffice.org

Changed in openoffice.org:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → ccheney
Olivier Blanc (olivier-blanc) wrote :

I can confirm, I have the same problem here

Hein-PietervanBraam (hp) wrote :

I'm seeing the exact same problem. A temporal fix appears to be:

sudo touch /usr/share/icons/loclor/index.theme and then running apt-get -f install

This is a workaround and will probably result in loss of the locolor icons (but at least openoffice.org finishes installation)

Thanks for your reply, I will have a try.

2007/7/12, Hein-PietervanBraam <email address hidden>:
>
> I'm seeing the exact same problem. A temporal fix appears to be:
>
> sudo touch /usr/share/icons/loclor/index.theme and then running apt-get
> -f install
>
> This is a workaround and will probably result in loss of the locolor
> icons (but at least openoffice.org finishes installation)
>
> --
> [MASTER] package openoffice.org-common 2.2.1-5ubuntu2 failed to
> install/upgrade: subprocess post-installation script returned error exit
> status 1
> https://bugs.launchpad.net/bugs/125400
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

this is due to debhelper, openoffice will need a rebuild after the debhelper upload.

Changed in openoffice.org:
status: Confirmed → In Progress
Elpram (d-marple) wrote :

Actually it turns out the problem I had was with vmware-server. It was
trying to autoconfigure, and was trying to set the default device to eth0; I
only have an eth1 and a wlan0 so it was exiting, but kept hanging around
even though I configured it manually. This was fixed by edited the perl
script that runs and replacing all instances of eth0 by wlan0.

Thanks

On 7/12/07, Sarah Hobbs <email address hidden> wrote:
>
> this is due to debhelper, openoffice will need a rebuild after the
> debhelper upload.
>
> ** Changed in: openoffice.org (Ubuntu)
> Status: Confirmed => In Progress
>
> --
> [MASTER] package openoffice.org-common 2.2.1-5ubuntu2 failed to
> install/upgrade: subprocess post-installation script returned error exit
> status 1
> https://bugs.launchpad.net/bugs/125400
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Chris Cheney (ccheney) wrote :

openoffice.org (2.2.1-5ubuntu3) gutsy; urgency=low

  * Rebuild for debhelper gtk-update-icon-cache fix. Closes LP: #125400
  * debian/control:
    - Updated Build-Depends for debhelper (>= 5.0.51ubuntu3)
  * debian/rules:
    - convert dh_iconcache call to dh_icons
    - Updated Build-Depends for debhelper (>= 5.0.51ubuntu3)

 -- Chris Cheney <email address hidden> Thu, 12 Jul 2007 07:21:24 -0500

Changed in openoffice.org:
status: In Progress → Fix Released

setting back to fix committed, as people are *still* reporting this, instead of searching for the bug, and that openoffice has ftbfs on i386 at least.

Changed in openoffice.org:
status: Fix Released → Fix Committed
TuxFan (make) wrote :

"setting back to fix committed, as people are *still* reporting this, instead of searching for the bug, and that openoffice has ftbfs on i386 at least."

I'd guess quite a lot users are on i386, so the fix isn't released to us yet. :)

And there seems to be a new bug reporting system on (k)ubuntu which probably makes it (too?) easy to send new bug reports...

Shirish Agarwal (shirishag75) wrote :

yup, the fix isn't released on us yet :(

Kansei (clauretano) wrote :

ubuntu (gnome) gutsy gibbon makes it crazy, ridiculously easy to file a bug report. If an app crashed or fails to install or quits unexpectedly, an icon and accompanying annoying bubble that you have to click away appears in the notification error, alerting you to the crash and offering to automatically file the bug report (with appropriate logs and dumps) via that apport thing. It's a decidedly sharp double-edged sword, no?

Nirav Patel (nrpatel) wrote :

I copied over the theme.index from /usr/share/icons/hicolor and edited it to remove the entries that locolor didn't need, for a duct tape style fix. I'm using AMD64, btw.

Shirish Agarwal (shirishag75) wrote :

Kamesel, that's apport doing not gutsy. The whole idea is at some point to have a crash database but apport needs to be ready before that , right. If it becomes easier to put up bug-reports with stacktraces etc. its a good thing not bad. So many times I felt frustrated as a user as I could describe some issue but no way to tell what's happening. With apport & all those de-bugging tools working together, I can atleast do that.

Will Nowak (compbrain) wrote :

Just pulled a dist-upgrade from a downstream mirror and hit this. The touch index.theme and re-dist-upgrade fix works just dandy in the interim.

John Vivirito (gnomefreak) wrote :

Changed to fix released since OO.o updates have hit the archive. Thank you for the quick work

Changed in openoffice.org:
status: Fix Committed → Fix Released
jtlb (jt-lb) wrote :

yeepe, it's finally there, thank you very much for your work!!

Alex Bernea (alex-bernea) wrote :

I just updated to kernel 2.6.22.8 and i works fine now.

Thank you!

hanselang (lesnah) wrote :

Same issues.

Experienced during:
a) Live CD
1) Using Synaptics Packet Manager and uploaded Universe and Multiverse on Ubuntu mirror
2) Followed Howto: FakeRaid
3) Howto: FakeRaid included apt-get install ubuntu-standard
4) failed to download openoffice packages.

Baptiste Lafontaine (magnetik) wrote :

Same issue from an apt dist-upgrade from gutsy

To post a comment you must log in.