nvidia drivers broken by the recent libc update on i386 arch

Bug #929384 reported by Jeroen T. Vermeulen on 2012-02-09
334
This bug affects 37 people
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
High
Unassigned
glibc (Fedora)
Fix Released
High
nvidia-graphics-drivers (Ubuntu)
Medium
Alberto Milone

Bug Description

Automatically reported crash while logging in after boot, running Precise beta with continuous updates.

Login was also very slow, and Unity doesn't seem to have appeared: there is no launcher panel or menu bar, non-maximized windows have their menus inside the window, and maximized windows have their menu bar at the top but without Ubuntu logo on the left. There are no indicators, clock, and so on.

I tried this with both “Ubuntu” and “Ubuntu 2D” logins; same result. I think I'm normally on Unity 2D (from PPA) but my session option in the login screen does show “Ubuntu” by default.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: nux-tools 2.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-14.23-generic-pae 3.2.3
Uname: Linux 3.2.0-14-generic-pae i686
NonfreeKernelModules: wl
ApportVersion: 1.91-0ubuntu1
Architecture: i386
CheckboxSubmission: e56271c144a9c8f9f675c77e2e4edb56
CheckboxSystem: 7e42599bda39ea7ff8b528272b6ef52b
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,mousepoll,place,vpswitch,regex,animation,move,resize,gnomecompat,snap,grid,imgpng,unitymtgrabhandles,wall,session,workarounds,fade,resizeinfo,expo,scale,ezoom,unityshell]
CompositorRunning: None
Date: Thu Feb 9 09:24:43 2012
DistUpgraded: Log time: 2012-01-13 23:13:05.060884
DistroCodename: precise
DistroVariant: ubuntu
ExecutablePath: /usr/lib/nux/unity_support_test
GraphicsCard:
 NVIDIA Corporation C79 [GeForce 9400M] [10de:0863] (rev b1) (prog-if 00 [VGA controller])
   Subsystem: Apple Inc. Device [106b:00ba]
MachineType: Apple Inc. MacBookPro5,4
ProcCmdline: /usr/lib/nux/unity_support_test
ProcEnviron:
 LC_TIME=en_DK.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: root=UUID=e82d9a35-caee-4503-8594-8cd1eb26eec9 ro quiet splash
SegvAnalysis:
 Segfault happened at: 0xb761f216: mov (%eax),%esi
 PC (0xb761f216) ok
 source "(%eax)" (0xffffe0b4) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nux
Stacktrace:
 #0 0xb761f216 in ?? () from /usr/lib/nvidia-current/libGL.so.1
 No symbol table info available.
StacktraceTop: ?? () from /usr/lib/nvidia-current/libGL.so.1
ThreadStacktrace:
 .
 Thread 1 (LWP 2423):
 #0 0xb761f216 in ?? () from /usr/lib/nvidia-current/libGL.so.1
 No symbol table info available.
Title: unity_support_test crashed with SIGSEGV
UnitySupportTest: Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code -11:
UpgradeStatus: Upgraded to precise on 2012-01-14 (25 days ago)
UserGroups: adm admin audio cdrom dialout kvm libvirtd lpadmin netdev plugdev pulse pulse-access sambashare video
dmi.bios.date: 06/15/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP53.88Z.00AC.B03.0906151647
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F22587A1
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro5,4
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22587A1
dmi.modalias: dmi:bvnAppleInc.:bvrMBP53.88Z.00AC.B03.0906151647:bd06/15/09:svnAppleInc.:pnMacBookPro5,4:pvr1.0:rvnAppleInc.:rnMac-F22587A1:rvrMacBookPro5,4:cvnAppleInc.:ct10:cvrMac-F22587A1:
dmi.product.name: MacBookPro5,4
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu8
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 8.0~rc2-0ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.11.3-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901-1ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Jeroen T. Vermeulen (jtv) wrote :
description: updated

Stacktrace:
 #0 0xb761f216 in ?? ()
 No symbol table info available.
 Backtrace stopped: Not enough registers or memory available to unwind further
StacktraceTop: ?? ()
ThreadStacktrace:
 .
 Thread 1 (LWP 2423):
 #0 0xb761f216 in ?? ()
 No symbol table info available.
 Backtrace stopped: Not enough registers or memory available to unwind further

tags: added: apport-failed-retrace
tags: removed: need-i386-retrace
description: updated

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in nux (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in nux (Ubuntu):
importance: Undecided → High
Carlo Piana (carlo-piana) wrote :

I resolved all issues by removing the proprietary accelerated driver (Nvidia). Now everything is blazingly fast.

tags: added: rls-mgr-p-tracking
Jeroen T. Vermeulen (jtv) wrote :

In my case, I don't think I have that driver installed in the first place. I tried it once but uninstalled it in a hurry. The Hardware Drivers UI doesn't show it installed either. But confusingly, I do seem to have nvidia-common, nvidia-settings, and nvidia-current installed.

Fabien Tassin (fta) wrote :

Happens here too, when running the nvidia-current driver from precise. It also makes gnome-shell crash on startup.

this is caused by the eglibc update (2.13-24ubuntu4 -> 2.15~pre6-0ubuntu10). I reverted it, it's fine now.
(but reverting this libc6 is not easy as more packages are rebuild for it, leading to failing GLIBC_2.15 version checks everywhere)

Thanks Fabian, that's very useful informations

summary: - unity_support_test crashed with SIGSEGV
+ nvidia drivers broken by the recent libc update
affects: nux (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Canonical Foundations Team (canonical-foundations)
Changed in eglibc (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Steve Langasek (vorlon) on 2012-02-09
Changed in eglibc (Ubuntu):
assignee: nobody → Matthias Klose (doko)
dino99 (9d9) wrote :

I have precise i386 + nvidia 290.10 + 8500gt and logged as gnome-classic (compiz/unity completly purged) and does not have special issue as described here.

Jeroen T. Vermeulen (jtv) wrote :

I've had one or two libc upgrades after reporting this earlier today, but the problem persists.

Jeroen T. Vermeulen (jtv) wrote :

Not sure this needs repeating, but note that I'm having this problem without nvidia-graphics-driver installed.

Oleksii Zhukov (axe-z) wrote :

@dino99 this issue affects exactly unity panel :)

have nvidia, did upgrade as normal this morning, which I noticed *did* include libc6 and kernel. Been using it since, with no problems except handbrake's picture setting window won't open when run locally, which is probably unrelated.

rachel@twilight:~$ uname -a
Linux twilight 3.2.0-15-generic #24-Ubuntu SMP Tue Feb 7 22:32:19 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
rachel@twilight:~$ aptitude show nvidia-current | grep ^Version
Version: 290.10-0ubuntu2
rachel@twilight:~$ aptitude show libc6 | grep ^Version
Version: 2.15~pre6-0ubuntu10

Though I think I might have seen something like it in the past, but probably unrelated and just looks similar.

Robert Hooker (sarvatt) wrote :

I may be missing something here, but all of the affected systems I've looked at so far are i386, amd64 seems to be unaffected

Robert Hooker (sarvatt) on 2012-02-09
summary: - nvidia drivers broken by the recent libc update
+ nvidia drivers broken by the recent libc update on i386 arch
Bryce Harrington (bryce) wrote :

Jeroen, to clarify, you may not think you are using nvidia, but the bug report captured a crash that appears to happen in nvidia's GL code:

 Thread 1 (LWP 2423):
 #0 0xb761f216 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Your X logs just show -vesa loaded, which doesn't tell us much.

I think to work around the issue, you should do an apt-get purge of the nvidia files (you can leave nvidia-common installed, it's harmless.)

We anticipate having an updated -nvidia ready later today that will support this new libc.

Fabien Tassin (fta) wrote :

indeed, I see this on i386 too.
I tried to get a proper trace, but a/ the apport crash file always gives a 1 line unresolvable trace and 2/ it doesn't crash in gdb.

Registers:
 eax 0xffffe0b4 -8012
 ecx 0xd1b330 13742896
 edx 0x0 0
 ebx 0x0 0
 esp 0xbf96e1f0 0xbf96e1f0
 ebp 0x0 0x0
 esi 0xe27c08 14842888
 edi 0xbf96e23c -1080630724
 eip 0xc8d216 0xc8d216
 eflags 0x210246 [ PF ZF IF RF ID ]
 cs 0x73 115
 ss 0x7b 123
 ds 0x7b 123
 es 0x7b 123
 fs 0x0 0
 gs 0x33 51
SegvAnalysis:
 Segfault happened at: 0xc8d216: mov (%eax),%esi
 PC (0x00c8d216) ok
 source "(%eax)" (0xffffe0b4) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading unknown VMA
Stacktrace:
 #0 0x00c8d216 in ?? () from /usr/lib/nvidia-current/libGL.so.1
 No symbol table info available.

Robert Hooker (sarvatt) wrote :

Bryce: The newer nvidia driver discussed in IRC was a red herring and does not fix this issue. the reason we couldn't reproduce it on the newer nvidia driver was because it was on amd64, this is an eglibc bug limited to the i386 arch

Bryce Harrington (bryce) wrote :

@Robert, gotcha. bummer

bobhuber (bobhuber-tampabay) wrote :

Nope - Nvidia GT430 - AMD AthonII X4 - 64/bit

Colin Watson (cjwatson) wrote :

@bobhuber: Are you definitely running a 64-bit OS on that, though? See what 'dpkg --print-architecture' says.

@Fabien: I don't suppose valgrind produces anything useful?

Andreas Hasenack (ahasenack) wrote :

output of nvidia-bug-report.sh attached

Fabien Tassin (fta) wrote :

@colin: it doesn't crash in valgrind either, but shows 1 unfreed block in libGL.

$ valgrind --leak-check=full --show-reachable=yes /usr/lib/nux/unity_support_test
==22940== Memcheck, a memory error detector
==22940== Copyright (C) 2002-2011, and GNU GPL'd, by Julian Seward et al.
==22940== Using Valgrind-3.7.0 and LibVEX; rerun with -h for copyright info
==22940== Command: /usr/lib/nux/unity_support_test
==22940==
--22940-- WARNING: Serious error when reading debug info
--22940-- When reading debug info from /usr/lib/nvidia-current/libGL.so.290.10:
--22940-- Can't make sense of .got.plt section mapping
--22940-- WARNING: Serious error when reading debug info
--22940-- When reading debug info from /usr/lib/nvidia-current/libnvidia-glcore.so.290.10:
--22940-- Can't make sense of .got section mapping
==22940==
==22940== HEAP SUMMARY:
==22940== in use at exit: 32 bytes in 1 blocks
==22940== total heap usage: 42 allocs, 41 frees, 122,009 bytes allocated
==22940==
==22940== 32 bytes in 1 blocks are still reachable in loss record 1 of 1
==22940== at 0x402BE68: malloc (in /usr/lib/valgrind/vgpreload_memcheck-x86-linux.so)
==22940== by 0x42072DE: ??? (in /usr/lib/nvidia-current/libGL.so.290.10)
==22940== by 0xBED338E9: ???
==22940== by 0x454B5F44: ???
==22940==
==22940== LEAK SUMMARY:
==22940== definitely lost: 0 bytes in 0 blocks
==22940== indirectly lost: 0 bytes in 0 blocks
==22940== possibly lost: 0 bytes in 0 blocks
==22940== still reachable: 32 bytes in 1 blocks
==22940== suppressed: 0 bytes in 0 blocks
==22940==
==22940== For counts of detected and suppressed errors, rerun with: -v
==22940== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 0 from 0)

I definitely am:

rachel@twilight:~$ dpkg --print-architecture
amd64

Also, started to suspect something when I didn't even have any such package eglibc; but wasn't sure what that was about, hence trying to be sensible and reporting my libc6 version instead.

Colin Watson (cjwatson) wrote :

@Rachel: eglibc is the source package that builds several binary packages including libc6.

It looks like the linked Fedora bug may have the answer here: http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=0c95ab64

Chris (fabricator4) wrote :

Confirmed here - I just updated.
No Launcher, No top panel. Nvidia Settings crashed, Apport crashed. I think some of the crashes crashed.

Wheee! that was fun.

Bryce Harrington (bryce) wrote :

These packages appear to fix it:
  http://people.canonical.com/~doko/tmp/eglibc-2.15/i386/

Bryce Harrington (bryce) wrote :

Verified on nvidia hardware, as well as an intel box (with nvidia-current installed).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.15-0ubuntu2

---------------
eglibc (2.15-0ubuntu2) precise; urgency=low

  * Revert commit c5a0802a. LP: #929713.
  * Fix nvidia libgl crashes. LP: #929384.
 -- Matthias Klose <email address hidden> Thu, 09 Feb 2012 20:33:14 +0100

Changed in eglibc (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

according to the comments on the eglibc patch from one of the upstream authors, this is a workaround for what's really a bug in the nvidia driver. I don't know if we want to keep the nvidia-graphics-drivers task open, but that's certainly not anything foundations can fix, so unassigning from us.

Changed in nvidia-graphics-drivers (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → nobody
Robert Hooker (sarvatt) on 2012-02-09
Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
Robert Hooker (sarvatt) on 2012-02-09
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: High → Medium
status: Invalid → Triaged
Alberto Milone (albertomilone) wrote :

I'm subscribing Nvidia to the bug report.

@Daniel: any ideas on the issue?

Matthias Klose (doko) on 2012-02-09
Changed in eglibc (Ubuntu):
assignee: Matthias Klose (doko) → nobody
Jeroen T. Vermeulen (jtv) wrote :

Last night's updates seem to have solved the problem. That makes about 16 hours from first hitting the problem to a fixed system, all the way at the other end of the package pipeline. Thanks!

dino99 (9d9) wrote :

Only waiting for all the packages using libc6 to be rebuilt (and they are numerous) to take advantages of the fixes. (might fix some other sad effects here & there)

Andreas Hasenack (ahasenack) wrote :

Working fine here too.

I've had plenty of issues with my video/driver. There's still one with unity corruption. I never had the performance hit, but that's because I've been using the most recent drivers off of nVidia's site.

Colin Watson (cjwatson) wrote :

@dino99: Nothing should need to be rebuilt for this.

Mark Hannon (markhannon) wrote :

Have upgraded to latest glibc as mentioned above but still crash on an 11.10 32 bit system upgraded to precise. (laptop running 64 bit with same versions not affected).

Martin Pitt (pitti) on 2012-02-17
tags: removed: rls-mgr-p-tracking
Daniel Dadap (ddadap) wrote :

The next 295 driver version will contain a fix for this issue.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Fix Committed
assignee: Alberto Milone (albertomilone) → Daniel Dadap (ddadap)
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: Daniel Dadap (ddadap) → Alberto Milone (albertomilone)
Ivo Anjo (knuckles) wrote :

I'm sorry if this is unrelated, but I used synaptic to upgrade my system today, and after reboot the nvidia binary driver was gone and I was running nouveau. Is this expected? I didn't see anything about nvidia-current being removed.
(I'm running a 64-bit system.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers - 295.33-0ubuntu1

---------------
nvidia-graphics-drivers (295.33-0ubuntu1) precise; urgency=low

  * New upstream release:
    - Added support for the following GPUs:
      o GeForce GTX 680
      o GeForce GT 630M
      o GeForce GT 620
    - Fixed a VDPAU bug where decoding some H.264 streams
      would cause hardware errors on lower-end products,
      resulting in corruption and poor performance.
    - Fixed a bug that caused DisplayPort audio to stop
      working after monitors are hotplugged on GeForce GT
      520.
    - Improved compatibility with recent Linux kernels.
    - Fixed a behavior change that prevented
      ConnectedMonitor from being usable with DisplayPort
      connectors.
    - Marked the GVO Clone mode NV-CONTROL attributes:
      NV_CTRL_GVO_DISPLAY_X_SCREEN
      NV_CTRL_GVO_X_SCREEN_PAN_X
      NV_CTRL_GVO_X_SCREEN_PAN_Y
      as deprecated. They will be removed in a future
      release. To display an X screen over GVO, it is
      recommended to use GVO with MetaModes, instead.
    - Fixed a bug that caused DisplayPort devices to not
      be listed in Xorg.*.log.
    - Added support for 3D Vision ready displays that
      have a NVIDIA 3D Vision infrared emitter built
      inside the panel itself.
    - Fixed a bug that caused OpenGL applications to
      crash with some libc versions, such as eglibc 2.15
      (LP: #929384).
    - Fixed a bug that caused HDMI audio to stop working
      on AppleTV devices when an X server was started.
  * debian/nvidia-$flavour.postrm{.in}:
    - Make sure to remove the blacklist for hybrid
      graphics and to rebuild the initramfs (LP: #958848).
 -- Alberto Milone <email address hidden> Tue, 27 Mar 2012 10:06:36 +0200

Changed in nvidia-graphics-drivers (Ubuntu):
status: Fix Committed → Fix Released
Changed in glibc (Fedora):
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.