the dash's entry get wrongly colored on left or right key use

Bug #868434 reported by Sebastien Bacher on 2011-10-05
104
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Medium
Gord Allott
Unity
Fix Released
Undecided
Unassigned
nux (Ubuntu)
Medium
Gord Allott
Oneiric
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Using 4.22 in Oneiric:

* open the dash
* hit the left or right keys
* see the entry background change like if you were selecting text, it goes over the borders as well

Related branches

Gord Allott (gordallott) on 2011-10-05
Changed in unity:
status: New → Incomplete
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: Triaged → Confirmed
importance: Undecided → Medium
assignee: nobody → Gord Allott (gordallott)
Changed in unity (Ubuntu):
assignee: nobody → Gord Allott (gordallott)
Changed in unity (Ubuntu):
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-10-05
Changed in unity:
milestone: none → 4.24.0
Gord Allott (gordallott) on 2011-10-11
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Gord Allott (gordallott) on 2011-10-11
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
Omer Akram (om26er) on 2011-10-16
Changed in unity:
status: Fix Committed → Fix Released

Hello Sebastien, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Omer Akram (om26er) wrote :

I can confirm this to be fixed in the proposed version of Unity.

tags: added: verification-done
removed: verification-needed
cmat (cmat555) wrote :

The update rectifies the problem here too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2

---------------
unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 12:47:54 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2b1

---------------
unity (4.24.0-0ubuntu2b1) oneiric-proposed; urgency=low

  * No-change reupload because of broken powerpc build.

unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Martin Pitt <email address hidden> Tue, 25 Oct 2011 07:01:51 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released

I'm still getting the wrong colour bug.

After updating, the dash entry bug is still occurring on all my notebooks.
Tested on Dell D630ATG, Sony Vaio SR21M, Dell Mini 10V.

issue still occurring in unity 4.24 on dell inspiron n4010

Omer Akram (om26er) on 2011-11-28
Changed in unity:
status: Fix Released → Won't Fix
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
affects: unity (Ubuntu) → nux (Ubuntu)
Changed in nux (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Won't Fix → Confirmed
Changed in nux (Ubuntu):
status: Fix Released → Confirmed
Changed in nux (Ubuntu Oneiric):
status: Fix Released → Confirmed
affects: unity → nux
Changed in nux:
milestone: 4.24.0 → none
status: Confirmed → Fix Committed
Changed in nux (Ubuntu Oneiric):
importance: Undecided → Medium
Omer Akram (om26er) wrote :

seems the fix was in NUX which needs to be SRUed

Sebastien Bacher (seb128) wrote :

the fix is already in the current SRU:
https://launchpad.net/ubuntu/+source/nux/1.16.0-0ubuntu1

Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
Changed in nux (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Omer Akram (om26er) wrote :

oops, I had -proposed disabled on this system :/

Didier Roche (didrocks) on 2012-02-01
Changed in unity:
status: New → Fix Committed
Omer Akram (om26er) on 2012-04-05
Changed in unity:
status: Fix Committed → Fix Released
Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in nux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers