Comment 5 for bug 1512603

Hi,
in Xenial 2.7.2-4ubuntu1 got merged.

The issue that our delta solved by dropping of the systemd service, seems solved in Debian >=2.7.2
The Debian Changelog part in 2.7.2-2 is:
   * Add wrappers that check the MODE in /etc/nut/nut.conf to avoid starting
      the daemons if nut is not configured (Closes: #747863).

Yet the merge kept our related delta:
     - Disable systemd unit; it does not check nut.conf whether nut is
       configured, and thus fails to start (and the package install). The
       init.d script works well enough for the time being.

Andrew (computershik-ya) wrote on 2015-11-05:
[...] The init.d script was a broken symlink to nut-client [...]
At least that seems solved as it installs correctly a init.d script that systemd uses as fallback.

file /etc/init.d/nut-client
/etc/init.d/nut-client: POSIX shell script, ASCII text executable
lrwxrwxrwx 1 root root 10 Jan 27 09:36 /etc/init.d/ups-monitor -> nut-client*

Debian has both systemd services again, but it might be too late before release to do that change in case it is working as-is again.
See: https://packages.debian.org/sid/amd64/nut-client/filelist

I had issues getting a proper Test done in my Xenial container.
But given the package merge and the proper link that is existing now I'd highly encourage the reporters who likely have a working UPS setup to test this with Xenial.

If you could share some of your setup to test it and the issues that appear that will also help to consider and work on dropping&testing the delta regarding the systemd services. Especially since it is late in the cycle.

Thanks in advance!