nut-monitor systemd service is absent in nut-client package since Ubuntu vivid

Bug #1512603 reported by Andrew Ignatov on 2015-11-03
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
nut (Ubuntu)
Medium
Unassigned

Bug Description

The systemd unit for the upsmon has disapperared from nut-client package since Ubuntu trusty:

http://packages.ubuntu.com/trusty/amd64/nut-client/filelist (2.7.1-1ubuntu1)

vs

http://packages.ubuntu.com/vivid/amd64/nut-client/filelist (2.7.1-1ubuntu4)

affects: kexec-tools (Ubuntu) → nut (Ubuntu)
description: updated
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

I looked at the changelog for this package and found that it was removed in 2.7.1-1ubuntu2 with the follwing message:

  * Disable systemd unit; it does not check nut.conf whether nut is
    configured, and thus fails to start (and the package install). The init.d
    script works well enough for the time being. (LP: #1313231)

See also bug 1313231 for more information.

Checking with Debian, it looks like they first included the same change as Ubuntu but then reverted them again. There's a longer discussion in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=747863 and it looks like they might have fixed it, but I've only skimmed that one.

tags: added: vivid wily xenial
Robie Basak (racb) on 2015-11-05
tags: added: systemd-boot
Andrew Ignatov (feliksas) wrote :

The init.d script was a broken symlink to nut-client, so I just copied the systemd unit from an earlier package, and it works fine now.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nut (Ubuntu):
status: New → Confirmed
Changed in nut (Ubuntu):
importance: Undecided → High

I installed 2.7.2 packages from Debian and it works for me on 15.10.

Changed in nut (Ubuntu):
importance: High → Critical
status: Confirmed → Triaged

Hi,
in Xenial 2.7.2-4ubuntu1 got merged.

The issue that our delta solved by dropping of the systemd service, seems solved in Debian >=2.7.2
The Debian Changelog part in 2.7.2-2 is:
   * Add wrappers that check the MODE in /etc/nut/nut.conf to avoid starting
      the daemons if nut is not configured (Closes: #747863).

Yet the merge kept our related delta:
     - Disable systemd unit; it does not check nut.conf whether nut is
       configured, and thus fails to start (and the package install). The
       init.d script works well enough for the time being.

Andrew (computershik-ya) wrote on 2015-11-05:
[...] The init.d script was a broken symlink to nut-client [...]
At least that seems solved as it installs correctly a init.d script that systemd uses as fallback.

file /etc/init.d/nut-client
/etc/init.d/nut-client: POSIX shell script, ASCII text executable
lrwxrwxrwx 1 root root 10 Jan 27 09:36 /etc/init.d/ups-monitor -> nut-client*

Debian has both systemd services again, but it might be too late before release to do that change in case it is working as-is again.
See: https://packages.debian.org/sid/amd64/nut-client/filelist

I had issues getting a proper Test done in my Xenial container.
But given the package merge and the proper link that is existing now I'd highly encourage the reporters who likely have a working UPS setup to test this with Xenial.

If you could share some of your setup to test it and the issues that appear that will also help to consider and work on dropping&testing the delta regarding the systemd services. Especially since it is late in the cycle.

Thanks in advance!

Robie Basak (racb) wrote :

I don't see how this is Critical. Setting to Medium as a workaround is available.

Changed in nut (Ubuntu):
importance: Critical → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.