npviewer.bin crashed with SIGSEGV

Bug #141613 reported by laga on 2007-09-21
This bug affects 3501 people
Affects Status Importance Assigned to Milestone
nspluginwrapper (Mandriva)
Fix Released
Critical
nspluginwrapper (Ubuntu)
High
Unassigned
Declined for Dapper by Sebastien Bacher
Declined for Gutsy by Steve Langasek
Declined for Hardy by Steve Langasek
Declined for Intrepid by Steve Langasek
Declined for Jaunty by Brian Murray
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

LATEST VERSION TESTED:
nspluginwrapper 0.9.91.5-1ubuntu1

Binary package hint: nspluginwrapper

Hum, I can't add much information here. I got an apport window telling me that npviewer.bin segfaulted. It didn't take firefox with it so I didn't even notice first. There was a youtube video playing in the background,

ProblemType: Crash
Architecture: amd64
Date: Sat Sep 22 00:01:15 2007
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
NonfreeKernelModules: nvidia
Package: nspluginwrapper 0.9.91.4-3ubuntu2
PackageArchitecture: amd64
ProcCmdline: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin --plugin /usr/lib/flashplugin-nonfree/libflashplayer.so --connection /org/wrapper/NSPlugins/libflashplayer.so/31316-1
ProcCwd: /home/laga
ProcEnviron:
 PATH=/home/laga/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: nspluginwrapper
Stacktrace:
 #0 0xf6d5b2e8 in ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
 #1 0xffdf90b8 in ?? ()
 #2 0xf70953a3 in ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
 Backtrace stopped: previous frame identical to this frame (corrupt stack?)
StacktraceTop:
 ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
 ?? ()
 ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
Title: npviewer.bin crashed with SIGSEGV
Uname: Linux prometheus 2.6.22-11-generic #1 SMP Mon Sep 17 03:18:44 GMT 2007 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin mythtv netdev plugdev powerdev scanner video
SegvAnalysis:
 Segfault happened at: 0xf6d5b2e8: cmpb $0x0,(%edx)
 PC (0xf6d5b2e8) ok
 source "$0x0" ok
 destination "(%edx)" (0x00000000) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA

laga (laga) wrote :

StacktraceTop:?? ()
?? ()
?? ()
?? ()

Juksu (jluostar) wrote :

As there are so many occurrences (duplicates), i think this bug is confirmed.

Changed in nspluginwrapper:
status: New → Confirmed

npviewer.bin related...
After updating to the adobe's non-free flash plugin... Several time I
had the following situation. I could not close a tab (it just freeze
my FF) until I kill the npviewer.bin process....

It directly affects the productivity of ff!!! Negatively!

--
  ASCII ribbon campaign ( )
    - against HTML email X
                      & vCards / \
http://stas.nerd.ro/ascii/

gururise (gururise) wrote :

I can confirm this bug. I am running 7.10 on AMD64 platform. Most of the crashes seemed to occur after upgrading to the latest flashplugin-nonfree 9.0.115.0

Firefox will usually not crash; however, npviewer.bin process will crash and consume 100% cpu on about 50% of flash websites.

This bug makes flash all but unusable on 64-bit Ubuntu platform.

Austin Lund (austin-lund) wrote :

This one is hard to reproduce I find. Does anyone have a website which reliably reproduces this?

If libflashplayer.so or npviewer.bin has a bug we will be reliant on the friendly people who produce this software (woo!! Go freedom!). Unless of course there is a workaround.

eric.rost (eric-rost) wrote :

I haven't had a recurrence of this bug in months (since I originally posted
it, I think). I haven't seen something reliably crash the flashplayer. Sorry
guys :)

On Jan 13, 2008 2:41 PM, Austin <email address hidden> wrote:

> This one is hard to reproduce I find. Does anyone have a website which
> reliably reproduces this?
>
> If libflashplayer.so or npviewer.bin has a bug we will be reliant on the
> friendly people who produce this software (woo!! Go freedom!). Unless
> of course there is a workaround.
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
The Propaganda Machine: Politics, Current Events, Opinion, and Controversy

http://mybabylon.homelinux.org/blog

gururise (gururise) wrote :

Still happens to me all the time, on just about any website with flash. Even the flash ads on http://www.slashdot.org sometimes cause npviewer.bin to crash.

gururise (gururise) wrote :

I've attached a screenshot of the npviewer.bin process windows hanging around on my desktop after a firefox crash. Also, the relevant line from 'top' is:

 PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
10150 gene 20 0 84956 17m 6964 S 198 0.4 3:50.01 npviewer.bin

Hope this helps someone track down the bug with npviewer.bin, as it makes firefox all but unusable on 64-bit systems

eric.rost (eric-rost) wrote :

Sorry that I can't help anymore, I think its been since a week after I
posted the bug that it disappeared off of my machine.

On Jan 25, 2008 12:18 PM, gururise <email address hidden> wrote:

> I've attached a screenshot of the npviewer.bin process windows hanging
> around on my desktop after a firefox crash. Also, the relevant line
> from 'top' is:
>
> PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
> 10150 gene 20 0 84956 17m 6964 S 198 0.4 3:50.01 npviewer.bin
>
> Hope this helps someone track down the bug with npviewer.bin, as it
> makes firefox all but unusable on 64-bit systems
>
> ** Attachment added: "Screenshot of npviewer.bin after firefox crash"
> http://launchpadlibrarian.net/11568981/Screenshot.png
>
> ** Tags added: npviewer npviewer.bin nspluginwrapper
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
The Propaganda Machine: Politics, Current Events, Opinion, and Controversy

http://mybabylon.homelinux.org/blog

Austin Lund (austin-lund) wrote :

So the original report is due to a null pointer problem. %edx is zero so (%edx) is sure to cause problems.

Perhaps valgrind is in order, but being a hard to repeat bug..... might be a little annoying.

Anyone want to try:

valgrind --trace-children=yes --tool=memcheck firefox

??

(I have no idea if this will be useful).

gururise (gururise) wrote :

I ran valgrind --trace-children=yes --log-file-exactly=valgrind.txt --tool=memcheck /usr/bin/firefox

I have attached the log file to this post. The website I visited, that sometimes doesnt work with flash (but doesn't necessarily cause npviewer.bin to crash) is: http://www.flasharcade.com/skill-games/paris-hilton-jail-escape-game.html

The following error messages appeared on the shell while valgrind was running:
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
*** NSPlugin Wrapper *** ERROR: NP_Initialize() invoke: Connection was NULL
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.

mabovo (mabovo) wrote :

My two cups contribution.

Jussi M. (vernerim) wrote :

Ramdom crashes of npviewer.bin also occur on Hardy. This time I was at http://www.itwire.com/content/view/16309/1148/. Has also occured with flash content at www.mtv3.fi.

firefox-3.0:
  Installed: 3.0~b3+nobinonly-0ubuntu2
nspluginwrapper:
  Installed: 0.9.91.5-1ubuntu1

Greetings,
Jussi M.

Jeremy Boden (jeremyboden) wrote :

I was playing a downloaded video in Miro - happened after about a minute.
Firefox was loaded but not active.

Austin Lund (austin-lund) wrote :

Is this a duplicate of Bug #179882?

It appears there is a potentially fix package for 8.04, but not for 7.10 at the moment.

hlhcomms (hlhcomms) wrote :

It coould be a duplicate... the screen turns grayscale while watching
video content via Firefox, then returns to colour after avariable
interlude. I can live with this problem for now, so I'll wait for 8.04.

Austin wrote:
> Is this a duplicate of Bug #179882?
>
> It appears there is a potentially fix package for 8.04, but not for 7.10
> at the moment.
>
>

Mateusz (mateusz-kaduk) wrote :

I dont use ubuntu anymore, sorry
btw, macromedia swf plugin just works fine with flash on 64bit systems.

2008/3/7, hlhcomms <email address hidden>:
>
> It coould be a duplicate... the screen turns grayscale while watching
> video content via Firefox, then returns to colour after avariable
> interlude. I can live with this problem for now, so I'll wait for 8.04.
>
>
> Austin wrote:
> > Is this a duplicate of Bug #179882?
> >
> > It appears there is a potentially fix package for 8.04, but not for 7.10
> > at the moment.
> >
> >
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "nspluginwrapper" in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: nspluginwrapper
>
> Hum, I can't add much information here. I got an apport window telling me
> that npviewer.bin segfaulted. It didn't take firefox with it so I didn't
> even notice first. There was a youtube video playing in the background,
>
> ProblemType: Crash
> Architecture: amd64
> Date: Sat Sep 22 00:01:15 2007
> DistroRelease: Ubuntu 7.10
> ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
> NonfreeKernelModules: nvidia
> Package: nspluginwrapper 0.9.91.4-3ubuntu2
> PackageArchitecture: amd64
> ProcCmdline: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin --plugin
> /usr/lib/flashplugin-nonfree/libflashplayer.so --connection
> /org/wrapper/NSPlugins/libflashplayer.so/31316-1
> ProcCwd: /home/laga
> ProcEnviron:
>
> PATH=/home/laga/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> Signal: 11
> SourcePackage: nspluginwrapper
> Stacktrace:
> #0 0xf6d5b2e8 in ?? () from
> /usr/lib/flashplugin-nonfree/libflashplayer.so
> #1 0xffdf90b8 in ?? ()
> #2 0xf70953a3 in ?? () from
> /usr/lib/flashplugin-nonfree/libflashplayer.so
> Backtrace stopped: previous frame identical to this frame (corrupt
> stack?)
> StacktraceTop:
> ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
> ?? ()
> ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
> Title: npviewer.bin crashed with SIGSEGV
> Uname: Linux prometheus 2.6.22-11-generic #1 SMP Mon Sep 17 03:18:44 GMT
> 2007 x86_64 GNU/Linux
> UserGroups: adm admin audio cdrom dialout dip floppy lpadmin mythtv netdev
> plugdev powerdev scanner video
>

alanpdodd (alan-dodd) wrote :

This may be a duplicate, however I am HH Alpha 5, latest updates when this
happened. Now on A6.

On Fri, Mar 7, 2008 at 4:45 AM, Austin <email address hidden> wrote:

> Is this a duplicate of Bug #179882?
>
> It appears there is a potentially fix package for 8.04, but not for 7.10
> at the moment.
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "nspluginwrapper" in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: nspluginwrapper
>
> Hum, I can't add much information here. I got an apport window telling me
> that npviewer.bin segfaulted. It didn't take firefox with it so I didn't
> even notice first. There was a youtube video playing in the background,
>
> ProblemType: Crash
> Architecture: amd64
> Date: Sat Sep 22 00:01:15 2007
> DistroRelease: Ubuntu 7.10
> ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
> NonfreeKernelModules: nvidia
> Package: nspluginwrapper 0.9.91.4-3ubuntu2
> PackageArchitecture: amd64
> ProcCmdline: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin --plugin
> /usr/lib/flashplugin-nonfree/libflashplayer.so --connection
> /org/wrapper/NSPlugins/libflashplayer.so/31316-1
> ProcCwd: /home/laga
> ProcEnviron:
>
> PATH=/home/laga/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> Signal: 11
> SourcePackage: nspluginwrapper
> Stacktrace:
> #0 0xf6d5b2e8 in ?? () from
> /usr/lib/flashplugin-nonfree/libflashplayer.so
> #1 0xffdf90b8 in ?? ()
> #2 0xf70953a3 in ?? () from
> /usr/lib/flashplugin-nonfree/libflashplayer.so
> Backtrace stopped: previous frame identical to this frame (corrupt
> stack?)
> StacktraceTop:
> ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
> ?? ()
> ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
> Title: npviewer.bin crashed with SIGSEGV
> Uname: Linux prometheus 2.6.22-11-generic #1 SMP Mon Sep 17 03:18:44 GMT
> 2007 x86_64 GNU/Linux
> UserGroups: adm admin audio cdrom dialout dip floppy lpadmin mythtv netdev
> plugdev powerdev scanner video
>

Ken Foskey (foskey) wrote :

I have Ubuntu 8.04 - the Hardy Heron - released in April 2008.

npviewer crashes regularly for me right now. It works but is not stable. It appears that if a single page has many flash elements then it will crash. Some of those joke sites with lots of adds will crash it.

I have Ubuntu with proprietary Nvidia drivers I went 8.04 because I have a new nvidia card.

aberlanas (angel-berlanas) wrote :

I'm in the same situation that waratah.

Scott Wegner (swegner) wrote :

I got this crash directly after upgrading to Hardy alpha from Gutsy. x64 processor.

Austin Lund (austin-lund) wrote :

Does the link in the bug report fix this for anyone here?

It worked for me.

http://launchpadlibrarian.net/12234800/nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb

Dara Adib (daradib) wrote :

Can someone clarify if Bug 193811 is a duplicate of this bug?

Noel J. Bergman (noeljb) wrote :

I've marked my report, Bug 193811, as a duplicate. And I reiterate what I said in Bug 179882, also marked as a duplicate of this, that the replacement package, http://launchpadlibrarian.net/12234800/nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb, fixes it for me.

description: updated
Sander Jonkers (jonkers) wrote :
Download full text (4.7 KiB)

1) I have the same crashes of npviewer.bin.
2) When I try to install the nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb, that install itself goes wrong. See below.

Platform: Ubuntu 8.04 AMD64 Alpha upgraded, running on an Athlon X2 3600+

Tips?

sander@ubuntu-804:~$ locate npviewer
/usr/lib/nspluginwrapper/i386/linux/npviewer
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin
/usr/lib/nspluginwrapper/noarch/npviewer
/var/crash/_usr_lib_nspluginwrapper_i386_linux_npviewer.bin.1000.crash

sander@ubuntu-804:~$ ll /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
-rwxr-xr-x 1 root root 107016 2008-02-26 17:05 /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
sander@ubuntu-804:~$

sander@ubuntu-804:~$ sudo dpkg -i Desktop/nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb
*** glibc detected *** sudo: free(): invalid pointer: 0x00007f3499da36c8 ***
======= Backtrace: =========
/lib/libc.so.6[0x7f34995d2fca]
/lib/libc.so.6(cfree+0x8c)[0x7f34995d6b5c]
/lib/libc.so.6(__libc_dlsym+0x80)[0x7f349966cfc0]
/lib/libc.so.6(__nss_lookup_function+0x16a)[0x7f3499646e6a]
/lib/libc.so.6[0x7f349961e939]
/lib/libc.so.6(getaddrinfo+0x1be)[0x7f349962029e]
sudo[0x407c49]
sudo[0x408c4d]
/lib/libc.so.6(__libc_start_main+0xf4)[0x7f349957d0b4]
sudo[0x4033a9]
======= Memory map: ========
00400000-0041c000 r-xp 00000000 08:05 307070 /usr/bin/sudo
0061b000-0061e000 rw-p 0001b000 08:05 307070 /usr/bin/sudo
0061e000-00641000 rw-p 0061e000 00:00 0 [heap]
7f3498b18000-7f3498b25000 r-xp 00000000 08:05 50997 /lib/libgcc_s.so.1
7f3498b25000-7f3498d25000 ---p 0000d000 08:05 50997 /lib/libgcc_s.so.1
7f3498d25000-7f3498d26000 rw-p 0000d000 08:05 50997 /lib/libgcc_s.so.1
7f3498d26000-7f3498d30000 r-xp 00000000 08:05 49001 /lib/libnss_files-2.7.so
7f3498d30000-7f3498f30000 ---p 0000a000 08:05 49001 /lib/libnss_files-2.7.so
7f3498f30000-7f3498f32000 rw-p 0000a000 08:05 49001 /lib/libnss_files-2.7.so
7f3498f32000-7f3498f3c000 r-xp 00000000 08:05 49003 /lib/libnss_nis-2.7.so
7f3498f3c000-7f349913b000 ---p 0000a000 08:05 49003 /lib/libnss_nis-2.7.so
7f349913b000-7f349913d000 rw-p 00009000 08:05 49003 /lib/libnss_nis-2.7.so
7f349913d000-7f3499153000 r-xp 00000000 08:05 48994 /lib/libnsl-2.7.so
7f3499153000-7f3499352000 ---p 00016000 08:05 48994 /lib/libnsl-2.7.so
7f3499352000-7f3499354000 rw-p 00015000 08:05 48994 /lib/libnsl-2.7.so
7f3499354000-7f3499356000 rw-p 7f3499354000 00:00 0
7f3499356000-7f349935e000 r-xp 00000000 08:05 48995 /lib/libnss_compat-2.7.so
7f349935e000-7f349955d000 ---p 00008000 08:05 48995 /lib/libnss_compat-2.7.so
7f349955d000-7f349955f000 rw-p 00007000 08:05 48995 /lib/libnss_compat-2.7.so
7f349955f000-7f34996b7000 r-xp 00000000 08:05 48988 /lib/libc-2.7.so
7f34996b7000-7f34998b7000 ---p 00158000 08:05 48988 /lib/libc-2.7.so
7f34998b7000-7f...

Read more...

Sander Jonkers (jonkers) wrote :
Download full text (4.2 KiB)

Never mind my last post; I get the same error message when trying to install another package, so the install error message is probably not related to npviewer.bin. Probably time for a fresh install of Hardy Heron Alpha.

sander@ubuntu-804:~$ sudo apt-get install clutch
*** glibc detected *** sudo: free(): invalid pointer: 0x00007fe8288b76c8 ***
======= Backtrace: =========
/lib/libc.so.6[0x7fe8280e6fca]
/lib/libc.so.6(cfree+0x8c)[0x7fe8280eab5c]
/lib/libc.so.6(__libc_dlsym+0x80)[0x7fe828180fc0]
/lib/libc.so.6(__nss_lookup_function+0x16a)[0x7fe82815ae6a]
/lib/libc.so.6[0x7fe828132939]
/lib/libc.so.6(getaddrinfo+0x1be)[0x7fe82813429e]
sudo[0x407c49]
sudo[0x408c4d]
/lib/libc.so.6(__libc_start_main+0xf4)[0x7fe8280910b4]
sudo[0x4033a9]
======= Memory map: ========
00400000-0041c000 r-xp 00000000 08:05 307070 /usr/bin/sudo
0061b000-0061e000 rw-p 0001b000 08:05 307070 /usr/bin/sudo
0061e000-00641000 rw-p 0061e000 00:00 0 [heap]
7fe82762c000-7fe827639000 r-xp 00000000 08:05 50997 /lib/libgcc_s.so.1
7fe827639000-7fe827839000 ---p 0000d000 08:05 50997 /lib/libgcc_s.so.1
7fe827839000-7fe82783a000 rw-p 0000d000 08:05 50997 /lib/libgcc_s.so.1
7fe82783a000-7fe827844000 r-xp 00000000 08:05 49001 /lib/libnss_files-2.7.so
7fe827844000-7fe827a44000 ---p 0000a000 08:05 49001 /lib/libnss_files-2.7.so
7fe827a44000-7fe827a46000 rw-p 0000a000 08:05 49001 /lib/libnss_files-2.7.so
7fe827a46000-7fe827a50000 r-xp 00000000 08:05 49003 /lib/libnss_nis-2.7.so
7fe827a50000-7fe827c4f000 ---p 0000a000 08:05 49003 /lib/libnss_nis-2.7.so
7fe827c4f000-7fe827c51000 rw-p 00009000 08:05 49003 /lib/libnss_nis-2.7.so
7fe827c51000-7fe827c67000 r-xp 00000000 08:05 48994 /lib/libnsl-2.7.so
7fe827c67000-7fe827e66000 ---p 00016000 08:05 48994 /lib/libnsl-2.7.so
7fe827e66000-7fe827e68000 rw-p 00015000 08:05 48994 /lib/libnsl-2.7.so
7fe827e68000-7fe827e6a000 rw-p 7fe827e68000 00:00 0
7fe827e6a000-7fe827e72000 r-xp 00000000 08:05 48995 /lib/libnss_compat-2.7.so
7fe827e72000-7fe828071000 ---p 00008000 08:05 48995 /lib/libnss_compat-2.7.so
7fe828071000-7fe828073000 rw-p 00007000 08:05 48995 /lib/libnss_compat-2.7.so
7fe828073000-7fe8281cb000 r-xp 00000000 08:05 48988 /lib/libc-2.7.so
7fe8281cb000-7fe8283cb000 ---p 00158000 08:05 48988 /lib/libc-2.7.so
7fe8283cb000-7fe8283ce000 r--p 00158000 08:05 48988 /lib/libc-2.7.so
7fe8283ce000-7fe8283d0000 rw-p 0015b000 08:05 48988 /lib/libc-2.7.so
7fe8283d0000-7fe8283d5000 rw-p 7fe8283d0000 00:00 0
7fe8283d5000-7fe8283d7000 r-xp 00000000 08:05 48991 /lib/libdl-2.7.so
7fe8283d7000-7fe8285d7000 ---p 00002000 08:05 48991 /lib/libdl-2.7.so
7fe8285d7000-7fe8285d9000 rw-p 00002000 08:05 48991 /lib/libdl-2.7.so
7fe8285...

Read more...

Nat Tuck (nat-ferrus) wrote :

Hardy's still doing this.

bill wood (wlwood3) wrote :

> I've marked my report, Bug 193811, as a duplicate. And I reiterate what I said in Bug 179882,
> also marked as a duplicate of this, that the replacement package,
> http://launchpadlibrarian.net/12234800/nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb, fixes it for me.

I tried this in Gutsy, and I get the following:

bill@bill-laptop:~$ sudo dpkg -i Desktop/nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb
[sudo] password for bill:
(Reading database ... 104764 files and directories currently installed.)
Preparing to replace nspluginwrapper 0.9.91.5-1ubuntu1 (using .../nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb) ...
Unpacking replacement nspluginwrapper ...
dpkg: dependency problems prevent configuration of nspluginwrapper:
 nspluginwrapper depends on libc6 (>= 2.7-1); however:
  Version of libc6 on system is 2.6.1-1ubuntu10.
 nspluginwrapper depends on libc6-i386 (>= 2.7-1); however:
  Version of libc6-i386 on system is 2.6.1-1ubuntu10.
dpkg: error processing nspluginwrapper (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nspluginwrapper

I checked Synaptic, and it shows 2.6.1-1ubuntu10 is the most current version of libc6.

Are you using Hardy? Does it come with a newer libc6? Is there a way to install that in Gutsy?

Thanks.

Bill

icejoe (thisisicejoe) wrote :
Download full text (3.7 KiB)

yes i am using hardy, and yes the version installed with synaptic is
2.7-9ubuntu2. I'm going to take a guess and say that a way you could install
it in gutsy is to either go compile from source or add "
http://mirror.anl.gov/pub/ubuntu/ hardy main" as a repository and just find
it from there ( though it may request you install other things as
dependencies.

On Wed, Mar 19, 2008 at 7:58 AM, bill wood <email address hidden> wrote:

> > I've marked my report, Bug 193811, as a duplicate. And I reiterate what
> I said in Bug 179882,
> > also marked as a duplicate of this, that the replacement package,
> >
> http://launchpadlibrarian.net/12234800/nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb,
> fixes it for me.
>
> I tried this in Gutsy, and I get the following:
>
> bill@bill-laptop:~$ sudo dpkg -i
> Desktop/nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb
> [sudo] password for bill:
> (Reading database ... 104764 files and directories currently installed.)
> Preparing to replace nspluginwrapper 0.9.91.5-1ubuntu1 (using
> .../nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb) ...
> Unpacking replacement nspluginwrapper ...
> dpkg: dependency problems prevent configuration of nspluginwrapper:
> nspluginwrapper depends on libc6 (>= 2.7-1); however:
> Version of libc6 on system is 2.6.1-1ubuntu10.
> nspluginwrapper depends on libc6-i386 (>= 2.7-1); however:
> Version of libc6-i386 on system is 2.6.1-1ubuntu10.
> dpkg: error processing nspluginwrapper (--install):
> dependency problems - leaving unconfigured
> Errors were encountered while processing:
> nspluginwrapper
>
> I checked Synaptic, and it shows 2.6.1-1ubuntu10 is the most current
> version of libc6.
>
> Are you using Hardy? Does it come with a newer libc6? Is there a way to
> install that in Gutsy?
>
> Thanks.
>
> Bill
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "nspluginwrapper" in Ubuntu: Confirmed
>
> Bug description:
> LATEST VERSION TESTED:
> nspluginwrapper 0.9.91.5-1ubuntu1
>
> Binary package hint: nspluginwrapper
>
> Hum, I can't add much information here. I got an apport window telling me
> that npviewer.bin segfaulted. It didn't take firefox with it so I didn't
> even notice first. There was a youtube video playing in the background,
>
> ProblemType: Crash
> Architecture: amd64
> Date: Sat Sep 22 00:01:15 2007
> DistroRelease: Ubuntu 7.10
> ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
> NonfreeKernelModules: nvidia
> Package: nspluginwrapper 0.9.91.4-3ubuntu2
> PackageArchitecture: amd64
> ProcCmdline: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin --plugin
> /usr/lib/flashplugin-nonfree/libflashplayer.so --connection
> /org/wrapper/NSPlugins/libflashplayer.so/31316-1
> ProcCwd: /home/laga
> ProcEnviron:
>
> PATH=/home/laga/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> Signal: 11
> SourcePackage: nspluginwrapper
> Stacktrace:
> #0 0xf6d5b2e8 in ?? () from
> /usr/lib/flashplugin-nonfree/libflashplayer.so
> #1 0xffdf90b8 in ?? ()
> #2 0xf709...

Read more...

bill wood (wlwood3) wrote :

I found a post here: https://bugs.launchpad.net/ubuntu/+source/nspluginwrapper/+bug/177856
that seems to have cured the problem for me.

It involves installing this version of the nsplugin wrapper file:

Mrts (mrts) wrote :

Confirming that the updated package fixes this for me.

Nico Bauer (oshelpdesk) wrote :

still the same problem for me.

<hp> (hplorenzana) wrote :

I've been encountering this since Gutsy. I just installed Hardy. I can sometimes get this through clicking on an HTML email from Evolution (Ad) and it opens FF.

James Clemence (jvc26) wrote :

Not much to say other than like the OP simply was informed of the crash. Running Hardy 8.04 beta, amd64. Any further information do ask,

Il

phenest (steve-clark) wrote :

I can confirm that this is now working in Hardy Heron AMD64.

phenest (steve-clark) wrote :

My apologies. Ignore last comment. Commented on wrong bug. (Maybe someone can delete it?)

This bug is a bit more severe on laptops. Because it puts continual background strain on processors it leads to very high running temps but otherwise a responsive system. users who are unaware of the problem risk hardware failure or at least decrease lifetime.

For example on my core2 7400 it will cause a proc that runs normally around the 50C mark to sit at 60-70C and sometimes rise to 80C this will cause battery, harddrive and other component to have signf shorter lifetimes.

Hew McLachlan (hew) on 2008-07-23
Changed in nspluginwrapper:
importance: Undecided → High
Hew McLachlan (hew) on 2008-08-10
Changed in nspluginwrapper:
status: Confirmed → Triaged
Changed in nspluginwrapper:
status: Unknown → Fix Released
Changed in nspluginwrapper:
status: Triaged → Fix Committed
Hew McLachlan (hew) on 2008-11-24
Changed in nspluginwrapper:
status: Fix Committed → Triaged
Oliver Sic (soliver) on 2009-01-16
Changed in nspluginwrapper:
status: Triaged → Fix Released
Hew McLachlan (hew) on 2009-01-16
Changed in nspluginwrapper:
status: Fix Released → Triaged
gissi (zerinol) on 2009-04-05
description: updated
Kees Cook (kees) on 2009-09-16
description: updated
Changed in nspluginwrapper (Ubuntu):
status: Triaged → Confirmed
194 comments hidden view all 274 comments
Kevin (kevinshlee) wrote :

Installing 64 bit flash and GPU acceleration.
http://blog.lckymn.com/2009/06/07/installing-64bit-flash-player-in-ubuntu-linux/

As far as I know, the alpha version of 64 bit flash has been available for almost one year (or longer than one year), but Adobe hasn't released any GA version yet. Anyway, in my case, the 64 bit alpha version works much better than 32bit one with npviewer.

Regards,
Kevin

krutoileshii (krutoileshii) wrote :

Already have that. still the same problem

2009/10/5 Blade II <email address hidden>

> Installing 64 bit flash and GPU acceleration.
>
> http://blog.lckymn.com/2009/06/07/installing-64bit-flash-player-in-ubuntu-linux/
>
> As far as I know, the alpha version of 64 bit flash has been available
> for almost one year (or longer than one year), but Adobe hasn't released
> any GA version yet. Anyway, in my case, the 64 bit alpha version works
> much better than 32bit one with npviewer.
>
> Regards,
> Kevin
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Kevin (kevinshlee) wrote :

Hello, krutoileshii

I'm sorry but I don't get what you mean by the same problem. The 64 bit
flash player does not use npviewer. How can you possibly have "npviewer.bin
crashed with SIGSEGV" problem with the 64 bit one?
Are you sure you removed the 32 bit flash player before installing the 64
bit one?

Regards,
Kevin

2009/10/8 krutoileshii <email address hidden>

> Already have that. still the same problem
>
> 2009/10/5 Blade II <email address hidden>
>
> > Installing 64 bit flash and GPU acceleration.
> >
> >
> http://blog.lckymn.com/2009/06/07/installing-64bit-flash-player-in-ubuntu-linux/
> >
> > As far as I know, the alpha version of 64 bit flash has been available
> > for almost one year (or longer than one year), but Adobe hasn't released
> > any GA version yet. Anyway, in my case, the 64 bit alpha version works
> > much better than 32bit one with npviewer.
> >
> > Regards,
> > Kevin
> >
> > --
> > npviewer.bin crashed with SIGSEGV
> > https://bugs.launchpad.net/bugs/141613
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>

krutoileshii (krutoileshii) wrote :

that's the message that gets reported. i don't use the 32 bit flash for
sure. maybe some other plugin that uses it

2009/10/8 Blade II <email address hidden>

> Hello, krutoileshii
>
> I'm sorry but I don't get what you mean by the same problem. The 64 bit
> flash player does not use npviewer. How can you possibly have "npviewer.bin
> crashed with SIGSEGV" problem with the 64 bit one?
> Are you sure you removed the 32 bit flash player before installing the 64
> bit one?
>
> Regards,
> Kevin
>
>
> 2009/10/8 krutoileshii <email address hidden>
>
> > Already have that. still the same problem
> >
> > 2009/10/5 Blade II <email address hidden>
> >
> > > Installing 64 bit flash and GPU acceleration.
> > >
> > >
> >
> http://blog.lckymn.com/2009/06/07/installing-64bit-flash-player-in-ubuntu-linux/
> > >
> > > As far as I know, the alpha version of 64 bit flash has been available
> > > for almost one year (or longer than one year), but Adobe hasn't
> released
> > > any GA version yet. Anyway, in my case, the 64 bit alpha version works
> > > much better than 32bit one with npviewer.
> > >
> > > Regards,
> > > Kevin
> > >
> > > --
> > > npviewer.bin crashed with SIGSEGV
> > > https://bugs.launchpad.net/bugs/141613
> > > You received this bug notification because you are a direct subscriber
> > > of the bug.
> > >
> >
> > --
> > npviewer.bin crashed with SIGSEGV
> > https://bugs.launchpad.net/bugs/141613
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Kevin (kevinshlee) wrote :

OK, I got it. I was just curious. Then that's probably something else. I
hope you can find what uses the npviewer and replace with the 64 bit version
of it if available.
Regards,
Kevin

2009/10/9 krutoileshii <email address hidden>

> that's the message that gets reported. i don't use the 32 bit flash for
> sure. maybe some other plugin that uses it
>
> 2009/10/8 Blade II <email address hidden>
>
> > Hello, krutoileshii
> >
> > I'm sorry but I don't get what you mean by the same problem. The 64 bit
> > flash player does not use npviewer. How can you possibly have
> "npviewer.bin
> > crashed with SIGSEGV" problem with the 64 bit one?
> > Are you sure you removed the 32 bit flash player before installing the 64
> > bit one?
> >
> > Regards,
> > Kevin
> >
> >
> > 2009/10/8 krutoileshii <email address hidden>
> >
> > > Already have that. still the same problem
> > >
> > > 2009/10/5 Blade II <email address hidden>
> > >
> > > > Installing 64 bit flash and GPU acceleration.
> > > >
> > > >
> > >
> >
> http://blog.lckymn.com/2009/06/07/installing-64bit-flash-player-in-ubuntu-linux/
> > > >
> > > > As far as I know, the alpha version of 64 bit flash has been
> available
> > > > for almost one year (or longer than one year), but Adobe hasn't
> > released
> > > > any GA version yet. Anyway, in my case, the 64 bit alpha version
> works
> > > > much better than 32bit one with npviewer.
> > > >
> > > > Regards,
> > > > Kevin
> > > >
> > > > --
> > > > npviewer.bin crashed with SIGSEGV
> > > > https://bugs.launchpad.net/bugs/141613
> > > > You received this bug notification because you are a direct
> subscriber
> > > > of the bug.
> > > >
> > >
> > > --
> > > npviewer.bin crashed with SIGSEGV
> > > https://bugs.launchpad.net/bugs/141613
> > > You received this bug notification because you are a direct subscriber
> > > of the bug.
> > >
> >
> > --
> > npviewer.bin crashed with SIGSEGV
> > https://bugs.launchpad.net/bugs/141613
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in nspluginwrapper (Ubuntu):
assignee: nobody → Jason Smith (jassmith)

I am running the 64bit Karmic Beta on an Intel i5.
This message appears almost randomly every few hours.
Happy to supply further information if requested.

MG

Jason Smith (jassmith) on 2009-10-17
Changed in nspluginwrapper (Ubuntu):
assignee: Jason Smith (jassmith) → nobody
Pali (pali) wrote :

I add 64 bit version of adobe flash plugin to my ppa https://launchpad.net/~pali.rohar/+archive/ppa

Vortex (ecbeachbum) wrote :

This sounds like the error I got, except I just upgraded from Ubuntu AMD64 9.04 to 9.10. Sorry, I don't know where to find the log file for this to post here...

matism (matism) wrote :

I clearly made a mistake in reporting this
problem and subscribing. How does one unsubscribe?

--Mark Matis

At 08:25 PM 11/1/2009 +0000, Vortex wrote:
>This sounds like the error I got, except I just upgraded from Ubuntu
>AMD64 9.04 to 9.10. Sorry, I don't know where to find the log file for
>this to post here...
>
>--
>npviewer.bin crashed with SIGSEGV
>https://bugs.launchpad.net/bugs/141613
>You received this bug notification because you are a direct subscriber
>of the bug.
>
>Status in “nspluginwrapper” package in Ubuntu: Confirmed
>Status in “nspluginwrapper” package in Mandriva: Fix Released
>
>Bug description:
>LATEST VERSION TESTED:
>nspluginwrapper 0.9.91.5-1ubuntu1
>
>Binary package hint: nspluginwrapper
>
>Hum, I can't add much information here. I got an
>apport window telling me that npviewer.bin
>segfaulted. It didn't take firefox with it so I
>didn't even notice first. There was a youtube video playing in the background,
>
>ProblemType: Crash
>Architecture: amd64
>Date: Sat Sep 22 00:01:15 2007
>DistroRelease: Ubuntu 9.04
>ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
>NonfreeKernelModules: nvidia
>Package: nspluginwrapper 0.9.91.4-3ubuntu2
>PackageArchitecture: amd64
>ProcCmdline:
>/usr/lib/nspluginwrapper/i386/linux/npviewer.bin
>--plugin
>/usr/lib/flashplugin-nonfree/libflashplayer.so
>--connection /org/wrapper/NSPlugins/libflashplayer.so/31316-1
>ProcCwd: /home/laga
>ProcEnviron:
>
>PATH=/home/laga/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
>Signal: 11
>SourcePackage: nspluginwrapper
>Stacktrace:
> #0 0xf6d5b2e8 in ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
> #1 0xffdf90b8 in ?? ()
> #2 0xf70953a3 in ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
> Backtrace stopped: previous frame identical to this frame (corrupt stack?)
>StacktraceTop:
> ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
> ?? ()
> ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
>Title: npviewer.bin crashed with SIGSEGV
>Uname: Linux prometheus 2.6.22-11-generic #1 SMP
>Mon Sep 17 03:18:44 GMT 2007 x86_64 GNU/Linux
>UserGroups: adm admin audio cdrom dialout dip
>floppy lpadmin mythtv netdev plugdev powerdev scanner video
>SegvAnalysis:
> Segfault happened at: 0xf6d5b2e8: cmpb $0x0,(%edx)
> PC (0xf6d5b2e8) ok
> source "$0x0" ok
> destination "(%edx)" (0x00000000) not located
> in a known VMA region (needed writable region)!
>SegvReason: writing NULL VMA

nussmaus (nussmaus111) wrote :

any fixez in sight?

--- On Sun, 11/1/09, matism <email address hidden> wrote:

From: matism <email address hidden>
Subject: Re: [Bug 141613] Re: npviewer.bin crashed with SIGSEGV
To: <email address hidden>
Date: Sunday, November 1, 2009, 12:37 PM

I clearly made a mistake in reporting this
problem and subscribing.  How does one unsubscribe?

--Mark Matis

At 08:25 PM 11/1/2009 +0000, Vortex wrote:
>This sounds like the error I got, except I just upgraded from Ubuntu
>AMD64 9.04 to 9.10. Sorry, I don't know where to find the log file for
>this to post here...
>
>--
>npviewer.bin crashed with SIGSEGV
>https://bugs.launchpad.net/bugs/141613
>You received this bug notification because you are a direct subscriber
>of the bug.
>
>Status in ânspluginwrapperâ package in Ubuntu: Confirmed
>Status in ânspluginwrapperâ package in Mandriva: Fix Released
>
>Bug description:
>LATEST VERSION TESTED:
>nspluginwrapper 0.9.91.5-1ubuntu1
>
>Binary package hint: nspluginwrapper
>
>Hum, I can't add much information here. I got an
>apport window telling me that npviewer.bin
>segfaulted. It didn't take firefox with it so I
>didn't even notice first. There was a youtube video playing in the background,
>
>ProblemType: Crash
>Architecture: amd64
>Date: Sat Sep 22 00:01:15 2007
>DistroRelease: Ubuntu 9.04
>ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
>NonfreeKernelModules: nvidia
>Package: nspluginwrapper 0.9.91.4-3ubuntu2
>PackageArchitecture: amd64
>ProcCmdline:
>/usr/lib/nspluginwrapper/i386/linux/npviewer.bin
>--plugin
>/usr/lib/flashplugin-nonfree/libflashplayer.so
>--connection /org/wrapper/NSPlugins/libflashplayer.so/31316-1
>ProcCwd: /home/laga
>ProcEnviron:
>
>PATH=/home/laga/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
>  LANG=de_DE.UTF-8
>  SHELL=/bin/bash
>Signal: 11
>SourcePackage: nspluginwrapper
>Stacktrace:
>  #0  0xf6d5b2e8 in ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
>  #1  0xffdf90b8 in ?? ()
>  #2  0xf70953a3 in ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
>  Backtrace stopped: previous frame identical to this frame (corrupt stack?)
>StacktraceTop:
>  ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
>  ?? ()
>  ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
>Title: npviewer.bin crashed with SIGSEGV
>Uname: Linux prometheus 2.6.22-11-generic #1 SMP
>Mon Sep 17 03:18:44 GMT 2007 x86_64 GNU/Linux
>UserGroups: adm admin audio cdrom dialout dip
>floppy lpadmin mythtv netdev plugdev powerdev scanner video
>SegvAnalysis:
>  Segfault happened at: 0xf6d5b2e8:      cmpb   $0x0,(%edx)
>  PC (0xf6d5b2e8) ok
>  source "$0x0" ok
>  destination "(%edx)" (0x00000000) not located
> in a known VMA region (needed writable region)!
>SegvReason: writing NULL VMA

--
npviewer.bin crashed with SIGSEGV
https://bugs.launchpad.net/bugs/141613
You received this bug notification because you are a direct subscriber
of the bug.

mark (powerofslack) wrote :

Not sure if this is related- in addition to the npviewer.bin crashed with SIGSEGV, I have this phenotype: ever since Karmic upgrade I cannot view any flash videos in firefox at all ever, specifically: The first frame with the big arrow in the middle of it comes on, the play/pause in the bottom left is there, no 'waiting'/'loading' icons are happening, but even if i waaaaaaaait I cannot click on the play arrow in the center of the flash vid, or the play/pause in the lower left, or drag the time scroller along the bottom, and get any response. processes show a firefox and npviewer.bin ok and running, but any flash vid is frozen. If this isn't the same bug let me know where to file it maybe? Killing npviewer.bin and reloading the page is no help. happens with any flahs vid any time since upgrade.

Karmic, Firefox 3.5.4, flashplugin-installer 10.0.32.18-ubuntu1, Gnome 2.28.1, kernel 2.6.28-16-generic (cannot start the 2.6.31 kernel due to both the cannot recognize two identical hard drives bug and the didn;t build nvidia drivers successfully bug for now).

nussmaus (nussmaus111) wrote :

hi mark,
i had the same prob with karmic-64bit....i re-installed with karmic 1-386, and, voila!
flash works, no more blue-green movie playback, still a bit buggy (not sure it's really utilizing all 4 of my processor cores)....nvidia 173 seems to work better with my 9500gt than nvidia 185 driverz....[never install ANYTHING that ends in.0].....i should know better....each version of 8.04 was better than the previous, with 8.10 turning out best of all
wish i'd kept it....oh, well, back to poland (if it ain't broke.......)
mike/out

--- On Thu, 11/5/09, mark <email address hidden> wrote:

From: mark <email address hidden>
Subject: [Bug 141613] Re: npviewer.bin crashed with SIGSEGV
To: <email address hidden>
Date: Thursday, November 5, 2009, 2:02 PM

Not sure if this is related- in addition to the npviewer.bin crashed
with SIGSEGV, I have this phenotype:  ever since Karmic upgrade I cannot
view any flash videos in firefox at all ever, specifically:  The first
frame with the big arrow in the middle of it comes on, the play/pause in
the bottom left is there, no 'waiting'/'loading' icons are happening,
but even if i waaaaaaaait I cannot click on the play arrow in the center
of the flash vid, or the play/pause in the lower left, or drag the time
scroller along the bottom, and get any response.  processes show a
firefox and npviewer.bin ok and running, but any flash vid is frozen.
If this isn't the same bug let me know where to file it maybe?  Killing
npviewer.bin and reloading the page is no help.  happens with any flahs
vid any time since upgrade.

Karmic, Firefox 3.5.4, flashplugin-installer 10.0.32.18-ubuntu1, Gnome
2.28.1, kernel 2.6.28-16-generic (cannot start the 2.6.31 kernel due to
both the cannot recognize two identical hard drives bug and the didn;t
build nvidia drivers successfully bug for now).

--
npviewer.bin crashed with SIGSEGV
https://bugs.launchpad.net/bugs/141613
You received this bug notification because you are a direct subscriber
of the bug.

Jim Braux-Zin (j-brauxzin) wrote :

Mark according to your description you could also be encountering this well-known bug: https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/410407.

tags: added: iso-testing
iMac (imac-netstatz) wrote :

This flash npviewer issue has been bugging me for ages (even moreso since Karmic). It seems the latest 64bit Flash PPA resolves my issues (for a few days now), avoiding the wrapper completely, and providing stability on repeated YouTubing (where I easily tripped on this). I expect similar results for firefox 3.5 version as well (noting my Ubuntu-Tweaked versions below), but have little motivation to downgrade and test more thoroughly.

ii firefox 3.6+nobinonly-0ubuntu1~mfs~karmic1
ii flashplugin64-installer 10.0.45.2-0ubuntu0~sevenmachines1

Trying to bring more awareness to properly installing the 64bit, I created a helpful little post

http://www.ianbmacdonald.com/wordpress/2010/02/19/install-64bit-flash-on-ubuntu

nussmaus (nussmaus111) wrote :

thank you...works well, doesn't it?

--- On Fri, 2/19/10, iMac <email address hidden> wrote:

From: iMac <email address hidden>
Subject: [Bug 141613] Re: npviewer.bin crashed with SIGSEGV
To: <email address hidden>
Date: Friday, February 19, 2010, 7:25 AM

This flash npviewer issue has been bugging me for ages (even moreso
since Karmic).  It seems the latest 64bit Flash PPA resolves my issues
(for a few days now), avoiding the wrapper completely, and providing
stability on repeated YouTubing (where I easily tripped on this).  I
expect similar results for firefox 3.5 version as well (noting my
Ubuntu-Tweaked versions below), but have little motivation to downgrade
and test more thoroughly.

ii  firefox                                         3.6+nobinonly-0ubuntu1~mfs~karmic1
ii  flashplugin64-installer                10.0.45.2-0ubuntu0~sevenmachines1

Trying to bring more awareness to properly installing the 64bit, I
created a helpful little post

http://www.ianbmacdonald.com/wordpress/2010/02/19/install-64bit-flash-
on-ubuntu

--
npviewer.bin crashed with SIGSEGV
https://bugs.launchpad.net/bugs/141613
You received this bug notification because you are a direct subscriber
of the bug.

Rolf Leggewie (r0lf) wrote :

Are bug 178038 and bug 141613 dupes?

Lars Kumbier (derlars) wrote :

This bug is fixed for me, too, with the new 64bit beta 3 flashplugin from adobe.com (http://labs.adobe.com/downloads/flashplayer10.html).

That's not a fix. That is called a workaround.
The fact is, there are still multiple bug in this 32-in-64 wrapper
thing. Because of the severe problems people were having with this,
choking up their linux workstations, I banned it from the network
altogether. I needed it for acroreader and flash. They do not provide
proper 64-bit versions, or uptodate versions of their product. No
64-bit acroread at all. Okular or evince is good enough as a pdf
reader plugin, and for flash there really is no proper substitute. I
hope some company will give some funding to bring Gnash up to the
level of support that the windows platform enjoys. I lost all faith in
good things coming from Adobe.
No photoshop for linux, no proper flash, no proper pdf reader, let
alone creator.
Still Adobe is an important provider of standards like PDF, flash,
postscript, so I hope that they do get their act together soon.
They are too important for linux indirectly to die. Otherwise I would
not care about them.

On Fri, Mar 19, 2010 at 10:36 AM, derLars
<email address hidden> wrote:
> This bug is fixed for me, too, with the new 64bit beta 3 flashplugin
> from adobe.com (http://labs.adobe.com/downloads/flashplayer10.html).
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Simon Ruggier (simon80) wrote :

On Wed, Mar 24, 2010 at 7:26 AM, perpetualrabbit
<email address hidden> wrote:
> That's not a fix. That is called a workaround.

This is true, but it's a very acceptable workaround. If you have no
philosophical misgivings about running Adobe Flash, this really is the
way to do it on 64-bit systems.

Noel J. Bergman (noeljb) wrote :

The fix is to move directly to the 64 bit version, and stop worrying about nspluginwrapper. How did a 32-bit stopgap become the only and blessed solution?

gushi (ubuntu-gushi) wrote :

On Wed, 24 Mar 2010, Noel J. Bergman wrote:

> The fix is to move directly to the 64 bit version, and stop worrying
> about nspluginwrapper. How did a 32-bit stopgap become the only and
> blessed solution?

No official non-alpha-quality x64 bit version from the upstream vendor,
maybe? And yes, while it's true you are CURRENTLY able to download it
(even in alpha), that was not the case at the original inception of this
bug.

-Dan

--

--------Dan Mahoney--------
Techie, Sysadmin, WebGeek
Gushi on efnet/undernet IRC
ICQ: 13735144 AIM: LarpGM
Site: http://www.gushi.org
---------------------------

Simon Ruggier (simon80) wrote :

On Wed, Mar 24, 2010 at 7:35 PM, gushi <email address hidden> wrote:
> On Wed, 24 Mar 2010, Noel J. Bergman wrote:
>
>> The fix is to move directly to the 64 bit version, and stop worrying
>> about nspluginwrapper.  How did a 32-bit stopgap become the only and
>> blessed solution?
>
> No official non-alpha-quality x64 bit version from the upstream vendor,
> maybe?  And yes, while it's true you are CURRENTLY able to download it
> (even in alpha), that was not the case at the original inception of this
> bug.

So does that mean the bug is grandfathered in because it got here
first? In this case, alpha is just a label, and the 64-bit flash
player is much more stable than running 32-bit flash under
nspluginwrapper, according to many users who have commented on this
thread. There doesn't seem to be any reason to keep the 32-bit flash
plugin under nspluginwrapper that makes up for its brokenness.

krutoileshii (krutoileshii) wrote :

64bit flash is not the only problem there are still closed-source codecs out there that only exist in a 32 bit form.

has (henrik-a-schultz) wrote :

This bug applies to nspluginwrapper under Google Chrome too.
I also second using the 64-bit alpha over the 32-bit wrapped version!
More stable, better performance etc.
At least make it available in the repo's as an option! Like with the wine beta that co-existed with the production one.

giorgio130 (gm89) wrote :

+1 for the "flash-64" package in the repos.

+2 for flash-64 in the repos.

On Sun, Mar 28, 2010 at 12:41 PM, giorgio130 <email address hidden> wrote:

> +1 for the "flash-64" package in the repos.
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Jonathan Aquilina

Johan Ryberg (jryberg) wrote :

+3 for flash-64 in the repos.

2010/3/28 eagles051387 <email address hidden>:
> +2 for flash-64 in the repos.
>
> On Sun, Mar 28, 2010 at 12:41 PM, giorgio130 <email address hidden> wrote:
>
>> +1 for the "flash-64" package in the repos.
>>
>> --
>> npviewer.bin crashed with SIGSEGV
>> https://bugs.launchpad.net/bugs/141613
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>
>
> --
> Jonathan Aquilina
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Pali (pali) wrote :

I have deb package of 64bit flash in my ppa: https://launchpad.net/~pali.rohar/+archive/ppa

Sandy Harris (sandyinchina) wrote :

Just updated Xubuntu 9.10 to 10.04 beta. Only things running are a few terminals, Pidgin & Firefox with many tabs. Plenty of RAM, 4 gigs. No flash on page I was browsing. This did not take Firefox down.

sandy what are you goign to do on pages that do have flash?

On Tue, Mar 30, 2010 at 4:28 AM, Sandy Harris <email address hidden>wrote:

> Just updated Xubuntu 9.10 to 10.04 beta. Only things running are a few
> terminals, Pidgin & Firefox with many tabs. Plenty of RAM, 4 gigs. No
> flash on page I was browsing. This did not take Firefox down.
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/141613
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Jonathan Aquilina

Better (mar94co) on 2010-04-18
Changed in nspluginwrapper (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
djchandler (djchandler) wrote :

Back to +2 after my -1 for flash 64 in the repos. We would be better off to have no flash than force an Alpha on AMD64 users. The need for any plug-in unnecessary soon. Adobe is talking with Google about complete integration into Chrome. So this bug discussion could be renedered moot in the near future.

What Adobe is developing may never become a full-fledged 64-bit product. There's no plug-in for Windows or Mac being developed at all presently. Some features aren't even implemented yet.

Don't force an Alpha down my throat. The 64-bit Alpha isn't faster, and it breaks websites, especially ones that stream video. That can't possibly be better for most end-users. At least Hulu and ESPN 3 work now with the 32-bit plug-in and the wrapper. Take those away and, IMHO, you may as well have no plug-in at all.

Let's either fix nspluginwrapper, or tell people we're going to wait to see what Adobe is going to do.

BTW, what's going on with these previous two posts?

[quote]Changed in nspluginwrapper (Ubuntu):
status: Confirmed → Incomplete[/quote]

[quote]Changed in nspluginwrapper (Ubuntu):
status: Incomplete → Confirmed[/quote]

Simon Ruggier (simon80) wrote :

I think they should both be in there, so people can choose for
themselves what sort of problems they want to experience. I've never
seen any video websites that don't work with the 64-bit plugin, and no
matter what package is in the repositories, you're not being forced to
run anything.

gushi (ubuntu-gushi) wrote :

On Sun, 18 Apr 2010, Simon Ruggier wrote:

> I think they should both be in there, so people can choose for
> themselves what sort of problems they want to experience. I've never
> seen any video websites that don't work with the 64-bit plugin, and no
> matter what package is in the repositories, you're not being forced to
> run anything.

Hulu.

-Dan

--

"Little tramp sits in her room all day, sewing dolls! Children
misbehaving in the basement, and one in the walls, doing his business God
knows where! You children will be the death of me, *sniff*."

'Mommy', The People Under The Stairs

--------Dan Mahoney--------
Techie, Sysadmin, WebGeek
Gushi on efnet/undernet IRC
ICQ: 13735144 AIM: LarpGM
Site: http://www.gushi.org
---------------------------

Simon Ruggier (simon80) wrote :

Alas, since I live outside the US, Hulu works perfectly well at
telling me that I can't watch it, so I couldn't confirm that. Maybe I
will in the future.

giorgio130 (gm89) wrote :

Right, a flash-64 package in the repos isn't going to hurt anyone. No one is speaking about making it the default.

> Right, a flash-64 package in the repos isn't going to hurt anyone.
> No one is speaking about making it the default.

+1

Niklas Herder (herder) wrote :

mån 2010-04-19 klockan 15:40 +0000 skrev Miro Hadzhiev (Хаджиев):
> > Right, a flash-64 package in the repos isn't going to hurt anyone.
> > No one is speaking about making it the default.

+1

--
Niklas Herder | <email address hidden> | +46(0)8-161438
Department of Computer and Systems Sciences
Stockholm University / Royal Institute Of Technology (KTH), Sweden

PGP: 145A6029 - PGP48D1 69F3 FA8E 4B58 74AC 086E D70B AFC6 145A 6029

Stéphane List (slist) wrote :

While listening music on Deezer, firefox becomes unstable after a lot of time (more than 30 minutes), it becomes slow, then the display freezes, my screen is full of white / grey. And after a few seconds, the PC reboots !

I'm using Ubuntu 10.04

Extract of my /var/log/messages :

...
Apr 19 11:19:18 Ubuntu-desktop kernel: [ 724.651464] npviewer.bin[17989]: segfault at ff999ea8 ip 00000000ff999ea8 sp 00000000ffb5537c error 14
Apr 19 11:24:34 Ubuntu-desktop kernel: [ 1040.788621] npviewer.bin[18365]: segfault at ff999ea8 ip 00000000ff999ea8 sp 00000000fff30b4c error 14
Apr 19 11:26:06 Ubuntu-desktop kernel: [ 1132.627558] npviewer.bin[24056]: segfault at ff999ea8 ip 00000000ff999ea8 sp 00000000ffabacdc error 14
Apr 19 11:28:27 Ubuntu-desktop kernel: Kernel logging (proc) stopped.
Apr 19 11:28:27 Ubuntu-desktop rsyslogd: [origin software="rsyslogd" swVersion="4.2.0" x-pid="551" x-info="http://www.rsyslog.com"] exiting on signal 15.
Apr 19 12:32:39 Ubuntu-desktop kernel: imklog 4.2.0, log source = /proc/kmsg started.
Apr 19 12:32:39 Ubuntu-desktop rsyslogd: [origin software="rsyslogd" swVersion="4.2.0" x-pid="823" x-info="http://www.rsyslog.com"] (re)start
Apr 19 12:32:39 Ubuntu-desktop rsyslogd: rsyslogd's groupid changed to 102
Apr 19 12:32:39 Ubuntu-desktop rsyslogd: rsyslogd's userid changed to 101
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] Initializing cgroup subsys cpuset
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] Initializing cgroup subsys cpu
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] Linux version 2.6.32-21-generic (buildd@yellow) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 (Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2)
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=3042a777-a192-4275-bca3-55ad0599f0fc ro quiet splash
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] KERNEL supported cpus:
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] Intel GenuineIntel
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] AMD AuthenticAMD
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] Centaur CentaurHauls
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] BIOS-provided physical RAM map:
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] BIOS-e820: 0000000000000000 - 000000000009b000 (usable)
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] BIOS-e820: 000000000009b000 - 00000000000a0000 (reserved)
Apr 19 12:32:39 Ubuntu-desktop kernel: [ 0.000000] BIOS-e820: 00000000000e4000 - 0000000000100000 (reserved)
...

Henrik Binggl (henrik-binggl) wrote :

Found a hint in the fedoraforums. Basically saying that this could be related because of other video plugins interference.

    http://www.fedoraforum.org/forum/showthread.php?t=174927&highlight=npviewer&page=3

In combination with the installation instructions for the native 64bit flash player of

    http://ubuntuforums.org/showthread.php?t=1358591

I could "solve" the problem for me.

> Right, a flash-64 package in the repos isn't going to hurt anyone.
> No one is speaking about making it the default.

+1

Tom Slominski (tomslominski) wrote :

For me, Flash Player sometimes displays a grey box on YouTube, but the sound is still playing. And often after about 4 seconds of the video, it restarts it and then just works fine. Weird.

Changed in nspluginwrapper (Mandriva):
importance: Unknown → Critical
Changed in nspluginwrapper (Ubuntu):
status: Confirmed → Triaged
Displaying first 40 and last 40 comments. View all 274 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.