npviewer.bin crashed with SIGSEGV

Bug #178038 reported by Chris Halse Rogers
This bug report is a duplicate of:  Bug #141613: npviewer.bin crashed with SIGSEGV. Edit Remove
This bug affects 3007 people
Affects Status Importance Assigned to Milestone
nspluginwrapper
Invalid
Undecided
Unassigned
nspluginwrapper (Ubuntu)
Triaged
Medium
Unassigned
Nominated for Karmic by wolfen69
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: nspluginwrapper

nspluginwrapper crashed when loading firefox 3.0 with a bunch of tabs open from last time. Many of the tabs contained arstechnica pages with embedded flash; one of these (or possibly trying to load all of them at once) is probably a good candidate culprit.

This seems to happen reliably when there are multiple flash objects, either on a single page or in multiple tabs. It doesn't seem to happen with just a single flash object.

ProblemType: Crash
Architecture: amd64
Date: apr 2009
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
NonfreeKernelModules: nvidia
Package: nspluginwrapper 0.9.91.5-1ubuntu1
PackageArchitecture: amd64
ProcCmdline: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin --plugin /usr/lib/flashplugin-nonfree/libflashplayer.so --connection /org/wrapper/NSPlugins/libflashplayer.so/13238-1
ProcCwd: /home/raof
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/zsh
Signal: 11
SourcePackage: nspluginwrapper
StacktraceTop:
 g_object_newv () from /usr/lib32/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib32/libgobject-2.0.so.0
 g_object_new () from /usr/lib32/libgobject-2.0.so.0
 gdk_pixbuf_new_from_data ()
 gdk_pixbuf_new () from /usr/lib32/libgdk_pixbuf-2.0.so.0
Title: npviewer.bin crashed with SIGSEGV in g_object_newv()
Uname: Linux CowboyLaputopu 2.6.24-2-generic #1 SMP Thu Dec 20 17:58:55 GMT 2007 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse kvm lpadmin netdev plugdev powerdev pulse-rt sambashare scanner tape video
SegvAnalysis:
 Segfault happened at: 0xf7b088ac <g_object_newv+668>: movl $0x0,(%edi)
 PC (0xf7b088ac) ok
 source "$0x0" ok
 destination "(%edi)" (0xffffffec) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA

Revision history for this message
Chris Halse Rogers (raof) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:g_object_newv () from /usr/lib32/libgobject-2.0.so.0
g_object_new_valist () from /usr/lib32/libgobject-2.0.so.0
g_object_new () from /usr/lib32/libgobject-2.0.so.0
gdk_pixbuf_new_from_data () from /usr/lib32/libgdk_pixbuf-2.0.so.0
gdk_pixbuf_new () from /usr/lib32/libgdk_pixbuf-2.0.so.0

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Revision history for this message
Apport retracing service (apport) wrote : Stack trace with source code
Changed in nspluginwrapper:
importance: Undecided → Medium
description: updated
Revision history for this message
indy (somik-raha) wrote : Re: npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash objects are playing simultaneously

My browser crashes each time I go to www.chipotle.com
AMD65, Firefox, nspluginwrapper

Revision history for this message
The Marauder (arn-epsilon) wrote :

Same problem with kubuntu gutsy since new maj of flashplayer.

And the flashplugin-nonfree package was no usable, I had to install this plugin from the official web site.

Revision history for this message
Christian Kellner (gicmo) wrote :

Same problem here, and not related to playing multiple files.

Revision history for this message
Dave Morley (davmor2) wrote :

ditto. I'm going to try the same thing on 32bit though and see if it is still an issue.

Revision history for this message
Nizar Kerkeni (nizarus) wrote :

same bug in hardy alpha4 on amd64

Revision history for this message
Wolfgang Glas (wglas) wrote :

same bug in hardy alpha4 on amd64, all packages up-to-date, using firefox-3.0-b3

Revision history for this message
Stefan Friesel (stefan-friesel) wrote :

same bug here in hardy alpha4 on amd64

Revision history for this message
rubenvb (vanboxem-ruben-deactivatedaccount) wrote :

I can confirm on hardy amd64

Revision history for this message
Stefan Ebner (sebner) wrote :

Can somebody test if new Debian revision fixed the issue? Here the amd64 deb so far:

http://launchpadlibrarian.net/12234800/nspluginwrapper_0.9.91.5-2ubuntu1_amd64.deb

Revision history for this message
nudepenguin (clintbrothers) wrote :
Revision history for this message
Matteo Dell'Amico (della) wrote :

I solved the problem on Gutsy by compiling the Debian source. If you want the 7.10 .deb, drop a mail at della(at)linux.it.

Revision history for this message
techitrucker (brian-j-sheehan) wrote : Re: [Bug 178038] Re: npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash objects are playing simultaneously

That would be great. If you could send it too this email I would
really appreciate it. Thanks.

Brian sheehan

On 3/6/08, Matteo Dell'Amico <email address hidden> wrote:
> I solved the problem on Gutsy by compiling the Debian source. If you
> want the 7.10 .deb, drop a mail at della(at)linux.it.
>
> --
> npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash
> objects are playing simultaneously
> https://bugs.launchpad.net/bugs/178038
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sent from Gmail for mobile | mobile.google.com

Brian J Sheehan
Sheehan Specialized Transport

Revision history for this message
Dara Adib (daradib) wrote : Re: npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash objects are playing simultaneously

I don't have this current bug, but I do think it would be beneficial for others if you attach the debian file (and its source) to this bug report, or provide a link. Thank you.

Revision history for this message
Lorenzo Chiesa (lorenzo-chiesa) wrote :

Thanks to Matteo for the info.
I have compiled the debian source from http://packages.debian.org/source/sid/nspluginwrapper for Gutsy and works for me.
I attach the file. Use at your own risk.

Revision history for this message
Stefan Ebner (sebner) wrote :

My attached (testing) package now finally hits the repos within the next hours ... :)

Revision history for this message
damvcoool (damvcoool) wrote :

attaching Crash file

Revision history for this message
Dean Owensby (dean-owensby) wrote :

still broken

Revision history for this message
John Pham (jhnphm) wrote :

Downgraded to the one in Debian, 0.9.91.5-2, works now. 0.9.91.5-2ubuntu1 is broken.

Revision history for this message
John Pham (jhnphm) wrote :

Nevermind, still broken.

Revision history for this message
Hew (hew) wrote :

Confirming this bug based on having a number of duplicates.

Changed in nspluginwrapper:
status: New → Confirmed
Revision history for this message
gissi (zerinol) wrote :

also afects jounty beta

Revision history for this message
dirk (dirkmeissner72) wrote : Re: [Bug 178038] Re: npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash objects are playing simultaneously

http://everflux.de/java-6u12-bringt-64bit-plugin-fur-ubuntu-linux-947/

-----Ursprüngliche Mitteilung-----
Von: gissi <email address hidden>
An: <email address hidden>
Verschickt: Mo., 30. Mrz. 2009, 19:03
Thema: [Bug 178038] Re: npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash objects are playing simultaneously

also afects jounty beta

--
npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash objects
are playing simultaneously
https://bugs.launchpad.net/bugs/178038
You received this bug notification because you are a direct subscriber
of the bug.

Status in “nspluginwrapper” source package in Ubuntu: Confirmed

Bug description:
Binary package hint: nspluginwrapper

nspluginwrapper crashed when loading firefox 3.0 with a bunch of tabs open from
last time. Many of the tabs contained arstechnica pages with embedded flash;
one of these (or possibly trying to load all of them at once) is probably a good
candidate culprit.

This seems to happen reliably when there are multiple flash objects, either on a
single page or in multiple tabs. It doesn't seem to happen with just a single
flash object.

ProblemType: Crash
Architecture: amd64
Date: Sat Dec 22 12:57:07 2007
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
NonfreeKernelModules: nvidia
Package: nspluginwrapper 0.9.91.5-1ubuntu1
PackageArchitecture: amd64
ProcCmdline: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin --plugin
/usr/lib/flashplugin-nonfree/libflashplayer.so --connection /org/wrapper/NSPlugins/libflash
player.so/13238-1
ProcCwd: /home/raof
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/zsh
Signal: 11
SourcePackage: nspluginwrapper
StacktraceTop:
 g_object_newv () from /usr/lib32/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib32/libgobject-2.0.so.0
 g_object_new () from /usr/lib32/libgobject-2.0.so.0
 gdk_pixbuf_new_from_data ()
 gdk_pixbuf_new () from /usr/lib32/libgdk_pixbuf-2.0.so.0
Title: npviewer.bin crashed with SIGSEGV in g_object_newv()
Uname: Linux CowboyLaputopu 2.6.24-2-generic #1 SMP Thu Dec 20 17:58:55 GMT 2007
x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse kvm lpadmin netdev
plugdev powerdev pulse-rt sambashare scanner tape video

________________________________________________________________________
AOL eMail auf Ihrem Handy! Ab sofort können Sie auch unterwegs Ihre AOL email abrufen. Registrieren Sie sich jetzt kostenlos.

Revision history for this message
Blake Munro (blake-munro) wrote : Re: [Bug 178038] Re: npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash objects are playing simultaneously
Download full text (3.2 KiB)

I think you posted that link in good spirit and to try and help others, but
unfortunately it looks to have backfired on you:

Forbidden

You don't have permission to access
/java-6u12-bringt-64bit-plugin-fur-ubuntu-linux-947/ on this server.

2009/3/31 dirk <email address hidden>

> http://everflux.de/java-6u12-bringt-64bit-plugin-fur-ubuntu-linux-947/
>
>
>
>
>
> -----Ursprüngliche Mitteilung-----
> Von: gissi <email address hidden>
> An: <email address hidden>
> Verschickt: Mo., 30. Mrz. 2009, 19:03
> Thema: [Bug 178038] Re: npviewer.bin crashed with SIGSEGV in
> g_object_newv() when multiple flash objects are playing simultaneously
>
>
>
>
>
>
> also afects jounty beta
>
> --
> npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash
> objects
> are playing simultaneously
> https://bugs.launchpad.net/bugs/178038
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “nspluginwrapper” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: nspluginwrapper
>
> nspluginwrapper crashed when loading firefox 3.0 with a bunch of tabs open
> from
> last time. Many of the tabs contained arstechnica pages with embedded
> flash;
> one of these (or possibly trying to load all of them at once) is probably a
> good
> candidate culprit.
>
> This seems to happen reliably when there are multiple flash objects, either
> on a
> single page or in multiple tabs. It doesn't seem to happen with just a
> single
> flash object.
>
> ProblemType: Crash
> Architecture: amd64
> Date: Sat Dec 22 12:57:07 2007
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
> NonfreeKernelModules: nvidia
> Package: nspluginwrapper 0.9.91.5-1ubuntu1
> PackageArchitecture: amd64
> ProcCmdline: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin --plugin
> /usr/lib/flashplugin-nonfree/libflashplayer.so --connection
> /org/wrapper/NSPlugins/libflash
> player.so/13238-1
> ProcCwd: /home/raof
> ProcEnviron:
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_AU.UTF-8
> SHELL=/bin/zsh
> Signal: 11
> SourcePackage: nspluginwrapper
> StacktraceTop:
> g_object_newv () from /usr/lib32/libgobject-2.0.so.0
> g_object_new_valist () from /usr/lib32/libgobject-2.0.so.0
> g_object_new () from /usr/lib32/libgobject-2.0.so.0
> gdk_pixbuf_new_from_data ()
> gdk_pixbuf_new () from /usr/lib32/libgdk_pixbuf-2.0.so.0
> Title: npviewer.bin crashed with SIGSEGV in g_object_newv()
> Uname: Linux CowboyLaputopu 2.6.24-2-generic #1 SMP Thu Dec 20 17:58:55 GMT
> 2007
> x86_64 GNU/Linux
> UserGroups: adm admin audio cdrom dialout dip fax floppy fuse kvm lpadmin
> netdev
> plugdev powerdev pulse-rt sambashare scanner tape video
>
>
>
>
> ________________________________________________________________________
> AOL eMail auf Ihrem Handy! Ab sofort können Sie auch unterwegs Ihre AOL
> email abrufen. Registrieren Sie sich jetzt kostenlos.
>
> --
> npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash
> objects are playing simultaneously
> https://bugs.launchpad.net/bugs/178038
> You received this bug notification because y...

Read more...

gissi (zerinol)
summary: - npviewer.bin crashed with SIGSEGV in g_object_newv() when multiple flash
- objects are playing simultaneously
+ npviewer.bin crashed with SIGSEGV
Revision history for this message
bungow (bungow) wrote :

same here

gissi (zerinol)
description: updated
Revision history for this message
Dim Zoom (dimzoom) wrote :

same bug in jaunty beta up to date. Thanks for all devs !!

Revision history for this message
Raul (raulr) wrote :

Same bug as all here.
I've uploaded the logfile from

sudo valgrind --trace-children=yes --log-file=valgrind.txt --tool=memcheck /usr/bin/firefox

Revision history for this message
Corey (corey-osgood) wrote :

Same bug here on jaunty beta, with "nvidia" graphics.

Revision history for this message
Corey (corey-osgood) wrote :

Oh, and nothing for videos on cbs.com works either, I think it may be related. They work fine on my other computer running 8.10 x64

Revision history for this message
ragnar33 (r-weber-deactivatedaccount) wrote :

Same here Jaunty Beta x64 with Nvidia Geforce 9500GT...

Revision history for this message
drjonze (ken-hamilton13) wrote :

It happened to me at tsn.ca , lots of flash content on their site

Revision history for this message
Chris McCormick (cjmccormick) wrote :

I get this crash periodically

1 comments hidden view all 242 comments
Revision history for this message
vnieto (vnieto) wrote :

I use the native amd64 bit of flash (beta) and work fine.
Some know if the sources version is the 64 version?

Revision history for this message
Kivech (kivech-deactivatedaccount) wrote :

Same problem here with a currently up to date Jaunty. It is not consistant since it doesn't always happen. And definately doen't seem to depend upon the quantity of flash content. At least not in my case. I'm not using any proprietary video drivers on my system.

Revision history for this message
Eli (elitrou) wrote :

Just the same here - using Jaunty beta (64 bit version) on Lenovo SL400 laptop with NVidia graphic card (using 180.44 driver).

Revision history for this message
Knut (knut-knutix) wrote :

Same here. Jaunty beta (64 bit version) on Dell E6400 with NVidia (180.44).

Kees Cook (kees)
description: updated
Karun Dambiec (kdambiec)
Changed in nspluginwrapper (Ubuntu):
status: Confirmed → Invalid
Changed in nspluginwrapper (Ubuntu):
status: Invalid → Confirmed
162 comments hidden view all 242 comments
Revision history for this message
bwallum (rbw2) wrote :

Lucid Aplha at 16/3/10 - crashed upon exit of Firefox (with flash components on the page).

Revision history for this message
wjm (wjayemm) wrote :

Lucid Alpha 3 x64 - crashes on exit with just Google.com open.

Revision history for this message
djchandler (djchandler) wrote :

Crashed while running Lucid Beta 1, Google Chrome Beta 5.0.307.11, and viewing email on AT&T/Yahoo and attempting to alphabetize by sender. Also the workspace switcher disappeared simultaneously.

The page is over-the-top scripted and draws on many resources. I actually hate it for those reasons and only visit it once a week to check its spam filter for wanted email.

For all I know this could have more to do with Chrome problems than Lucid.

Revision history for this message
bhachech (bhachech) wrote :

Crashed while running Lucid Beta 1, Firefox 3.6, while trying to close a reader.google.com tab displaying a blog with embedded flash components.

Revision history for this message
PresuntoRJ (fabio-tleitao) wrote :

crashed on 10.04 beta1 closing a youtube tab

Revision history for this message
Josh Anders (cybiko123) wrote :

Crashed on Lucid beta 1 on YouTube

Revision history for this message
Ed Coles (edicoles) wrote :

This happened to me on the Lucid Lynx AMD64 beta as well using Google Chrome

Revision history for this message
Adam Michael Roach (adammichaelroach) wrote :

Crashed on Lucid Beta1 64-bit

Revision history for this message
Miroslav Hadzhiev (xtigyro) wrote :

Off-topic:

This is one of the bugs, which has made me use 32-bit Ubuntu again.

Changed in nspluginwrapper (Ubuntu):
assignee: nobody → A. Hunt (anthonyhunt55)
Revision history for this message
notoriousdbp (david-baird-parker) wrote :

Just had a report of this happening on Lucid Beta. The official release of 64-bit flash can't be too far away now surely?

Revision history for this message
Greg666 (gregory-bekkers) wrote : RE: [Bug 178038] Re: npviewer.bin crashed with SIGSEGV

happens all the time..
we're working on it.

> Date: Fri, 2 Apr 2010 07:46:19 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 178038] Re: npviewer.bin crashed with SIGSEGV
>
> Just had a report of this happening on Lucid Beta. The official release
> of 64-bit flash can't be too far away now surely?
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/178038
> You received this bug notification because you are a direct subscriber
> of the bug.

_________________________________________________________________
Download gratis emoticons voor Messenger
http://www.rulive.nl/aspx/emoticons.aspx

Revision history for this message
wdesmet (kromagg) wrote :

AFAIK the latest 64 bit flash player is still an alpha version and doesn't seem to have had much in the way of updates(? not sure). In any case, before it can go to full release it still has to enter beta. Considering the 32 bit flash player 10.1 is currently at beta 3, a 64 bit version would probably also need to go through 3 beta stages. Since the beta process takes months, I do not think an official release of 64 bit flash is close. Especially considering adobe only has a single developer working on linux flash, AFAIK.

So it is important to try and either fix up the 32 bit embedded version of the player (or write a new one ourselves), since it will definitely be around for quite a while.

NB: I believe this bug is reported upstream as https://bugs.adobe.com/jira/browse/FP-2609

Revision history for this message
vnieto (vnieto) wrote :

I using the 64 bit versión and i don't hace any ussiu. With 32 bits
versión i have several problems

Enviado desde mi iPod

El 2/04/2010, a las 3:26 a.m., wdesmet <email address hidden> escribió:

> AFAIK the latest 64 bit flash player is still an alpha version and
> doesn't seem to have had much in the way of updates(? not sure). In
> any
> case, before it can go to full release it still has to enter beta.
> Considering the 32 bit flash player 10.1 is currently at beta 3, a 64
> bit version would probably also need to go through 3 beta stages.
> Since
> the beta process takes months, I do not think an official release of
> 64
> bit flash is close. Especially considering adobe only has a single
> developer working on linux flash, AFAIK.
>
> So it is important to try and either fix up the 32 bit embedded
> version
> of the player (or write a new one ourselves), since it will definitely
> be around for quite a while.
>
> NB: I believe this bug is reported upstream as
> https://bugs.adobe.com/jira/browse/FP-2609
>
> --
> npviewer.bin crashed with SIGSEGV
> https://bugs.launchpad.net/bugs/178038
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.

Revision history for this message
Mathew Hennessy (ubuntu-unixslave) wrote :

I am getting this when using Chromium on Lucid.

Revision history for this message
brentpieczynski (brentpieczynski) wrote :

You might need to go to the Ubuntu support place at the main site then forward this message to every e-mail address on that web-site along with the related projects. The situation might not be a technology problem instead it might be, a people problem.

This place known as the Linux Outlaws will need to know what you have done while following my advice, along with your sending the blame for the advice to me in the event that some people do become angry. Those people at the Linux Outlaws do need some interesting story even if it will embarrass some people, such as being about neglected individuals with a need to unsubscribe.

--- On Sun, 2/21/10, Uncle Spellbinder <email address hidden> wrote:

From: Uncle Spellbinder <email address hidden>
Subject: [Bug 178038] Re: npviewer.bin crashed with SIGSEGV
To: <email address hidden>
Date: Sunday, February 21, 2010, 6:20 PM

This is getting old. I'd like to unsubscribe but it's not letting me. If
an admin is reading, PLEASE unsubscribe me.

Thanks.

--
npviewer.bin crashed with SIGSEGV
https://bugs.launchpad.net/bugs/178038
You received this bug notification because you are a direct subscriber
of the bug.

Arturs (artursj11)
Changed in nspluginwrapper (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
deotix (giulio-saletti) wrote :

Also on 10.04

Revision history for this message
Rolando Blanco (rolando) wrote :

I did have the same but, was in Chrome Ubuntu LL (10.04) Beta 2 when visit the www.miniusa.com

Revision history for this message
JosephB (joseph-bouchard) wrote :

This was fixed for a while, but seems to be back again. Go to any flash embedded site, instant crash of nspluginwrapper.

Ubuntu 10.04 Lucid amd64

nspluginwrapper:
  Installed: 1.2.2-0ubuntu6

firefox:
  Installed: 3.6.3+nobinonly-0ubuntu2

Shockwave Flash

    File: npwrapper.libflashplayer.so
    Version:
    Shockwave Flash 10.0 r45

Revision history for this message
Andrew (adhenry) wrote :

me too...

Ubuntu 10.04 Lucid amd64 beta2 with daily updates. Still crashing as per JosephB's comments.

Revision history for this message
Randy Barlow (rbarlow) wrote :

I also just experienced the crash again.

Changed in nspluginwrapper (Ubuntu):
status: Fix Released → Incomplete
Revision history for this message
rew (r-e-wolff) wrote :

I don't think it "always" crashes as JosephB says. At least not here. I was browsing "There I fixed it" or something like that. (Maybe it crashed the moment I clicked away from the homepage of "failblog.org" after playing one embedded video. )

I'm thinking I might have seen firefox hang and/or crash on i386 in similar cases. However it seems this happens more often on amd64 than I see the hangs on i386...

At least this isn't fatal to firefox, so it feels better.....

Revision history for this message
Wes Barnett (wes-barnett) wrote :

Just had this crash on AMD64 of Lucid Beta2 with daily upgrades using Chromium.

Ssaha (shinjansaha)
Changed in nspluginwrapper (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Daniel (hackie) wrote :

I did not read the above comments, but here my 10c:

1) I think ndiswrapper should fork sometime so a crash does not affect all pages (like apache does in some worker threads: simply fork for each 10 applets or for each different applet(even better) ). when forking for different applets, we can also see the bad plugin in a particular case

2) If the/an ndiswrapper instance is gone because of some errors, the browser part of ndiswrapper should be able to start a new instance to fill the applet area again at lest when the user opens a new page or presses F5. This will generally improve stability, even for users running i386 which are not forced to used ndiswrapper yet.

3) as Rolf Leggewie already mentioned, for me Bug 178038 and Bug 141613 are dupes

Revision history for this message
GNUbie (gnubie) wrote :
  • Logs Edit (22.1 KiB, application/x-tar)

Hello all,

I'm also having this problem. I first posted my problem to the mailing list <https://lists.ubuntu.com/archives/ubuntu-users/2010-June/221205.html>. Kindly check the attached compressed logs for more information.

On the side note, anybody knows if on the other GNU/Linux distributions also have this problem?

Thank you in advance.

Regards,

GNUbie

Revision history for this message
Stew Ellis (ellis-kettering) wrote :

I have the latest version of flash talked about at

https://launchpad.net/ubuntu/karmic/+source/flashplugin-nonfree/10.1.53.64ubuntu0.9.10.1

It was installed with synaptic.

and I still get imbedded flash crashes, particularly at eWeek slide shows such as:

http://www.eweek.com/c/a/Mobile-and-Wireless/10-Laptop-and-Netbook-Alternatives-to-the-Apple-iPad-553015/?kc=EWKNLSTE06222010MOSTREAD1

It obviously needs to be on one line, but this comment box shows it split.

I have uninstalled gnash and any other flash libs, but here is what is in the nsplugin dirs:

/usr/lib/nspluginwrapper/:
dirs.d/ i386/ noarch/ plugins/ x86_64/

/usr/lib/nspluginwrapper/dirs.d:
flashplugin-installer

/usr/lib/nspluginwrapper/i386:
linux/

/usr/lib/nspluginwrapper/i386/linux:
libnoxshm.so libxpcom.so npviewer* npviewer.bin*

/usr/lib/nspluginwrapper/noarch:
npviewer*

/usr/lib/nspluginwrapper/plugins:
npwrapper.nppdf.so*

/usr/lib/nspluginwrapper/x86_64:
linux/

/usr/lib/nspluginwrapper/x86_64/linux:
npconfig* npplayer* npwrapper.so

Revision history for this message
Dooitze de Jong (dooitze) wrote :

The problem is in Ubuntu Maverick too

Revision history for this message
Glen Ditchfield (gjditchfield) wrote :

I see this problem every few hours, when viewing web sites with rekonq in Kubuntu Maverick.

Revision history for this message
Bruce Kearns (brkearns67) wrote :

I encountered this bug in both Lucid and Maverick, but the issue with flash on 64 bit systems is well known. Adobe Labs has released a new 64 bit version (alpha-level) of Flash for all platforms.

http://labs.adobe.com/downloads/flashplayer10.html

I removed the default flash that came with the Maverick upgrade and followed the instructions for installing the Adobe Square release. No further crashes with the npviewer and libflashplayer. The Square release does not use nswrapper.

Revision history for this message
Matthew Woerly (nattgew) wrote :

Thanks for the Adobe link!!! The old 64-bit plugin worked great, but they discontinued it and I had to go back to the nspluginwrapper solution which crashes. I will try the new version.

Ílson Bolzan (ilbolzan)
Changed in nspluginwrapper:
status: New → Invalid
Changed in nspluginwrapper (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Please do not change the status without knowing the meaning of the change. By moving this to incomplete, you are asking for more information for the developers to begin working to resolve the issue. If more information is needed, you must comment as to what that information is. Otherwise, in approximately 60 days, the bug will move to EXPIRED status, and no longer be looked at. Thanks.

Changed in nspluginwrapper (Ubuntu):
status: Incomplete → Triaged
Revision history for this message
KevinM (kevbert1) wrote :

I'm getting this problem with Lucid 64bit kernel 2.6.32-28-generic #55-Ubuntu SMP Mon Jan 10 23:42:43 UTC 2011 x86_64 GNU/Linux with all updates installed.

From message log:
Feb 22 14:47:28 kevin-dt1b pulseaudio[1922]: ratelimit.c: 37 events suppressed
Feb 22 14:47:33 kevin-dt1b pulseaudio[1922]: ratelimit.c: 2 events suppressed
Feb 22 14:47:57 kevin-dt1b kernel: [ 83.807669] Clocksource tsc unstable (delta = -197896334 ns)
Feb 22 15:44:57 kevin-dt1b kernel: [ 3503.762731] __ratelimit: 15 callbacks suppressed
Feb 22 15:44:57 kevin-dt1b kernel: [ 3503.762737] npviewer.bin[2606]: segfault at f03ae256 ip 00000000f5eabd33 sp 00000000fff33f80 error 4 in libflashplayer.so[f5e51000+b5f000]
The PC is left unattended as I run BOINC in the background and the PC powers down. This is repeatable and occurs after approximately 1 hour of me not accessing the PC .

Revision history for this message
xteejx (xteejx-deactivatedaccount) wrote :

Please don't assign yourself unless you are actively developing for this. In other words, if you don't know what you're doing, leave it alone :)

Changed in nspluginwrapper (Ubuntu):
assignee: A. Hunt (anthonyhunt55) → nobody
Revision history for this message
Davor Cubranic (cubranic) wrote :

Can this be marked a duplicate of #141613 please?

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Do the stack traces match ? Please give the actual bug number that you believe this to be a duplicate of. #141613 is not valid.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Revision history for this message
Atanas Atanasov (thenasko) wrote :

     rfgf

Revision history for this message
phiscribe (dcbevins) wrote :

I had this with Kubuntu 11.04 with the Chrome web browser.

It would eat all my memory over maybe 2 hours, (5gb) then would segfault.

But now is doing fine. I also had crazy behavior from my cdrom and dvd drives. The would spin for no reason, like refreshing. I was getting high cpu usage from jbd2, and gvfs-gdu-volume. Usb thumb drives would be continually read.

Practical ever app I would launch was spitting out QNotify and ibus errors from terminal, the gui one's that is.

Only thing I can think of was I installed ibus. I created manual y folders for ibus in home/user/.config/ibus/bus.

I went into Locales and set the default locale to en-us and the input method to ibus-kde. It seemed to clear dozens of problems.

1 comments hidden view all 242 comments
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

(^o^)

Displaying first 40 and last 40 comments. View all 242 comments or add a comment.
This report contains Public information  
Everyone can see this information.

Other bug subscribers