Brightness notification works only with Human Icons

Bug #344385 reported by Mike Basinger on 2009-03-17
64
This bug affects 4 people
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
Medium
Unassigned
Nominated for Karmic by Claudio Moretti

Bug Description

notify-osd does not show the brightness notification unless the icon theme is set to Human.

WORKAROUND: "sudo ln -s /usr/share/icons/Human/scalable/status/notification-display-brightness-*.svg /usr/share/notify-osd/icons/hicolor/scalable/status/"

dbasinge@mikebuntu:~$ apt-cache policy notify-osd
notify-osd:
  Installed: 0.9.5-0ubuntu1
  Candidate: 0.9.5-0ubuntu1
  Version table:
 *** 0.9.5-0ubuntu1 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Related branches

Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. This seems to be because notify-osd doesn't ship a complete equivalent set of icons in /usr/share/notify-osd

Changed in notify-osd (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in notify-osd:
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

Human ships the following brightness related icons:

notification-display-brightness-full
notification-display-brightness-high
notification-display-brightness-low
notification-display-brightness-medium
notification-display-brightness-off

Whereas notify-osd only ships a single icon:

notification-display-brightness.

I suspect that is probably the issue, although I don't have a laptop with brightness keys to test. Mike - perhaps you could create some symlinks in /usr/share/notify-osd just to verify that?

Michael Rooney (mrooney) wrote :

Chris, I've created symlinks for those files to notification-display-brightness.svg (which won't display the right thing certainly, but should display an icon at least I believe), but I still don't see anything for brightness.

lrwxrwxrwx 1 root root 35 2009-03-17 11:17 notification-display-brightness-full.svg -> notification-display-brightness.svg
lrwxrwxrwx 1 root root 35 2009-03-17 11:17 notification-display-brightness-high.svg -> notification-display-brightness.svg
lrwxrwxrwx 1 root root 35 2009-03-17 11:17 notification-display-brightness-low.svg -> notification-display-brightness.svg
lrwxrwxrwx 1 root root 35 2009-03-17 11:17 notification-display-brightness-medium.svg -> notification-display-brightness.svg
lrwxrwxrwx 1 root root 35 2009-03-17 11:18 notification-display-brightness-off.svg -> notification-display-brightness.svg
-rw-r--r-- 1 root root 11583 2009-03-17 05:42 notification-display-brightness.svg

Michael Rooney (mrooney) wrote :

I also tried linking in the icons from /usr/share/icons/Human/scalable/status/, including both notification-display-brightness and notification-keyboard-brightness, but nothing seems to work.

Changing the icon theme to Human however does allow brightness notifications to work, just as a sanity check.

Michael Rooney (mrooney) wrote :

Scratch that, the display-brightness icons work, if you have them ALL (I initially tested with just the full and high figuring it would show notifications in just that zone at least, apparently not).

So for me a "sudo ln -s /usr/share/icons/Human/scalable/status/notification-display-brightness-*.svg /usr/share/notify-osd/icons/hicolor/scalable/status/" makes brightness notifications work.

description: updated
Michael Rooney (mrooney) wrote :

I'll set this to Triaged as we seem to know the solution. Is anyone able to symlink these in for Jaunty? I don't think it would be good to not have brightness notifications working robustly.

Changed in notify-osd (Ubuntu):
status: Confirmed → Triaged
Claudio Moretti (flyingstar16) wrote :

for me, it now works :)

Mirco Müller (macslow) on 2009-03-20
Changed in notify-osd:
assignee: nobody → macslow
importance: Undecided → Medium
Changed in notify-osd (Ubuntu):
assignee: nobody → macslow
status: Triaged → Confirmed
Leonid Selivanov (bravebug) wrote :

For me, it now works too. I think bug fixed.

Changed in notify-osd:
status: Confirmed → Fix Released
assignee: macslow → silvanus
status: Confirmed → Fix Released
assignee: macslow → silvanus
Claudio Moretti (flyingstar16) wrote :

I have found out there's a problem: I can't see the "wireless" icon when I connect or disconnect from a wireless network

Changed in notify-osd:
status: Fix Released → Confirmed
status: Fix Released → Confirmed

Cеливанов, you moved it back to Confirmed, do you still experience the
issue? I ask as I do too; for me brightness notifications still are
not working without the manual workaround I mentioned above.

Leonid Selivanov (bravebug) wrote :

Michael, sorry, I was not careful, I thought that the problem is solved.
But it seems to me that it's not a problem Notify OSD. It is a problem incompleted themes.

David Barth (dbarth) wrote :

Hi,

I cannot reproduce the problem here.

Please verify that you have up to date packages installed:
 * notify-osd-0.9.6-0ubuntu2
 * gnome-power-manager-2.24.2-2ubuntu7
 * human-icon-theme-0.33.4

Logout and login again, if you have done so for a while, just to make sure that the right version is /running/.

Here is the expected behavior:
System -> Appareances -> Theme -> Customize -> Icons -> Human: you should see the Human icons in the notification brightness notification

System -> Appareances -> Theme -> Customize -> Icons -> any other icon set: you should see the default (Tango) icons in the brightness notification

If you still get blank notifications, or notifications without icons, or old notifications: please send a screenshot, or detail what you see on the screen that does not match the expected behavior.

Thanks

Michael Rooney (mrooney) wrote :

David, where are you getting human-icon-theme-0.33.4? That is not the
current version in Jaunty; my updated system and packages.ubuntu.com
both say 0.33.6ubuntu1 is the latest. Other than that my packages
match.

Claudio Moretti (flyingstar16) wrote :

Apart from version 0.33.6ubuntu1 of human-icon-theme, David Barth, that is my configuration.
Here's my screenshots: as you can see, with a non-human icon theme I cannot see wireless-related icons :(

Italian version, but fully understandable IMHO

Human connected/disconnected
http://img210.imageshack.us/img210/2186/connectedhuman.png
http://img210.imageshack.us/img210/6718/disconnectedhuman.png

Snowish connected/disconnected
http://img210.imageshack.us/img210/5333/connectedsnowish.png
http://img210.imageshack.us/img210/2186/connectedhuman.png

Changed in notify-osd (Ubuntu):
milestone: none → ubuntu-9.04
Claudio Moretti (flyingstar16) wrote :

Found out a (simple and stupid) workaround:
sudo mv /usr/share/notify_osd/icons/hicolor/scalable/status /usr/share/notify_osd/icons/hicolor/scalable/status_bak
sudo ln -s /usr/share/icons/Human/scalable/status/ /usr/share/notify_osd/icons/hicolor/scalable/status
and now it works.
(Notice that I already had a symlink between "/usr/share/notify_osd/" and "/usr/share/notify-osd/" that is needed to make icons work)

Michael Rooney (mrooney) wrote :

Claudio, did the already existing one-line workaround in the description not
work for you that you tried that?

Claudio Moretti (flyingstar16) wrote :

It worked in fixing the brightness problem, but not in fixing the wireless icon one.
And neither my workaround completely fixed the problem, because I still cannot see the wireless-connected icon (even if I can see the disconnected one)

Sebastien Bacher (seb128) wrote :

you should really wait for official updates moving directory around this way will break your system and upgrades

Claudio Moretti (flyingstar16) wrote :

I had really not thought about this, and I thank you for pointing it out; I'm moving back the "real" icons folder;
I'll only copy-and-replace files from the Human folder, to the Notify-OSD one. This should not break anything, because icons in those folders are scalable, and icons that do not exist will be replaced from the first update.
Thanks again,
Claudio

Sebastien is right, you should NOT move icons around. Instead make a copy (cp command) or a symlink (ln command).

The following makes a symlink for all the icons.

"sudo ln -s /usr/share/icons/Human/scalable/status/notification-*.svg /usr/share/notify-osd/icons/hicolor/scalable/status/"

Claudio Moretti (flyingstar16) wrote :

As I said, I moved back the right folder and copy-and-pasted all the icons.. I could have done a symlink and I know this, but I preferred just copying, in case I need/want to replace an icon with another.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd - 0.9.7-0ubuntu1

---------------
notify-osd (0.9.7-0ubuntu1) jaunty; urgency=low

  * New upstream version:
    - added and improved multihead support,
      notifications stick to panel whatever the monitor it is on (lp: #331369)
    - crashers fixes (lp: #331927, #349133)
    - enable the icon lookup fallback mechanism for fallback icons like
      notification-display-brightness-* (lp: #344385)
    - reworked parts of notify-osd in order to make it adapt dynamically to
      changes of font-face, font-size and dpi (lp: #339731)
    - ensure X errors will not kill notify-osd
    - use HTML- and markup-filter for title- and body-message-text also
      in fallback-dialog
  * debian/patches/correct_service_install.patch:
    - correctly install the dbus service
  * debian/rules:
    - use simple-patchsys rules

 -- Sebastien Bacher <email address hidden> Sat, 28 Mar 2009 12:45:12 +0100

Changed in notify-osd:
status: Confirmed → Fix Released
Claudio Moretti (flyingstar16) wrote :

I still can't see the "Wireless network connected" icon;
I tried purging (apt-get purge) notify-osd, removing all the work I had done to make it work (symlinks and folders) and reinstalling it, but even if I see new icons, I still can't see that one.

Changed in notify-osd (Ubuntu):
status: Fix Released → Confirmed
Julius Thor (joolli) wrote :

For some reason my volume stopped working the other day. I've tried creating a symlink (ln -s notify-osd notify_osd) but that does not do anything. All packages are up to date. Strange thing is, it was all working fine and then one day it decided to go away. That's about 5 days ago, I believe.

To my knowledge, all other notifications work. Wireless, Pidgin and brightness.

Julius Thor (joolli) wrote :

I thought I would mention that I'm on a ThinkPad T60. Thinkpads have had problems with the volume up and down keys before. However, for the first time they were working correctly and also with notifications after I installed Jaunty, until a few days ago, like I just described in the post before this one.

Mark Shuttleworth (sabdfl) wrote :

@Julius: I think the lack of volume keys on Thinkpad X/T60 is a separate
issue, since the Gnome volume applet isn't seeing the key presses
either. So I've filed #364442 for that.

Tom Harris (tom-harris) wrote :

A lot of icons seem to be missing. Connecting to wireless doesn't display, though oddly disconnecting does. The icon used in the latter case is /usr/share/notify-osd/icons/hicolor/scalable/status/notification-network-wireless.svg. Wouldn't it just be easier to copy all the Canonical supplied icons into the fallback folder. There's 59 notification-* icons in /usr/share/icons/Human/scalable/status and only 19 in /usr/share/notify-osd/icons/hicolor/scalable/status.

I also have to make the point though that the fallback ethernet icon is a hell of a lot better than the Human one. Most people don't know what an ethernet port looks like, adding the cable for context makes a lot of sense.

ggsamm (ggsamm) wrote :

in my case, the Bubble looks like was behind the panel, but only in case of Brightness and Volume, another Notifications works Good.

Rami Al-Rfou' (rmyeid) wrote :

I am running up to date karmic, everything was fine. Till I installed kubuntu according to the failure of logging in I removed kubuntu. However, the brightness bubble is no more working now, instead I still have the kubuntu one. I tried my best to uninstall all kubuntu packages but I still have the old one. I tried the above trick and reinstalling notify-osd without use :(

Changed in notify-osd (Ubuntu):
status: Confirmed → Triaged
Mirco Müller (macslow) wrote :

Under Karmic this is no issue anymore.

Changed in notify-osd:
status: Confirmed → Fix Released
Changed in notify-osd (Ubuntu):
status: Triaged → Fix Released
Changed in notify-osd:
milestone: none → ubuntu-9.10
Changed in notify-osd (Ubuntu):
assignee: Leonid Selivanov (bravebug) → nobody
Changed in notify-osd:
assignee: Leonid Selivanov (bravebug) → nobody
no longer affects: notify-osd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers