No lua 5.2 support

Bug #1324062 reported by Robie Basak
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Fix Released
High
Unassigned
nginx (Ubuntu)
Triaged
Wishlist
Unassigned

Bug Description

We'd like to support lua 5.2 in main only, and move away from 5.1. But some upstreams don't yet have support for lua 5.2 yet.

Related: apache bug 1323930 (lua support regression due to failed move to 5.2) and bug 1262710 (in particular comment 25) for discussion of the same issue with nginx, and of having both lua 5.1 and 5.2 in main.

Robie Basak (racb)
Changed in apache2 (Ubuntu):
importance: Undecided → High
Changed in nginx (Ubuntu):
importance: Undecided → High
Changed in apache2 (Ubuntu):
status: New → Triaged
Changed in nginx (Ubuntu):
status: New → Triaged
Changed in apache2 (Ubuntu):
milestone: none → later
Changed in nginx (Ubuntu):
milestone: none → later
Revision history for this message
Robie Basak (racb) wrote :

Some discussion with upstream nginx here: https://github.com/openresty/lua-nginx-module/issues/343

"If as you said there are quite a few people already using ngx_lua + lua 5.1, then linking against Lua 5.2 will probably break these people's existing Lua code. Lua 5.2 is essentially an incompatible different language."

Changed in nginx (Ubuntu):
assignee: nobody → farhan saleh robleh (farhn)
Changed in apache2 (Ubuntu):
assignee: nobody → farhan saleh robleh (farhn)
Changed in nginx (Ubuntu):
status: Triaged → Confirmed
Changed in apache2 (Ubuntu):
status: Triaged → Confirmed
Thomas Ward (teward)
Changed in apache2 (Ubuntu):
assignee: farhan saleh robleh (farhn) → nobody
status: Confirmed → Triaged
Changed in nginx (Ubuntu):
assignee: farhan saleh robleh (farhn) → nobody
status: Confirmed → Triaged
Changed in apache2 (Ubuntu):
assignee: nobody → farhan saleh robleh (farhn)
Changed in nginx (Ubuntu):
assignee: nobody → farhan saleh robleh (farhn)
Changed in apache2 (Ubuntu):
status: Triaged → Confirmed
Changed in nginx (Ubuntu):
status: Triaged → Confirmed
Thomas Ward (teward)
Changed in apache2 (Ubuntu):
status: Confirmed → Triaged
Changed in nginx (Ubuntu):
status: Confirmed → Triaged
assignee: farhan saleh robleh (farhn) → nobody
Changed in apache2 (Ubuntu):
assignee: farhan saleh robleh (farhn) → nobody
no longer affects: apache2
description: updated
tags: added: airhostess chennai in institute training
affects: apache2 → libbot-training-perl (Ubuntu)
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Was changed to (IMHO) spam about firstflyaviation

Restoring original description:
We'd like to support lua 5.2 in main only, and move away from 5.1. But some upstreams don't yet have support for lua 5.2 yet.

Related: apache bug 1323930 (lua support regression due to failed move to 5.2) and bug 1262710 (in particular comment 25) for discussion of the same issue with nginx, and of having both lua 5.1 and 5.2 in main.

description: updated
tags: removed: airhostess chennai in institute training
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

I found this was reported (but not yet handled and showing up in my triage) in https://answers.launchpad.net/launchpad/+question/677288

Revision history for this message
Andreas Hasenack (ahasenack) wrote :

Nowadays this seems worse, as disco has all 3 main 5.x versions of lua in the repo:
andreas@nsnx:~$ rmadison lua5.1 lua5.2 lua5.3 -s disco
 lua5.1 | 5.1.5-8.1build2 | disco/universe | source, amd64, arm64, armhf, i386, ppc64el, s390x
 lua5.2 | 5.2.4-1.1build1 | disco | source
 lua5.2 | 5.2.4-1.1build1 | disco/universe | amd64, arm64, armhf, i386, ppc64el, s390x
 lua5.3 | 5.3.3-1.1 | disco | source
 lua5.3 | 5.3.3-1.1 | disco/universe | amd64, arm64, armhf, i386, ppc64el, s390x

Revision history for this message
Andreas Hasenack (ahasenack) wrote :

Disco: apache2-bin has mod_lua linked with lua5.2
Cosmic: apache2-bin has mod_lua linked with lua5.2
Bionic: apache2-bin has mod_lua linked with lua5.2
xenial: apache2-bin has mod_lua linked with lua5.1
trusty: apache2-bin has NO mod_lua (see #1323930)

I'm marking the apache2 task as resolved.

Changed in apache2 (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Andreas Hasenack (ahasenack) wrote :

nginx:
trusty: lua 5.1
xenial: lua 5.1
bionic: uses libluajit-5.1.so.2
cosmic: uses libluajit-5.1.so.2
disco: uses libluajit-5.1.so.2

I also quickly grepped the nginx package source in all these ubuntu releases and there is no reference to lua5.2, just lua5.1.

... quick googling ...

Found https://github.com/openresty/lua-nginx-module/issues/343 and https://github.com/openresty/lua-nginx-module/issues/204. Looks like 5.1 it is.

Changed in nginx (Ubuntu):
importance: High → Wishlist
Colin Watson (cjwatson)
no longer affects: libbot-training-perl (Ubuntu)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.