NetworkManager does not reconnect to hidden SSID after reboot -- orinico

Bug #295796 reported by Roman Polach on 2008-11-09
152
This bug affects 25 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Unassigned
Nominated for Intrepid by Andrew G
Nominated for Jaunty by Andrew G
Nominated for Karmic by Buck Evan

Bug Description

Binary package hint: network-manager

In Intrepid final I have set Wireless connection to AP with hidden SSID.
When I choose "Connect to Hidden Wireless Network" and select saved connection name, it connects succesfully.
But after system restart it does not reconnect automatically, so I must choose "Connect to Hidden Wireless Network"
and select saved connection name again after every restart. This is very annoying.

Magnus S (magnuss) wrote :

Hi,

right-click on the network-manager-applet in the panel > Edit connections > wireless tab. Double-click on your connection. There is an option called "Connect automatically", is it checked?

//magnus

Changed in network-manager:
status: New → Incomplete
Roman Polach (rpolach) wrote :

yes, "Connect automatically" is checked.

Changed in network-manager:
status: Incomplete → New
Magnus S (magnuss) wrote :

Ok, in that case we are dealing with a real bug.

Although i am pretty sure it is not related to this bug, it might be good to know what hardware you are using. Please post the output from the following commands:

* lshw -C network
* uname -a
* dpkg -p network-manager

Reboot your computer and login. Wait a few seconds and connect to your wireless network and wait a few more seconds. Please attach your /var/log/syslog file to this bug report.

Thanks in advance.

(setting status back to incomplete since the bug needs to be confirmed by someone else to be fixed)

Changed in network-manager:
status: New → Incomplete

I reported bug #286168 witch has been marked as a duplicate of this bug - I would rather say that it must be opposite. No matter this, I move to this bug...

I have experienced that my issue on reconnecting on reboot or hibernate, seem partly is solved. One night I logged on, at did some other things for a few minutes. When I was back to the computer, KNetworkManager had created a connection. Then I rebooted, and found that it automatically reconnected after a minute or two. Tested this a cuple of times more, and it seems it happens every time. Only testet it with a Intel wireless card yet, and don't know if this works with other chipsets. The time for automatically reconnection, seems a little long comparing with KNM for KDE 3.5.x releases...

Roman Polach (rpolach) wrote :

I have tried few minutes but connection was not established automatically.. I can try wait longer if it helps..

Attaching outputs of
 * lshw -C network
 * uname -a
 * dpkg -p network-manager

Roman Polach (rpolach) wrote :
Roman Polach (rpolach) wrote :
Roman Polach (rpolach) wrote :

attaching last parts of syslog...
login at 20:16
manual connect to network at 20:21

Roman Polach (rpolach) wrote :

note: eth1 is wireless,
eth0 is unused ethernet adapter.

Magnus S (magnuss) wrote :

@ Christiansen:
Welcome:) I moved you here because this bug was about to get more information - and i was right. But you found the bug first - credits to you.
Perhaps you could also follow the steps in comment # 3 above? That way we can compare the logs and output.

@ Roman Polach:
Thanks for the attachments! I'll look into this soon.

Roman Polach (rpolach) wrote :

I am entering some additional information:

1) For that wireless connection I use a WEP key,

2) There is strange behaviour of wired (eth0) connection that can be related to this problem:
    There is an item "Auto eth0" in "Wired" tab in "Network Connection" dialog of nm
    and it is set with "Connect automatically" and "System settings" on.
    When I tried to uncheck "Connect automatically" and "System settings", it gets automatically
    checked again after reboot. When I have completely deleted this "Auto eth0" item,
    it was back after reboot (and with "Connect automatically" and "System settings" checked again).
    Maybe this is related because then I have always two items with "Connect automatically"...

Roman Polach (rpolach) wrote :

Should I clear the INCOMPLETE status to avoid this bug get expired?
https://help.launchpad.net/BugExpiry

Magnus S (magnuss) wrote :

Your wired connection is not related to this issue. NetworkManager is smart, it always chooses the fastest connection. If there is a cable connected it will use it (no reason not to). If there is no cable it tries wifi. If no wifi it tries gsm. One can have many connections set to connect automatically, and NM will choose which connection it thinks is the best.

Setting the status back to "new" is not a good idea. The status is "incomplete" since it has yet to be confirmed by a second person. If nobody can confirm this within 59 days it it likely not to be applicable to Ubuntu in general. https://wiki.ubuntu.com/Bugs/Status

//magnus

Christiansen (happylinux) wrote :

@Magnus S:
Sorry that I'm first reporting back now, but now it seems at this could be WiFi chipset related. As far as I can see Mr. Polach is using a Prism chipset whereas I'm using Intel 2915ABG. I don't know if the very delayed (1-2 min.) auto connect I'm experiencing could be related - further more I'm using WPA1. So I can't decide if there is any idea in supplying any log-output from my setup - or that issue should be reported as a different bug ?.

Magnus S (magnuss) wrote :

@ Christiansen:
It seems to be different bugs, so i unmarked your bug as a duplicate of this one. Your bug report is open.
//magnus

Roman Polach (rpolach) wrote :

Is there any possible workaround?
In Hardy and previous releases there was option to define network connection statically/manually (e.g. outside network manager)
...one could even uninstall network-manager and still has usable network...

Is something that possible in Intrepid? Can I install a static configuration somehow?

Roman Polach (rpolach) wrote :

I found a workaround.. seems that old method still works without change:

filling these informations to /etc/network/interfaces

  iface eth1 inet static
  address ......
  netmask ......
  gateway ......
  wireless-key ......
  wireless-essid .....
  auto eth1

and adding one line to /etc/resolv.conf

  nameserver .....

with disabling networking in network-manager completely
makes me connected all the time :)

Mike Ollington (mike-mro) wrote :

Hello, I'm also experiencing this bug with network manager and an Intel 3945.

Magnus S (magnuss) on 2008-11-29
Changed in network-manager:
status: Incomplete → Confirmed
igarvey (igarvey) wrote :

I am also experiencing this bug. It will not connect to a hidden wireless network automatically, but has no problem connecting manually using "Connect to Hidden Wireless Network..."

Todd S (gtodd69) wrote :

I'm having the same problem. Connecting manually to a hidden wireless network works fine. But the system doesn't automatically connect to that network (the only one in the list) after reboot.

Broadcom 43xx and NDISWrapper

I'll post the requested config files momentarily.

Todd S (gtodd69) wrote :
Todd S (gtodd69) wrote :
Todd S (gtodd69) wrote :
Todd S (gtodd69) wrote :
Charlie Kravetz (charlie-tca) wrote :

Set status to triaged; importance Medium. There is enough information for the developers to begin work. Thanks for helping improve Ubuntu.

Changed in network-manager:
importance: Undecided → Medium
status: Confirmed → Triaged

I also see this. I have added a AP with hidden SSID and I can see no way of connecting to it. Mine is WPA Enterprise with PEAP.

Aha, I didn't see the "Connect to hidden wireless network" until now. Now I can connect :)

Alexander Sack (asac) wrote :

the named drivers/chipset (orinoco, bcm4xxxx, ndiswrapper) are probably not up to scanning of hidden nets.

anyone can test with iwl driver to check if this is a broader issue?

Mike Ollington (mike-mro) wrote :

I experienced this with an Intel 3945. "iwlist scan" would see the unnamed hidden ssid, it seemed (in layman's terms) that network-manager wasn't automatically passing the SSID to wpa-supplicant to probe until you manually pressed "connect to hidden wireless".

Brett K (bretterino) wrote :

I have the same problem running intrepid on a playstation 3. I tried Roman's workaround, but i keep getting a permission denied error when I try to edit or copy/delete the file. How do you disable the administration security feature in order to edit the file? Also, there is no gateway listed in the network information. Is that referred to as Default Route instead?

Samir KHERZI (skherzi) wrote :

Hi, any progress on this topic?
I just upgrade to 8.10 from 8.04, and I have this issue.

Buck Evan (bukzor) wrote :

Confirmed on Jaunty.
2.6.28-13-generic #44-Ubuntu SMP Tue Jun 2 07:57:31 UTC 2009 i686 GNU/Linux

Using Broadcom BCM43XG with wl driver.

Buck Evan (bukzor) wrote :
Buck Evan (bukzor) wrote :
Buck Evan (bukzor) wrote :
basillea (basillea) wrote :

Hey guys,
I have the same issue here. It seems to be either card or driver specific.
http://ubuntuforums.org/showthread.php?t=649769

I have an ASUS M51Sn with a 4965AGN card that does not automatically connect.
Im running 9.04 completely updated using wicd 1.5.9. I have to open wicd then add the hidden network and then hit 'connect'. Connection settings are saved.
I had the same issue using the network-manager.

My house mate has an eeepc with the netbook install who can use network-manager to join automatically.

Wolfgang Fahl (wf-bitplan) wrote :

I'm using 9.10 karmic koala on a Samsung Netbook. I'd like to make my GSM connection available via wifi so I do need two autoconnects - one via the GSM (USB or Bluettooth) and one via WIFI (adhoc). I do get an autoconnect for the GSM via USB. For the second connection I have to manually start with connect to hidden network. Also the DHCP configuration is complaining - it seems the order of things is such that the dhcp server starts before the ip addresses for Bluetooth and WLan get assigned.
I am confused on what the proper method is to get this working. One comment above mentions modifying /etc/network/interfaces to be the "old" method of doing things. So what is the "new" method then?

mozafary (mozafarymohammad) wrote :

This issue affected to Acer4810T laptop with Ubuntu10.04

emarkay (mrk) wrote :

An old Gateway laptop (W730-K8X) with the Broadcomm with b43-fwcutter and ndiswrapper installed. it's a BCM4318 variant.

This is a fresh, updated Lucid install.

The wireless connection is "hidden" and originally I could not get a connection at all, unless I entered "sudo modprobe b43" at each boot. I then added "modprobe b43" to the /etc/rc.local file so at least I get a "there are wireless networks available.. " dialog at each boot, but I still have to click, password, scroll, click each time. The information is there and it works; there is just no "Automatic connection..)

It must have something to do with this particular PC, as there are 3 other wireless "Lucid Ubuntu's" that boot and autoconnect.

Oh and "Connect automatically" and "Available to all users" are both checked. :)

emarkay (mrk) wrote :

This needs to be also nominated for Lucid, and one would think that after 3 years it would have been assigned to someone... :)

emarkay (mrk) wrote :

Been doing some research, confirmed that there is nothing in my "blacklist" file, and I have installed and run B43-fwcutter. bcmwl-kernel-source and bcmwl-modaliases are also installed. The broadcom-sta.. are not. "Modprobe ndswrapper" confirms that that module is not found.

What is strange, is that if I have my wired connection plugged in, it connects (as "normal") to the wired connection, but then it also autoconnects to the Wireless one! The "radar" icon disappears, but I do show 2 "Active network connections", wired and wireless. If I unplug the wired connection, the wireless icon appears and I am still connected wirelessly.

There's a bunch of posts on teh Ubuntu forums on the b43 and theBCM4318, and while many are outdated, and some reference to a few official and "homebrew" sites.

OK, waitaminute - there IS now a "Restricted Driver" on this machine. Activated it and now, we are one step close. I get the "there are wireless networks available" pop-up, and by clicking on it it autoconnects.

This is acceptable to me, but I still would prefer a "no point-and-click" autoconnect, as the other machines do. I am bowing out for now, but there is obviously both a need for this to be addressed in Lucid, and actual "official" page:
https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx
needs to note that this may not "autoconnect" as is now.

gpothier (gpothier) wrote :

Problem still occurs in Natty alpha. Hardware is an Intel WiFi Link 5100:
description: Wireless interface
       product: WiFi Link 5100
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: wlan0
       version: 00
       serial: 00:24:d6:90:d9:50
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=2.6.38-1-generic firmware=8.24.2.12 ip=192.168.1.103 latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:48 memory:c8000000-c8001fff

gpothier,

Please open a new, separate bug using the command "ubuntu-bug network-manager", so we can get all the necessary information to debug this issue.

John Doe (b2109455) wrote :

Same thing happens on Ubuntu 10.10 on Lenovo ThinkPad T410.

Michal Predotka (mpredotka) wrote :

I have the same problem in 11.04 beta. This is my bug report: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/760015

Thomas Hood (jdthood) on 2012-07-13
summary: - [orinoco][intrepid] Network Manager does not reconnect to hidden SSID
- after reboot
+ NetworkManager does not reconnect to hidden SSID after reboot -- orinico
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers