package network-manager-config-connectivity-ubuntu 1.8.4-1ubuntu3 failed to install/upgrade: installed network-manager-config-connectivity-ubuntu package post-installation script subprocess returned error exit status 1

Bug #1742403 reported by Jean-Baptiste Lallement on 2018-01-10
136
This bug affects 49 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Jean-Baptiste Lallement
Artful
Medium
Jean-Baptiste Lallement

Bug Description

[Description]
Installation of network-manager-config-connectivity fails if network-manager is not running.

The patch appends " || true " to force-reload in the postinst script to not fail in this case.

[QA]
Test Case:
1. On a machine without network-manager already install (eg server install) install network-manager-config-connectivity-ubuntu

Expected Result:
It installs successfully with all its dependencies

buckets on errors.u.c
https://errors.ubuntu.com/problem/ff73bf3ac18fbeb732d1d4f6676a15e24e7f7399
https://errors.ubuntu.com/problem/6da94ccacd3e341967667bc1e7b2e83e4ac82026

[Regression potential]
Low to none. If the fix works the package will install, and if it does not work it will still fail to install.

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: network-manager-config-connectivity-ubuntu 1.8.4-1ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-17.20-generic 4.13.8
Uname: Linux 4.13.0-17-generic x86_64
ApportVersion: 2.20.8-0ubuntu6
Architecture: amd64
Date: Wed Jan 10 08:50:17 2018
ErrorMessage: installed network-manager-config-connectivity-ubuntu package post-installation script subprocess returned error exit status 1
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2013-09-03 (1589 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=false
 WWANEnabled=true
PackageArchitecture: all
Python3Details: /usr/bin/python3.6, Python 3.6.4, python3-minimal, 3.6.3-0ubuntu2
PythonDetails: /usr/bin/python2.7, Python 2.7.14+, python-minimal, 2.7.14-2ubuntu1
RelatedPackageVersions:
 dpkg 1.19.0.4ubuntu1
 apt 1.6~alpha5
SourcePackage: network-manager
Title: package network-manager-config-connectivity-ubuntu 1.8.4-1ubuntu3 failed to install/upgrade: installed network-manager-config-connectivity-ubuntu package post-installation script subprocess returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-nm:
 RUNNING VERSION STATE STARTUP CONNECTIVITY NETWORKING WIFI-HW WIFI WWAN-HW WWAN
 running 1.8.4 connected started full enabled enabled disabled enabled enabled

Jean-Baptiste Lallement (jibel) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Changed in network-manager (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Jean-Baptiste Lallement (jibel) wrote :

Patched nm-config-connectivity-*.postinst to not fail if force-reload fails.

description: updated
Changed in network-manager (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
status: Triaged → In Progress
status: In Progress → Triaged
importance: Medium → High
Changed in network-manager (Ubuntu Artful):
importance: Undecided → High
importance: High → Medium
status: New → Triaged
status: Triaged → In Progress
assignee: nobody → Jean-Baptiste Lallement (jibel)
Didier Roche (didrocks) on 2018-01-10
Changed in network-manager (Ubuntu):
status: Triaged → Fix Committed
description: updated

The attachment "network-manager_1.8.4-1ubuntu4.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch

Hello Jean-Baptiste, or anyone else affected,

Accepted network-manager into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.8.4-1ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.8.4-1ubuntu4

---------------
network-manager (1.8.4-1ubuntu4) bionic; urgency=medium

  * Do not fail installation of network-manager-config-connectivity-* if
    network-manager fails to reload (LP: #1742403)

 -- Jean-Baptiste Lallement <email address hidden> Wed, 10 Jan 2018 10:23:38 +0100

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of network-manager from artful-proposed was performed and bug 1746258 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1746258 (not this bug). Thanks!

tags: added: verification-failed
tags: removed: verification-failed
tags: added: verification-failed
tags: added: bot-stop-nagging
removed: verification-failed
To post a comment you must log in.