WiFi networks list disappears (device type not reloaded)

Bug #1574347 reported by Shinjan Saha on 2016-04-24
974
This bug affects 211 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
OEM Priority Project
Critical
Unassigned
network-manager (Ubuntu)
High
Unassigned
Xenial
High
Canonical Desktop Team

Bug Description

************
💥 WARNING 💥
************
If you are still experiencing this bug please don't comment here, but look at these: (https://goo.gl/LdPpYG)

******************
 HOW TO REPRODUCE
******************
Boot the system.

********
 RESULT
********
From time to time, some of these happen:
- The applet doesn't list any wireless network.
- The applet doesn't show the name of the current network.
- The icon shows the wired connection symbol, instead of the wifi one.

*************
 WORK AROUND
*************
(http://askubuntu.com/questions/762198/16-04-lts-wifi-connection-issues)

*****
 FIX
*****
The applet needs to re-read the DEVTYPE after the device name changed.

*******************
 HOW TO TEST A FIX
*******************
In the Terminal application enter:
nmcli dev

If it works, in the line for the wireless device, the TYPE column should be "wifi". If it doesn't it will be "ethernet".

Shinjan Saha (sahashinjan) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Cip Man (cipman-p) wrote :

Same here.
It does the same if the steps to reproduce (2) + (3) are replaced with suspend/wake up.

Cip Man (cipman-p) wrote :

Easier workaround:

sudo systemctl restart network-manager.service

Dragon Ball (dragonballz2k) wrote :

also for me if you go into system settings, and go into network I can you still see the wifi network list.

Changed in network-manager (Ubuntu):
importance: Undecided → High
Shinjan Saha (sahashinjan) wrote :

Is there any ETA for fixing this bug?

Cip Man (cipman-p) wrote :

ETA is with the release of Ballsy Baboon (i.e next ubuntu LTS - 18.04) :):)

Try disabling bluetooth if your system has it and you don't need it. Works for my laptop - now wifi works as it should on suspend or enable/disable wifi. If no luck, search askubuntu, there are some scripts that might fix this for your system.

MBWD (xmbwd) wrote :

This works to reset the wifi temporarily: `sudo systemctl restart network-manager.service`.

The scripts can help fix the wifi resume on suspend issues. However, I have not seen a script that fixes the inability to switch networks on an active wifi connection without it going dead.

Also, on a fresh install, I experienced a fourth problem:

4. Network manager creates a new instance of the network each time it connects to it (e.g., wifi_1; wifi_2; wifi_3. As a result, the user has to input a new password each time.

This bug caused me to roll back to 15.10. Hoping it gets fixed soon.

bford16 (bford16) wrote :

On my machine, the network connection resumes - if I do [nmcli g], I see that the network is connected. For me, the only issue is that the nm-applet reverts to the Ethernet setting (two arrows), and does not show the list of wireless networks available. Are we really going to have to wait TWO YEARS for a fix?

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1574347

tags: added: iso-testing
Shih-Yuan Lee (fourdollars) wrote :

The fix is at https://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=dd4d8b24da29abfc786ce0b3030c74559b93d034.
NetworkManager 1.2.0 in xenial-proposed still has this issue.

Changed in network-manager:
importance: Unknown → Medium
status: Unknown → Fix Released
Jane Atkinson (irihapeti) wrote :

I'm still having the issue on my EeePC 900 after installing NetWorkManager 1.2.0 from xenial-proposed.

hussain (lovalim) wrote :

I m also having the same issue.

Cip Man (cipman-p) wrote :

1.2.0 version was compiled before the fix mentioned in post #11 was released.
In other words, version 1.2.0 *does not* include the patch presumed to fix this bug.

To double check this, compare NetworkManager-1.2.0/src/platform/nm-linux-platform.c in the source archive https://launchpad.net/ubuntu/+archive/primary/+files/network-manager_1.2.0.orig.tar.xz located at https://launchpad.net/ubuntu/+source/network-manager/1.2.0-0ubuntu0.16.04.1
with the diff from https://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=dd4d8b24da29abfc786ce0b3030c74559b93d034

hussain (lovalim) wrote :

The network manager version on my laptop is 1.1.93 how can i update it to 1.2?

Cip Man (cipman-p) wrote :

The recommended method to update packages to proposal versions is described at https://wiki.ubuntu.com/Testing/EnableProposed - note the *selective upgrading*.

Jane Atkinson (irihapeti) wrote :

@Cip Man:

That explains it, then. I'm happy to wait for the patched version to come through.

My current workaround is to add the line

service NetworkManager restart

to /etc/rc.local

hussain (lovalim) wrote :

Thanks friends , but i m not that expert with commands in ubuntu. should i wait @jane, will it auto update once the patched version releases and how u installed 1.2 on ur Eeepc

Jane Atkinson (irihapeti) wrote :

@hussain

I installed 1.2 on my EeePC by enabling the Proposed repository in Software and Updates. This isn't usually recommended for everyone as it can break things, but is useful for testing.

Once the patched version is released and is moved from the Proposed to the regular repository, it will automatically be updated.

hussain (lovalim) wrote :

@Jane

Thank you for the information. but i dont have proposed repository in software and updates.

Cip Man (cipman-p) wrote :

The option is in the Developer tab (last on the right), see this image http://i.imgur.com/CdTRGqF.png

hussain (lovalim) wrote :

@Cip Man

Thank you for the information.

Changed in network-manager (Ubuntu):
assignee: nobody → Aron Xu (happyaron)
Kent Lin (kent-jclin) on 2016-05-10
Changed in oem-priority:
importance: Undecided → Critical
Marcin Sochacki (wanted) wrote :

So is there some Ubuntu package containing the fix already, so that we could test it?

Cip Man (cipman-p) wrote :

No package to test yet.
The good news is that a new source, namely 1.2.2, was just released upstream few hours ago: https://download.gnome.org/sources/NetworkManager/1.2/

Will Cooke (willcooke) on 2016-05-11
tags: added: desktop-trello-import
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu Xenial):
status: New → Confirmed
Aron Xu (happyaron) on 2016-05-12
summary: - WiFi network list disappears from network manager applet
+ [SRU]network-manager
Will Cooke (willcooke) on 2016-05-12
Changed in network-manager (Ubuntu Xenial):
importance: Undecided → High
Aron Xu (happyaron) on 2016-05-12
description: updated

Hello Shinjan, or anyone else affected,

Accepted network-manager into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.2.0-0ubuntu0.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed

That fixes it for me on my T450! Thanks everyone!

tags: added: verification-done
removed: verification-needed
Cip Man (cipman-p) wrote :

It does *not* fix it for me.
On a clean installed Xenial I upgraded from xenial-proposed only the packages related to network-manager. Namely:

$ dpkg -l | grep 1.2.0-0ubuntu0.16.04.2
ii libnm-glib-vpn1:amd64 1.2.0-0ubuntu0.16.04.2
ii libnm-glib4:amd64 1.2.0-0ubuntu0.16.04.2
ii libnm-util2:amd64 1.2.0-0ubuntu0.16.04.2
ii libnm0:amd64 1.2.0-0ubuntu0.16.04.2
ii network-manager 1.2.0-0ubuntu0.16.04.2

No dice. Returning from suspend no networks listed, wired or grayed wifi symbol but the network works.

Cip Man (cipman-p) wrote :

P.S. Just to be thorough, I also followed the 'Steps to reproduce' stated in the bug description and the results are the same as described in 'Problems'.

Perhaps you should also have updated network-manager-gnome package which contains the nm-applet.

I updated both network-manager and network-manager-gnome, then restarted both network-manager and nm-applet and now the problem is gone.

Robert Hooker (sarvatt) wrote :

No luck here either, the indicator is broken after a suspend/resume only showing a wired connection.

ii libnm-glib-vpn1:amd64 1.2.0-0ubuntu0.16.04.2 amd64 network management framework (GLib VPN shared library)
ii libnm-glib4:amd64 1.2.0-0ubuntu0.16.04.2 amd64 network management framework (GLib shared library)
ii libnm-util2:amd64 1.2.0-0ubuntu0.16.04.2 amd64 network management framework (shared library)
ii libnm0:amd64 1.2.0-0ubuntu0.16.04.2 amd64 GObject-based client library for NetworkManager
ii network-manager 1.2.0-0ubuntu0.16.04.2 amd64 network management framework (daemon and userspace tools)
ii libnm-gtk-common 1.2.0-0ubuntu0.16.04.1 all library for wireless and mobile dialogs - common files
ii libnm-gtk0:amd64 1.2.0-0ubuntu0.16.04.1 amd64 library for wireless and mobile dialogs (libnm-glib version)
ii libnma-common 1.2.0-0ubuntu0.16.04.1 all library for wireless and mobile dialogs - common files
ii libnma0:amd64 1.2.0-0ubuntu0.16.04.1 amd64 library for wireless and mobile dialogs (libnm version)
ii network-manager-gnome 1.2.0-0ubuntu0.16.04.1 amd64 network management framework (GNOME frontend)

Cip Man (cipman-p) wrote :

@Alan: network-manager-gnome was already at the latest version, the one mentioned by Robert above. But I also upgraded to everything xenial-proposed had 30 mins ago (thinking maybe you did that) and still no luck.

But this is how I made this version work for me (@Robert, maybe you'd like to test this?):
a. reboot (just to make sure we all start from the same point - I noticed it matters here)
b. open a terminal and $ sudo systemctl restart NetworkManager.service
c. test wifi off/on and suspend/resume - now NM works perfect for me (didn't test AP off/on as I can't do that now).
This workaround also works if between a. and b. you perfom c. to check if it works (which isn't for me).

Sebastien Bacher (seb128) wrote :

the issues reported there could be different one, no point trying to make the SRU perfect before landing or it's never going to move to update, if you still have issue with that new version better to open a new bug and use that for debugging

Marcin Sochacki (wanted) wrote :

For me, the version 1.2.0-0ubuntu0.16.04.2 fixes the issue with wifi not visible after fresh boot. Now it works fine.

Pinghao Qi (feifeiqph) wrote :

I'm running the newest versions in stable, just upgraded the applet yesterday:
network-manager 1.1.93-0ubuntu4
network-manager-gnome 1.2.0-0ubuntu0.16.04.1
For me, the issue is already fixed somehow, without needing to update to proposed.

Cip Man (cipman-p) wrote :

@Pinghao Qi, which issue did the stable version fixed for you, as there are several bug reports merged/duplicated/etc here?

Pinghao Qi (feifeiqph) wrote :

@Cip Man The issue where after disabling and reenabling wifi makes all wifi APs disappear. Mine also does the same when resuming from suspend. After upgrading, both cases above works fine.

hussain (lovalim) wrote :

i checked for update many times since yesterday no update for network manager. my version for network manager is still, network-manager 1.1.93-0ubuntu4.

Cip Man (cipman-p) wrote :

My production box is also updated to the current stable versions (mentioned in post #36) but it still has the issues with vanishing network list & wrong indicator symbol when you turn wifi/AP/suspend off/on (and the workaround in post #33 doesn't work).

tags: added: verification-failed
removed: verification-done
Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
tags: added: verification-done
removed: verification-failed
summary: - [SRU]network-manager
+ [SRU] Re-read the link type if the name changed
tags: added: verification-needed
removed: verification-done
WirelessMoves (gsmumts) on 2016-05-21
Changed in network-manager (Ubuntu Xenial):
status: Fix Committed → Fix Released
tags: added: verification-failed
tags: added: verification-done
removed: verification-failed verification-needed
Aron Xu (happyaron) on 2016-05-25
Changed in network-manager (Ubuntu Xenial):
status: Fix Released → Fix Committed
Changed in network-manager (Ubuntu Xenial):
status: Fix Committed → Fix Released
description: updated
Changed in oem-priority:
status: New → Fix Released
jay patel (jay-patel736) on 2016-07-19
Changed in network-manager (Ubuntu):
assignee: Aron Xu (happyaron) → jay patel (jay-patel736)
45 comments hidden view all 125 comments

I am on 16.04.1, and I too am having this issue. Whenever my laptop (W520) goes into Suspend or Hibernate mode and I boot it back up, the WiFi icon displays the "disconnected" message briefly, and then reconnects--only to display the up and down arrows associated with the Ethernet icon and the Ethernet drop-down menu in the top panel. No SSIDs are shown, and the menu asks me to connect to a WiFi network even though I'm already connected to one.

I have Thinkpad 11 bgn WiFi. Ubuntu displays it as "Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)". Device name is wlp3s0 rather than wlan0.

John M (takenreality) wrote :

Same here Lenovo T530 Intel 6205 wifi adapter.
The work around (sudo systemctl restart network-manager.service) works for me most of the time. Sometimes my machine needs a reboot then a router reboot to reconnect. It's an old router but didn't present any issues before Ubuntu 16LTS install. Hopefully coincidental. Good luck!

Viktor (clicman) wrote :

ubuntu 16.04.1
dpkg -l network-manager*|grep ii
ii network-manager 1.2.0-0ubuntu0.16.04.3 amd64 network management framework (daemon and userspace tools)
ii network-manager-gnome 1.2.0-0ubuntu0.16.04.3 amd64 network management framework (GNOME frontend)
ii network-manager-pptp 1.1.93-1ubuntu1 amd64 network management framework (PPTP plugin core)
ii network-manager-pptp-gnome 1.1.93-1ubuntu1 amd64 network management framework (PPTP plugin GNOME GUI)

Bug still exists.
Lenovo x220
lspci|grep Ne
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

Peter Amaral (amaralpeter) wrote :

Please reopen this defect and mark In Progress or other appropriate status. This bug still affects me on Ubuntu 16.04.1, all latest updates applied. The fix released does not work.

$ lspci | grep Ne
09:02.0 Network controller: Ralink corp. RT2561/RT61 rev B 802.11g

I also lose connectivity intermittently after restarting NetworkManager. Please let us know what information we can provide that will help resolve this defect, it is extremely frustrating and significantly breaks the user's experience in Ubuntu.

I am pretty sure I'm having this problem on a Toshiba Chromebook 2 (CB35-B3340) running 16.04 fully updated as of this week. I get the ethernet up/down arrows, there is no ethernet on this laptop. I also get the state where it is disconnected and not showing any wifi networks. It seems to be related to suspend/wake, but doesn't always happen.

$ lspci |grep -i net
01:00.0 Network controller: Intel Corporation Wireless 7260 (rev bb)

ii network-manager 1.2.0-0ubuntu0.16.04.3 amd64
ii network-manager-gnome 1.2.0-0ubuntu0.16.04.3 amd64
ii network-manager-pptp 1.1.93-1ubuntu1 amd64
ii network-manager-pptp-gnome 1.1.93-1ubuntu1 amd64

Running this got things back to normal:
$ sudo service network-manager restart

This looked noteworthy:

# dmesg |grep iwl
[ 10.658028] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-7260-17.ucode failed with error -2
[ 11.064468] iwlwifi 0000:01:00.0: loaded firmware version 16.242414.0 op_mode iwlmvm
[ 11.545992] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[ 11.546081] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[ 11.546326] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[ 11.771068] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[ 11.777060] iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0
[ 12.285642] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[ 12.285883] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[ 12.491349] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[ 12.491592] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[ 461.381354] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[ 461.381596] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled

armageddon08 (sayak90) wrote :

I can confirm that this problem still exists on my Acer V5-573G.

I am having this problem but in addition nm-applet is often gone from the notifications when my laptop wakes from suspend. I wonder if that is related. I fix it by doing a "killall nm-applet; nohup nm-applet &" but I would rather not have to.

Gaël Rousseau (rodney78310) wrote :

It happens on my Dell Latitude E6430 after I shut down then restart the wifi with the physical switch. Never happened if I shutdown the wifi from the GUI.

This bug is not resolved from my point of view.

Gaël Rousseau (rodney78310) wrote :

Result from the test:

GUI: Enable wifi (normal behaviour)
GUI: Enable network (blank wifi icon, then if I restart I have the ethernet icon)
Physical switch (blank wifi icon, then ethernet icon).

This bug also affects my Toshiba Satellite C645 with a Qualcomm Atheros WiFi card and happens even if the connection is lost abruptly, like when there is a power outage and both the modem and the router shut down.

Yiyao Yu (py-tek) wrote :

Still happening on Dell XPS 14 l421x with Intel Corporation Centrino Advanced-N 6235 (rev 24). Already running network-manager 1.2.0. It seems that the network manager applet wifi icon changes back to the ethernet icon every time the system wakes from sleep.

Yiyao Yu (py-tek) wrote :

More info:
network-manger version: 1.2.0-0ubuntu0.16.04.3
Caused by:
Disabling/Enabling Network via GUI (Blank icon)
Sleep/Hibernate (Ethernet icon)

Stole Kotev (stolekotev) wrote :

I've been trying to fix this network-manager problem for quite some time and guess what. In the it turned out that it isn't a network manager or ubuntu problem at all. It's a 4.4 kernel issue. Just change the kernel. I manually downloaded and installed kernel 4.6, and ... the problem is gone

Brian Murray (brian-murray) wrote :

Could somebody on the desktop team please follow up with this bug?

Changed in network-manager (Ubuntu Xenial):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Aron Xu (happyaron) wrote :

@Brian, I believe the patch should fix mentioned bug, feedbacks shouldn't be the same issue, perhaps another one not addressed yet or kernel issue.

lauricat (lauricat) wrote :

I can report I'm running 16.04.1, AND the latest stable kernel 4.7.4.

Same problem exists.

x220, Intel 6205 wifi.

Surely Ubuntu must be aware of this massive problem?

...
~L

Michael J. Ford (finlstrm) wrote :

Same issue here.

Linux voyager 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]

I also installed the lastest 4.7.x kernel, issue persists...

This is UNACCEPTABLE for an LTS release...

Dea1993 (andrea-deangelis93) wrote :

same issue, on Ubuntu 16.04.1 64bit, and also ubuntu 16.10 beta 2 (updated).

please solve the issue.

If you're seeing the wrong icon in nm-applet, please file *YOUR OWN* new bug report, and write the number here. Me-too's distract developers from being able to understand what the problem is, because many people have slightly different issues that all look similar.

As we understand it, the original bug is fixed, where wireless would be detected as wired on boot. That means it would show the arrows icon, but my other issues can lead to the icon being wrong.

Unless you run 'nmcli dev' and see that the wireless device says "ethernet" beside its name, then you are not seeing this here bug and should open a new bug report.

If you run 'nmcli dev', and you have wireless that is connected, but also wired or some other network device connected and you see the arrows, then it *might* be expected behavior. Wired networks always take precedence over wireless if both are connected. If you still think it's wrong, please file a new bug, and include the output of 'nmcli dev' and 'ip route'.

Ubuntu 16.04 on dell E6430, after upgrade:

- after suspend/resume sometimes the network manager cannot connect (but it tries: it keeps associating/de-associating) [before upgrade, the wifi was broken at this stage, cf below]
dmesg:
[101381.710749] wlan0: authenticate with 42:01:40:59:9f:3c
[101381.712600] wlan0: send auth to 42:01:40:59:9f:3c (try 1/3)
[101381.714512] wlan0: authenticated
[101381.716173] wlan0: associate with 42:01:40:59:9f:3c (try 1/3)
[101381.726242] wlan0: RX AssocResp from 42:01:40:59:9f:3c (capab=0x411 status=0 aid=4)
[101381.728513] wlan0: associated
[101388.076989] wlan0: deauthenticated from 42:01:40:59:9f:3c (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
[101388.104508] cfg80211: World regulatory domain updated:
[101388.104511] cfg80211: DFS Master region: unset
[101388.104512] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)

- if I deactivate and then reactivate the wifi, then it reverts to the old bug (where there is only one network available and nothing happens). sudo service network-manager restart repairs everything...
The bug is still at this point:
[101418.822530] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[101418.869145] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[101423.443499] e1000e: eth0 NIC Link is Down
[101426.202627] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[101426.202873] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[101426.210391] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[101426.210491] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[101426.434605] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[101426.442165] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[101426.442267] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
a problem with the /dev/something, no?

strange...
hope this can be repaired soon. But also in the 14.04 distrib it was sometimes necessary to deactivate/restart the network manager to catch back the signal after resume...
good luck, thanks

Dea1993 (andrea-deangelis93) wrote :

now i'm using ubuntu 16.10 with proposed updates enabled.
Network-Manager is at version 1.2.4-0ubuntu1
and seems that the problem is solved

thanks

Titantux (israel-m-dj) wrote :

Hi, 2 days a go I've updated from 16.04.4 to 16.10 and problem still, as @Dea1993 said got that version, but noticed than restarting just the nm-applet, bring to me all wifi networks again.. as on https://bugs.launchpad.net/oem-priority/+bug/1574347/comments/79

killall nm-applet && nm-applet &

Dea1993 (andrea-deangelis93) wrote :

i confirm that the problem still present on an updated ubuntu 16.10.
if i turnoff wifi and then i turn on again, nm-applet not shown wireless connections, and the icon of connection became the icon of ethernet (but nm is connected to wifi).

solve this problem

This bug is still present in Ubuntu 16.10! Do you know if other desktop distributions like Fedora or openSUSE also have this bug?

Peter Amaral (amaralpeter) wrote :

Hi everybody, I realize that this fix I found may not help everybody. However, the symptoms I was seeing are the same as described in this bug report so maybe it will work for some other folks as well. The solution was to do the following:

$ sudo vim /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Change the value of wifi.powersave to 0

:wq

After rebooting I have not experienced the problems with disconnect, even after resuming from suspend.

As I understand it, this setting will disable power management for wifi adapters if its not supported in the driver/kernel by default.

Hansen (moteprime) wrote :

The "wifi.powersave to 0" did not make any difference for me.

tim__b (timb) wrote :

Same problem with freshly installed Xubuntu Xenial 16.04.1 here.

Changed in network-manager (Ubuntu):
assignee: jay patel (jay-patel736) → ImhotepOsumare157 (imhoteposumare157)

Can ubuntu consider switching to Wicd or wicd is more buggy than networkmanager ?

bug still happens in

network-manager 1.2.4-0ubuntu0.16.04.1

MaTachi (matachi) wrote :

larabi: I came from Fedora, and I had been running it for the last releases on my laptop. Never had any WiFi issues, so there's not anything wrong with my hardware. I recently installed Ubuntu 16.04.1 LTS, but these WiFi issues are quite annoying and I'm contemplating switching back to Fedora. I don't understand how this still hasn't been fixed in an LTS version of the OS.

description: updated
description: updated
summary: - [SRU] Re-read the link type if the name changed
+ WiFi network list disappears
summary: - WiFi network list disappears
+ WiFi networks list disappears
summary: - WiFi networks list disappears
+ WiFi networks list disappears (device type not reloaded)
description: updated

The "HOW TO TEST A FIX" is meaningless.

nmcli dev

DEVICE TYPE STATE CONNECTION
wlp2s0 wifi connected Thomson_etc

but the applet still doesn't list any wireless network.

@ Stavros Daliakopoulos

That simply means this report isn't related with your bug. Even when the consequences are the same, the causes aren't.

Hansen (moteprime) wrote :

If i set "All users may connect to this network" in 'network connections'for the used wi-fi connection, nm-applet does no longer crash when returning from suspend?

rjb (ron-buehler) wrote :

I can't confirm. unfortunately this doesn't do the trick for me.
What's different now is that the WiFi is already conected on the login screen with the arrow icon. As soon as I login, it's the WiFi icon. When I suspend and return I have arrows again.

bug still happens in

network-manager 1.2.6-0ubuntu1

Tim Embler (nonparity) wrote :

this issue still appears to be occurring. I am experiencing the same problem for the past two days.

Tim Embler (nonparity) wrote :

Also just to add I am using network-manager version 1.2.6-0ubuntu1

Khoi (minhkhoitran2) wrote :

Bug still occurs with network-manager 1.2.6-0ubuntu0.16.04.1

Changed in network-manager (Ubuntu):
assignee: ImhotepOsumare157 (imhoteposumare157) → Marzenco Alexandru Ionuț (thors-hand)
Daniel van Vugt (vanvugt) wrote :

All: Commenting on a closed bug will generally be ignored (even if it was closed erroneously).

If you have continuing issues then please log a new bug.

Changed in network-manager (Ubuntu):
assignee: Marzenco Alexandru Ionuț (thors-hand) → nobody
loveme (lovemej) wrote :

wifi disconnects frequently

Displaying first 40 and last 40 comments. View all 125 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.