NetworkManager does not set channel when creating ad-hoc network

Bug #112009 reported by Ohad Lutzky on 2007-05-03
2
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
network-manager (Ubuntu)
Medium
Alexander Sack
wpasupplicant (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

I'm trying to use NetworkManager to create an ad-hoc network with my ipw2200. The following manual method works:

sudo iwconfig eth1 essid mynetwork channel 11 mode ad-hoc

(That is, the laptop next to me will then see the network)

However, when trying to do that with NetworkManager's "create wireless network", the laptop next to me
will not see the network. Checking iwconfig shows that the essid and mode were set properly - but unfortunately, one can't tell using iwconfig whether a channel was set. However, running

sudo iwconfig eth1 channel 11

aftwards fixes the problem. NM should do this automatically.

Boris Dušek (dusek) wrote :

Very same problem here with ipw3945. Quite a disappointment for me, since I hoped I will not have to touch the command-line for network configuration in Feisty.

Alexander Sack (asac) wrote :

is this bug still present in latest gutsy network-manager?

Changed in network-manager:
status: New → Incomplete
Ohad Lutzky (lutzky) wrote :

Yes, bug is still present in Gutsy Tribe 4.

Changed in network-manager:
status: Unknown → New
Alexander Sack (asac) wrote :

sorry for the delay,

if you still see this bug, please attach your /var/log/syslog and /var/log/daemon.log.

Thanks,

 - Alexander

Download full text (11.8 KiB)

Relevant Syslog bit:

Sep 21 17:17:23 dolphin NetworkManager: <info> Creating network
'my_adhoc_network' on device
'/org/freedesktop/NetworkManager/Devices/eth1'.
Sep 21 17:17:23 dolphin NetworkManager: <info> Device eth1 activation
scheduled...
Sep 21 17:17:23 dolphin NetworkManager: <info> Deactivating device eth1.
Sep 21 17:17:23 dolphin dhclient: There is already a pid file
/var/run/dhclient.eth1.pid with pid 25518
Sep 21 17:17:23 dolphin dhclient: killed old client process, removed PID file
Sep 21 17:17:23 dolphin dhclient: DHCPRELEASE on eth1 to 192.168.1.1 port 67
Sep 21 17:17:24 dolphin avahi-daemon[4895]: Withdrawing address record
for 192.168.1.101 on eth1.
Sep 21 17:17:24 dolphin avahi-daemon[4895]: Leaving mDNS multicast
group on interface eth1.IPv4 with address 192.168.1.101.
Sep 21 17:17:24 dolphin avahi-daemon[4895]: Interface eth1.IPv4 no
longer relevant for mDNS.
Sep 21 17:17:24 dolphin dhcdbd: dhclient 25518 down (9) but si_code
== 0 and releasing==0 !
Sep 21 17:17:24 dolphin NetworkManager: <info> SUP: sending command
'DISABLE_NETWORK 0'
Sep 21 17:17:24 dolphin NetworkManager: <info> SUP: response was 'OK'
Sep 21 17:17:24 dolphin NetworkManager: <info> SUP: sending command 'AP_SCAN 0'
Sep 21 17:17:24 dolphin NetworkManager: <info> SUP: response was 'OK'
Sep 21 17:17:24 dolphin NetworkManager: <info> SUP: sending command 'TERMINATE'
Sep 21 17:17:24 dolphin NetworkManager: <info> SUP: response was 'OK'
Sep 21 17:17:24 dolphin NetworkManager: <info> Activation (eth1) started...
Sep 21 17:17:24 dolphin NetworkManager: <info> Activation (eth1)
Stage 1 of 5 (Device Prepare) scheduled...
Sep 21 17:17:24 dolphin NetworkManager: <info> DHCP daemon state is
now 14 (normal exit) for interface eth1
Sep 21 17:17:24 dolphin NetworkManager: <info> DHCP daemon state is
now 11 (unknown) for interface eth1
Sep 21 17:17:24 dolphin NetworkManager: <info> DHCP daemon state is
now 14 (normal exit) for interface eth1
Sep 21 17:17:24 dolphin avahi-daemon[4895]: Withdrawing address record
for fe80::20e:35ff:fe65:57e8 on eth1.
Sep 21 17:17:24 dolphin NetworkManager: <info> Activation (eth1)
Stage 1 of 5 (Device Prepare) started...
Sep 21 17:17:24 dolphin NetworkManager: <info> Activation (eth1)
Stage 2 of 5 (Device Configure) scheduled...
Sep 21 17:17:24 dolphin NetworkManager: <info> Activation (eth1)
Stage 1 of 5 (Device Prepare) complete.
Sep 21 17:17:24 dolphin NetworkManager: <info> Activation (eth1)
Stage 2 of 5 (Device Configure) starting...
Sep 21 17:17:24 dolphin NetworkManager: <info> Activation
(eth1/wireless): access point 'my_adhoc_network' is unencrypted, no
key needed.
Sep 21 17:17:25 dolphin NetworkManager: <info>
supplicant_interface_init() - connect to global ctrl socket (0/10).
Sep 21 17:17:25 dolphin NetworkManager: <info>
supplicant_interface_init() - connect to global ctrl socket (1/10).
Sep 21 17:17:26 dolphin NetworkManager: <info>
supplicant_interface_init() - connect to global ctrl socket (2/10).
Sep 21 17:17:26 dolphin NetworkManager: <info>
supplicant_interface_init() - connect to global ctrl socket (3/10).
Sep 21 17:17:26 dolphin NetworkManager: <info> SUP: sending command
'INTERFACE_ADD eth1^I^Iwext...

Alexander Sack (asac) wrote :

you did not include the syslog bits that show which driver is detected. Please do so (should be logged on n-m startup).

Thanks,

 - Alexander

Ohad Lutzky (lutzky) wrote :
Download full text (34.4 KiB)

Here it is (grepped for NetworkManager from oldest syslog)

Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.033006]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/pci_8086_3580').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.499577]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/pci_8086_3584').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.504303]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/pci_8086_3585').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.506369]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/pci_8086_3582').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.514977]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/pci_8086_3582_0').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.516156]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/pci_8086_24c2').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.517027]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/usb_device_0_0_0000_00_1d_0').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.521762]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/usb_device_0_0_0000_00_1d_0_if0').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.608223]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/pci_8086_24c4').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.611123]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/usb_device_0_0_0000_00_1d_1').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.613741]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/usb_device_0_0_0000_00_1d_1_if0').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.615094]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/usb_device_45e_83_noserial').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.617447]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/usb_device_45e_83_noserial_if0').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.618713]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/pci_8086_24c7').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.621129]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/usb_device_0_0_0000_00_1d_2').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.625902]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/usb_device_0_0_0000_00_1d_2_if0').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.627595]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/pci_8086_24cd').
Sep 16 09:20:25 dolphin NetworkManager: <debug> [1189927225.628775]
nm_hal_device_added(): New device added (hal udi is
'/org/freedesktop/Hal/devices/usb_device_0_0_0000_00_...

Alexander Sack (asac) wrote :

so which channel should be chosen by network-manager? maybe that should be done by wpasupplicant?

Ohad Lutzky (lutzky) wrote :

I don't really know... I usually choose 11, but I don't know if
there's a standard. I'm not too sure as to which one of them should do
it, but I guess it would be better to do it from NM first, as it's
easier, and then migrate it over into WPASupplicant if that solution
is deemed cleaner.

On 9/24/07, Alexander Sack <email address hidden> wrote:
> so which channel should be chosen by network-manager? maybe that should
> be done by wpasupplicant?
>
> --
> NetworkManager does not set channel when creating ad-hoc network
> https://bugs.launchpad.net/bugs/112009
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Man is the only animal that laughs and weeps, for he is the only
animal that is struck with the difference between what things are and
what they ought to be.
 - William Hazlitt

Ohad Lutzky

Alexander Sack (asac) wrote :

this looks like a wpasupplicant issue.

Changed in wpasupplicant:
status: New → Confirmed
Changed in network-manager:
status: Incomplete → Invalid
Ohad Lutzky (lutzky) wrote :

It is, at the very least, not STRICTLY a wpasupplicant issue: wpasupplicant
can add an interface to set the channel, but even if that were the case,
NetworkManager would still need to use that interface. Please reopen.

On 10/8/07, Alexander Sack <email address hidden> wrote:
>
> this looks like a wpasupplicant issue.
>
> ** Also affects: wpasupplicant (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Changed in: wpasupplicant (Ubuntu)
> Status: New => Confirmed
>
> ** Changed in: network-manager (Ubuntu)
> Status: Incomplete => Invalid
>
> --
> NetworkManager does not set channel when creating ad-hoc network
> https://bugs.launchpad.net/bugs/112009
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Man is the only animal that laughs and weeps, for he is the only animal that
is struck with the difference between what things are and what they ought to
be.
- William Hazlitt

Ohad Lutzky

Ohad Lutzky (lutzky) wrote :

OK, I now have much more insight into how this works. This is not a wpa_supplicant issue. Attached is a patch which *should* resolve the problem.

Ohad Lutzky (lutzky) wrote :

In case it wasn't clear, I request to reopen, and remove wpasupplicant from "affects".

Changed in network-manager:
status: New → Confirmed
Changed in network-manager:
status: Confirmed → Fix Released
Alexander Sack (asac) on 2008-01-08
Changed in network-manager:
assignee: nobody → asac
status: Invalid → In Progress
Changed in wpasupplicant:
status: Confirmed → Invalid
Ohad Lutzky (lutzky) wrote :

Note that this bug is only Fixed for wpasupplicant 0.6 and above, so if we want NM to work with it, wpasupplicant has to be updated. (I have a fix for current wpasupplicant, which Dan Williams sent, but it would probably be better to go for all-out 0.6)

On Tue, Jan 08, 2008 at 09:48:02AM -0000, Ohad Lutzky wrote:
> Note that this bug is only Fixed for wpasupplicant 0.6 and above, so if
> we want NM to work with it, wpasupplicant has to be updated. (I have a
> fix for current wpasupplicant, which Dan Williams sent, but it would
> probably be better to go for all-out 0.6)
>

we will not upgrade to 0.6 before we ship nm 0.7

 - Alexander

Alexander Sack (asac) wrote :

could you attach the supplicant patch for 0.5.8?

Yes, that's the one.

On Feb 12, 2008 12:36 AM, Alexander Sack <email address hidden> wrote:
> is it: http://bugzilla.gnome.org/attachment.cgi?id=101662&action=view ?
>
>
> --
> NetworkManager does not set channel when creating ad-hoc network
> https://bugs.launchpad.net/bugs/112009
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Man is the only animal that laughs and weeps, for he is the only
animal that is struck with the difference between what things are and
what they ought to be.
 - William Hazlitt

Ohad Lutzky

Alexander Sack (asac) wrote :

ok, we should try the supplicant patch then. milestoning.

Changed in wpasupplicant:
milestone: none → ubuntu-8.04-beta
status: Invalid → Triaged
Changed in network-manager:
importance: Undecided → Medium
milestone: none → ubuntu-8.04-beta
status: In Progress → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wpasupplicant - 0.6.0+0.5.8-0ubuntu2

---------------
wpasupplicant (0.6.0+0.5.8-0ubuntu2) hardy; urgency=low

  * 10_set_channel_in_adhoc_mode: make wpasupplicant set the frequency when.
    LP: #112009. Patch prepared by Kel Modderman for debian.
  * 10_silence_siocsiwauth_icotl_failure: patch taken from upstream.
    when using the wext driver, the error message on the SIOCSIWAUTH ioctl
    is no longer printed via stderr, but properly in the debug log.
    Patch prepared by Kel Modderman for debian.

 -- Reinhard Tartler <email address hidden> Wed, 12 Mar 2008 17:40:06 +0100

Changed in wpasupplicant:
status: Triaged → Fix Released
Alexander Sack (asac) wrote :

does this now work in hardy with the new supplicant?

Alexander Sack (asac) wrote :

moving milestone ahead - waiting for answer.

Changed in network-manager:
milestone: ubuntu-8.04-beta → ubuntu-8.04
Ohad Lutzky (lutzky) wrote :

The channel seems to be set appropriately (according to iwlist
channel), but I haven't had the chance to test this with another
laptop. (Also, I'm not sure, but it seems that the mode and ESSID
aren't set to what I request)

On Tue, Mar 18, 2008 at 11:54 PM, Alexander Sack <email address hidden> wrote:
> moving milestone ahead - waiting for answer.
>
>
> ** Changed in: network-manager (Ubuntu)
> Target: ubuntu-8.04-beta => ubuntu-8.04
>
>
>
> --
> NetworkManager does not set channel when creating ad-hoc network
> https://bugs.launchpad.net/bugs/112009
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Man is the only animal that laughs and weeps, for he is the only
animal that is struck with the difference between what things are and
what they ought to be.
 - William Hazlitt

Ohad Lutzky

Alexander Sack (asac) wrote :

ok, could you please test with the latest version?

Alexander Sack (asac) wrote :

ping! ... would be good to know if this need attention before we release hardy in a few days.

Ohad Lutzky (lutzky) wrote :

I'll only be able to check this on Sunday, when I'm at my laptop.
Sorry for the delay.

On Thu, Apr 3, 2008 at 7:33 PM, Alexander Sack <email address hidden> wrote:
> ping! ... would be good to know if this need attention before we release
> hardy in a few days.
>
>
>
> --
> NetworkManager does not set channel when creating ad-hoc network
> https://bugs.launchpad.net/bugs/112009
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Man is the only animal that laughs and weeps, for he is the only
animal that is struck with the difference between what things are and
what they ought to be.
 - William Hazlitt

Ohad Lutzky

Ohad Lutzky (lutzky) wrote :

Mode, ESSID and channel are now set correctly, but only momentarily -
network-manager roams to a stronger network (a preferred one) after a
few seconds. I'm not sure whether this should be considered a part of
this bug. (wpasupplicant 0.6.0+0.5.8-0ubuntu2, network-manager
0.6.6-0ubuntu5)

On Thu, Apr 3, 2008 at 9:19 PM, Ohad Lutzky <email address hidden> wrote:
> I'll only be able to check this on Sunday, when I'm at my laptop.
> Sorry for the delay.
>
>
>
> On Thu, Apr 3, 2008 at 7:33 PM, Alexander Sack <email address hidden> wrote:
> > ping! ... would be good to know if this need attention before we release
> > hardy in a few days.
> >
> >
> >
> > --
> > NetworkManager does not set channel when creating ad-hoc network
> > https://bugs.launchpad.net/bugs/112009
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
>
> --
>
>
> Man is the only animal that laughs and weeps, for he is the only
> animal that is struck with the difference between what things are and
> what they ought to be.
> - William Hazlitt
>
> Ohad Lutzky
>

--
Man is the only animal that laughs and weeps, for he is the only
animal that is struck with the difference between what things are and
what they ought to be.
 - William Hazlitt

Ohad Lutzky

Alexander Sack (asac) wrote :

please attach your /var/log/syslog taken after you reproduced this bug.

Ohad Lutzky (lutzky) wrote :

Attached. Note that I've changed my wireless interface to be called "wlan0" using /etc/iftab.

Steve Langasek (vorlon) on 2008-04-26
Changed in network-manager:
milestone: ubuntu-8.04 → ubuntu-8.04.1
Steve Langasek (vorlon) on 2008-06-05
Changed in network-manager:
milestone: ubuntu-8.04.1 → none
Alexander Sack (asac) wrote :

can we close the NM task now that 0.7 is in intrepid?

Alexander Sack (asac) wrote :

fixed in 0.7 (available in intrepid)

Changed in network-manager:
status: Triaged → Fix Released
Changed in network-manager:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.