Showing many "Don't Show This Messege again"

Bug #606825 reported by Kangarooo Jānis on 2010-07-18
112
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Xfce4 Notifyd
Unknown
Unknown
network-manager-applet (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

Binary package hint: xfce4-notifyd

RATIONALE:
Low-risk changes to notification code to display/update notifications being shown. No strings are touched, this only applies to updated notifications which are being added extra "Don't show this message again" buttons instead of clearing actions before adding the new button to match the new action.

TEST CASE:
Connect to a wireless network, then connect to a VPN. You should see a notification for connecting to the wireless network, then an update of the notification to show you're connected to the VPN; each with only *one* action button.

see screenshot
every next time messege appears it gives button Dont Show This Messege again as much times this notification has showed up

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xfce4-notifyd (not installed)
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic i686
Architecture: i386
Date: Sun Jul 18 10:15:42 2010
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.utf8
SourcePackage: xfce4-notifyd

Kangarooo Jānis (kangarooo) wrote :
Charlie Kravetz (charlie-tca) wrote :

Thank you for reporting this issue. Were all of the messages triggered on the same day? After closing all the "Don't show this message again" tabs, do they reappear? You have many tabs with problems in the browser. If each one triggered an error, you must close each error before the message will not appear again.

Changed in xfce4-notifyd (Ubuntu):
status: New → Incomplete
Lionel Le Folgoc (mrpouit) wrote :

> Package: xfce4-notifyd (not installed)

This doesn't look like xfce4-notifyd on the screenshot, rather notification-daemon...

affects: xfce4-notifyd (Ubuntu) → notification-daemon (Ubuntu)

This also happens in 10.10 alpha 2 (the latest one on this date if i
wrote not correct name)
Charlie With FF im having a lot problems. One of them FF makes X Boom
to login Bug 587710 and also in 10.10 FF with flash or sometimes some
ajax buttons (like in YT Favorites button clicking) makes Xorg freeze
but not mouse.
In those moments to respawn all tabs i closed WiFi connection to start
FF without loading all tabs.

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in notification-daemon (Ubuntu):
importance: Undecided → Low
status: Incomplete → Confirmed

This bug still exists in Xubuntu Natty.

David Fraser (davidf) wrote :

I'm getting this on natty and reported bug #813904 which I marked as a duplicate of this. Attaching a screenshot - I confirmed with wmctrl -l -p that this is a xfce4-notifyd process showing this window

David Fraser (davidf) wrote :

Linked to the xfce4-notifyd bug which states that this is distribution-specific...

I experience the same problem with oneiric alpha 2.

I listened to the notify messages that xfce4-notifyd receives using dbus-monitor. It seems the problem is network-manager. Take a look at the captured notification method call (attached). It seems nm-applet explicitly requests that many "Don't show again" action buttons, so IMHO it's not xfce4-notifyd's fault.

Please confirm.

Addendum: If I kill nm-applet and restart it, the long list of buttons is gone and the "one more button per notification" routine starts over.

affects: notification-daemon (Ubuntu) → network-manager (Ubuntu)

I can't reproduce this bug on my system in a Xubuntu session, no matter what notification "theme" I use, but I think I know what's wrong: every time the notify_notification_add_action() function is called, it just adds the action (the button). I can work around this by clearing the actions every time before adding them. I'll try this out and upload a package with the fix, but I will not be able to test it and will need to rely on someone testing this in Oneiric and reporting back on this bug with the result.

affects: network-manager (Ubuntu) → network-manager-applet (Ubuntu)
Changed in network-manager-applet (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Low → Medium
status: Confirmed → In Progress

Please do, I'll be happy to test.

David Fraser (davidf) wrote :

I'll test on natty when a patch is available

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.0-0ubuntu3

---------------
network-manager-applet (0.9.0-0ubuntu3) oneiric; urgency=low

  * debian/patches/clear-notification-actions.patch: clear actions tied to
    notifications being sent; otherwise stacking notifications also causes the
    attached actions to be stacked (resulting in multiple "Don't show this"
    buttons appearing in the notification bubble. (LP: #606825)
  * debian/control: drop gnome-bluetooth to Suggests. (LP: #844027)
  * debian/patches/key-certificate-extensions.patch: allow using a key
    certificate with a .key extension in network security dialogs. (LP: #839864)
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 15 Sep 2011 13:48:23 -0400

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Released
David Fraser (davidf) wrote :

I've built a package for natty in my PPA: https://launchpad.net/~davidf/+archive/ppa/+sourcepub/1943413/+listing-archive-extra
Testing shortly...

VS (storvann) wrote :

Seems to be fixed for me (tested davidf's package in natty). Thanks a lot!

Awesome.

David, want to apply the same patch/changes to the Natty branch (https://code.launchpad.net/~network-manager/network-manager-applet/network-manager-applet.natty), or provide a debdiff that could be sponsored to fix the bug in natty?

Changed in network-manager-applet (Ubuntu Natty):
status: New → Triaged
importance: Undecided → Medium

I'm using nm-applet from network-manager-gnome 0.9.0-0ubuntu3 for a few days now and the error hasn't shown since, despite my additional tries to provoke it. Seems fixed, thanks!

Paul Sladen (sladen) on 2011-09-25
summary: - Showing many Dont Show This Messege again
+ Showing many "Don't Show This Messege again"
Changed in network-manager-applet (Ubuntu Natty):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
description: updated

This is fixed in Oneiric and later; and a package is available for Natty in a PPA -- as such, I'm unassigning myself from this bug because I don't think I'll spend time to provide a fixed package for SRU soon.

If someone wants to provide a fixed package, please feel free to take the changes from David or from the revision in Oneiric and contact me or another Ubuntu Developer for sponsoring :)

Thanks!

Changed in network-manager-applet (Ubuntu Natty):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
Adolfo Jayme (fitojb) on 2013-02-27
no longer affects: network-manager-applet (Ubuntu Natty)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.