indicator session applet missing after upgrade to Karmic with UNR

Bug #461115 reported by sciencewhiz on 2009-10-26
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
netbook-launcher (Ubuntu)
High
UNR in Ubuntu

Bug Description

On some UNR upgrades, "indicator-session" applet isn't added to the panel which makes it really hard to shutdown.

Workaround:
Add indicator-session applet manually to the panel; follow these steps:
- right click on the Ubuntu logo on the top left ("go-home-applet"), unlock it from the panel
- right click in the same place and select Move and move it a bit to the right to make some free panel space
- right click on the free panel space you just created and chose "Add to panel"; search for
- search for "session" and add the "Indicator Applet Session" applet (NOT the "Log Out..." applet)
- move applets around on the panel as you prefer; usually the session indicator applet goes to the very far right and the go-home applet to the very left

Proposed release notes:
Ubuntu Netbook Remix missing a shutdown applet in the top panel after upgrade
--
On Ubuntu Netbook Remix, you might miss a shutdown applet on the top panel; as a workaround, add the "Indicator Applet Session" applet manually after moving the current applets around to free some space; this is all achieved by right-clicking the top panel. See Bug:461115 for detailed instructions.

sciencewhiz (christmasboy-81) wrote :
Paul Larson (pwlars) on 2009-10-26
Changed in netbook-launcher (Ubuntu):
importance: Undecided → High
summary: - indicator session applet missing after upgrade to Karmin with UNR
+ indicator session applet missing after upgrade to Karmic with UNR
Loïc Minier (lool) wrote :

We had reports from mdz and others on IRC that this happened for them, but this issue is hard to reproduce; I'm marking it as confirmed because we had two reports for it already.

My personal suspicion goes to usage of desktop-switcher in jaunty, then upgrading to karmic as a possible explanation of steps leading to this bug.

Changed in netbook-launcher (Ubuntu):
status: New → Confirmed
assignee: nobody → UNR in Ubuntu (ubuntu-unr)
François Tissandier (baloo) wrote :

I can confirm I have this problem too. I can easily reproduce it as our 9.04 configuration is installed using CloneZilla. I tried the upgrade a couple of times this week to make sure it can be reproduced. So I can easily send you all the files from the original 9.04 installation.

Loïc Minier (lool) on 2009-10-28
description: updated
description: updated
Mark Fraser (launchpad-mfraz) wrote :

When I upgraded mine, both indicator-applet (looks like an envelope) and indicator-applet-session (to log-out) were missing from the panel. I tried to add them manually, but the colours were inverted, dark on light instead of light on dark.

Loïc Minier (lool) on 2009-10-28
description: updated
description: updated
François Tissandier (baloo) wrote :

I tried your workaround, but the new icons have a grey background, not a dark one. So it helps, but it looks quite ugly :)

Paul Larson (pwlars) wrote :

Could you post a screenshot of what it looks like after the upgrade please? Thanks

Loïc Minier (lool) wrote :

What is the output of:
gconftool-2 -g /desktop/gnome/interface/gtk_theme

If it is Human, please set it to Dust with:
gconftool-2 -s /desktop/gnome/interface/gtk_theme -t string Dust
and try adding the indicators again; are these more visible?

Did you use desktop-switcher when running 9.04/Jaunty's UNR?

François Tissandier (baloo) wrote :

Output:
Human-Murrine-Netbook
Please note that i dont think I have touched anything regarding themes. It's more or less a standard system we are using.

After your change: yes they look better

Did I use desktop-switcher? Hard to remember, but I guess I tried it once at least, yes.

Loïc Minier (lool) wrote :

Where did you get the Human-Murrine-Netbook theme from? Could you please send the output of dpkg -S Human-Murrine-Netbook?

How was this system installed? Factory pre-installed with UNR, or Jaunty install or...?

François Tissandier (baloo) wrote :

dpkg -S Human-Murrine-Netbook
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/panel.rc
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/Panel/panelbutton1.png
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/Panel/handle-h.png
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/Panel/drawing.svg
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/Panel/panelbutton2.png
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/Panel/panel-bg.png
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/gtkrc
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/index.theme
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/Panel/panelbutton3.png
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/Panel
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/Panel/button2.png
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/Panel/handle-v.png
human-netbook-theme: /usr/share/themes/Human-Murrine-Netbook/gtk-2.0/Panel/panelbutton4.png

Installed from the ISO I guess, I don't remember well. But it was preconfigured with a Dell 8.04 or 8.10 version, we replaced it with Jaunty.

Loïc Minier (lool) wrote :

Hmm so what happened is that you used desktop-swicher and that changed the GConf settings from "use the defaults" (Gtk+ theme and panel layout notably) to "user set". On upgrade, the defaults were changed but your "manually" set settings were kept as overrides.

(This is typically why we drop desktop-switcher and want to use separate session types which override the GConf path in next release.)

I guess we need some piece of code on upgrades which forces fixing the panel config, the gtk+ theme and the like when we detect that you one used desktop-switcher.

Steve Langasek (vorlon) wrote :

Documented at <https://wiki.ubuntu.com/KarmicKoala/ReleaseNotes#Ubuntu%20Netbook%20Remix%20missing%20shutdown%20applet%20after%20upgrade>:

After upgrading Ubuntu Netbook Remix, the shutdown applet may be absent from the top panel. As a workaround, move the current applets to make some available space on the panel, then right-click in the freed space to add the "Indicator Applet Session" applet manually. See Bug:461115 for detailed instructions.

Changed in ubuntu-release-notes:
status: New → Fix Released
sciencewhiz (christmasboy-81) wrote :

I also had to change the theme to dust to get the color right. I'm going to guess that is also related to the use of desktop-switcher and should be mentioned in the description of how to fix it.

Using the instructions above, I could not get the indicator session applet moved past the notification area, until I realized that I had to right-click a little to the left of the audio icon to unlock the notification area. That might also be worth mentioning for novice users.

David Abernathy (dabernat) wrote :

I upgraded my Acer Aspire One D250 from UNR 9.04 to 9.10 and, in addition to missing the shutdown applet, I also can't find the battery status indicator or the wireless signal applet. They are not included in the options when I right click a panel and try to add them. Anyone else have this problem? Other than that, 9.10 is looking good so far...

Brandon Thomson (gravix) wrote :

On my eeepc 901 without UNR I didn't even get the indicator-applet-session package installed during the upgrade. However after installing it manually the panel looks like it should.

Thanks for the tip about unlocking the notification area, I needed it to get the applet over there.

David Abernathy (dabernat) wrote :

Oh, duh, never mind. I added the "notification area" applet to the panel and got the missing notification icons.

viganiko (aniko-nagyne-vig) wrote :

For me the update on an Acer Aspire One worked. My problem is I don't have the add to panel option, even if I create new space with the workaround.

ohiomoto (ohiomoto) wrote :

I also lost my indicator-applet-session after my upgrade and got the ugly gray background after adding on the panel. I'm using the default Human-Murrine-Netbook theme and I do use my desktop-switcher. If I switch to any other theme, indicator-applet-session looks better, but Human-Murrine-Netbook looks the best for everything else.

Any chance of fixing it so I can use the Human-Murrine-Netbook theme?

ohiomoto (ohiomoto) wrote :

I found that if I changed the Background settings in the Panel Properties to Solid Color and then adjusting the transparency level I could replicate the original look or the panel. It would be nice to change the font color of the indicator-applet-session, but I'll live with it the way it is until there is an update.

ohiomoto (ohiomoto) wrote :

I'm sorry. I never posted the original screens hot with the gray background in the indicator-applet-session. Here is the "before".

Omer Akram (om26er) wrote :

what can we do about this bug now. we are not gonna release karmic again for sure so what can be done for this bug report?

Didier Roche (didrocks) wrote :

@om26er: I guess we can set it as won't fix it as the transition as been mostly done.

Changed in netbook-launcher (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.