Merge with Debian

Bug #133110 reported by André Klitzing on 2007-08-17
56
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.24 (Ubuntu)
Undecided
Unassigned
ndiswrapper (Ubuntu)
Undecided
Unassigned

Bug Description

I like to request the merge of ndiswrapper from Debian. I had problems with every version of ndiswrapper since feisty. But this version (1.47 or higher) fixed my problems and I can connect to my APs again.
So please merge the new version to Ubuntu Gutsy in this package and kernel-module.

1.49
    * If a driver returns invalid MAC address (00:00:00:00:00) when queried with OID_802_3_CURRENT_ADDRESS (probably because NdisReadNetworkAddress returns NDIS_STATUS_FAILURE?), use OID_802_3_PERMANENT_ADDRESS to get the correct address. This is required for some atheros devices (e.g., AR5007EG)
    * Fixed a kernel crash with non-preempt kernels (observed with acx111 driver)
    * Preemption, as required by Windows, has been reimplemented. With this, ndiswrapper works with RT-preempt and non-preempt kernels
    * Dropped support for 2.4 kernels (and very old 2.6 kernels)

1.48
    * Support for 2.6.23 kernel
    * Disassocation with wpa_supplicant is fixed (earlier, after disassociation, the driver and ndiswrapper would be configured differently, requiring unloading and reloading of ndiswrapper module)
    * (Re)Association / (Re)Authentication issues with wpa_supplicant with 2.6.23 kernels fixed
    * Fixed an issue with 64-bit Broadcom drivers that cause ntos_wq worker thread to take up all the CPU in some cases

1.47
    * Fixed random (occassional) crash issues with 64-bit drivers (observed with Broadcom driver)
    * Fixed compilation issues with version 1.46

1.46
     * Fixed crash with large transfers (bug in version 1.45)

1.45
    * Fixes 'NOHZ: local_softirq_pending: 08' warnings from tickless kernels
    * Fixed issues with RT-preempt enabled kernels
    * Fixed ndiswrapper script to handle installation of Intel 4965AGN driver (which apparently works with ndiswrapper)
    * Fixed a warning when SLUB allocator is used
    * Fixed kernel crash with PsCreateSystemThread that manifested with sis163u when preempt is enabled
    * Changing MAC address with 'ifconfig hw ether' should work with all drivers now. If MAC address should be changed everytime ndiswrapper is loaded, change 'NetworkAddress' setting, as explained in wiki entry 'Tips' (earlier 'mac_address' setting was used, but that no longer applies)
    * Fixed an issue with some drivers (e.g., sis163u) that would stall after working for a while
    * Fixed crashes when removing module with usb devices

1.44
    * Fixed issues with Ubuntu kernels (where PREEMPT is not enabled)
    * Issues with combination of DEBUG_PREEMPT and RT-preempt fixed
    * Fixed issues with newer 64-bit Broadcom driver when more than 1GB RAM is present
    * Added support for upcoming 2.6.22 kernels

Changed in ndiswrapper:
status: New → Confirmed
André Klitzing (misery) wrote :

Well... I know the "duplicate" bug is older than this one. :-)

New ndiswrapper-version!
1.48
    * Support for 2.6.23 kernel
    * Disassocation with wpa_supplicant is fixed (earlier, after disassociation, the driver and ndiswrapper would be configured differently, requiring unloading and reloading of ndiswrapper module)
    * (Re)Association / (Re)Authentication issues with wpa_supplicant with 2.6.23 kernels fixed
    * Fixed an issue with 64-bit Broadcom drivers that cause ntos_wq worker thread to take up all the CPU in some cases

I used 1.48 and 1.49rc2 at my notebook without problems (bcm4312).

description: updated
Andreas Gnau (rondom) wrote :

1.49rc1 is preferred. 1.49rc2 contains a patch that could cause other things to break and therefore (according to giri, the ndiswrapper-dev) isn't well-tested enough to be included into ubuntu. So I think including 1.49rc1 in ubuntu would really make sense.

The ndiswrapper in Gutsy also does not work for me and my Broadcom 4312 in 64 bit (ndisw in Gutsy 1.43 as of writing). I manually installed 1.48 and it works fine now.

Judging by the tonnes of forum posts about ndiswrapper/broadcom/bcm43xx/amd64, I say, please upgrade to 1.48 or later.

Chow Loong Jin (hyperair) wrote :

I really can't get any version of ndiswrapper to work with my ACX100 (D-Link DWL-520+) card. It used to work well for Feisty, and worked for Ubuntu Gutsy Tribe 5 LiveCD as well. However, recently none of the versions work. They can detect the network, but they won't associate. When I check my dmesg log, it shows this:
[ 95.563443] ADDRCONF(NETDEV_UP): wlan0: link is not ready

Some extra information: My network has a hidden SSID and is WEP encrypted with a 128-bit ASCII string.

André Klitzing (misery) on 2007-10-31
description: updated
Chow Loong Jin (hyperair) wrote :

It seems that ndiswrapper insists on attempting to connect using restricted key although my network is on open key. I edited my /etc/network/interfaces file to show something like this:

wireless-key open s:<key>

Then it worked again.

Chow Loong Jin (hyperair) wrote :

I can confirm that this problem is not fixed in Ubuntu Hardy.

ndiswrapper (1.50-1ubuntu1) hardy; urgency=low

  * Merge with Debian; remaining changes:
    - Build for lpia.
    - debian/control:
      + Update description to point out that the kernel source package is
        not required with the standard Ubuntu kernel.
      + Change the Maintainer address.
    - debian/control:
      + Drop ndiswrapper-source.

Changed in ndiswrapper:
status: Confirmed → Fix Released
Andreas Gnau (rondom) wrote :

The version number of the ndiswrapper-package should be in sync with the version of the module in LUM in order to not confuse users too much.

Therefore I suggest uploading the corresponding version of the utils (I know they don't really change throughout the releases as long as there are no bugs) before the final release of gutsy i.e before UVF.

Andreas Gnau (rondom) wrote :

1.52 is in current LUM

Changed in linux-ubuntu-modules-2.6.22:
status: New → Fix Released
Changed in ndiswrapper:
status: Fix Released → Confirmed
Chow Loong Jin (hyperair) wrote :

Uploading the corresponding version of the utils? What do you mean exactly? The ndiswrapper-utils is still at 1.9 even in the one downloaded from http://ndiswrapper.sf.net!

Chow Loong Jin (hyperair) wrote :

Aah, nevermind I get what you mean. The ndiswrapper source is still at ndiswrapper-1.50.

Dimitrios Symeonidis (azimout) wrote :

I'm not sure I understand the problem very well, but isn't this fixed by now? ndiswrapper-utils-1.9 is at 1.53-2ubuntu1 in jaunty...

Changed in ndiswrapper (Ubuntu):
status: Confirmed → Incomplete
Artur Rona (ari-tczew) wrote :

ndiswrapper (1.54-2ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes: LP: #369841
    - Build for lpia.
    - debian/control:
      + Change the Maintainer address.
    - debian/control:
      + Drop ndiswrapper-source.

Changed in ndiswrapper (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers