NetworkManager causes kernel NULL dereference

Bug #158803 reported by Ted on 2007-10-30
This bug report is a duplicate of:  Bug #133110: Merge with Debian. Edit Remove
6
Affects Status Importance Assigned to Milestone
ndiswrapper (Ubuntu)
Undecided
Unassigned
network-manager (Ubuntu)
Low
Basilio Kublik

Bug Description

Binary package hint: network-manager-gnome

NetworkManger or the kernel seems to be crashing, causing an "Oops" and bringing down my system.

I can see from the kern and syslogs that the crashes are somewhat related to ndiswrapper, but I'm not fully sure and I'm reporting it here to be safe. If this is not a ubuntu-related bug, please close this report.

Ted (tedks) wrote :

If there's anything else I could do to get more information, let me know. I'm not sure what's causing this, but I'll try to find situations to reproduce the bug.

Ted (tedks) wrote :

This seems to definitely be a bug in ndiswrapper. This brings the question, why is ndiswrapper 1.45 in use in Ubuntu when ndiswrapper 1.49 is out?

Ted (tedks) wrote :

changing affected package to ndiswrapper

Andreas Gnau (rondom) wrote :

Ted, have you tried installing 1.49? Is it fixed, then?
If yes, this bug is a duplicate of #133110

Aziz (azizkh) on 2007-11-03
Changed in network-manager-applet:
status: New → Invalid
status: Invalid → New
Tommstein (tommstein) wrote :

I can confirm this bug with whatever the latest ndiswrapper is. I'm attaching my dmesg output, although it's almost identical to Ted's (minus a big prefix on each line). I don't know if this helps the cause, but when this error happens, sudo just hangs too. I think some other (network-related) programs hang too, but I don't have a list off the top of my head. Suspend and hibernate also stop working when this happens. This is starting to happen every day, which is ticking me off since Ubuntu/Kubuntu takes an eternity to reboot. This wasn't happening until the other day, so it seems likely that one of the kernel updates I let APT apply has something to do with it.

Ted (tedks) wrote :

I'm fairly sure this was fixed by updating to the latest ndiswrapper, which is a long way ahead of the version that currently ships with Ubuntu. I'm no longer able to duplicate the bug, having lost the hardware and environment that it originally occurred in.

Tommstein (tommstein) wrote :

Here is the dmesg output from tonight's daily crash, which I am only adding because it is longer than the previous one (it's like two crashes or something). If it's fixed in the newest ndiswrapper, and there's no compelling reason to stay with this broken version, I would say that we should probably update our ndiswrapper.

Tommstein (tommstein) wrote :

Does anyone even care about this bug? I just had to reboot (a ridiculously long process in Ubuntu) a whopping 40 minutes after my previous reboot. I recently came to Ubuntu when I got tired of Gentoo's BS, but an operating system that's more unstable than Windows 95 isn't acceptable.

Basilio Kublik (sourcercito) wrote :

Hi there
do you still experience this issue with the current version of the application?, could you please try to reproduce this using the live environment of the Desktop CD of the development release - Hardy Heron.

Thanks in advance

Changed in network-manager:
assignee: nobody → sourcercito
importance: Undecided → Low
status: New → Incomplete
Ted (tedks) wrote :

This issue was fixed by upgrading to the upstream ndiswrapper and is not in fact a bug in network-manager. This report is a duplicate of #133110.

Changed in network-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers