nautilus crashed with SIGSEGV in g_closure_invoke()

Bug #630884 reported by Uphaar Agrawalla on 2010-09-05
This bug affects 342 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: nautilus

The crash occurred when unmounting one of the two partitions of an external USB hard drive.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: nautilus 1:2.31.90-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Sep 5 15:21:26 2010
ExecutablePath: /usr/bin/nautilus
ProcCmdline: nautilus --sm-client-id 10928320c4a96d9667123966432354984000000032280024 --sm-client-state-file /home/username/.config/session-state/nautilus-1283608771.desktop
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x44c9af: mov (%r12),%rax
 PC (0x0044c9af) ok
 source "(%r12)" (0x00000020) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? ()
 g_closure_invoke ()
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist ()
 g_signal_emit () from /usr/lib/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in g_closure_invoke()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Uphaar Agrawalla (uphaar) wrote :
visibility: private → public
Changed in nautilus (Ubuntu):
importance: Undecided → Medium
Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → New

StacktraceTop:
 nautilus_path_bar_size_allocate (widget=0x22e4140,
 g_closure_invoke (closure=0x1ab8d70,
 signal_emit_unlocked_R (node=0x1ad8ce0,
 g_signal_emit_valist (instance=0x1f4f2c0,
 g_signal_emit (instance=0x2, signal_id=0, detail=3)

tags: removed: need-amd64-retrace
Pedro Villavicencio (pedro) wrote :

Thanks for the report, this looks similar to bug https://bugzilla.gnome.org/show_bug.cgi?id=627901 ; linking the report.

Changed in nautilus (Ubuntu):
status: New → Triaged
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus:
importance: Unknown → Critical
status: Unknown → New
Changed in nautilus:
status: New → Fix Released
Pedro Villavicencio (pedro) wrote :

This was fixed upstream, the developer said it will be backported to 2.32 after the hard code freeze. Thanks for reporting.

Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed

Great to hear and you're welcome! ;)

On 27 September 2010 14:00, Pedro Villavicencio <email address hidden> wrote:

> This was fixed upstream, the developer said it will be backported to
> 2.32 after the hard code freeze. Thanks for reporting.
>
> ** Changed in: nautilus (Ubuntu)
> Status: Triaged => Fix Committed
>
> --
> nautilus crashed with SIGSEGV in g_closure_invoke()
> https://bugs.launchpad.net/bugs/630884
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (639961).
>
> Status in Nautilus: Fix Released
> Status in “nautilus” package in Ubuntu: Fix Committed
>
> Bug description:
> Binary package hint: nautilus
>
> The crash occurred when unmounting one of the two partitions of an external
> USB hard drive.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: nautilus 1:2.31.90-0ubuntu3
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> Date: Sun Sep 5 15:21:26 2010
> ExecutablePath: /usr/bin/nautilus
> ProcCmdline: nautilus --sm-client-id
> 10928320c4a96d9667123966432354984000000032280024 --sm-client-state-file
> /home/username/.config/session-state/nautilus-1283608771.desktop
> ProcEnviron:
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x44c9af: mov (%r12),%rax
> PC (0x0044c9af) ok
> source "(%r12)" (0x00000020) not located in a known VMA region (needed
> readable region)!
> destination "%rax" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: nautilus
> StacktraceTop:
> ?? ()
> g_closure_invoke ()
> ?? () from /usr/lib/libgobject-2.0.so.0
> g_signal_emit_valist ()
> g_signal_emit () from /usr/lib/libgobject-2.0.so.0
> Title: nautilus crashed with SIGSEGV in g_closure_invoke()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/nautilus/+bug/630884/+subscribe
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.32.0-0ubuntu1

---------------
nautilus (1:2.32.0-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Fix places sidebar sometimes not changing location when clicking on a
      place (LP: #625938)
    - Fix various crashers (LP: #630884)
    - Translation updates
 -- Didier Roche <email address hidden> Tue, 28 Sep 2010 01:18:38 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Pedro Villavicencio (pedro) wrote :

reopening the bug is still there with latest package. also commented on the upstream report.

Changed in nautilus (Ubuntu):
status: Fix Released → Triaged
Changed in nautilus:
status: Fix Released → New
chrigu (ch-ba) on 2010-10-06
tags: added: i386
tags: added: iso-testing
steubens (steubens) wrote :

this along with the extension selection on rename has made maverick very annoying for me :[

Changed in nautilus:
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

Just fixed upstream.

Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Changed in nautilus:
status: Confirmed → Fix Released
Changed in nautilus (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → Medium
Changed in nautilus (Ubuntu Maverick):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.32.0-0ubuntu3

---------------
nautilus (1:2.32.0-0ubuntu3) natty; urgency=low

  * debian/patches/96_git_unmount_crash.patch: backport an upstream commit
    to fix nautilus crashing un unmount (lp: #630884)
  * debian/patches/99_ltmain_as-needed.patch:
    - dropped, it's not required with as-needed by default in natty
  * debian/patches/series: updated
 -- Sebastien Bacher <email address hidden> Fri, 05 Nov 2010 11:09:49 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :
Crusty Barnacle (calipengo) wrote :

Nautilus crashed when I tried to unmount an SD card on a USB card reader (internal).

Bus 001 Device 005: ID 0bda:0151 Realtek Semiconductor Corp. Mass Storage Device (Multicard Reader)

Brownout (brownout) wrote :

Any ETA for the SRU?

Accepted nautilus into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I've verified that the maverick-proposed version has fixed the bug.
Tried out many unmountings with different nautilus windows etc, no crashing anymore.

tags: added: verification-done
removed: verification-needed
steubens (steubens) wrote :

i'm still getting crashes with the proposed version, 1:2.32.0-0ubuntu1.1

it says something about accessing 0x00000001 and segfaulting, i can add another report from apport if anyone will point out how :]

steubens (steubens) wrote :

i thought i should add that i almost always have the extra pane open (F3) when this occurs, the drive being ejected is only in one tab on one pane. i've also noticed with a single pane, it tends to crash every _other_ drive ejection; i can get away with ejecting one, but the second one crashes it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.32.0-0ubuntu1.1

---------------
nautilus (1:2.32.0-0ubuntu1.1) maverick-proposed; urgency=low

  * debian/patches/96_git_unmount_crash.patch: backport an upstream commit
    to fix nautilus crashing un unmount (lp: #630884)
 -- Sebastien Bacher <email address hidden> Fri, 05 Nov 2010 11:09:49 +0100

Changed in nautilus (Ubuntu Maverick):
status: Fix Committed → Fix Released
steubens (steubens) wrote :

ah i missed that it was in natty; i will report back if it is still broken for me.

steubens (steubens) wrote :

read the comments again; i didn't misinterpret them, my comment in #20 stands

steubens (steubens) wrote :

it wont let me change the status, this bug is _not_ fixed

@steubens, can you catch this crash with apport and open a new bug?
This one is fixed for most of us.

Dmitry Shachnev (mitya57) wrote :

2010/11/18, steubens <email address hidden>:
> it wont let me change the status, this bug is _not_ fixed
>
> --
> nautilus crashed with SIGSEGV in g_closure_invoke()
> https://bugs.launchpad.net/bugs/630884
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Nautilus: Fix Released
> Status in “nautilus” package in Ubuntu: Fix Released
> Status in “nautilus” source package in Maverick: Fix Released
>
> Bug description:
> Binary package hint: nautilus
>
> The crash occurred when unmounting one of the two partitions of an external
> USB hard drive.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: nautilus 1:2.31.90-0ubuntu3
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> Date: Sun Sep 5 15:21:26 2010
> ExecutablePath: /usr/bin/nautilus
> ProcCmdline: nautilus --sm-client-id
> 10928320c4a96d9667123966432354984000000032280024 --sm-client-state-file
> /home/username/.config/session-state/nautilus-1283608771.desktop
> ProcEnviron:
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x44c9af: mov (%r12),%rax
> PC (0x0044c9af) ok
> source "(%r12)" (0x00000020) not located in a known VMA region (needed
> readable region)!
> destination "%rax" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: nautilus
> StacktraceTop:
> ?? ()
> g_closure_invoke ()
> ?? () from /usr/lib/libgobject-2.0.so.0
> g_signal_emit_valist ()
> g_signal_emit () from /usr/lib/libgobject-2.0.so.0
> Title: nautilus crashed with SIGSEGV in g_closure_invoke()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/nautilus/+bug/630884/+subscribe
>

steubens (steubens) wrote :

i will, and was planning to; thanks

I Kovalev (iakovalev) wrote :

I confirm the crash still occurs with nautilus 1:2.32.0-0ubuntu1.1:
_______________
ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: nautilus 1:2.32.0-0ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic x86_64
Architecture: amd64
Date: Tue Nov 30 11:59:42 2010
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419)
ProcCmdline: nautilus
ProcCwd: /home/kovalev
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x44c5a6: mov (%rax),%r14
 PC (0x0044c5a6) ok
 source "(%rax)" (0x64657469736976) not located in a known VMA region (needed readable region)!
 destination "%r14" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? ()
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in g_closure_invoke()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
___________

Any additional information from apport is available upon request.

steubens (steubens) wrote :

@Dmitry Shachnev, new report and apport stuff here: https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/683972

checking if it does it every time under stated scenario will have to wait until tomorrow, it is late.

posting this here, from apport on other bug only because it is really odd that all the information matches #29 exactly:

SegvAnalysis:
 Segfault happened at: 0x44c5a6: mov (%rax),%r14
 PC (0x0044c5a6) ok
 source "(%rax)" (0x64657469736976) not located in a known VMA region (needed readable region)!
 destination "%r14" ok
SegvReason: reading unknown VMA

stack is the same, too.

OK, let's say bug 683972 is the place where we track the crash that still occurs with nautilus 1:2.32.0-0ubuntu1.1. What feels weird is that the trace is very very similar, but let's see...

gvlists (gvlists) wrote :

The fix has not gone into current Ubuntu 10.10 installation media downloadable from the website.

Changed in nautilus:
status: Fix Released → Confirmed
Changed in nautilus:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.