nautilus crashed with SIGSEGV in g_closure_invoke() ejecting drives

Bug #683972 reported by steubens on 2010-12-02
160
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: nautilus

TEST CASE:
1. unmount a usb device, see nautilus crashes
2. now installed nautilus from maverick-proposed
3. see it does not crash anymore

i was ejecting 2 drives, ejected the second before the very final phase of eject for the first -> crash; currently not at home, will verify if this is reproducible like this then

will report on other g_closure_invoke bug i reported earlier, they were waiting for this crash dump

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: nautilus 1:2.32.0-0ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.37-7.18-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic x86_64
Architecture: amd64
Date: Wed Dec 1 18:42:21 2010
ExecutablePath: /usr/bin/nautilus
ProcCmdline: nautilus
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x44c5a6: mov (%rax),%r14
 PC (0x0044c5a6) ok
 source "(%rax)" (0x64657469736976) not located in a known VMA region (needed readable region)!
 destination "%r14" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? ()
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in g_closure_invoke()
UserGroups: adm admin cdrom dialout disk lpadmin plugdev sambashare

Related branches

steubens (steubens) wrote :
Milan Bouchet-Valat (nalimilan) wrote :

What you should have said in the description is that this crash is very close to bug 630884, which is reported to be fixed with nautilus 1:2.32.0-0ubuntu1.1.

Changed in nautilus (Ubuntu):
importance: Undecided → High
steubens (steubens) wrote :

it looks like it may be related to one usb drive i have; and the way that it sleeps, (it's a samsung story 1tb) i don't have this drive with me at the moment, so the window to interleave ejects to reproduce the bug isn't large enough

steubens (steubens) wrote :

ok, i can no longer test for this bug, as the package version of nautilus from proposed apparently went away (apport said it didn't exist, and sure enough it didn't! now i'm getting the plain old boring crash from the other bug)

I Kovalev (iakovalev) wrote :

I tried to reproduce the crash without success for some time, but eventually have got it again on the same scenario. The crash had occurred when I tried to unmount a media (an USB drive) while still having its content displayed in one of nautilus tabs. On such an event nautilus is supposed to switch the content of this tab to the "Computer" representing a list of all storage devices available in the system.

Note: on both those faults the system had been loaded heavily (both in CPU and hard drive usage). Thus, my guess is the fault was due to an attempt of nautilus to access a resource which either had been locked or had not been created yet. I'd suppose to continue testing on different machines under similar heavy load conditions.

steubens (steubens) wrote :

ok i sorted out the package snafu that made the proposed version disappear; i'll be looking at getting exact steps for reproduction asap

Id2ndR (id2ndr) wrote :

It seems that the bug is fixed for me. I think the udev related package updates may be related (version 162-2.2).

Omer Akram (om26er) wrote :

could anyone else also confirm if the issue has been fixed with the udev update, the changelog seems irrelevant though.

Pedro Villavicencio (pedro) wrote :

if you can still reproduce the issue, please provide a backtrace of the issue, thanks.

Changed in nautilus (Ubuntu):
importance: High → Medium
status: New → Incomplete

For me, it does not happen anymore if I eject the drive by clicking on the arrow. But if I right-click, and I choose "safely eject drive", nautilus still crashes.
If you give me an hint on how to produce a backtrace I will do.

BTW, in my log I had:

SYS: Jan 9 23:29:14 romano-asus kernel: [31037.528851] usb 1-5: USB disconnect, address 4
SYS: Jan 9 23:29:14 romano-asus kernel: [31037.609198] nautilus[2122]: segfault at 69736976 ip 0808a884 sp bfe03dd0 error 4 in nautilus[8048000+198000]
SEC: Jan 9 23:29:17 romano-asus dbus-daemon: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.379" (uid=1153 pid=32651 comm="nautilus) interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply=0 destination=":1.6" (uid=0 pid=874 comm="/usr/sbin/console-kit-daemon))

Romano: see https://wiki.ubuntu.com/Apport#How%20to%20enable%20apport about how to get a trace.

The log is interesting, it may indicate that Nautilus tries to get some information from ConsoleKit, which fails. Then, maybe it follows a code path that hasn't been really tested because it doesn't normally happen.

I tried to trigger it again with an USB stick, but it didn't crash. I will let apport enabled and try again at home, this evening, with the SD card that gave me the crash yesterday.

steubens (steubens) wrote :

this is still happening with some regularity, i can attach newer dumps if someone tells me how, i have a few at hand

steubens (steubens) wrote :

i use "safely eject drive" as well, and did with the other, similar bug; and it's also happening with another drive

Ok, had the crash and the trace. See bug#701375

Hmm. I posted the trace in (new) bug #701375, but it went marked as a duplicate of bug #699664, which I cannot access.

Puzzled. Awaiting instructions :-)

Thanks Romano, it allowed us to discover those forgotten reports! I've made the other bug public.

These traces are very confusing, since they are all very similar to the original bug 630884. I'm going to report this upstream, and see what they say...

Changed in nautilus (Ubuntu):
status: Incomplete → Triaged
importance: Medium → High
Omer Akram (om26er) on 2011-01-11
Changed in nautilus (Ubuntu):
assignee: nobody → Omer Akram (om26er)
status: Triaged → In Progress
Changed in nautilus:
importance: Unknown → Critical
status: Unknown → Confirmed
Omer Akram (om26er) wrote :

the bug is fixed in natty since nautilus 2.32.0.1 is already in Natty. linked the branch for the maverick fix.

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
assignee: Omer Akram (om26er) → nobody
Changed in nautilus (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → High
milestone: none → maverick-updates
Omer Akram (om26er) on 2011-01-11
description: updated
Jamie Strandboge (jdstrand) wrote :

Uploaded to maverick-proposed. Unsubscribed ubuntu-sponsors (ubuntu-sru already subscribed).

Changed in nautilus (Ubuntu Maverick):
status: Triaged → Confirmed

If this is reported to work, it might be wise to directly upload nautilus 2.32.2.1 to maverick-updates, because it includes this fix among others.

tags: added: verification-needed
Changed in nautilus:
status: Confirmed → Fix Released
steubens (steubens) wrote :

Accepted nautilus into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nautilus (Ubuntu Maverick):
status: Confirmed → Fix Committed
Omer Akram (om26er) wrote :

I have been using the proposed version of nautilus for 8days and have found no regressions, marking verification done.

tags: added: verification-done
removed: verification-needed

Thanks for the swift response
Murali

On Sun, Jan 23, 2011 at 11:11 PM, Omer Akram <email address hidden> wrote:

> I have been using the proposed version of nautilus for 8days and have
> found no regressions, marking verification done.
>
> ** Tags added: verification-done
> ** Tags removed: verification-needed
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (699664).
> https://bugs.launchpad.net/bugs/683972
>
> Title:
> nautilus crashed with SIGSEGV in g_closure_invoke() ejecting drives
>
> Status in Nautilus:
> Fix Released
> Status in “nautilus” package in Ubuntu:
> Fix Released
> Status in “nautilus” source package in Maverick:
> Fix Committed
>
> Bug description:
> Binary package hint: nautilus
>
> TEST CASE:
> 1. unmount a usb device, see nautilus crashes
> 2. now installed nautilus from maverick-proposed
> 3. see it does not crash anymore
>
> i was ejecting 2 drives, ejected the second before the very final
> phase of eject for the first -> crash; currently not at home, will
> verify if this is reproducible like this then
>
> will report on other g_closure_invoke bug i reported earlier, they
> were waiting for this crash dump
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: nautilus 1:2.32.0-0ubuntu1.1
> ProcVersionSignature: Ubuntu 2.6.37-7.18-generic 2.6.37-rc3
> Uname: Linux 2.6.37-7-generic x86_64
> Architecture: amd64
> Date: Wed Dec 1 18:42:21 2010
> ExecutablePath: /usr/bin/nautilus
> ProcCmdline: nautilus
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_US.utf8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x44c5a6: mov (%rax),%r14
> PC (0x0044c5a6) ok
> source "(%rax)" (0x64657469736976) not located in a known VMA region
> (needed readable region)!
> destination "%r14" ok
> SegvReason: reading unknown VMA
> Signal: 11
> SourcePackage: nautilus
> StacktraceTop:
> ?? ()
> g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
> ?? () from /usr/lib/libgobject-2.0.so.0
> g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
> g_signal_emit () from /usr/lib/libgobject-2.0.so.0
> Title: nautilus crashed with SIGSEGV in g_closure_invoke()
> UserGroups: adm admin cdrom dialout disk lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/nautilus/+bug/683972/+subscribe
>

steubens (steubens) wrote :

i'm still getting crashes in nautilus; _around_ ejects, and some just while its running, i'll file new bugs

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.32.0-0ubuntu1.2

---------------
nautilus (1:2.32.0-0ubuntu1.2) maverick-proposed; urgency=low

  * debian/patches/97_unmount_crash_2.patch:
    - Don't crash when unmounting usb devices. (LP: #683972)
 -- Omer Akram <email address hidden> Tue, 11 Jan 2011 17:56:31 +0500

Changed in nautilus (Ubuntu Maverick):
status: Fix Committed → Fix Released
Abdusamed Ahmed (sir508) wrote :

What about a fix for 10.04.2??? :'(

tags: added: testcase

Still seeing this in 12.04.2.

Ben (pumrum) wrote :

Still seeing this in 12.04.2 using Nautilus 3.4.2 with all updates current as of 2013-07-03

Any chance of getting this fixed in the LTS release? This is serious impediment to my workflow. Please let me know if I can be of any assistance with troubleshooting

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.