"Keep Aligned" right click menu option should not allow desktop icon overlap

Bug #292465 reported by manzur on 2008-11-02
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

After checking the keep aligned setting on the desktop, dragging icons should not allow overlap. Instead, dragging icons should rearrange them into neat columns. This behavior is confirmed on Ubuntu 8.10.

manzur (sl-solaris) wrote :
manzur (sl-solaris) wrote :

and people that like it, leave it as it is by default! as i said sometimes i like it!

Anthony Noto (angusthefuzz) wrote :

There currently exists a right click option to "Keep Aligned" which will stop icon overlap. Please let us know if this is what you were referring to. If it is not what you are referring to, please try to include more information. Thank you.

manzur (sl-solaris) wrote :

no, it is not what i am trying to say, i know that option "keep Aligned", i have this option activated, but when i move an icon near another one, it lets me to put it as you see in the screen shot, it would be good if ubuntu desktop stop icons overlap.

manzur (sl-solaris) wrote :

please help, it sometimes drives me crazy!

Anthony Noto (angusthefuzz) wrote :

You can also select "clean up by name" to reorganize the icons. Since what you submitted is not really a bug, or a problem, but rather an idea to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at https://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers. Thanks for taking the time to share your opinion!

manzur (sl-solaris) wrote :

i mean maybe is a bug in, "keep align" option, because, it should keep it organized, when we select this option, i think!

Anthony Noto (angusthefuzz) wrote :

You are correct manzur, keep aligned should keep the icons aligned. Thank you for your bug report.

description: updated

that's an upstream wishlist and likely a duplicate

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
Changed in nautilus:
importance: Wishlist → Low
status: Confirmed → Triaged
Changed in nautilus:
status: Unknown → New
cenora (cenora) wrote :

This Bug is present forever.

Wishlist? Low importance?

Organization in the desktop = keep aligned that actually "keeps icons aligned", or snapped to the grid.

I can say that this also drives me crazy.

j0sh (jazzedupj0sh) wrote :

Ubuntu 9.04
Gnome 2.26.1
Kernel 2.6.28-11-generic

I have 'Keep Aligned' checked. But when I mount volumes through windows shared folders using (Places->Network), sometimes the volume icons overlap, this is a low priority bug, but is a very embarrassing one. Attached png file shows the problem.

I'm ready to assist with any further information that anyone requires.

knownuthin (larry-thunderbolt) wrote :

Ubuntu 9.10

May not be related to this bug however it is irritating that the setting "Keep Aligned" if unchecked by the user remains that way only during the current session. If the computer is turned off, at next startup the "Keep Aligned" setting is once again checked. I personally do not want all my icons aligned to some specific grid. However it appears there is a bug that prevents the "Keep Aligned" setting from retaining the choice set by the user.

YannUbuntu (yannubuntu) wrote :

@all: I confirm this very annoying bug on ubuntu 9.10 (which is corresponding to https://bugzilla.gnome.org/show_bug.cgi?id=560788 ). I think importance should be increased as it is default behavior and it frequently hides icons (Firefox download, mounting media..) which looses the user. By the way, there are related bugs : https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/32577 and https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/12608

@knownuthin: the bug you describe is https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/399974 and is different from the one here.

Changed in nautilus:
importance: Unknown → Wishlist
Changed in nautilus:
status: New → Invalid
YannUbuntu (yannubuntu) on 2012-10-05
Changed in nautilus:
importance: Wishlist → Unknown
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → Low
status: Unknown → Confirmed
Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in nautilus:
importance: Low → Medium
Changed in nautilus:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.