'keep aligned' does not work right

Bug #12608 reported by Janis Blechert on 2005-02-07
This bug affects 54 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
nautilus (Ubuntu)

Bug Description

How it does work:
If I add some icons they are not realigned automaticly, instead I have to
deselect 'keep aligned' in the context menu (of the desktop) and then reselect it.
how it should work:
If anything happens with the icons on the desktop realign them to fit into the grid.

Seems to me like there's just the part missing where the desktop calls the
realign function if an icon is moved/created.


Sebastien Bacher (seb128) wrote :

right, there is a bug open upstream about this:

Karl Hegbloom (karl.hegbloom) wrote :

I sort of like the Windows (tm) behavior where when you drag an icon out of the
stack and let go, it flies to the end of the stack and they all repack and
realign. That's almost what I want. Has anyone ever used GWM? It is a window
manager that has a lisp interpreter built into it. It is probably the first
"emacs of window managers" ever written. There was an icon sorting thing for it
where you could write some lisp code to make icons group and sort along the edge
of the screen. An idea I read of but never had code to try out or witness in
action was to have icon boxes or areas on the screen for certain types of or
manually dropped groups of icons.

Having too many icons on the desktop, to me, is clutter. It would be better to
have virtual icon sets kind of like the virtual screen thing, to where you could
pick what task you are working on and have that select your displayed desktop
icon set. Each should have icon corals that are user definable maybe using an
interface kind of like a seive or evolution mail filter editor that determine
match constraints for what coral to slot the icon into, plus a manual override
or hint. It should not require a course in discrete mathematics and graph
theory to understand how to use it... it ought to be very intuitive once you get
shown the basics. At the same time, there will be power users (artists, etc)
who will enjoy having that kind of organization capability, perhaps. It could
potentially go beyond the square box file manager with icons per directly mapped
file system directory. Maybe applications could specify hints? Or system
admins? Hmmm.... overkill, right?

lexual (lexhider) on 2006-04-25
Changed in nautilus:
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Unconfirmed → Confirmed
Changed in nautilus:
assignee: seb128 → desktop-bugs
importance: Medium → Low
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

Jorge, isn't the design team supposed to list those issues and decide what are usuability issues or not? What is lacking there is a clear design description to start

Sebastien Bacher (seb128) wrote :

The issue is not trivial because icons can be streched and the grid is not easy to draw in such cases, could the design team suggest what the behaviour should be for icons there?

Mat Tomaszewski (mat.t.) wrote :

Seb, can you explain what you mean by "icons can be stretched"?

A. Walton (awalton) wrote :

Right-click an icon, select "Stretch Icon", drag the blue boxes. The icon can be scaled to arbitrary sizes this way.

GonzO (gonzo) wrote :

Suggestion 1: the upper-left hand corner of each icon is what should be aligned to the grid. (I am aware that this may cause icons of differing sizes to overlap when aligned, but I'm not entirely certain "stretch icon" is easy enough to do - or popularly used enough - to compromise the "keep aligned" functionality.

Suggestion 2: One could also dim out the "keep aligned" option if any icons are stretched, given how difficult it would be to actually align/keep aligned icons of varied sizes.

Mat Tomaszewski (mat.t.) wrote :

GonzO, interesting suggestions. I agree that "stretch icon" functionality should never take precedence over aligning the icons. I would go with your suggestion 1.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

What would you do if somebody has lot of customize icons on the desktop and click the option, reset all the settings without asking before? Do ask a question and reset those option? Not allow to enable the align option?

keredson (public-kered) wrote :

i think the answer to the stretched icon issue is not to difficult:

1) divide screen into grid divided by the default width/height of icons
2) order icons in whatever natural order you choose (alpha, date, etc.)
3) use a greedy placement algorithm such that:
 - icon is placed in the farthest-left, then farthest-top empty grid square, anchored by it's top-left corner
 - icon claims as non-empty any grid squares it overlaps
 - repeat with next icon

obviously replace top-left with the text layout locale pref for right-left langs.

Thiago Negri (evohunz) wrote :

I think this item is not a "low" priority bug.
I've switched to XFCE because of this.

Majority of users saves things on desktop (firefox's default download folder) and it is very annoying to see my dekstop messed up a lot of times because I save images and the icons got stretched automatically. I even found my USB drive hidding under my CD-ROM some times.

Isn't there an option to deactivate icon stretching and activating something like "gnome-desktop-boxing" (to act same as XFCE does) option?

I want to see the right icons of my desktop aligned with the left icons but not one next to the other. And I don't want to see diferent icons sizes.

I save things in desktop on-the-go and have no time to keep alligning and reorganizing my desktop.

What's the advantage of having a "cute desktop" with "a lot of options" if you lose usability?
In my opinion, usability must come before cosmetic purposes.

I wan't a simple and working desktop and do not want icons stretching until it can allign correctly. At least make it an option.

This is part of a much larger set of complex problems with the way Nautilus manages the display of the desktop. Unfortunately, this is not a trivially fixable bug, so it cannot be considered a paper cut.

Changed in hundredpapercuts:
status: Confirmed → Invalid
YannUbuntu (yannubuntu) wrote :

I agree with Thiago: default behavior should be to keep usability (no hidden icon under another , and no text half mixed with a neighbor text).

Sebastien Bacher (seb128) wrote :

https://bugzilla.gnome.org/show_bug.cgi?id=601469 ' "Keep aligned" should have a snap to grid behaviour' is closer from this request

Sebastien Bacher (seb128) wrote :

see also https://bugzilla.gnome.org/show_bug.cgi?id=613111 which list quite some issues around the desktop behaviour

description: updated
description: updated
tags: added: desktop-icons
tags: added: nautilus-desktop-icons
removed: desktop-icons
Changed in nautilus:
status: Confirmed → New
Changed in nautilus:
importance: Unknown → Wishlist
Chris Wilson (notgary) wrote :

I can confirm that this bug has been fixed on 11.10.

Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in nautilus:
status: New → Invalid
Changed in nautilus:
importance: Wishlist → Unknown
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → Low
status: Unknown → Confirmed
Todor Velichkov (tosho) wrote :

Will this bug be fixed in the near future? it seems like an UX bug for me. I'm using 13.10 and still the icons on the Desktop get messy all the time.

Giannis (karzisss) wrote :

I confirm that still icon alignment is a disaster on Ubuntu (13.10).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.