DVD mounted and played by wrong user

Bug #230694 reported by Patrice Vetsel
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs
Declined for Intrepid by Sebastien Bacher

Bug Description

Take a fresh Hardy system
2 users, user A created during installation and user B added by A with defaults options.

1/ Start system
2/ login with B
3/ switch to A with the user applet
4/ under A, open tray and put a dvd

-> BUG
error message + totem launched but black screen + you can hear the dvd sound ...

5/ switch to B with applet

-> totem is already reading DVD

6/ close totem
7/ logout
8/ go to A session (already opened)
9/ try to eject DVD

-> BUG -> you can not eject because DVD was mounted by B (But B is logout :/ )

The mecanism to mount a DVD (In fact all external devices are affected) should use the active user/session and not the first loged user in the system.

Revision history for this message
AJ ONeal (coolaj86) wrote :

Of course it affects other media too, not just DVD playback. More than once I get the 'Only otheruser Can eject /dev/device' when that's not the case.

I also have been experiencing this problem since Ubuntu 7.10. It's annoying but I usually just use the terminal to log in to the other account and kill totem. Looking forward to seeing it fixed.

Revision history for this message
Patrice Vetsel (vetsel-patrice) wrote :

Indeed, all external media are affected.

Changed in dbus:
status: New → Confirmed
description: updated
Changed in gnome-mount:
milestone: none → intrepid-alpha-6
Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue was a nautilus one and has been fixed in jaunty, the mounts are only active for the session which is on screen now

affects: gnome-mount (Ubuntu) → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
milestone: intrepid-alpha-6 → none
status: Confirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

see bug #222643 too about the issue

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers