wallpaper not updating

Bug #1128492 reported by Rick Spencer on 2013-02-17
72
This bug affects 33 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
High
Sebastien Bacher

Bug Description

Steps:
1. Find a wallpaper image on the web in firefox
2. Right click and choose Set as Desktop Background
3. Log out, notice that it uses the new background in the greeter for that user, as expected
4. Login again
5. repeat #2 with a different image
6. Log out, note that the backgorund is the background set in #2, not the one set in #5

I even went and renamed the wallpaper image and put it in my Pictures directory. Then I set the background image with the settings tool. The image still did not update in the greeter.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: lightdm 1.4.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-5.10-generic 3.8.0-rc6
Uname: Linux 3.8.0-5-generic i686
ApportVersion: 2.8-0ubuntu4
Architecture: i386
Date: Sun Feb 17 15:11:27 2013
LightdmConfig:
 [SeatDefaults]
 autologin-user=ubuntu
 user-session=ubuntu
 greeter-session=unity-greeter
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: Upgraded to raring on 2013-02-11 (6 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed

Not certain where to put this, so subscribing Robert and assigning to the desktop team. Please reassign as appropriate

Changed in lightdm (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Sebastien Bacher (seb128) wrote :

Thank you for the bug report Rick.

There is a long standing known issue: user wallpapers, if stored in a non world readable directory, are not visible to the greeter. That's bug #928553. The reason is that only the URL is shared (to not "leak" private infos), so the greater (which runs as another user) needs to be able to read the file to display it

Is the directory the image is stored in world readable?

Not sure that's the case there though, since you seem to do twice the same steps and that should lead to the same directory to be used/result

if you run "gsettings get org.gnome.desktop.background picture-uri", does it list the correct image?

affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)
Changed in unity-greeter (Ubuntu):
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

Could you also run:

"dbus-send --print-reply --system --dest="org.freedesktop.Accounts" /org/freedesktop/Accounts/User1000 org.freedesktop.DBus.Properties.Get string:"org.freedesktop.Accounts.User" string:"BackgroundFile""

when "1000" is your user uid

royden (ryts) wrote :

:~$ ls -al /usr/share/
drwxr-xr-x 3 root root 4096 mar 8 01:55 backgrounds

:~$ gsettings get org.gnome.desktop.background picture-uri
'file:///usr/share/backgrounds/warty-final-ubuntu.png'

:~$ dbus-send --print-reply --system --dest="org.freedesktop.Accounts" /org/freedesktop/Accounts/User1000 org.freedesktop.DBus.Properties.Get string:"org.freedesktop.Accounts.User" string:"BackgroundFile"

method return sender=:1.77 -> dest=:1.188 reply_serial=2 variant string "/usr/share/backgrounds/Vanishing_by_James_Wilson.jpg"

Background was stuck on "Vanishing_by...." set in 12.10 some time ago. After upgrade noticed that the unity-greeter version of the background (i.e. with password box) transferred to desktop background (i.e. it had the password box). Was not possible to set another background via system-settings. Using dconf -editor I got it to disappear from the desktop but not the greeter; desktop however now blank.

ionash. (janusz-arch) wrote :

This affect me too. Unity-greeter stuck with wallpaper set before upgrade to 13.04.
Wallpaper doesn't change even when I'm manually edit in dconf it's name.
When I'm trying change greeter background using Ubuntu Tweak, new wallpaper shows up for a little moment, and after that again visible is the old one.
Even when I deleted from /usr/share/backrounds this wallpaper, greeter does not show my actual wallpaper, instead default wallpaper shows up.
And now command from Sebastien's post returns name of the wallpaper, that no longer exists in /usr/share/backgrounds!

ionash. (janusz-arch) wrote :

:~/Pulpit$ gsettings get org.gnome.desktop.background picture-uri
'file:///usr/share/backgrounds/Last_breath%E2%80%A6_by_Francisco_Javier_Epinoza_P%C3%A9rez.jpg'
:~/Pulpit$ dbus-send --print-reply --system --dest="org.freedesktop.Accounts" /org/freedesktop/Accounts/User1000 org.freedesktop.DBus.Properties.Get string:"org.freedesktop.Accounts.User" string:"BackgroundFile"
method return sender=:1.15 -> dest=:1.552 reply_serial=2
   variant string "/usr/share/backgrounds/A_Little_Quetzal_by_vgerasimov.jpg"

@seb128

gsettings get org.gnome.desktop.background picture-uri - prints the correct file
dbus-send --print-reply --system --dest="org.freedesktop.Accounts" /org/freedesktop/Accounts/User1001 org.freedesktop.DBus.Properties.Get string:"org.freedesktop.Accounts.User" string:"BackgroundFile" - prints the old file

@seb128 -

That second command pointed to the old picture which was still in my downloads directory, I deleted it, and then logged out. Then I had the default UG wallpaper not my custom desktop.

Sebastien Bacher (seb128) wrote :

keeping this bug since it has more details than the other one

affects: unity-greeter (Ubuntu) → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Sebastien Bacher (seb128)
status: Incomplete → In Progress
Sebastien Bacher (seb128) wrote :

Thanks everyone, we relied on gnome-settings-daemon to write the updated image to accountsservices before but since it's nautilus doing the work it should be the one updating the value as well, I'm going to copy that patch over and adapt it to nautilus

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.6.3-0ubuntu11

---------------
nautilus (1:3.6.3-0ubuntu11) raring; urgency=low

  * debian/patches/10_sync_background_to_accountsservice.patch:
    - write the background image to accountsservice when it changes,
      gnome-settings-daemon was doing that but we stopped using that plugin
      to avoid duplication so we need to do it here (lp: #1128492)
 -- Sebastien Bacher <email address hidden> Thu, 21 Mar 2013 12:53:17 +0100

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Yonsy (yonsy) wrote :

if you use nemo for Ubuntu (without Cinnamon extensions) and disable Nautilus to be launched, the problem happens again. You will need to check if nautilus is not operative and in this case, re-use gnome-settings daemon

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers