white noise or no sound after seeking when using PULSEAUDIO:default

Bug #550100 reported by Nico on 2010-03-28
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
MythTV
Unknown
Unknown
mythtv (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: mythtv

I have an FE on my laptop. This laptop is also a generic desktop, so I want to use Pulseaudio so that I can get sounds, like chat events, etc...

The FE is configured to use PULSEAUDIO:default.

If I seek inside a normally playing recording, ffw or rwd, I lose proper audio, getting either white noise (raw digital data?) or no soundat all.

Getting out of play mode and starting play again restores proper sound.

Selecting an alternative audio channel and coming back to the default one while playing the recording also restores sound.

Disregard the info on MythTV directory permissions, the bug was recorded on the remote FE not mounting anything

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: mythtv-frontend 0.23.0+fixes23820-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-17-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Mar 28 09:18:33 2010
EcryptfsInUse: Yes
Installed_mythplugins-dbg: 0.0
Installed_mythtv-dbg: 0.0
MythTVDirectoryPermissions:
 total 16
 drwxrwsr-x 2 mythtv mythtv 4096 2010-03-25 06:40 music
 drwxrwxr-x 3 mythtv mythtv 4096 2010-01-26 21:37 pictures
 drwxr-xr-x 2 mythtv mythtv 4096 2008-11-06 22:02 recordings
 drwxr-xr-x 2 root root 4096 2010-03-25 06:40 videos
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: mythtv

Nico (nico-rdo) wrote :
ShaunS (shauns) wrote :

Hi,

I have the same issue with PULSEAUDIO:default.

Recorded or Live TV will start out playing correct audio, if I then skip ahead or back I sometimes get static. If I then skip again or hit pause a few times the static sometimes reverts to the correct audio.

I am also running:
10.4 updated from Beta1
 mythtv-frontend 0.23.0+fixes23820-0ubuntu1

Thanks,
Shaun

MarcRandolph (mrand) wrote :

Thank you for helping to improve Mythbuntu by opening this ticket. I've forwarded the bug upstream.

Changed in mythtv (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in mythtv:
status: Unknown → New
Jeremy Nickurak (nickurak) wrote :

Since ALSA:pulse doesn't seem to work any more (as it did in Karmic), Pulseaudio:default is the only option... not having that working means mythtv is largely unusable under Lucid. :(

Changed in mythtv:
status: New → Confirmed
ShaunS (shauns) wrote :

Hi,

If you are having trouble getting any sound, try:

Audio Output Device: /dev/dsp

or

Audio Output Device: ALSA:default

One or both of these options work for me in Lucid, on four separate machines. The trouble is that all other sound sources are disabled. This is an issue but not a complete cluster.

Changed in mythtv:
status: Confirmed → Fix Released
MarcRandolph (mrand) wrote :

This is a WAF (wife-acceptance-factor) killer.

Changed in mythtv (Ubuntu):
importance: Medium → High
milestone: none → ubuntu-10.04
Brian Murray (brian-murray) wrote :

The upstream bug report has a small patch in it.

ShaunS (shauns) wrote :

Hi,

I have applied the patch to the Ubuntu Lucid source in the repository. Installed the rebuilt libmyth-0.23-0_0.23.0+fixes24158-0ubuntu2_i386.deb.

It works and fixes the white noise issue.
Thanks go to danielk for the upstream patch.

For those who need to get it working today, build the package from source (apt-get source).
I have attached the patch I made from the upstream diff.
Place it in the folder:

mythtv-0.23.0+fixes24158/debian/patches

Modify your series file to include it.

Cheers,
Shaun

PS: My wife is very happy.
PPS: For help on building packages from source: https://wiki.ubuntu.com/PackagingGuide/Complete

ShaunS (shauns) wrote :

Hi,

After playing around with the upstream patch I noticed a sound sync problem of about 200ms.

I have tweaked the patch to fix this problem, but I do not understand the code or the implications of this tweak. It does seem to fix the annoying lip sync issue.

I changed the line:
    soundcard_buffer_size = 16 * fragment_size;
to
    soundcard_buffer_size = 6 * fragment_size;

The idea is that this will shorten the buffer size by 10 x 20ms.

I suggest that if the upstream patch gives lip sync issues try this one.

Cheers,
Shaun

MarcRandolph (mrand) wrote :

Thanks for the testing, Shaun! This kind of stuff helps make the developers more confident when making a last minute change. I've forwarded your sound sync fix upstream as well:
http://svn.mythtv.org/trac/ticket/8378

tags: added: patch
ShaunS (shauns) wrote :

Cheers Marc,
Testing is not a problem, this issue is very important to me and will be to others I am sure.

There seems to be an interesting upstream discussion on latency and sync regarding pulseaudio.
http://svn.mythtv.org/trac/ticket/7496

Thanks for the good work,
Shaun

ShaunS (shauns) wrote :

I just mentioned to my wife that I was about to try another mythtv pulseaudio patch.
The WAF took a nose dive.

Testing may be a little more complicated than I thought :)

ShaunS (shauns) wrote :

Hi,

Thanks to Marc submitting http://svn.mythtv.org/trac/ticket/8378 I have found a patch that believe needs to be included in the Ubuntu Lucid release. The ticket Marc submitted was marked as a duplicate of http://svn.mythtv.org/trac/ticket/7496

I removed all the pulse related patches I have tested previously, and applied the patch linked to in ticket 7496 (pulse-latency-001.patch) and it works like a charm. It essentially works with pulseaudio and solves the white noise and latency issues in a very clean and proper way.

I would like to know what the procedure is to get pulse-latency-001.patch included?
Do I have to maintain my own build of libmyth-0.23-0_0.23.0+fixes24158-0ubuntu2_i386.deb?

Thanks,
Shaun

ShaunS, the Mythbuntu developers try to keep as small a diff as
absolutely possible with upstream (with a very strong preference for
no difference at all). Since your first patch is based on what is
committed to upstream trunk, it would be preferred over the
pulse-latency-001.patch since upstream hasn't indicated they are
planning on using it.

Having said that, I don't know enough about this code to know if your
buffer size change has any negative impacts, or if it impacts
non-Pulse audio applications... do you? I'd hope being named
"audiooutputpulse.cpp", it would only apply to pulse - but making
assumptions about such things can be dangerous.

BTW, Dealing with audio upstream requires patience, and that's even
ignoring the fact that this relates to pulse audio, which gets even
less love.

ShaunS (shauns) wrote :

Hi Marc,

Thank you for your response, the information is informative. I understand that these things take time.
I am really out of my depth as far as how to move this forward, but I would like to help as much as possible.

1. As far as I understand the "audiooutputpulse.cpp" contains only pulse related code.

Searching through the directory contents of the libs folder I would say that this is a fair assumption to make. If anyone has input I would love to hear it.

2. The small change that I made to the original, fixes lip sync but I have only tested it on one box.

I will roll back my test setup to use this tweaked patch and test it on all four of my boxes and report back.
To be clear I am talking of the patch linked to: http://launchpadlibrarian.net/45196373/99_white_noise_pulseaudio

It would be great if we could get a compiled version, to allow more widespread testing of this patch.
Does Mythbuntu have a ppa?

Cheers,
Shaun

Steve Langasek (vorlon) on 2010-04-27
Changed in mythtv (Ubuntu Lucid):
milestone: ubuntu-10.04 → lucid-updates
ShaunS (shauns) wrote :

I have tested the patch on all four of my machines and it works on all.
No white noise and lip-sync seems fine.

I have a repository with the patched binaries and sources, if there is a requirement
and I am not violating any rules, I can make it public.

Andrew (andrew-rw-robinson) wrote :

Sorry to bug you all. I am only getting white noise with sound set to ALSA:default. I was using ALSA:mixed-digital. I see this is going to be in lucid-updates, or should it already be?

My mythmusic sound is fine, it is only the TV playback that is giving me problems.

ShaunS (shauns) wrote :

Hi Andrew,

This bug is specifically related to pulseaudio. I am very suprised to learn that ALSA:default is giving you trouble. have you managed to get any TV playback sound working properly?

The as far as I know the fix has not yet been released.

ShaunS (shauns) wrote :

If anyone is interested I have a PPA that contains a patched version of MythTV.
This should fix the bug when using audio output PULSEAUDIO:default

ppa:shauns/mythtv-lucid-testing

Please report back if you have tested the patch.

Thanks,
Shaun

Jeff Sereno (jsereno) wrote :

This is a relatively old bug now, yet until I upgraded last night to 2:0.24.0~trunk-24634-0ubuntu1, I never had this issue on my Lucid box, and now I do.

I notice that is seems to impact anything related to the internal player, eg: Live/Pre-recorded TV and MythVideo. For me, the simplest solution has been to pause/unpause untilt he white noise stops.

I do not have the white noise problem with a Karmic box using the same MythTV build.

Might give ShaunS's PPA a shot to see how it goes for me tonight.

Nico (nico-rdo) wrote :

http://svn.mythtv.org/trac/changeset/25041 - backport r24214 to 0.23-fixes

http://svn.mythtv.org/trac/changeset/24214 - Fixes #8237 (upstream bug). Fixes some math & adds some explanation.

Jeremy Nickurak (nickurak) wrote :

New upstream ticket against 0.24 branch.

Changed in mythtv:
status: Fix Released → Unknown

This bug is still active in 12.04. I just upgraded from 10.04 and encountered this.

I have not checked if the patches are applied to 0.25. A workaround that appears to be fine for me is to change the default sampling rate in pulsed.

Add this line to /etc/pulse/daemon.conf:
default-sample-rate = 48000

I encountered this on upgrade from 10.04 to 12.04 ( My upgrade went via all the intermediate steps as well dues to a misconfiguration on my part)

The fix mentioned by Matt Forrest worked for me too.

Tim Abell (tim-abell) wrote :

Thanks Matt for the workaround, worked for me too.

I'd just like to add that this bug is really jarring as the white noise is at full volume, which can be a *lot* louder than the tv audio. Made me cringe every time.

Changed in mythtv (Ubuntu Lucid):
milestone: lucid-updates → none
no longer affects: mythtv (Ubuntu Lucid)
walter---- (walter-van) wrote :

note: I have this issue in 4 computers; default settings of mythtv on ubuntu 12.04 and pulseaudio cause 'random' noise. And random means it can start at any action you do; after a pause, switching to program guide, it can happen (about 15% chance).
Another pause can fix it.
My solution to stay with Pulse audio without changing pulseaudio default settings:
in go to 'Advanced Audio Settings' on the audio Config Page.
Here activate 'Override SRC audio quality Sample rate conversion' and select 'Disabled'
Also activate 'Force audio device output to 48kHz".
The other option I kepped on the default settings.

This worked on my 4 computers, all with different hardware.

Walter

Conrad Firm (confirm) wrote :

hello all

I recently upgraded from 0.25 to 0.27 and was having issues with the frontend crashing - which appeared to be caused by a problem with the ALSA:surround51 configuration inherited from previous versions

unfortunately when I tried changing FE to Pulseaudio:default I started getting this strange white noise issue

I cannot tell you if it affected 0.25 but it definitely affected my upstream in 0.27

I can confirm the above workaround (fix?) where I changed "Override SRC audio quality Sample rate conversion" from "Fastest" to "Disabled" worked for me - thanks walter

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.