[lucid] update to lucid shows as mythbuntu and doesn't work

Bug #550237 reported by Kieren Davies on 2010-03-28
66
This bug affects 9 people
Affects Status Importance Assigned to Milestone
mythbuntu-meta (Ubuntu)
Undecided
Unassigned
netbook-meta (Ubuntu)
Undecided
Unassigned
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Updated plymouth package with corrected recommends is on the line.

***For anyone hit by this bug you will need to manually install the package:
plymouth-theme-ubuntu-text

And then remove these packages:
lubuntu-plymouth-theme
mythbuntu-default-settings

***If you are stuck with a black desktop after boot:
Switch over to a terminal via CTRL+ALT+F2

Login and run the commands:
sudo aptitude remove mythbuntu-default-settings
sudo aptitude install plymouth-theme-ubuntu-text
   (above command will also auto-remove several xfce-related packages)

and finally reboot.

------

Binary package hint: plymouth

Automatically updating from Jaunty to Karmic, then from Karmic to Lucid, resulted in the splash screen displaying "mythbuntu", and the desktop interface not working and only displaying a single panel with clock at the top.

DistroRelease: Ubuntu 10.04

Related branches

Kieren Davies (kierendavies) wrote :
Fredrik Öhrström (oehrstroem) wrote :

This happened to me as well.
1) Installed Lucid Beta 1 Desktop Edition succesfully onto my Asus 1008p netbook.
2) Started update-manager and saw that there were a very large amount of packages to be updated.
3) Allowed update-manager to do its work, as expected it said that restart was necessary.
4) Restarted and saw that the shutdown splash said mythbuntu.....oh oh!
5) It boots into a black Xfce environment with no working menues at all..

Michiel (michielbaird) on 2010-03-28
tags: added: karmic2lucid
Steve Langasek (vorlon) on 2010-03-28
affects: plymouth (Ubuntu) → mythbuntu-meta (Ubuntu)
Martin Erik Werner (arand) wrote :

This seems to be due to:
Current plymouth package pulls in plymouth-theme
which picks mythbuntu-default-settings as the providing package (instead of the appropriate plymouth-theme-ubuntu-logo or plymouth-theme-ubuntu-text I think)
which pulls in xfce4-utils

Mario Limonciello (superm1) wrote :

So this isn't a bug in mythbuntu, it just so happens that plymouth is pulling in the mythbuntu package. If it doesn't want people to pull in the mythbuntu theme, it should Recommends plymouth-theme-ubuntu-logo | plymouth-theme instead.

Also, any of the metas that aren't pulling in an explicity plymouth theme need to start doing so.

Changed in mythbuntu-meta (Ubuntu):
status: New → Invalid

This also affect me from a freshly done installation of the 1st beta-version on a HP Compaq Presario CQ60-415so.

After all the updates are done I see something has crashed, but no report-window appeared.

Could it be 'cause of this error?

Martin Erik Werner (arand) wrote :

On my virtualbox system, it instead wants to pull in
lubuntu-plymouth-theme
weirder by th minute...

Martin Erik Werner (arand) wrote :

On my virtualbox system it (now?) instead wants to pull in:
lubuntu-plymouth-theme

Changed in netbook-meta (Ubuntu):
status: New → Invalid
Changed in plymouth (Ubuntu):
status: New → Confirmed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.1-1ubuntu2

---------------
plymouth (0.8.1-1ubuntu2) lucid; urgency=low

  * Make sure all the plymouth themes declare Replaces: plymouth (<< 0.8.1-1~)
    to give a smooth upgrade. LP: #549701.
  * Add Breaks: against the old versions of the out-of-tree plymouth theme
    packages.
  * Recommend plymouth-theme-ubuntu-text | plymouth-theme, to avoid pulling
    in a theme at random. LP: #550237.
 -- Steve Langasek <email address hidden> Sun, 28 Mar 2010 15:36:41 -0700

Changed in plymouth (Ubuntu):
status: Confirmed → Fix Released
Martin Erik Werner (arand) wrote :

Updated plymouth package with corrected recommends is on the line.

For anyone hit by this bug you will need to manually install the package:
plymouth-theme-ubuntu-text

And then remove these packages:
lubuntu-plymouth-theme
mythbuntu-default-settings

description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions