Ubuntu

Package MySQL 5.5.x for Ubuntu

Reported by Michael Marley on 2010-12-16
244
This bug affects 38 people
Affects Status Importance Assigned to Milestone
MySQL Server
New
Undecided
Unassigned
mysql-5.1 (Ubuntu)
Wishlist
Clint Byrum
Declined for Oneiric by Clint Byrum

Bug Description

MySQL 5.5.8 was just released today, and I was wondering if it might be possible to package that for Natty, or at least put it in a PPA somewhere. I would do it myself, except they changed from GNU automake to cmake for 5.5, and it is beyond my level of skill to update the packaging script for that change.

Clint Byrum (clint-fewbar) wrote :

Hi Machael, thanks for filing this report.

I agree and hope that we can at least ship 5.5 in universe for natty. We'll be working directly with the Debian mysql maintainers on this.

Marking Confirmed and Wishlist per policy on needs-packaging bugs.

tags: added: needs-packaging
Changed in mysql-5.1 (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Changed in mysql-5.1 (Ubuntu):
assignee: nobody → Clint Byrum (clint-fewbar)
status: Confirmed → In Progress
Clint Byrum (clint-fewbar) wrote :

Ok, I've built the branch linked to this report in a PPA here:

https://launchpad.net/~clint-fewbar/+archive/fixes

Note that that PPA is full of other things that aren't dependencies of
mysql, so be careful using the ppa, upgrades may break your box. :)

Jimmy Merrild Krag (beruic) wrote :

As far as I can see it's only published for Natty. Why is this? I could use it for Maverick or (preferably) Lucid.

Clint Byrum (clint-fewbar) wrote :

Jimmy, the effort is ongoing and we want to get it right for future versions before attempting any backports, if for no other reason than we want to make sure those backports are upgradable!

That said, you're welcome to pull down the packaging as it sits right now in the linked branch and build it on lucid or maverick.. I don't see anything in the build that would prevent that from working. One thing to watch out for though, is that libmysqlclient16 is not ABI compatible, and so will likely be removed from the build until we figure that out with upstream. This bug is tracking the issue there:

http://bugs.mysql.com/bug.php?id=60061

Adam Nelson (adam-varud) wrote :

It looks like the above referenced ticket has been closed and fixed as of 5.5.10 :-)

In my personal situation, I'd be happiest to see libmysqlclient-dev and mysql-client available sooner at the expense of any of the server packages. I suspect that many people will upgrade clients before servers and would be happiest with that situation as well.

Clint Byrum (clint-fewbar) wrote :

Indeed, 5.5.10 is out now, so I'll take a look at generating packages with libmysqlclient18.

However, now that we're well past Feature Freeze, natty will definitely not see 5.5 for the client libraries (I'd still like to get the daemon into universe).

I will start working with Norbert to get 5.5 into Debian now, so we can just sync and merge when oneiric opens.

Chuck Short (zulcss) wrote :

This isnt going to happen in natty.

chuck

Gabriel Mazetto (brodock) wrote :

Could it be backported to natty and Hardy when done?

summary: - Package MySQL 5.5.x for Natty
+ Package MySQL 5.5.x for Ubuntu
Clint Byrum (clint-fewbar) wrote :

FYI for those of you wondering where this is, I've submitted a package of 5.5.13 for upload to Debian. You can take a look here:

http://mentors.debian.net/cgi-bin/sponsor-pkglist?action=details;package=mysql-5.5

Once that hits Debian we should be able to move forward with bringing MySQL 5.5 into Ubuntu.

Duffy (ratman345) wrote :

Clint,

About how long do you think it will be until we have a 5.5 package for Ubuntu?

Excerpts from Duffy's message of Mon Jul 25 23:17:00 UTC 2011:
> Clint,
>
> About how long do you think it will be until we have a 5.5 package for
> Ubuntu?

My initial mysql 5.5 packaging was rejected because of copyright file
discrepancies. I hope to re-submit it in the next 2 weeks. :-P

Bart Verwilst (verwilst) wrote :

I guess this will pretty much miss the Oneiric window of merging? :)

Clint Byrum (clint-fewbar) wrote :

Excerpts from Bart Verwilst's message of Sun Jul 31 22:30:32 UTC 2011:
> I guess this will pretty much miss the Oneiric window of merging? :)
>

Indeed, the packaging is stalled on the almost herculean effort to
re-evaluate the copyright status of all files in mysql. I should be
finished with that soon, but its probably too late to complete such a
transition for Oneiric, given the number of reverse dependencies that
need to be rebuilt.

dfrg.msc (dfrg-msc) wrote :

It seems that there is no developers for MySQL in the Debian team at present, 5.1.59 and 5.5.16 were released but not uploaded to Debian yet. Would Ubuntu developers package MySQL-5.5 for Debian?

Clint Byrum (clint-fewbar) wrote :

Excerpts from dfrg.msc's message of Wed Oct 19 06:21:01 UTC 2011:
> It seems that there is no developers for MySQL in the Debian team at
> present, 5.1.59 and 5.5.16 were released but not uploaded to Debian yet.
> Would Ubuntu developers package MySQL-5.5 for Debian?
>

Norbert still participates, he just has very little time.

I'm currently awaiting completion of the DD process, and then I will be
adding some muscle to the process as well.

We should get 5.5 into Debian, and then hopefully 12.04, very soon.

Szymon (szymon-szypulski-1) wrote :

Is there any ETA for this?

Clint Byrum (clint-fewbar) wrote :

5.5.17 was just accepted into Debian experimental, so the ETA is "sooner than before".

Next we need to merge 5.5 into precise, and change 5.1 to not build any of the main packages (libmysqlclient-dev, mysql-server, mysql-client, etc. etc.) anymore. Then we have to rebuild all of libmysqlclient16's reverse dependencies to pick up the new libmysqlclient18.

It has taken a while, but we're quite close now!

Clint Byrum (clint-fewbar) wrote :

5.5.17-1ubuntu4 is in the NEW queue for precise.. so.. close..

Clint Byrum (clint-fewbar) wrote :

err, 5.5.17-4ubuntu1 ;)

Changed in mysql-5.1 (Ubuntu):
status: In Progress → Fix Committed
mrl586 (mrl586) wrote :

Can you package mysql 5.5.18?

Clint Byrum (clint-fewbar) wrote :

Excerpts from mrl586's message of Tue Nov 22 07:49:52 UTC 2011:
> Can you package mysql 5.5.18?
>

Heh, baby steps. 5.5.18 was released *6 days ago* .. this packaging has
taken nearly a year. Lets land 5.5.17 and then I'm certain we'll ship
5.5.18 in 12.04.

Clint Byrum (clint-fewbar) wrote :

5.5.17 has landed in Precise.. 5.5.18 will come along soon.

Changed in mysql-5.1 (Ubuntu):
status: Fix Committed → Fix Released
dfrg.msc (dfrg-msc) wrote :

The date of Debian import freeze of Ubuntu 12.04 is coming soon, will 5.5.19 be uploaded to Debian experimental?

Clint Byrum (clint-fewbar) wrote :

Yes, actually, I would like to land 5.5.19 in Debian unstable soon actually. However, remember that DIF is just the stop of *automatic* syncs from Debian.

https://wiki.ubuntu.com/PrecisePangolin/ReleaseSchedule

Feature Freeze is not until mid-February, but even then, 5.5.19 would be fine since its a bug fix release.

dfrg.msc (dfrg-msc) wrote :

Upstream 5.5.20 is out, but there is no sign of 5.5.x in Debian unstable now. Maybe 5.5.20 is now a choice.

dfrg.msc (dfrg-msc) wrote :

Well, mid-February has passed, so we will have neither MySQL 5.5.19 nor MariaDB in Precise?

I see mysql-server-5.5.20 in Pangolin archives (not in debian ones, unfortunately)

dfrg.msc (dfrg-msc) wrote :

Well, I had not noticed that. I think Clint Byrum will land MariaDB into Debian unstable rather than MySQL 5.5, MySQL 5.5.20 has landed in precise because it's too late to have the brand new package of MariaDB to Ubuntu 12.04.

Clint Byrum (clint-fewbar) wrote :

If you'd like to discuss the future of mysql-5.5 in Debian, I'd suggest the pkg-mysql-maint mailing list:

http://lists.alioth.debian.org/mailman/listinfo/pkg-mysql-maint

5.5.20 has landed in precise, and is pending soon for Debian experimental.

dfrg.msc (dfrg-msc) wrote :

Seems 5.5.20 has a medium 0day bug, will there be 5.5.21 in precise?

Clint Byrum (clint-fewbar) wrote :

Excerpts from dfrg.msc's message of Mon Feb 27 13:09:10 UTC 2012:
> Seems 5.5.20 has a medium 0day bug, will there be 5.5.21 in precise?
>

Yes, it should land soon.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.