gnome-shell crashed with signal 5 in _XIOError() from _XReply() from XSync() from gdk_x11_display_error_trap_pop_internal() from gdk_error_trap_pop_internal() from meta_screen_free() from meta_display_close()

Bug #1556601 reported by Matt Austin on 2016-03-13
668
This bug affects 83 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Medium
Unassigned

Bug Description

https://errors.ubuntu.com/problem/c639f8bfee916c8847cf5b231bd46cc7788f7095

---

Prompted to report this bug after login.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: gnome-shell 3.18.4-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-12.28-generic 4.4.4
Uname: Linux 4.4.0-12-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CrashCounter: 1
CurrentDesktop: GNOME
Date: Sun Mar 13 19:48:37 2016
DisplayManager:

ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:

InstallationDate: Installed on 2015-04-07 (341 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Beta amd64 (20150326)
ProcCmdline: gnome-shell --mode=gdm --wayland --display-server
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_AU.UTF-8
 SHELL=/bin/false
Signal: 5
SourcePackage: gnome-shell
StacktraceTop:
 ?? () from /usr/lib/libmutter.so.0
 _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 _XReply () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 XSync () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
Title: gnome-shell crashed with signal 5 in _XIOError()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Matt Austin (mattaustin) wrote :

StacktraceTop:
 x_io_error () from /tmp/apport_sandbox__ddKhF/usr/lib/libmutter.so.0
 _XIOError (dpy=dpy@entry=0x24f6000) at ../../src/XlibInt.c:1464
 _XReply (dpy=dpy@entry=0x24f6000, rep=rep@entry=0x7ffd6d9135f0, extra=extra@entry=0, discard=discard@entry=1) at ../../src/xcb_io.c:708
 XSync (dpy=0x24f6000, discard=discard@entry=0) at ../../src/Sync.c:44
 gdk_x11_display_error_trap_pop_internal (display=0x2506010, need_code=<optimized out>) at /build/gtk+3.0-BLS5EL/gtk+3.0-3.18.8/./gdk/x11/gdkdisplay-x11.c:2760

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
tags: added: yakkety
tags: added: zesty
tags: added: bugpattern-needed
tags: added: artful
information type: Private → Public
tags: added: xorg
description: updated
summary: - gnome-shell crashed with signal 5 in _XIOError()
+ gnome-shell crashed with signal 5 in _XIOError() from _XReply() from
+ XSync() ["Connection to xwayland lost"]
summary: gnome-shell crashed with signal 5 in _XIOError() from _XReply() from
- XSync() ["Connection to xwayland lost"]
+ XSync() from gdk_x11_display_error_trap_pop_internal() from
+ gdk_error_trap_pop_internal() from meta_screen_free() from
+ meta_display_close()
Daniel van Vugt (vanvugt) wrote :

mutter (3.28.1-1ubuntu1) bionic; urgency=medium

  * Add xwayland-use-g_autoptr-for-GError-in-xserver_died.patch,
    xwayland-Don-t-abort-if-Xwayland-crashes.patch:
    - Cherry picked from upstream, to reduce noise of mutter on crashes
      which are actually caused by XWayland (LP: #1748450)

 -- Marco Trevisan (Treviño) <email address hidden> Mon, 23 Apr 2018 10:46:57 -0500

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
affects: gnome-shell (Ubuntu) → mutter (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers