updater crashes in multiarch scenarios where there is no native package

Bug #1295440 reported by Harald Sitter on 2014-03-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Muon
Fix Released
High
muon (Ubuntu)
Medium
Unassigned

Bug Description

updater crashes in multiarch scenarios where there is no native package

Download full text (15.1 KiB)

Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.8.0-29-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

Wasn't doing anything special; just launched the updater by clicking the tray icon.

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8d0f8387c0 (LWP 6925))]

Thread 5 (Thread 0x7f8cfc99f700 (LWP 6926)):
#0 0x00007f8d0ce96f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007f8d0a2236a4 in g_main_context_poll (priority=2147483647, n_fds=2, fds=0x7f8cf8002c00, timeout=-1, context=0x7f8cf80009a0) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:4006
#2 g_main_context_iterate (context=context@entry=0x7f8cf80009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3707
#3 0x00007f8d0a2237ac in g_main_context_iteration (context=0x7f8cf80009a0, may_block=1) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3773
#4 0x00007f8d0d61ca76 in QEventDispatcherGlib::processEvents (this=0x7f8cf80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5 0x00007f8d0d5ee5ef in QEventLoop::processEvents (this=this@entry=0x7f8cfc99ed70, flags=...) at kernel/qeventloop.cpp:149
#6 0x00007f8d0d5ee8e5 in QEventLoop::exec (this=this@entry=0x7f8cfc99ed70, flags=...) at kernel/qeventloop.cpp:204
#7 0x00007f8d0d4ed88f in QThread::exec (this=this@entry=0x19c1710) at thread/qthread.cpp:542
#8 0x00007f8d0d5cfd13 in QInotifyFileSystemWatcherEngine::run (this=0x19c1710) at io/qfilesystemwatcher_inotify.cpp:265
#9 0x00007f8d0d4eff2f in QThreadPrivate::start (arg=0x19c1710) at thread/qthread_unix.cpp:338
#10 0x00007f8d0a6fbf6e in start_thread (arg=0x7f8cfc99f700) at pthread_create.c:311
#11 0x00007f8d0cea39cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f8cf79b4700 (LWP 6927)):
#0 0x00007f8d0ce9bde3 in select () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007f8d0d5ccad1 in QProcessManager::run (this=0x7f8d0d955540 <processManager()::processManager>) at io/qprocess_unix.cpp:245
#2 0x00007f8d0d4eff2f in QThreadPrivate::start (arg=0x7f8d0d955540 <processManager()::processManager>) at thread/qthread_unix.cpp:338
#3 0x00007f8d0a6fbf6e in start_thread (arg=0x7f8cf79b4700) at pthread_create.c:311
#4 0x00007f8d0cea39cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f8ced5f6700 (LWP 6956)):
#0 pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:238
#1 0x00007f8d0d4f03e4 in wait (time=30000, this=0x291e6a0) at thread/qwaitcondition_unix.cpp:84
#2 QWaitCondition::wait (this=<optimized out>, mutex=mutex@entry=0x291e968, time=30000) at thread/qwaitcondition_unix.cpp:158
#3 0x00007f8d0d4e38a5 in QThreadPoolThread::run (this=0x291d680) at concurrent/qthreadpool.cpp:141
#4 0x00007f8d0d4eff2f in QThreadPrivate::start (arg=0x291d680) at thread/qthread_unix.cpp:338
#5 0x00007f8d0a6fbf6e in st...

This is now happening every time. I get this message in stdout:

Couldn't find the package: "wine1.6-i386"

I just added Wine's PPA for Ubuntu ("sudo add-apt-repository ppa:ubuntu-wine/ppa"), so I'm guessing that's related.

*** Bug 327761 has been marked as a duplicate of this bug. ***

Created attachment 83705
New crash information added by DrKonqi

muon-updater (2.1.1) on KDE Platform 4.11.2 using Qt 4.8.4

I had a problem updating a while back with muon downloading a config file. I left it running overnight and it never completed when i killed process removed locks and cleaned up This kept on happening

-- Backtrace (Reduced):
#6 UpdateModel::setResources (this=0x22e8110, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7 0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x20ce3a0) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8 0x000000000041127e in UpdaterWidget::activityChanged (this=0x20ce3a0) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9 0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
[...]
#11 0x00007f73c71d6485 in ResourcesModel::qt_static_metacall (_o=0x20e4130, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:90

Created attachment 83749
New crash information added by DrKonqi

muon-updater (2.1.1) on KDE Platform 4.11.2 using Qt 4.8.4

- What I was doing when the application crashed:

Just opened the Muon Updater. The crash seem to be introduced after a previous system update.

- Unusual behavior I noticed:

No special unusual behavior.

-- Backtrace (Reduced):
#6 UpdateModel::setResources (this=0x1cb8b00, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7 0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x1cb9620) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8 0x000000000041127e in UpdaterWidget::activityChanged (this=0x1cb9620) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9 0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
[...]
#11 0x00007faf6def9485 in ResourcesModel::qt_static_metacall (_o=0x1be0e70, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:90

*** Bug 328088 has been marked as a duplicate of this bug. ***

I fixed my problem by rebuilding Xapian with the command:

 sudo update-apt-xapian-index -f

No idea why Xapian broke

*** Bug 328269 has been marked as a duplicate of this bug. ***

Created attachment 83972
New crash information added by DrKonqi

muon-updater (2.1.1) on KDE Platform 4.11.2 using Qt 4.8.4

- What I was doing when the application crashed:Muon Updater crash every time I click the icon on the toolbar

-- Backtrace (Reduced):
#6 UpdateModel::setResources (this=0x114c9c0, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7 0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x114c350) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8 0x000000000041127e in UpdaterWidget::activityChanged (this=0x114c350) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9 0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
[...]
#11 0x00007fa274cff485 in ResourcesModel::qt_static_metacall (_o=0x1070660, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:90

*** Bug 328536 has been marked as a duplicate of this bug. ***

*** Bug 328633 has been marked as a duplicate of this bug. ***

*** Bug 328875 has been marked as a duplicate of this bug. ***

*** Bug 328931 has been marked as a duplicate of this bug. ***

*** Bug 328475 has been marked as a duplicate of this bug. ***

Created attachment 84437
New crash information added by DrKonqi

muon-updater (2.1.1) on KDE Platform 4.11.3 using Qt 4.8.4

- What I was doing when the application crashed:

Clicking the update icon in the system tray results in Muon update manager crashing every time.

-- Backtrace (Reduced):
#6 UpdateModel::setResources (this=0x25525f0, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7 0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x2540590) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8 0x000000000041127e in UpdaterWidget::activityChanged (this=0x2540590) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9 0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
[...]
#11 0x00007f9ea3197485 in ResourcesModel::qt_static_metacall (_o=0x2652b40, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:90

*** Bug 329614 has been marked as a duplicate of this bug. ***

*** Bug 329725 has been marked as a duplicate of this bug. ***

Rebuilding the Xapian index as described in comment 6 did not resolve the issue for me.

*** Bug 329755 has been marked as a duplicate of this bug. ***

2.1.2: http://quickgit.kde.org/?p=muon.git&a=blob&h=bc323388a1fe39aae325545ae0bd178a645fc9b4&hb=01dcf56267dfa0480840cf4fb0d0be900708d562&f=updater%2FUpdateModel%2FUpdateModel.cpp

    foreach(AbstractResource* res, resources) {
        UpdateItem *updateItem = new UpdateItem(res);
        if (res->isFromSecureOrigin()) {
            securityItem->appendChild(updateItem);
>>>>> } else if(!res->isTechnical()) { <<<<<<

why it would crash there is beyond me unfortunately.

*** Bug 329760 has been marked as a duplicate of this bug. ***

Does it always happen? If so, can I get the valgrind execution output maybe?

Dear Aleix,

thanks for your reply!
Some days ago I removed a HP printer/scanner package from my computer.
Since that day Muon didn't crash anymore.

Regards

Jens

Am Donnerstag, den 09.01.2014, 14:09 +0000 schrieb Aleix Pol:A
leix Pol <email address hidden> changed:
>
> What |Removed |Added
> ----------------------------------------------------------------------------
> CC| |<email address hidden>
>
> --- Comment #21 from Aleix Pol <email address hidden> ---
> Does it always happen? If so, can I get the valgrind execution output maybe?
>

Dear Harald,

some days ago I removed a HP printer/scanner package from my computer.
Since then Muon didn't crash anymore. I'll keep an eye on it and give
more information when it should happen again.

Many thanks and regards

Jens

Am Donnerstag, den 09.01.2014, 12:07 +0000 schrieb Harald Sitter:
> https://bugs.kde.org/show_bug.cgi?id=327544
>
> Harald Sitter <email address hidden> changed:
>
> What |Removed |Added
> ----------------------------------------------------------------------------
> CC| |<email address hidden>
> Version|2.1.1 |2.1.2
>
> --- Comment #19 from Harald Sitter <email address hidden> ---
> 2.1.2:
> http://quickgit.kde.org/?p=muon.git&a=blob&h=bc323388a1fe39aae325545ae0bd178a645fc9b4&hb=01dcf56267dfa0480840cf4fb0d0be900708d562&f=updater%2FUpdateModel%2FUpdateModel.cpp
>
> foreach(AbstractResource* res, resources) {
> UpdateItem *updateItem = new UpdateItem(res);
> if (res->isFromSecureOrigin()) {
> securityItem->appendChild(updateItem);
> >>>>> } else if(!res->isTechnical()) { <<<<<<
>
> why it would crash there is beyond me unfortunately.
>

Created attachment 84534
New crash information added by DrKonqi

muon-updater (2.1.1) on KDE Platform 4.11.3 using Qt 4.8.4

- What I was doing when the application crashed:

tested " sudo update-apt-xapian-index -f" as a fix... Negative.

this did not fix my problem either.

-- Backtrace (Reduced):
#6 UpdateModel::setResources (this=0x1eda9f0, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7 0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x1eda470) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8 0x000000000041127e in UpdaterWidget::activityChanged (this=0x1eda470) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9 0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
[...]
#11 0x00007f57bbbc8485 in ResourcesModel::qt_static_metacall (_o=0x1cfee40, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:90

Created attachment 84651
New crash information added by DrKonqi

muon-updater (2.1.2) on KDE Platform 4.12.0 using Qt 4.8.4

- What I was doing when the application crashed:

I clicked the updater icon in the tray, it showed the updater window and after a few seconds crashed.

-- Backtrace (Reduced):
#6 UpdateModel::setResources (this=0x1023990, resources=...) at /build/buildd/muon-2.1.2/updater/UpdateModel/UpdateModel.cpp:248
#7 0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0xfd17f0) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:163
#8 0x000000000041127e in UpdaterWidget::activityChanged (this=0xfd17f0) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:148
#9 0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
[...]
#11 0x00007f6b24daf355 in ResourcesModel::qt_static_metacall (_o=0x1035590, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:90

*** Bug 330421 has been marked as a duplicate of this bug. ***

*** Bug 330484 has been marked as a duplicate of this bug. ***

*** Bug 330516 has been marked as a duplicate of this bug. ***

We are having a hard time getting to the bottom of this and really need some more information on this.

Can anyone still reproduce this reliably?
If so, please run `kdebugdialog`, active everything and after that run muon-updater from a terminal:
muon-updater --noforok &> log; xz -9 log && echo "log.xz"

Then wait for the crash, so the crash handler dialog comes up. DO NOT CLOSE THE CRASH DIALOG. Your terminal should return and print "log.xz", this file is now in the terminal's current directory. Please attach the file to this report.

Additionally, please run the following in a terminal *while* the crash handler dialog is active:
gcore `pidof muon-updater` && xz -9 core.`pidof muon-updater` && echo core.`pidof muon-updater`.xz

This will take quite a while since it's compressing the entire memory of the application. Once it is done the last line will be the name of the compressed file, something like "core.31686.xz", that was created in the terminal's current directory. Please attach the file to this report (should be somewhere around 20MiB).

With the additional information we should be able to track the cause for this down (one can hope anyway :))

Created attachment 84897
Output of muon-updater --nofork &> log; xz -9 log && echo "log.xz"

Output of
muon-updater --nofork &> log; xz -9 log && echo "log.xz"

(corrected a small typo in the command line)

As the core file is too big to be added as an attachment (it's 19MB), I've put it in my Dropbox: https://www.dropbox.com/s/n4j0xxdoo7z1igh/core.16677.xz

It's the output of
sudo gcore `pidof muon-updater` && xz -9 core.`pidof muon-updater` && echo core.`pidof muon-updater`.xz
(note the leading "sudo" otherwise the dump didn't work)

Created attachment 84898
Output of muon-updater --nofork &> log; xz -9 log && echo "log.xz"

Output of
muon-updater --nofork &> log; xz -9 log && echo "log.xz"

Output of sudo gcore `pidof muon-updater` && xz -9 core.`pidof muon-updater` && echo core.`pidof muon-updater`.xz is available on http : / / smallhaven.com / core.3345.xz
(Sorry, you'll have to remove the spaces)

Thanks for keeping the interest up and thanks to enrico for posting the typo correction.

Git commit 2992e8b979eede6048929e43d869d91ccfb43742 by Aleix Pol.
Committed on 30/01/2014 at 16:18.
Pushed by apol into branch '2.1'.

Make sure we don't provide null packages

Sometimes, apparently, some packages aren't listed when all Application
instances are created. This would become a crash in some special
situations, especially the cases where the architecture of the package
is specified as a suffix to the package name (e.g. primus-libs-ia32).

This patch fixes that crash by not reporting these, but then we still
have the problem that these won't be listed as updates.

M +4 -2 libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp

http://commits.kde.org/muon/2992e8b979eede6048929e43d869d91ccfb43742

Hi everyone. So we found out what causes the crash and introduced measures to prevent it in the short term. To get this resolved properly we'll have to find out why exactly some packages cannot be resolved, which is a bit tricky.

Shane and Enrico, if you could upload the log files generated by this it would be really great:

echo "____/etc/apt/sources.list" > aptlog
cat /etc/apt/sources.list >> aptlog
echo "____/etc/apt/sources.list.d/" >> aptlog
cat /etc/apt/sources.list.d/* >> aptlog
echo "___aptcache" >> aptlog
apt-cache show primus-libs-ia32 >> aptlog
xz -9 aptlog
echo "aptlog.xz"

Created attachment 84912
aptlog info as requested

Output of the following, as requested:

echo "____/etc/apt/sources.list" > aptlog
cat /etc/apt/sources.list >> aptlog
echo "____/etc/apt/sources.list.d/" >> aptlog
cat /etc/apt/sources.list.d/* >> aptlog
echo "___aptcache" >> aptlog
apt-cache show primus-libs-ia32 >> aptlog
xz -9 aptlog
echo "aptlog.xz"

Created attachment 84917
Output of aptlog commands

Here's my aptlog.xz after running these commands:

echo "____/etc/apt/sources.list" > aptlog
cat /etc/apt/sources.list >> aptlog
echo "____/etc/apt/sources.list.d/" >> aptlog
cat /etc/apt/sources.list.d/* >> aptlog
echo "___aptcache" >> aptlog
apt-cache show primus-libs-ia32 >> aptlog
xz -9 aptlog
echo "aptlog.xz"

Thanks for all your effort!
Enrico

Still unable to reproduce unfortunately, going to do one last try before we'll have to look into somewhat more extreme measure....

The following commands will basically collect every bit of low level information about your available and installed packages, (hopefully) allowing me to replicate your exact package situation. Or at least manually track why exactly your muons cannot find the package primus-libs-ia32. Should this also fail I'll have to ask you to do manual debugging of the muon-updater itself, which is always a gigantic pain, so I'd rather avoid that ^^

Please attach the tar.xz created by:

rm -rf verboselog
mkdir verboselog
cd verboselog
touch log
echo "___apt-cache-show___" >> log
apt-cache show primus-libs-ia32 >> log
echo "___apt-cache-policy___" >> log
apt-cache policy primus-libs-ia32 >> log
echo "___dpkg-get-selections___" >> log
dpkg --get-selections '*' >> log
echo "___dpkg-query___" >> log
dpkg-query -W --showformat='${binary:Package};${Version};${Status}\n' | grep -v deinstall >> log
echo "___apt-cache-dump___" >> log
apt-cache dump >> log
cp -r /etc/apt etc-apt
cp -r /var/log/dpkg* .
cp -r /var/log/apt .
cd ..
rm verboselog.tar verboselog.tar.xz
tar -cf verboselog.tar verboselog
rm -rf verboselog
xz -9 verboselog.tar
echo "verboselog.tar.xz"

Created attachment 84920
verboselog.tar.xz

Good luck and thanks again!

Here it is.
I've put the commands into a Bash script, and run it with "sudo bash verboselog.sh"

The output is at https://www.dropbox.com/s/wm8gybite4ipsb5/verboselog.tar.xz

#!/bin/sh
set -e

rm -rf verboselog
mkdir verboselog
cd verboselog
touch log
echo "___apt-cache-show___" >> log
apt-cache show primus-libs-ia32 >> log
echo "___apt-cache-policy___" >> log
apt-cache policy primus-libs-ia32 >> log
echo "___dpkg-get-selections___" >> log
dpkg --get-selections '*' >> log
echo "___dpkg-query___" >> log
dpkg-query -W --showformat='${binary:Package};${Version};${Status}\n' \
| grep -v deinstall >> log
echo "___apt-cache-dump___" >> log
apt-cache dump >> log
cp -r /etc/apt etc-apt
cp -r /var/log/dpkg* .
cp -r /var/log/apt .
cd ..
set +e
  rm verboselog.tar verboselog.tar.xz
set -e
tar -cf verboselog.tar verboselog
rm -rf verboselog
xz -9 verboselog.tar
echo "verboselog.tar.xz"

Thanks guys, I found the issue.

To work around the issue you can use the following command or wait for Muon 2.1.3, which will be available in about 7 days:
sudo apt-get dist-upgrade

Analysis
=======
upgrades from nvidia-331.20 on xorgedgers will pull in bumblebee, bumblebee depends on primus depends on libprimus-libs-ia32:i386. However muon-updater cannot resolve libpriums-libs-ia32 because of the architecture difference.

In particular QApt::Package::isMultiArchDuplicate() apparently yields the wrong value. This is supposedly because it uses
> d->packageIter.Group().FindPkg()
rather than
> d->packageIter.Group().FindPreferredPkg()
which would yield the correct result. The function comments that it attempts to check whether /this/ is the best possible version of a multiarch package, which appears to not be what FindPkg is doing, rather it is checking whether it is the host architectures' duplicate package (i.e. in order to have the function return false the package needs to be :amd64 when running amd64...). However primus-libs-ia32 has no actual native version, there only is the i386 version, so isMultiArchDuplicate leads to it being discarded even tough it is the preferred package, or rather it is the only possible package.

Recommendation solution
a) use FindPreferredPkg inside isMultiArchDuplicate
b) kDebug() when a package is being discarded be it because of duplicatedness or other factors, to improve debugability of similar issues
c) evaluate whether discarding packages based on duplicatedness is even an acceptable thing to do in the update/upgrade use case

Also there's other weirdness with the updater exposed by this particular package lineup, needs separate investigation and doesn't seem related to the bug at hand though.

Beware dist-upgrade. It broke my system due to an Nvidia/Bumblebee issue.
The solution for me was
sudo apt-get remove --purge bumblebee
after dist-upgrade.

More details here: http://askubuntu.com/questions/399153/after-apt-get-upgrade-system-always-boot-to-low-graphics-mode

Now I'll wait and see what it does for Muon.
Thanks for all your time on this Harald!

BTW, I came out of it better off. Fixed a distortion issue I was having with my graphics driveres. :-D

This appears to have fixed it. Muon updater ran successfully today.
Thanks again, Harald!

I did apt-get dist-upgrade. It didn't finish due to some broken nvidia-opencl packages. I solved the issue by removing all OpenCL-related packages and doing dist-upgrade again. And then, muon-updater got back to work. Thank you all :)

Changed in muon:
importance: Unknown → High
status: Unknown → In Progress

Created attachment 85994
New crash information added by DrKonqi

muon-updater (2.1.2) on KDE Platform 4.11.3 using Qt 4.8.4

- What I was doing when the application crashed:

I noticed I hadn't been getting the notification popup for updates lately, and opened Update Manager from the K Menu.
The application crashed shortly after opening the window and never listed available updates.
I was also surfing with Firefox and downloading files using KTorrent at the time, and was on a VPN.

-- Backtrace (Reduced):
#6 UpdateModel::setResources (this=0x10205d0, resources=...) at /build/buildd/muon-2.1.2/updater/UpdateModel/UpdateModel.cpp:248
#7 0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x11041a0) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:163
#8 0x000000000041127e in UpdaterWidget::activityChanged (this=0x11041a0) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:148
#9 0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
[...]
#11 0x00007f48b8b97355 in ResourcesModel::qt_static_metacall (_o=0x106ab50, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:90

Can somebody confirm this is still a problem?

Can't speak for everyone, but it's certainly resolved for me. Thanks!

Please re-open if anybody can reproduce.

Changed in muon:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.