Play Album and Play Song didn't work anymore

Bug #366620 reported by Keywan Najafi Tonekaboni on 2009-04-25
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
muine
Fix Released
Medium
muine (Debian)
Fix Released
Unknown
muine (Ubuntu)
Medium
Daniel T Chen
Jaunty
Undecided
Daniel T Chen

Bug Description

Jaunty SRU information follows:

Impact: Users who install/upgrade to Muine in Jaunty will not have a properly destroyed dialog for Play Album/Song due to missing method invocations. Using the window manager to close the dialog will function once, but choosing Play Album/Song immediately afterward results in an application exception.

Fix: Apply upstream fix from http://git.gnome.org/cgit/muine/commit/?id=ed0e81a673fbe09fa18622ff437c36075d33984d. pbuilt, tested with piuparts, tested and confirmed to resolve the issue in a Jaunty virtualbox instance.

SRU debdiff: http://launchpadlibrarian.net/26165643/muine_0.8.10-1ubuntu2.1.debdiff

karmic debdiff: http://launchpadlibrarian.net/26165656/muine_0.8.10-1ubuntu3.debdiff

Diff sent to Debian BTS.

TEST CASE: Install Muine in Jaunty. Click Play Album/Song. Click Close/Queue/Play and note the lack of response.

Regressions: none identified

--
Original bug report information follows:

Binary package hint: muine

The "Play Album/Song"-buttons open the the correct dialog to add a song, but doesn't react on a click on one of the three buttons (Close, Queue, Play). I can close it with the close button of the metacity-frame. If I try to open the dialog again (click on "Play Album" button in main window) muine crashes.

Console output:

Marshaling clicked signal
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.IndexOutOfRangeException: Array index is out of range.
  at Muine.HandleView.SelectFirst () [0x00000]
  at Muine.AddWindow.Run (UInt32 time) [0x00000]
  at Muine.PlaylistWindow.PlayAlbum (UInt32 time) [0x00000]
  at Muine.PlaylistWindow.OnAddAlbumButtonClicked (System.Object o, System.EventArgs args) [0x00000]
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000]
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000]
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000]
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000]
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000]
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000]
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000]
  at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000]
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Muine.Global.Main(System.String[] args)

System information:

Description: Ubuntu 9.04
Release: 9.04
Codename: jaunty

muine:
  Installiert: 0.8.10-1ubuntu2
  Kandidat: 0.8.10-1ubuntu2
  Versions-Tabelle:
 *** 0.8.10-1ubuntu2 0
        500 http://de.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

Dean Sas (dsas) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 294659, so it is being marked as such.

The bug has been fixed by developers and the fixed version should be available in the next version of Ubuntu

No, this bug isn't a duplicate of 294659, which was reported by me, too. The bug 294659 affects the *keyboard* play-key (a hardware-button). If there is already a track in the playlist (e.g. drag-and-drop of files into muine playlist), there is no problem to starting and stopping muine. Please compare bugs carefully before marking something as an duplicate.

Keywan Najafi Tonekaboni wrote:
> No, this bug isn't a duplicate of 294659, which was reported by me, too.

> Please compare bugs carefully before marking something as an
> duplicate.

Sorry Keywan, you're quite right, I should have noticed that.

Brian Burger (bburger) wrote :

I can confirm this in Ubuntu 9.04 - got the same behaviour and substantially the same console error message as the original reporter.

Damned shame, as Muine is the only music player I've ever actually LIKED. Rhythmbox I tolerate, the rest just suck.

Changed in muine (Ubuntu):
status: New → Confirmed
Changed in muine (Debian):
status: Unknown → New
Changed in muine:
status: Unknown → Fix Released
Daniel T Chen (crimsun) on 2009-04-30
Changed in muine (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Medium
status: Confirmed → In Progress
Daniel T Chen (crimsun) wrote :

Diff sent to Debian BTS for sid, attaching debdiffs for jaunty-proposed and karmic.

Daniel T Chen (crimsun) wrote :
description: updated
Daniel T Chen (crimsun) on 2009-04-30
Changed in muine (Ubuntu):
status: In Progress → Fix Committed
Changed in muine (Debian):
status: New → Confirmed
Changed in muine (Debian):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muine - 0.8.10-4

---------------
muine (0.8.10-4) unstable; urgency=low

  * debian/control:
    + Unpipe gnome# build-deps as Ubuntu has fixed this in Karmic
    + Remove dependency on gstreamer0.10-gnomevfs as it is obsolete now that
      playbin handles the opening of files.
    + Version debhelper and cli-common-dev build-deps for DH7 integration
    + Add quilt build-dep for below patches
  * debian/rules:
    + Update packaging to DH7 and add quilt for below patches
    + Rewrite get-orig-source to conform with policy using Mirco Bauer's
      snippet.
  * debian/patches/correct-glade-signals.diff: Add. Backport patch from
    upstream to correctly connect signal handlers so "Play Song" and "Play
    Artist" buttons work properly (Closes: #524181, LP: #366620).
  * debian/patches/metadata-crash.diff: Add. Backport patch from upstream
    BTS/ubuntu to workaround crash when track metadata is edited externally.
  * Override dh_auto_test to do nothing as these cause the build to fail.
  * Override dh_makeclilibs to correctly version muine dependency.

 -- Stefan Ebner <email address hidden> Mon, 11 May 2009 13:09:20 +0100

Changed in muine (Ubuntu):
status: Fix Committed → Fix Released

Hi,

how can I test this package? It has a dependency to libgconf2.0-cil (>= 2.24.0) and in proposed there is no newer version. I also tried to compile/build it by my own, which either didn't helped (still same problem) or the build-deps (debhelper >= 7.0.50) wasn't fulfilled

I see again a low urgency. Will this fix be in jaunty, too? I like to remember, that a main part of this application doesn't work (adding music to playlist)...

Daniel T Chen (crimsun) wrote :

On Tue, May 12, 2009 at 5:06 AM, Keywan Najafi Tonekaboni
<email address hidden> wrote:
> I see again a low urgency. Will this fix be in jaunty, too? I like to

It's awaiting processing through the universe StableReleaseUpdates procedure.

John Dong (jdong) wrote :

ACK on SRU debdiff 0.8.10-1ubuntu2.1.

Changed in muine (Ubuntu Jaunty):
status: New → Confirmed
Daniel T Chen (crimsun) on 2009-05-12
Changed in muine (Ubuntu Jaunty):
assignee: nobody → Daniel T Chen (crimsun)
Scott Kitterman (kitterman) wrote :

Accepted into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in muine (Ubuntu Jaunty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Brian Burger (bburger) wrote :

Updated from jaunty-proposed.

The queue/play buttons work now, but for some reason Muine isn't listing my entire music collection - I have a dozen Rolling Stones albums, for example, but Muine only shows me one of them.

I deleted /,gnome2/muine entirely, tried to re-import my Music directory, and even tried a complete remove & reinstall, and it's still refusing to list all my music.

If this counts as a new bug, let me know, I'll open one.

Peter Adolphs (futzilogik) wrote :

Confirming that the (original) problem is fixed in 0.8.10-1ubuntu2.1 in jaunty-proposed.

Martin Pitt (pitti) on 2009-06-25
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muine - 0.8.10-1ubuntu2.1

---------------
muine (0.8.10-1ubuntu2.1) jaunty-proposed; urgency=low

  * Apply http://git.gnome.org/cgit/muine/patch/?id=ed0e81a673fbe09fa18622ff437c36075d33984d
    to resolve LP: #366620

 -- Daniel T Chen <email address hidden> Wed, 29 Apr 2009 23:02:35 -0400

Changed in muine (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in muine:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.