For additional hardware support, modemmanager needs to be upgraded to 1.10 on Bionic

Bug #1819615 reported by Till Kamppeter on 2019-03-12
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Yuan-Chen Cheng
libmbim (Ubuntu)
Status tracked in Eoan
Bionic
High
Till Kamppeter
Disco
Undecided
Unassigned
Eoan
High
Unassigned
libqmi (Ubuntu)
Status tracked in Eoan
Bionic
High
Till Kamppeter
Disco
Undecided
Unassigned
Eoan
High
Unassigned
modemmanager (Ubuntu)
Status tracked in Eoan
Bionic
High
Till Kamppeter
Disco
Undecided
Unassigned
Eoan
High
Till Kamppeter

Bug Description

[Impact]

 * The new modemmanager package adds DW5820e and DW5821 support.
 * This modemmanager version is needed to support new devices.

[Test Case]

 * install modemmanager, libmbim, and libqmi from -proposed
 * reboot and try WWAN function to see if any regression there.
 * perform general dogfooding of its reverse dependencies (network-
   manager, gnome-control-center etc.)

[Regression Potential]

 * The package comes from Disco and should not have regression there.
 * Every new upstream release can potentially break existing dependencies
   if any of the required features have been changed/removed, so besides
   regular testing a general dogfooding session with the new modemmanager
   is advised.

[Original Description]

To have Bionic, the current LTS, working with as wide of a range of modems as possible we need to have it upgraded to the current 1.10 versions. Also the underlying libraries need to get upgraded appropriately.

Changed in libmbim (Ubuntu):
importance: Undecided → High
milestone: none → bionic-updates
Changed in libqmi (Ubuntu):
importance: Undecided → High
milestone: none → bionic-updates
Till Kamppeter (till-kamppeter) wrote :

Added tasks for libmbim and libqmi as their current versions are needed by ModemManeger 1.10.

Changed in libmbim (Ubuntu Bionic):
importance: Undecided → High
Changed in libqmi (Ubuntu Bionic):
importance: Undecided → High
Changed in modemmanager (Ubuntu Bionic):
importance: Undecided → High
Changed in libmbim (Ubuntu):
status: New → Fix Released
Changed in libqmi (Ubuntu):
status: New → Fix Released
Changed in modemmanager (Ubuntu):
status: New → Fix Released
Changed in libmbim (Ubuntu Bionic):
milestone: none → bionic-updates
Changed in libqmi (Ubuntu Bionic):
milestone: none → bionic-updates
Changed in modemmanager (Ubuntu Bionic):
milestone: none → bionic-updates
Changed in modemmanager (Ubuntu):
milestone: bionic-updates → none
Changed in libqmi (Ubuntu):
milestone: bionic-updates → none
Changed in libmbim (Ubuntu):
milestone: bionic-updates → none
Changed in libmbim (Ubuntu Bionic):
status: New → In Progress
Changed in libqmi (Ubuntu Bionic):
status: New → In Progress
Changed in modemmanager (Ubuntu Bionic):
status: New → In Progress
Till Kamppeter (till-kamppeter) wrote :

debdiff for modemmanager 1.10 in Bionic. The upstream source tarball is the same as for Disco.

Till Kamppeter (till-kamppeter) wrote :

debdiff for libmbim 1.18.0 in Bionic. The upstream source tarball is the same as for Disco.

Till Kamppeter (till-kamppeter) wrote :

debdiff for libqmi 1.22.0 in Bionic. The upstream source tarball is the same as for Disco.

Till Kamppeter (till-kamppeter) wrote :

I have made Bionic packages for ModemManager 1.10 and the needed libraries now. I have attached the debdiffs and the upstream tarballs are the same as of the Disco packages.

Ken, could you upload these packages for me.

Alex, if we need to go through the SRU process (is this needed for hardware enablement), could you add the info about impact, reproducer, regression potential, ...

description: updated
description: updated
Will Cooke (willcooke) on 2019-03-19
Changed in modemmanager (Ubuntu Bionic):
assignee: nobody → Till Kamppeter (till-kamppeter)
Till Kamppeter (till-kamppeter) wrote :

Replacement for the debdiff for libqmi 1.22.0 in Bionic.

This debdiff also contains the most recent fixes In Debian and in Disco (see https://bugs.launchpad.net/ubuntu/+source/libqmi/1.22.0-1.2):

----------
libqmi (1.22.0-1.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Add debian/patches/git_reset-offset-before-2nd-call.patch from upstream.
    - equivalent to 1.22.2 release except the broken manpages in that release.

 -- Andreas Henriksson <email address hidden> Tue, 12 Mar 2019 14:19:35 +0100

libqmi (1.22.0-1.1) unstable; urgency=medium

  * Non-maintainer upload
  * Bump Build-Depends on libmbim-glib-dev to 1.18.0 to fix build
    (Closes: #921321)

 -- Jeremy Bicha <email address hidden> Thu, 07 Feb 2019 18:22:46 -0500
----------

The patch solves a regression from 1.10 which made some modems not work.

Alex Tu (alextu) on 2019-03-20
Changed in oem-priority:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
Till Kamppeter (till-kamppeter) wrote :

Yuan-Chen, Alex: I have finished to prepare the three needed packages, including a fix on libqmi coming in yesterday. Now I am simply waiting for the upload of the packages getting sponsored (probably by Ken VanDine) and the SRU team putting the packages into bionic-proposed.

Feel free to add anything relevant for testing the package to the description of this bug report.

Ken VanDine (ken-vandine) wrote :

The libqmi debdiff doesn't include the latest version that's in bionic (1.18.0-3ubuntu1) in the changelog and it also reverts the change in that version. Please ensure the debdiff is against that version.

Ken VanDine (ken-vandine) wrote :

The libmbim debdiff doesn't include the latest version that's in bionic (1.14.2-2.1ubuntu1) in the changelog and it also reverts the change in that version. Please ensure the debdiff is against that version.

Fixed libqmi package.

Fixed libmbim package.

Fixed modemmanager package.

Edhelharn (edhelharn) wrote :

Hello, I'm probably impacted by this bug here : https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1821052

So I post a comment to subscribe to this thread.

Changed in oem-priority:
importance: Undecided → Critical
status: New → In Progress
Yuan-Chen Cheng (ycheng-twn) wrote :

@Till, Add DW5821 which also need new mm to support. I'll test both here as it hit the proposed channel.

description: updated
Ken VanDine (ken-vandine) wrote :

I've sponsored these packages

Changed in libqmi (Ubuntu Bionic):
assignee: nobody → Till Kamppeter (till-kamppeter)
Changed in libmbim (Ubuntu Bionic):
assignee: nobody → Till Kamppeter (till-kamppeter)

Hello Till, or anyone else affected,

Accepted libmbim into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libmbim/1.18.0-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libmbim (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Till, or anyone else affected,

Accepted libqmi into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libqmi/1.22.0-1.2~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libqmi (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in modemmanager (Ubuntu Bionic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Till, or anyone else affected,

Accepted modemmanager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/modemmanager/1.10.0-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Yuan-Chen Cheng (ycheng-twn) wrote :

per test in bionic, turn on proposed channel, do a 'apt install modemmanager'. it will upgrade to version 1.10.0-1~ubuntu18.04.1 and also upgrade related libmbim and libqmi library.

I do that separate on two machine, that have DW5820e and DW5821e separately with a sim card inside.

I confim I can properly add a new connection and connect to internet successfully.

Note: for today, need to set DW5820e to USB mode in BIOS per information from HW vendor.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

What's going on with the network-manager arm64 autopkgtest failure with the new modem-manager?

Brian, do you have some link (bug report, ...) to this failure?

yparitcher (yparitcher) wrote :

I would like to report a regression.
i have a verizon samsung phone using as a bluetooth CDMA/3G modem.
after the upgrade modemmanager disconnects ~30sec after connecting.

attached find modem manager --debug logs

<debug> [1556654159.032559] Running registration checks (CDMA1x: 'yes', EV-DO: 'yes')
<debug> [1556654159.032629] Will skip all QCDM-based registration checks
<debug> [1556654159.032649] Will skip generic detailed registration check, we don't have Sprint commands
<debug> [1556654159.032684] loading signal quality...
<debug> [1556654159.032748] Starting QCDM-based registration checks
<debug> [1556654159.032766] Skipping all QCDM-based checks and falling back to AT-based checks
<debug> [1556654159.032782] Starting AT-based registration checks
<debug> [1556654159.032841] Couldn't refresh signal quality: 'No AT port available to run command'
<debug> [1556654159.032887] EVDO registration: 0
<debug> [1556654159.032899] CDMA1x registration: 1
<debug> [1556654159.032911] Fallback access tech: 0x00000400
<debug> [1556654159.032927] Fallback access technology: 0x00000400
<debug> [1556654159.032977] No CDMA service found
<debug> [1556654159.032991] All CDMA registration state checks done
<debug> [1556654159.033076] Connected bearer not registered in CDMA network
<debug> [1556654159.033172] Periodic signal quality checks scheduled in 30s
<debug> [1556654161.006911] Connection monitoring is unsupported by the device
<debug> [1556654174.016444] Forcing bearer disconnection, not registered in CDMA network
<debug> [1556654174.016472] Forcing disconnection of bearer '/org/freedesktop/ModemManager1/Bearer/0'
<info> [1556654174.016551] Modem /org/freedesktop/ModemManager1/Modem/0: state changed (connected -> disconnecting)

yparitcher (yparitcher) wrote :

i am very happy to try any fixes helping to try different versions to see where the regression was introduced.
thanks.

yparitcher, as this SRU consists of three packages, ModemManager itself and the two libraries, try at first to downgrade only modemmanager to the original. If this solves the problem, it is caused by modemmanager, if not, downgrade one of the libraries, then try to downgrade the other, ... until you could spot one of the three packages having caused your problem.

yparitcher (yparitcher) wrote :

i downgraded ModemManager back to 1.6.8-2ubuntu1 and the problem went away, so it is caused by ModemManager.

attached are the logs for ModemManager 1.6.8-2ubuntu1

yparitcher (yparitcher) wrote :
Download full text (4.9 KiB)

1.8.2-1 from cosmic also has this regression

<debug> [1556659895.024512] Starting detailed registration state check
<debug> [1556659895.024533] Skipping detailed registration state check
<debug> [1556659895.024543] All CDMA registration state checks done
<debug> [1556659895.024636] Will start keeping track of state for subsystem 'cdma1x'
<info> [1556659895.024671] Modem /org/freedesktop/ModemManager1/Modem/0: state changed (enabled -> registered)
<debug> [1556659895.024907] Periodic signal checks enabled
<debug> [1556659895.024921] Periodic signal check refresh requested
<debug> [1556659895.024931] loading signal quality...
<debug> [1556659895.024956] (rfcomm0) device open count is 4 (open)
<debug> [1556659895.025046] Will start keeping track of state for subsystem 'evdo'
<debug> [1556659895.025076] Modem is currently registered in a CDMA network (CDMA1x: 'yes', EV-DO: 'no')
<info> [1556659895.025092] Simple connect state (6/8): Bearer
<debug> [1556659895.025104] Creating new bearer...
<debug> [1556659895.025120] Creating Broadband bearer in broadband modem
<debug> [1556659895.025620] (rfcomm0) device open count is 5 (open)
<debug> [1556659895.025679] (rfcomm0) device open count is 4 (close)
<info> [1556659895.026094] Simple connect state (7/8): Connect
<debug> [1556659895.026129] Connecting bearer '/org/freedesktop/ModemManager1/Bearer/0'
<info> [1556659895.026155] Modem /org/freedesktop/ModemManager1/Modem/0: state changed (registered -> connecting)
<debug> [1556659895.026456] Launching 3GPP2 connection attempt
<debug> [1556659895.026485] (rfcomm0) device open count is 5 (open)
<debug> [1556659895.026495] Connection through a plain serial AT port (rfcomm0)
<debug> [1556659895.026515] (rfcomm0) device open count is 6 (open)
<debug> [1556659895.026554] (rfcomm0) device open count is 5 (close)
<debug> [1556659895.026584] (rfcomm0): --> 'AT+CSS?<CR>'
<debug> [1556659895.049351] (rfcomm0): <-- '<CR><LF>?, 26<CR><LF><CR><LF>OK<CR><LF>'
<debug> [1556659895.049510] Starting detailed registration state check
<debug> [1556659895.049527] Skipping detailed registration state check
<debug> [1556659895.049537] All CDMA registration state checks done
<debug> [1556659895.049702] Initial CDMA registration checks finished
<debug> [1556659895.049727] (rfcomm0) device open count is 4 (close)
<debug> [1556659895.049766] (rfcomm0): --> 'AT+CSQ<CR>'
<debug> [1556659895.070553] (rfcomm0): <-- '<CR><LF>22, 99<CR><LF><CR><LF>OK<CR><LF>'
<debug> [1556659895.070772] Modem /org/freedesktop/ModemManager1/Modem/0: signal quality updated (70)
<debug> [1556659895.070809] EVDO registration: 0
<debug> [1556659895.070818] CDMA1x registration: 1
<debug> [1556659895.070825] Fallback access tech: 0x00000400
<debug> [1556659895.070836] Fallback access technology: 0x00000400
<debug> [1556659895.070867] (rfcomm0) device open count is 3 (close)
<debug> [1556659895.071116] Modem /org/freedesktop/ModemManager1/Modem/0: access technology changed (unknown -> 1xrtt)
<debug> [1556659895.071149] Periodic signal quality checks scheduled in 30s
<debug> [1556659895.071290] (rfcomm0): --> 'ATDT#777<CR>'
<debug> [1556659896.924337] (rfcomm0): <-- '<CR><LF>CONNECT 2400000<CR><LF>'
<debu...

Read more...

Chris Halse Rogers (raof) wrote :

Marking as verification-failed as per the last couple of comments.

It looks like that might want to be split out into a new bug, particularly as it also affects cosmic (and disco?)

tags: added: regression-proposed verification-failed
removed: verification-done
tags: added: verification-failed-bionic
removed: verification-done-bionic
yparitcher (yparitcher) wrote :

regression submitted upstream see https://gitlab.freedesktop.org/mobile-broadband/ModemManager/issues/119
for further details

yparitcher, thank you for the upstream bug report. As soon as upstream finds a (backportable) solution we will add it to this SRU and report back here.

Changed in modemmanager (Ubuntu Bionic):
status: Fix Committed → Confirmed
yparitcher (yparitcher) wrote :

found a fix upstream, was a issue in error propagation.
attached is a patch for ModemManager 1.10 in Bionic / Dingo, and 1.8.2 in Cosmic

Changed in modemmanager (Ubuntu Bionic):
status: Confirmed → Triaged

yparitcher, thank you very much for your fix. We will add it to the SRU of the modemmanager package and also apply it to eoan. Please watch out this bug report for a new verification call.
To the SRU team: The regression of the modemmanager SRU is fixed and I will soon put up a new debdiff for upload. The two libraries (libmbim and libqmi) did not cause any regression. Please do not remove them from -proposed as they are still needed for the modemmanager SRU.
yparitcher, could you open a Launchpad bug report for your regression/fix for eoan and SRUs on disco and cosmic? Thanks.

Changed in libmbim (Ubuntu Disco):
status: New → Fix Released
Changed in libqmi (Ubuntu Disco):
status: New → Fix Released
Changed in modemmanager (Ubuntu Eoan):
status: Fix Released → In Progress
Changed in modemmanager (Ubuntu Bionic):
status: Triaged → In Progress
Changed in modemmanager (Ubuntu Disco):
status: New → Fix Released

debdiff to fix the regression in eoan.

debdiff to update the Bionic SRU to fix the regression.

debdiff for the full SRU for Bionic: Upgrade to 1.10 plus regression fix.

yparitcher (yparitcher) wrote :

how do i open an sru for cosmic?, it looks like you took care of disco and eon already.

yparitcher, simply report a new bug describing the regression and in which Ubuntu/ModemManager versions you have found it. We will add the rest to make an SRU bug report out of it. Post a link to your bug report here. Thanks.

Changed in modemmanager (Ubuntu Eoan):
assignee: nobody → Till Kamppeter (till-kamppeter)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 1.10.0-1ubuntu1

---------------
modemmanager (1.10.0-1ubuntu1) eoan; urgency=medium

  * debian/patches/error-propagation-fix.patch: mm-broadband-modem: Fix error
    propagation in CDMA service status (LP: #1819615, Upstream Issue #119).

 -- Till Kamppeter <email address hidden> Mon, 06 May 2019 15:40:29 +0200

Changed in modemmanager (Ubuntu Eoan):
status: In Progress → Fix Released
Łukasz Zemczak (sil2100) wrote :

Hello Till, or anyone else affected,

Accepted modemmanager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/modemmanager/1.10.0-1~ubuntu18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in modemmanager (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-failed verification-failed-bionic

yparitcher, first, thanks for reporting bug 1828102, we need this separate bug as Cosmic and Disco originally came with ModemManager 1.10 and so did not suffer the bug treated here, only the regression which you have found. Eoan I have already treated here as the SRU team requires that the issues which are fixed by an SRU are also fixed in the current development cycle.

yparitcher, please test the new modemmanager package in bionic-proposed on your Bionic systems to see whether the regression is actually fixed and report back here. Thanks.

Alex Tu, please test the new packages in bionic-proposed whether they correctly support the modems for which you asked for support for. Thanks.

yparitcher (yparitcher) wrote :

regression fixed in 1.10.0-1~ubuntu18.04.2

however please note now that ModemManager is started by default with filter-policy=strict in order for MM to see Bluetooth modems you need a udev rule like such:

ACTION!="add|change|move", GOTO="mm_whitelist_internal_modem_end"
#ACTION=="add", KERNEL=="rfcomm0", ENV{ID_MM_DEVICE_PROCESS}="1"
#ATTRS{idVendor}=="8087", ATTRS{idProduct}=="07dc", ENV{ID_MM_DEVICE_PROCESS}="1"
ACTION=="add|change|move", KERNEL=="rfcomm*", DEVPATH!="*/virtual/*", SUBSYSTEM=="tty", ENV{ID_MM_DEVICE_PROCESS}="1"
LABEL="mm_whitelist_internal_modem_end"

Yuan-Chen Cheng (ycheng-twn) wrote :

Test passed by using the modemmanager 1.10.0-1~ubuntu18.04.2 with the related libmbim and libqmi library.

Did separate on two machine, that have DW5820e and DW5821e separately with a sim card inside. And they can connect to internet via it successfully.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Robie Basak (racb) wrote :

> Every new upstream release can potentially break existing dependencies if any of the required features have been changed/removed, so besides regular testing a general dogfooding session with the new modemmanager is advised.

Has this been performed with modemmanager 1.10.0-1~ubuntu18.04.2 please?

Also, there's a dep8 regression reported (https://people.canonical.com/~ubuntu-archive/pending-sru.html). Please could someone look into that?

Robie, what do you mean with dep8 regression? The only mention of ModemManager on https://people.canonical.com/~ubuntu-archive/pending-sru.html is this bug report here. The regression reported by yparitcher got fixed upstream and the SRU re-posted with this fix. This is the version currently verified in comments #42 and #43.

On Wed, May 08, 2019 at 01:37:41PM -0000, Till Kamppeter wrote:
> Robie, what do you mean with dep8 regression? The only mention of
> ModemManager on https://people.canonical.com/~ubuntu-archive/pending-
> sru.html is this bug report here. The regression reported by yparitcher
> got fixed upstream and the SRU re-posted with this fix. This is the
> version currently verified in comments #42 and #43.

Robie was referring to the autopackagetest failure for network-manager
which happens with the new modemmanager.

http://autopkgtest.ubuntu.com/packages/n/network-manager/bionic/arm64

--
Brian Murray

This autopkg test failure does not look much as induced by ModemManager. Could someone with appropriate right re-initiate it? Thanks.

The autopkg test failure is now fixed in the network-manager SRU 1.10.14-0ubuntu2.

The network-manager SRU 1.10.14-0ubuntu2 is in -updates now and the autopkg test got successfully repeated with it, so this SRU can be tranferred to -updates, too.

Chris Halse Rogers (raof) wrote :

Gah. Sorry about not picking this up on my first pass through, but what's happening with Cosmic here? As far as I can tell, this also applies to Cosmic (but not Disco), and Cosmic is still supported for a couple of months (long enough that I'm hesitant to go “sure, we don't need to worry about it”).

Ken VanDine (ken-vandine) wrote :

@roaf: This was driven by an OEM request, so the priority was bionic. We also needed to make sure disco (and later) was covered to ensure we made the next LTS as well.

Łukasz Zemczak (sil2100) wrote :

We should think about cosmic indeed, but it's not really blocking the release for bionic. Currently upgrades from bionic to cosmic will very very very rare. With disco released, there's no 'official' upgrade path - not to mention bionic users by default should be only informed of new LTS versions. So I'll proceed with getting this out.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package modemmanager - 1.10.0-1~ubuntu18.04.2

---------------
modemmanager (1.10.0-1~ubuntu18.04.2) bionic; urgency=medium

  * debian/patches/error-propagation-fix.patch: mm-broadband-modem: Fix error
    propagation in CDMA service status (LP: #1819615, Upstream Issue #119).

modemmanager (1.10.0-1~ubuntu18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1819615)
  * debian/control: Update build dependencies as now libmbim >= 1.18.0 and
    libqmi >= 1.22.0 are required.
  * debian/libmm-glib0.symbols: update symbols for new release.
  * debian/patches/0001-m4-compiler_warnings.m4-Let-Werror-be-disabled.patch:
    Removed, included upstream.

 -- Till Kamppeter <email address hidden> Mon, 06 May 2019 16:09:29 +0200

Changed in modemmanager (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for modemmanager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libqmi - 1.22.0-1.2~ubuntu18.04.1

---------------
libqmi (1.22.0-1.2~ubuntu18.04.1) bionic; urgency=medium

  * Build for Bionic (LP: #1819615).
  * debian/libqmi-glib5.symbols: update symbols for new release.

libqmi (1.22.0-1.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Add debian/patches/git_reset-offset-before-2nd-call.patch from upstream.
    - equivalent to 1.22.2 release except the broken manpages in that release.

libqmi (1.22.0-1.1) unstable; urgency=medium

  * Non-maintainer upload
  * Bump Build-Depends on libmbim-glib-dev to 1.18.0 to fix build
    (Closes: #921321)

libqmi (1.22.0-1) unstable; urgency=medium

  * New upstream release
    - Needed by ModemManager 1.10.
  * debian/patches/0001-qmicli-remove-implicity-casts-to-GDestroyNotify-in-g.patch:
    Dropped, included upstream.
  * debian/libqmi-glib5.symbols: update symbols for new release.

libqmi (1.20.0-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Add upstream fix for FTBFS with glib 2.58,
    thanks to Juhani Numminen. (Closes: #908016)

libqmi (1.20.0-1) unstable; urgency=medium

  * New upstream version 1.20.0. (Closes: #887975)
  * debian/patches/0001-utils-drop-useless-g_file_test-call.patch: dropped,
    included upstream.
  * debian/libqmi-glib5.symbols: update symbols for new release.
  * debian/control: changing Maintainer field to claim the package. Marius is
    no longer interested in maintaining it.
  * debian/control: bump Standards-Version to 4.1.3.

 -- Till Kamppeter <email address hidden> Wed, 20 Mar 2019 14:28:39 +0100

Changed in libqmi (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libmbim - 1.18.0-1~ubuntu18.04.1

---------------
libmbim (1.18.0-1~ubuntu18.04.1) bionic; urgency=medium

  * New upstream release
    - Needed by ModemManager 1.10 (LP: #1819615).
  * debian/libmbim-glib4.symbols: Updated symbols for new release.
  * debian/patches/ref_cast.patch: Removed, not applicable any more on
    1.18.0.

libmbim (1.16.0-1) unstable; urgency=medium

  * New upstream release 1.16.0 (Closes: #887974)
  * Adopting the package. (Closes: #888680)
  * debian/control: bump libglib-dev Depends to (>= 2.36) as required by the
    new release.
  * debian/libmbim-glib4.symbols: update symbols for new release.
  * debian/rules: add DPKG_GENSYMBOLS_CHECK_LEVEL=4; it's more verbose with
    added or changed symbols then.

 -- Till Kamppeter <email address hidden> Thu, 20 Mar 2019 20:37:29 +0100

Changed in libmbim (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: In Progress → Fix Released
To post a comment you must log in.