Ubuntu

Wine d3d9 test causes unhandled exception

Reported by Ken Sharp on 2009-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned

Bug Description

Running the d3d9 tests from the current git Wine (wine-1.1.20-185-g2d8f252) causes an unhandled exception.

From #winehq:
<TBBle> KenSharp: Anyway, looks like you're in Mesa3D software rendering, and it and Wine are not getting along. Is that intentional?
<KenSharp> i'm using whatever comes with Ubuntu 8.10 for the ATI Radeon 5900. fglrx simply doesn't work so I don't use it
<TBBle> Neat. You probably want to install libgl1-mesa-dri (or something like that). I'd blame a bug in mesa's software rasteriser for crashing when compiling a GLSL program.
<KenSharp> fair enough
<KenSharp> libgl1-mesa-dri is installed
<TBBle> Well, then I stand by my suggestion that it's mesa crashing, and it shouldn't be. What's xdriinfo say, BTW?
<TBBle> There's Wine debug channels that'll dump the shaders being produced, that would let you see what the GLSL being fed to Mesa looks like, and then you could chase it up with Mesa developers, or even write yourself a test harness if you're up to it.
<KenSharp> i have no programming skills unfortunately. my days ended with BASIC
<KenSharp> Xlib: extension "XFree86-DRI" missing on display ":20.0".
<KenSharp> Screen 0: not direct rendering capable.
<KenSharp> that's not good!

If you are aware of Wine, you will be aware that there are many debug channels available, but I do not know enough about this kind of error to know what further information would be useful (including which package is causing the problem).

Graphics card is an ATI Radeon 5900. I am not running fglrx.
Ubuntu 8.10 x86
---
Architecture: i386
DistroRelease: Ubuntu 10.04
Package: mesa (not installed)
ProcEnviron:
 LANG=en_AU.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups: audio cdrom kqemu netdev scanner vboxusers
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-22-generic

Ken Sharp (kennybobs) wrote :
Ken Sharp (kennybobs) wrote :

..possibly

affects: ubuntu → mesa (Ubuntu)
Ken Sharp (kennybobs) wrote :

Hmmm, ignore previous comment.

Problem apparently in the MESA drivers.

Ken Sharp (kennybobs) wrote :

Added the +d3d_shader output. HTH

Bryce Harrington (bryce) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command in a terminal after reproducing the issue, and it it will automatically gather debugging information needed for this bug:

  apport-collect 371750

(You may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report.)

Changed in mesa (Ubuntu):
status: New → Incomplete
Ken Sharp (kennybobs) wrote :

"apport-collect" apparently doesn't show up until Jaunty, I'm using Intrepid.
Is there another way to collect this data?
"apport-cli" or "apport-gtk" seem to be my options.

The unhandled exception no longer occurs, but that could simply mean that Wine handles the exception, the test still fails in latest git.

fixme:d3d_shader:shader_glsl_load_constants >>>>>>>>>>>>>>>>> GL_INVALID_OPERATION (0x502) from glUniform4fvARB @ glsl_shader.c / 667
visual.c:619: Test failed: Color components differ: c1 = 80, c2 = 00, c3 = 80
visual.c:621: Test failed: Color component value is 80
make[2]: *** [visual.ok] Error 5
make[2]: Leaving directory `/home/test/wine-git/dlls/d3d8/tests'
make[1]: *** [d3d8/tests/__test__] Error 2
make[1]: Leaving directory `/home/test/wine-git/dlls'
make: *** [dlls/__test__] Error 2

Ken Sharp (kennybobs) wrote :

Scrub that last error, my apologies, that's a different problem.
The original problem remains.

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: mesa
ProcEnviron:
 SHELL=/bin/bash
 LANG=es_ES.UTF-8
ProcVersion: Linux version 2.6.28-15-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #49-Ubuntu SMP Tue Aug 18 18:40:08 UTC 2009
Uname: Linux 2.6.28-15-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Ken,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 371750

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 371750 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/371750

Changed in mesa (Ubuntu):
status: Incomplete → New
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
Ken Sharp (kennybobs) wrote :

Hard to tell if this is fixed or not.

Tested using the Lucid live CD as I don't feel like risking my system with a full upgrade yet (will do this in the next month).

The test throws up a load of screen garbage over and over again and eventually stops. Because the screen is garbage it is impossible to tell what is going on. Top confirms the test is still running. Killing the test causes the system to shut down and turn off, which isn't very helpful. As it's a live CD, apport-collect cannot be used.

Will try again in the next few weeks when the system is installed properly, but initially it looks like a problem still exists.

Ken Sharp (kennybobs) wrote :

The crash does indeed still occur with Lucid.

I have attached an updated backtrace with the latest Wine git. I added the -dbg package for the graphics drivers too but they don't seem to have made any difference.

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

Changed in mesa (Ubuntu):
status: Incomplete → New
tags: removed: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) on 2010-06-10
tags: added: lucid
Bryce Harrington (bryce) on 2010-07-07
Changed in mesa (Ubuntu):
status: New → Confirmed
Ken Sharp (kennybobs) on 2014-01-23
tags: removed: mesa ubuntu unhandled wine
tags: removed: 3-d 3d exception
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers