Comment 0 for bug 1332114

mawk in Ubuntu is 15 years old and very buggy (see https://bugs.debian.org/cgi-bin/pkgreport.cgi?src=mawk and https://bugs.launchpad.net/ubuntu/+source/mawk , also bugs in other products, like bug #1331381) :(

Almost all bugs, reported in Ubuntu and Debian are fixed in 1.3.4-nnnn upstream releases, see http://invisible-island.net/mawk/CHANGES.html

Please update mawk to latest upstream release - all the other major distributions (Fedora/Redhat, Suse, even FreeBSD) have switched to mawk 1.3.4-2013nnnn. Five years since the bug asking to upload new mawk in Debian didn't change anything, so, I'm reporting bug in Ubuntu - sticking to 1.3.3 is now causing headeach to lots of people rather than saving from regressions :(

Please, update mawk package in Ubuntu 14.10.