Please update mawk to latest upstream release

Bug #1332114 reported by Mantas Kriaučiūnas on 2014-06-19
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
mawk (Debian)
New
Unknown
mawk (Ubuntu)
Wishlist
Unassigned

Bug Description

mawk in Ubuntu is 18 years old and very buggy (see https://bugs.debian.org/cgi-bin/pkgreport.cgi?src=mawk and https://bugs.launchpad.net/ubuntu/+source/mawk , also bugs in other products, like bug #1331381) :(

Almost all bugs, reported in Ubuntu and Debian are fixed in 1.3.4-nnnn upstream releases, see http://invisible-island.net/mawk/CHANGES.html

Please update mawk to latest upstream release - all the other major distributions (Fedora/Redhat, Suse, even FreeBSD) have switched to mawk 1.3.4-2014nnnn. Five years since the bug asking to upload new mawk in Debian didn't change anything, so, I'm reporting bug in Ubuntu - sticking to 1.3.3 is now causing headeach to lots of people rather than saving from regressions, see for example bug #1005077 :(

Please, update mawk package before major Ubuntu 16.04 LTS release.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mawk (Ubuntu):
status: New → Confirmed
Changed in mawk (Debian):
status: Unknown → New
Jarno Suni (jarnos) wrote :

Mythbuntu 14.04 uses mawk as default awk, so it is important to fixed it.

Robie Basak (racb) wrote :

Marking Importance: Wishlist based on the corresponding Debian bug. If there are specific issues causing real problems for users, then please use separate bugs to help us track the actual issues and assess their importance individually and objectively. "It's buggy" isn't particularly helpful on its own.

tags: added: upgrade-software-version
Changed in mawk (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
summary: - Please update mawk to latest upstream release - mawk in Ubuntu is 15
- years old and very buggy :(
+ Please update mawk to latest upstream release
Jarno Suni (jarnos) wrote :

Also Xubuntu 14.04, and all latest releases of Lubuntu have only mawk installed, by default, not gawk (according to Distrowatch).

summary: - Please update mawk to latest upstream release
+ Please update mawk to latest upstream release - mawk in Ubuntu is 16
+ years old!
description: updated
summary: - Please update mawk to latest upstream release - mawk in Ubuntu is 16
+ Please update mawk to latest upstream release - mawk in Ubuntu is 18
years old!
tags: added: trusty wily xenial

Please stop changing the subject line. How old it is doesn't have a bearing on anything. Some software moves slowly.

summary: - Please update mawk to latest upstream release - mawk in Ubuntu is 18
- years old!
+ Please update mawk to latest upstream release
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.