lubuntu 19.04/19.10 two displays, programs maximized uses only part of 2nd display

Bug #1809201 reported by Chris Guiver on 2018-12-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxqt-session (Ubuntu)
Undecided
Unassigned

Bug Description

19.04 daily image QA testing x86 & x86_64

Added additional info:
this bug was originally discovered on x86 & concentrates on firefox. It occurs on other programs/windows (eg. qterminal, pcmanfm-qt) and occurs on other systems (hp 8200 x86_64 qa-test, d980 x86_64 test & more...)
BIG NOTE: on original x86 dell latitude d610 the monitors were left-right configuration, on x86_64 it only occurs (more recently) on a vertical configuration; maybe a different issue, but the effect [from my [user] perspective] is the same...
--- end additional added info.

dell d610 laptop, with external vga monitor setup as display-to-right of laptop
(vga external has higher resolution than internal laptop display)

firefox on laptop monitor maximizes as expected.

when firefox window is on external monitor, it uses all the width, but only 2/3rds of vertical landscape of display, where I'd expect/hope it would use all of display.

// i've noted this before, but I didn't see lp bug report, sorry if duplicate
// but could also be just in notes in qa-testing comments

attached screen shows firefox window was drawn to height of htop window (htop being on laptop's lower resolution internal display), and the wasted/unused space on 2nd monitor as background (for 2nd display - laptop doesn't have this).

This bug is low importance, I can re-size manually to use space, and I don't believe I have the issue where both screens have the same resolution (from memory; I can confirm/re-test if worthwhile).

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: lxqt-session 0.13.0-0ubuntu2
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic i686
ApportVersion: 2.20.10-0ubuntu14
Architecture: i386
CasperVersion: 1.401
CurrentDesktop: LXQt
Date: Thu Dec 20 03:33:08 2018
LiveMediaBuild: Lubuntu 19.04 "Disco Dingo" - Alpha i386 (20181219)
SourcePackage: lxqt-session
UpgradeStatus: No upgrade log present (probably fresh install)

---
2019-04-11 - This is NOT a Lubuntu only issue.

I recently installed opensuse tumbleweed over a sick leap install on my hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600) box - and it exhibits the identical behavior when using LXQt.
https://bugzilla.opensuse.org/show_bug.cgi?id=1132180

Filed upstream: https://github.com/lxqt/lxqt/issues/1704

Chris Guiver (guiverc) wrote :
Chris Guiver (guiverc) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1809201

tags: added: iso-testing
Chris Guiver (guiverc) wrote :

QA-test on x86_64 machine "hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)" and very similiar behavior so I won't create new bug-report; I'm adding here.

Reporting another bug had me run `ubuntu-bug`.. which opened `firefox` on 2nd monitor; it opened full width of monitor but occupied only about 1/8th of vertical position of monitor, meaning I could see only panel [of firefox], tabs, url line but no real page ('ubuntu one' asking for my login when window was expanded).

Clicking maximize (as toggle) would not maximize it, but switch between a usual-window size & full-width-but-tiny-vertical. This strange behavior occurs only on 2nd display!

I have two 1920x1080 resolution monitors (not differing resolutions), positioned vertically (one above the other).

I've taken screendumps, but will add shortly as I'm typing this on machine to right of box.

Chris Guiver (guiverc) wrote :

qa-test on x86_64 - firefox window when unmaximized on display 2

( if you click on the maximize button on the top border of the window it toggles between this state & that shown in the next attached picture - next comment)

Chris Guiver (guiverc) wrote :

see prior comment please too

firefox window on 2nd (bottom) display maximized or fullscreen - it's at top of bottom monitor, full width but using minimal real-estate. If the maximize window button is clicked, the window toggles between this position and what I consider normal 'window' position shown in prior comment picture

Chris Guiver (guiverc) wrote :
Chris Guiver (guiverc) on 2019-01-18
summary: - lubuntu 19.04 two displays (different res.), firefox maximized uses only
- part of 2nd display
+ lubuntu 19.04 two displays, firefox maximized uses only part of 2nd
+ display

this needs a re-test; it's not doing it on my installed (& rather modified) lubuntu 19.04 system on d960 I just realized. i don't often qa-test with this box (it's usually running & where I enter comments etc) but has same [vertical] screen placement. maybe it's related to video driver? or no longer an issue. i need to re-test

Chris Guiver (guiverc) wrote :

QA-Test 2019-02-16 on hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)

// 19.04 daily x86_64
// following are selected portions copied/pasted from QA-test report.

change monitor-settings to match my [weird] vertical setup (one monitor above other)
my left open pcmanfm-qt & firefox windows got pushed [mostly] off screen, but i was able to drag back correctly...

firefox now on lower (was right most monitor before change) & maximize goes full width but nothing viewable - https://bugs.launchpad.net/ubuntu/+source/lxqt-session/+bug/1809201 but expected behavior if on other window..
..
..

i adjusted monitor-settings back to left-right configuraton (as it was when booted) & re-did some of the above bug-report tests, the screensaver did not correct itself ..

Chris Guiver (guiverc) wrote :
Download full text (3.4 KiB)

2019-02-17 19:30 QA-Test Lubuntu 19.04 daily (live)

// the following is selected bits pasted from my QA-TEST comment
// note in prior cut/pastes I only pasted the bit relating to each specific bug, but as they all relate (none occur until I change orientation of displays, then all are annoying-bugs, but if I change back display.orientation they all disappear) this will be all (without exceptions removed, eg. screensaver is different issue)

dell [optiplex] 960 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)

/ plan is some simple stuff, then change setup to my used setup (vertical layout of my monitors)
// this is my most used system which has run Lubuntu 19.04 for all 2019; before then was mostly XFCE (a Ubuntu install back when 17.10 was testing with Xubuntu and Lubuntu added). I have been having fewer issues with display strangeness of my installed system than prior QA-tests using 'live' so this will be focus again today (as per recent hp8200 test)

pcmanfm-qt to play (expecting no issues before I re-arrange monitors, selecting random devices, folders, minimize, maximize
firefox (ublock origin, stream utube as window, f11, fullscreen on each monitor, maximize, minimize etc)
searching for an starting some music (dc7700 where I log this has poor speakers & it's annoying me), found some so `vlc` will be playing music from now on

// then adjust displays to my vertical placement & re-do what I just did...
// note: possibly typos on this system, I'm having issues with this model.m kbd browser & this dc7700 running ubu 14.04 (installed) that I normally don't have, so apologies for any strange things..

ZERO issues at this point on either screen, everything performs perfectly (as expected).
Closed pcmanfm-qt & firefox (vlc still running for background music)
Now change orientation of displays, pref->lxqtsett->monitor.settings_set.position
DVI-1 is setup directly BELOW DVI-0 (my real setup has slight horizontal diff, but that creates more issues I now ignore for qa-testing; vertical arrangement is simpler to replicate)
drag VLC so it's full onscreen (only left part was visible - ignoring this)..

pcmanfm-qt is perfect on top (dvi0) screen, selecting different folders or devices has no issue, selecting menus display as expected.. move it to dvd1 (bottom display) and warps/moves around screen partially obscured by panel & part on display0, part on display1 - https://bugs.launchpad.net/ubuntu/+source/pcmanfm-qt/+bug/1804329 & https://bugs.launchpad.net/ubuntu/+source/pcmanfm-qt/+bug/1812342
if i maximize pcmanfm-qt (dvi1, was good on dvi0) it goes full width but is only using ~2cm of display & so it useless https://bugs.launchpad.net/ubuntu/+source/lxqt-session/+bug/1809201 .. on minimize I get https://bugs.launchpad.net/ubuntu/+source/pcmanfm-qt/+bug/1804329

This is my USED system, and yet don't suffer this. Yes my system is hugely modified (xubuntu & ubuntu are installed, lots of apps, lots of changes but mostly to xfce)...

..
opened qterminal (ctrl+alt+T) and maximized, fine on dvi0, but fullwidth & no only top panel (no black area visible on maximized (https://bugs.launchpad.net/ubuntu/+source/lxqt-session/+bug/1809201)
..

i cha...

Read more...

description: updated
tags: removed: i386
summary: - lubuntu 19.04 two displays, firefox maximized uses only part of 2nd
+ lubuntu 19.04 two displays, programs maximized uses only part of 2nd
display

QA-Test of Lubuntu 19.04 x86_64

dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt)

two displays; both dell but DVI0 is landscape, DVI1 is portrait (left) orientation.

Adjust displays to match setup, then conducted tests (for another bug-report) & noted that firefox wasn't maximizing to whole of DVI1 display. Picture attached.

Note: As I had featherpad open, I tried it too, it used the exact same proportions of the display as firefox used, as did pcmanfm-qt. They performed as expected on DVI0, but not DVI1 (portrait-left oriented screen)

Chris Guiver (guiverc) wrote :

Lubuntu 19.04 daily x86_64 QA-test (20190314)

I maximized windows on both displays - getting a strange reaction on portrait display.
https://bugs.launchpad.net/ubuntu/+source/lxqt-session/+bug/1809201
When window is maximized, it won't let me drag it larger to cover the whole of the display.

note: these displays are old 4/3; i wonder if proportions of cover/uncovered relate to more usual 16/9 (or 16/10) displays of today...

Chris Guiver (guiverc) wrote :

QA-test Lubuntu 19.04 on hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)

// following from qa-test comments (slightly edited)

I adjusted monitors to vertical as my displays are (prefs->lxqt.settings->monitor.settings) - monitor which was on right is now below

I tested https://bugs.launchpad.net/ubuntu/+source/lxqt-session/+bug/1809201

I got expected behavior on top display, but on the bottom windows (tested with qterminal running `htop`, and pcmanfm-qt) and both windows jump from being a small window to full width & not very high

I noted different sizes (heights) for each, pcmanfm-qt is far larger (vertical direction; difference is the icons & directory. The height in Qterminal is top border + menu + tab for qterminal when maximized on bottom display.

On clicking unmaximize qterminal returns to correct position, however pcmanfm-qt does NOT return to it's prior position (different bug).

Chris Guiver (guiverc) on 2019-04-11
description: updated
Chris Guiver (guiverc) on 2019-04-11
description: updated
Chris Guiver (guiverc) on 2019-04-11
description: updated
Chris Guiver (guiverc) wrote :

dell [optiplex] 780 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)
lubuntu 19.10 QA-test on d780
--- notes taken from qa-test comment
firefox; add ublock origin, stream vids in window, maximized, f11 & fullscreen on each display, firefox would NOT maximize correctly on portrait display
open term - it would NOT maximize on portrait display (not using all of screen; the part of the portrait display that's lower than the landscape display isn't used unless manually dragged there)

Chris Guiver (guiverc) wrote :

Sorry - PLEASE IGNORE comment #14; attached to wrong report - Apologies.

Chris Guiver (guiverc) wrote :

I need to give up today; comment #14 is good, my request to ignore it was wrong (ie. please ignore my comment 15). apologies for my wrong apology

Chris Guiver (guiverc) wrote :

19.10 QA-test on d755[-8]
dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt)
this box shares the same screens as #14 yet no issues here [today] !!!
but scrolling up - this d755 box had the issue in comment #11 ???
(same displays, but I forget when I fixed d780 to share the screens permanently which would have caused cabling to change..)

--- notes taken from qa-test comment
firefox; stream abc news 24 as small window, maximized, f11 & fullscreen on each display
ctrl+alt+T to open qterm, maximize & return small on each display - no issues with http://launchpad.net/bugs/1809201

Chris Guiver (guiverc) wrote :

QA-Test on Lubuntu 19.10 - hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)
no issues for two hours until I adjusted displays to match my setup, then https://bugs.launchpad.net/ubuntu/+source/lxqt-session/+bug/1809201, https://bugs.launchpad.net/ubuntu/+source/pcmanfm-qt/+bug/1812342 ..

(copy/pasted from qa-comments) - these are upstream issues (LXQt) - this comment made only because I'd not added eoan tag before...

tags: added: eoan
Chris Guiver (guiverc) on 2019-09-27
summary: - lubuntu 19.04 two displays, programs maximized uses only part of 2nd
- display
+ lubuntu 19.04/19.10 two displays, programs maximized uses only part of
+ 2nd display
Chris Guiver (guiverc) wrote :

hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)
purpose of this test is to start looking for old bugs & confirm focal impacted; these bugs are old & upstream issues and will impact very few end-users (impact me thus why chased)
boot up; adjust displays to match my setup (default-right display is below other display)
..
on lower display (as i adjust matching my setup) maximized windows go full width but only use 1/8th of vertical part of screen; this again is an upstream issue - https://bugs.launchpad.net/ubuntu/+source/lxqt-session/+bug/1809201

tags: added: focal
Chris Guiver (guiverc) wrote :
Chris Guiver (guiverc) wrote :

Lubuntu 20.04 QA-Test 2019-11-12 test on
hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)

attempted to re-create this; and could NOT do so.
upstream have CLOSED this issue... hopefully it's fixed & gone.

HOWEVER the fix done by upstream STOPS panels being created between two screens, I can create a panel on all four corners of both my screens which should not be possible with fix... but regardless I couldn't re-create this bug today.

Chris Guiver (guiverc) wrote :

This bug is marked against `lxqt-session`; and was filed upstream (LXQt). Upstream LXQt linked a number of bugs, and have now said they aren't LXQt bugs, but an bug/issue in `openbox`.

This issue requires a specific screen setup to get it to occur, plus you must open vlc on a specific screen so it's pretty minor.

Chris Guiver (guiverc) wrote :

20.04 QA-test on daily on dell [optiplex] 780 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)
Purpose today was testing for a different bug so loads of different screens setups were being tried.. I noticed I'd lost ability to maximize qterminal on one display

This image shows screen setup (both displays are same resolution; one is portrait orientation, other is landscape). The panels are both on top or portrait display; this image's purpose is to show Monitor.Settings and Qterminal appearing normal on landscape display

See next comment for how it looks when MAXIMIZE is performed on Qterminal window (Note: order of creation is reversed; this image was 3rd created with Monitor.Settings window made larger to be more easily understood)

Chris Guiver (guiverc) wrote :

Same sessin as #23; except Qterminal is maximized
Qterminal is full width of display (landscape display) but has almost no height and is unusable as a terminal. Top window dressing, menu & tab is about all that can be seen

(technically this image was done before #23; but I enlarge Monitor.Settings window as I felt it wasn't clear enough to see my setup of displays... I just didn't re-create this image)

Chris Guiver (guiverc) wrote :

Lubuntu 20.04 QA-Test on
dell [optiplex] 960 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)

This issue was re-created today. Please refer to comments on http://iso.qa.ubuntu.com/qatracker/milestones/408/builds/204243/testcases/1303/results/ as to what I did (started >60 mins ago)

Of primary note was once it issue was created..

Running `xfwm4 --replace` would STOP the issue from occurring.
Stopping xfwm4 followed by `openbox --replace` would have the issue RE-OCCUR.

Chris Guiver (guiverc) wrote :

Lubuntu 20.04 QA-Test 2020-04-17 (20200416 ISO) test on
hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)

this behavior again; firefox window as opened can be seen at this picture
(next comment will include firefox window maximized)

(closing and re-opening firefox and the reaction is the same; it's related to monitor position; if I play with it (position relative to each other) I can cause this issue to go away (keep monitors attached unticked) or return (have keep.monitors.attached ticked & they'll snap together and have this issue regularly). The panel should be on top monitor according to upstream; it should have moved & I should have been unable to have it put there, but I can move & put it back.. )

Chris Guiver (guiverc) wrote :

refer prior comment.

all I did here was hit maximize on the firefox window; it's now using full width of display but isn't using any more vertical real-estate..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.