lxqt-panel: menu-button opens in wrong position (on portrait display, normal on landscape..)

Bug #1810075 reported by Chris Guiver on 2018-12-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxqt-panel (Ubuntu)
Undecided
Unassigned

Bug Description

Lubuntu 19.04 & 19.10 daily image ISO QA-Testing

// Update 2019-04-30 on later QA-test (19.10)
I just noticed today that I only refer to menu in this bug report, but it occurs with volume adjuster, but doesn't with the date/calendar. In test this I've got in the habit of only adding menu, as it'll only occur to others (like volume) if it occurs to menu display. Of note: the calendar (view-able by clicking WorldClock) does not appear high, but is pixels above panel. Volume & menu however were ~9.5cm above panel (measured using nearby ruler, ie. specific to dpi of screen)

// Update 2019-03-15 on later QA-test (see comment #6 & screen capture)
// the menu today appears bottom right of wrong display (see comment #6)
Panel added on bottom-right (portrait display1) monitor. When clicked, the menu appears on display0 (the other monitor far right, so nearby). This actually looks better than initial description (not sitting in the middle of nowhere) alas wrong screen and requires more mouse movement than just the vertical.

--- Original bug report
I noticed this problem on debian (testing) and so tested it I get the same issue here on Lubuntu

Two displays - left is landscape orientation, right is portrait.
I add extra panel on right (portrait) monitor @ bottom, add a few widgets including menu

Click menu-icon (bottom right of display; LXQt bird) and the menu is drawn ~5.5cm above the panel with the gap below it being filled with currently firefox (where I'm typing this). I have the same issue with [installed] Debian [testing/sid] & Ubuntu.

It does NOT effect operation; just not ideal.
I tried various positions of panel, at any position on landscape oriented display it opens as expected, on portrait oriented display it only misbehaves at the bottom.

The following is as reported on debian (#916105)
---
My system is dell 755 (optiplex) with two displays, one landscape & one
portrait.

I've added two panels, one at bottom of each display.

If I open (click) menu on landscape monitor, behavior is expected.

If I open (click) menu on portrait monitor, I'd expect menu to open
just above panel, but it opens with ~5.5cm gap between panel & bottom of
displayed menu.

The gap between panel (at bottom of display) & menu contains the normal
background (be it wallpaper, terminal, browser, or file manager). Menu
works naturally, but having to move mouse further up ~5.5cm isn't ideal.

(I tried taking screenshot, but menu would disappear on touch of keys to
take image & I'd not get the menu appearing sorry)

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: lxqt-panel 0.13.0-0ubuntu5
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu14
Architecture: amd64
CasperVersion: 1.401
CurrentDesktop: LXQt
Date: Sun Dec 30 08:42:50 2018
LiveMediaBuild: Lubuntu 19.04 "Disco Dingo" - Alpha amd64 (20181229)
SourcePackage: lxqt-panel
UpgradeStatus: No upgrade log present (probably fresh install)

---
Upstream bug report : https://github.com/lxqt/lxqt/issues/1709

Debian filing : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=916105
(note: the debian report is oldest; being noticed before I started using the box for Lubuntu QA-testing too)

opensuse tumbleweed filing : https://bugzilla.opensuse.org/show_bug.cgi?id=1132937

Chris Guiver (guiverc) wrote :
Chris Guiver (guiverc) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1810075

tags: added: iso-testing
Chris Guiver (guiverc) wrote :

Could be related - https://bugs.launchpad.net/ubuntu/+source/lxqt-panel/+bug/1810079
Both are menu's not appearing where expected (just not the same place)

Chris Guiver (guiverc) wrote :

QA-test on dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt) today on 19.04 daily - issue remains.

Chris Guiver (guiverc) wrote :

QA-test (19.04 daily) on same dell 755 (c2d, 8gb, radeon rv610)
i changed the right-side monitor so it was rotated left (look at picture for clue)

TODAY the panel menu was NOT appearing as described for this bug, but on display0 (the other monitor far right, so nearby) as far right on it's panel as possible. This actually looks better (not sitting in the middle of nowhere, but attached to the panel alas wrong screen) but requires more mouse movement than just the vertical.

The way I have monitors setup can be seen in picture, as can menu. My mouse didn't show, but it was on the right (portrait) screen over the menu bottom left corner (of right monitor).

summary: - lxqt-panel: menu-button opens ~5.5cm above panel (on portrait display,
+ lxqt-panel: menu-button opens in wrong position (on portrait display,
normal on landscape..)
description: updated
Chris Guiver (guiverc) on 2019-03-15
description: updated
Chris Guiver (guiverc) wrote :

QA-test (19.04 daily) on same dell 755 (c2d, 8gb, radeon rv610)
i changed the right-side monitor so it was rotated left (look at picture for clue)
head /etc/apt/sources.list says i'm using 20190318

TODAY the panel menu was NOT appearing as it did in prior (#6) comment but back to ~7.5cm (i believe it's higher!) above the panel on display1.

The way I have monitors setup matches the screencapture from #6, plus additional panel setup the same way I believe. This is unexpected.

Both different to last comment, and I believe higher than original 5.5cm (quite a bit higher than panel on other display where it used to be only slightly higher)

Chris Guiver (guiverc) wrote :

Lubuntu 19.04 daily QA-Test comments -

dell [optiplex] 780 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)

adjust monitors to match my setup (change left & right position;
..
I'll explore https://bugs.launchpad.net/ubuntu/+source/lxqt-panel/+bug/1810075 as these are the same monitors, but on this box the default panel is drawn on the portrait display, so the additional panel will be created on the landscape monitor...

I didn't expect this (same monitors, but different cables & box) - yet when I add the second panel on now-left monitor, the now-right-portrait menu is appearing ~7cm above the panel :(

Note: this is occurring to the menu the system booted with (on portrait display), not the newly added panel.

Chris Guiver (guiverc) wrote :

QA-TEST 2019-04-05 (AEST (au) local time) -- comments from test

dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt)
two displays, right is portrait mode - adjusted monitor.settings to match my setup; for some reason it's seeing resolution as differing (they should be identical) but i'm ignoring this for now (it has occurred before so i'm blaming hardware (screen or cable))
..
added second panel to second display... add widgets a little like default panel -- it's opening menu ~13.5cm above panel today?? and ~9.5cm below top of screen!! it's getting higher again! (measurements are using a ruler & to closest half-cm; possibly unhelpful for debugging but it's easy...)

this could be related to resolution (dell displays should be same resolution; i'm blaming hardware issue for resolution diff), AND this is occurring on the monitor that monitor.settings has declared is lower res (1024x768 instead of 1280x1024 the monitor should be getting).

Chris Guiver (guiverc) wrote :

Upstream bug report : https://github.com/lxqt/lxqt/issues/1709

Debian filing : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=916105
(the debian report is the oldest; was done prior to noticing on lubuntu)

opensuse tumbleweed filing : https://bugzilla.opensuse.org/show_bug.cgi?id=1132937

description: updated
Chris Guiver (guiverc) on 2019-04-30
description: updated
Chris Guiver (guiverc) on 2019-04-30
description: updated
Chris Guiver (guiverc) wrote :

Lubuntu 19.10 QA-test.

Picture of issue reported in comments of qa-test. My cursor is over the icon "Funny Cockatoo Video - Crazy Corellas.." but the menu opens much higher on the display than expected.

This box (d755-8) has two displays, the right is portrait-left tilted (why the menu on landscape-left display is not at bottom). The top of displays was roughly equal (on picture you can see it's not perfectly aligned).

tags: added: eoan
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.