udev rules missing from udeb

Bug #105623 reported by Fabio Massimo Di Nitto
108
Affects Status Importance Assigned to Milestone
devmapper (Ubuntu)
High
Scott James Remnant (Canonical)
lvm2 (Ubuntu)
Undecided
Unassigned
mdadm (Baltix)
Undecided
Unassigned
mdadm (Ubuntu)
Undecided
Unassigned

Bug Description

How to reproduce:
install i386 server in vmware. select autopartitioning with lvm
make sure to have strace and a console available.

the process seems to hang in calculating partitions (60% or there about)

on console check ps ax
and strace the lvcreate command:

nanosleep({1, 530000000}, NULL) = 0
stat64("/dev/mapper/sunfire-swap_1", 0xfffe6ce0) = -1 ENOENT (No such file or directory)

tons of those until:
  Rendezvous with udev timed out for 'sunfire-swap_1'; stat failed: No such file or directory
  Logical volume "swap_1" created

and the device appear in /dev/mapper.

Fabio

Related branches

Revision history for this message
Fabio Massimo Di Nitto (fabbione) wrote :

Confirmed also by mvo

Changed in devmapper:
importance: Undecided → High
status: Unconfirmed → Confirmed
Changed in devmapper:
assignee: nobody → keybuk
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Confirmed, almost certainly caused by missing udev rules in the udebs

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

oops. not baltix

Changed in mdadm:
status: Unconfirmed → Rejected
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Have spoken with Colin - dropping these rules in would mean that existing LVM VG/LVs would be activated automatically within the installer, which doesn't happen right now -- this could cause problems.

This will instead be a known issue in the release notes

Revision history for this message
Jerome Soyer (saispo) wrote :

Confirmed also by me.

Revision history for this message
Colin Watson (cjwatson) wrote :

Moving milestone forward.

Revision history for this message
DanWei (danielweigl) wrote :

Same problem here, if I want to Install Feisty 7.04 with -alternative.

i switched to a console and invoked the lvcreate manually - the command stoped (with no cpu activity and no hdd act.) for about 1...2min, than the error message ("Rendezvous with udev timed out for 'main-home'; stat failed: No such file or directory" as stated above) poped up.

After that, the partitioning step found the LVM-drives correctly and setup continued as normal.

Before i was patient enough, too wait for the timeout, i killes (kill -s9) the lvcreate, and a lvs (resp. a lvdisplay) displayed everyting correct, and i thought it worked fine. But in this case, the partman didnt list the LVM-drives....

pls get it fixed....

TIA
Daniel WEIGL

Revision history for this message
Philip Lowman (philip-yhbt) wrote :

This bug makes for a very disturbing user experience while trying to use the Ubuntu alternate installer with LVM (as shipped with 7.04). When activating a volume group or creating a new volume the installer hangs for 4-5 minutes on my machine.

This was properly diagnosed as an issue in Bug #105704 and was supposed to be fixed. Not sure when 7.04.1 is due out but updated alternate install CDs with the fix for this is probably not a bad idea as I imagine a lot of the people that use the alternate install disks do so primarily for LVM support.

Revision history for this message
Cameron Braid (cameron-braid) wrote :

The same error is happening on my computer when using the alternative installer for 7.04. I downloaded the alternative CD because it explicitly stated that it supports LVM.

Within the installer, I chose manual partitoning, configure LVM, then activate volume groups.

The installer seems to lock up showing a blank blue screen without any indication that something is hapening.

I pressed ALT-F4 to view the log.

I am getting an error for each lvm logical volume that I have. Each one takes about 3 minutes to timeout.

Apr 26 18:38:26 partman-lvm: Rendezvous with udev timed out for 'Ubuntu-edgyroot'; stat failed: No such file or directory

Once all logical volumes have timed out (21 minutes later) the installer proceeded as normal. My logical volumes were activated and I could choose one from the partition manager.

I created a new logical volume, then had to wait another 3 minutes for it to timeout.

The nstallation proceeded as normal from this point on.

Revision history for this message
Cameron Braid (cameron-braid) wrote :

Sorry... The installation didn't proceed as normal... it failed installing the base system.

I can't seem to get page-up to work for the console, so I can't see what the error is.

Revision history for this message
Matti Lindell (mlind) wrote :

Cameron, could you check if you're experiencing the same problem as I am in Bug #108954.

You can see the syslog if you switch to another VT (Ctrl+Alt+F2) and check /var/log/syslog.
I transferred the log file(s) into USB memory stick and attached to bug report.

Revision history for this message
Andreas Hasenack (ahasenack) wrote :

I have 12 LVs, without counting the one I would create for ubuntu. So I guess I should wait about 36-39min to be able to proceed with the partition? Isn't there any workaround?

Revision history for this message
Cameron Braid (cameron-braid) wrote :

@mlind

My installation was failing when I had configured an existing boot partition /dev/hda3 to be mounted as /boot during the install process.

I ended up not explicitly configuring a /boot mount (so that /boot would be a folder in the root partition) the installation worked.

Sorry, I didn't keep a copy of the install log.

It would be nice if the installer could save the install log to a http server on the internet, or use an embedded http server to allow accessing it over the network. I don't have a USB stick, and I should probably buy a floppy disk one of these days :)

Revision history for this message
Ian Jackson (ijackson) wrote : Re: [Bug 105623] Re: udev rules missing from udeb

Andreas Hasenack writes ("[Bug 105623] Re: udev rules missing from udeb"):
> I have 12 LVs, without counting the one I would create for ubuntu. So I
> guess I should wait about 36-39min to be able to proceed with the
> partition? Isn't there any workaround?

Yes, there is a workaround. If you switch to VC 2 (Alt-F2) and hit
return to activate it, you can manually create the missing devices
with mknod. I don't have a test system in this state here right now
so my instructions might be slightly inaccurate, but it goes something
like this:

When the installer UI is frozen, in the VC2 shell, say
  dmsetup ls
which will print lines looking something like this
  vg--anarres-lv--u (253, 0)

Each time the UI hangs, another one of these lines will have been
added, typically with a one-higher 2nd number (the `0', above). For
the new one, which is the one it's waiting for, say:
  mknod /dev/mapper/vg--anarres-lv--u b 253 0
(with appropriate values substituted).

NB that it is VERY IMPORTANT that you get the numbers right or very
bad things can happen; it could scribble all over your disk.

Also there might be ERRORS IN THE ABOVE INSTRUCTIONS which could cause
SERIOUS DATA LOSS so please make sure your backups are up to date,
test on an isolated system, etc.

Ian.

Revision history for this message
DaveAbrahams (boostpro) wrote :

The workaround is nasty but it seems to work

Revision history for this message
Phil Mocek (pmocek) wrote : see related discusstion at Ubuntu forums

see also: Ubuntu forums: "LVM broken on feisty install cd?" <http://ubuntuforums.org/showthread.php?p=2615743#post2615743>

Revision history for this message
Trey Blancher (ectospasm) wrote :

I'm about to install Ubuntu on a machine that already has several PVs and LVs, several of which I do not want to lose or wipe. If I booted the alternate installer, could I just jump to a new virtual console and run pvscan and lvscan from there? And then choose manual partitioning? Or would I run into the same error/timeout delay?

The workaround suggested scares me, because of the very real possibility of data loss. I'm gonna hold off installing until I get a better solution.

Revision history for this message
Phillip Susi (psusi) wrote :

Suggested fix:

Add a debconf setting to enable/disable the automatic activation of the lvm volumes, and leave it disabled on the cd. That way you can have the udev rules in there, but they will only allow the devices created by libdevmapper to show up, not detect and activate volumes found on physical disks. This would also allow you to pass the debconf setting as a kernel boot parameter to force it on or off at boot time.

Revision history for this message
Thomas Werzmirzowsky (werzi2001) wrote :

Same problem here (just wanted to be informed on changes)

Revision history for this message
Cameron Braid (cameron-braid) wrote :

The same problem exists when using the CD to boot into a recovery console

Revision history for this message
Trey Blancher (ectospasm) wrote :

I went ahead with my install, and after the error timeouts, I was able to adjust the partitions normally, and everything thus far has appeared to install normally.

The bug (at least for me) appears to be a mere annoyance and not a show stopper.

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

devmapper 1.02.18-1ubuntu2 ships the udev rules in the udeb

Changed in devmapper:
status: Confirmed → Fix Released
Revision history for this message
Bryan McLellan (btm) wrote :

Note that the udev rules in the gutsy udeb are significantly different than those in the feisty deb. (backporting the udebs appears difficult). To work around this problem on feisty I've taken /etc/udev/rules.d/25-dmsetup.rules from the feisty deb and added it to the netboot initrd. Everything appears immediate and without error in relation to LVM now. This was easier than patching the udeb and having to mangle my repository signatures.

Revision history for this message
Moritz Maisel (mail-maisel) wrote :

I ran into this after "do-release-upgrade" from edgy to feisty.
How can I fix this and get a working devmapper in feisty?

Revision history for this message
Carl Larson (cslarson) wrote :

Could someone articulate a fix for this? I have also run into this after doing a "do-release-upgrade" from edgy to feisty.

Revision history for this message
Bryan McLellan (btm) wrote :

@Moritz & Carl,

I believe that's a different bug. This bug is related to the udeb used in the installation not containing lvm udev rules for devmapper, which the regular deb did contain. Additionally, this bug does not prevent you from using lvm, it just induces significant delays in the installation. I'd recommend providing additional information as to the current state of your upgrade.

Revision history for this message
Nicolas_Raoul (nicolas-raoul) wrote : vgachange sluggish and installation fails

I had Ubuntu 6.10 installed with my filesystems on LVM.
I wanted to wipe them out and perform a fresh install of Ubuntu 7.04 on the same partitions.

So I downloaded and burnt the alternate CD (for LVM support), and booted on it. The beginning was as usual. Then came the partitionning wizard, I gave the small lone ext3 partition for /boot and proceeded with the special LVM wizard.

It said "Keep current partition layout and configure LVM ?" so I pressed "Yes".

It said "1 existing volume group have been found. Please indicate whether you want to activate them. Activate existing volume groups?" so I pressed "Yes". Then a blue screen (of death?) appeared... and stayed... for a very long time... after two minutes I thought it was frozen, so I pressed CTRL+ALT+F2 to get a console, and checked the running processes, the last four were:

/bin/sh /bin/partman
parted_server
/bin/sh /lib/partman/choose_partition/30lvm/do_option log-output -t partman-lvm vgchange -a y
vgchange -a y

I had to wait for 12 minutes (time measured with my watch) before vgchange finally decided to go on. (Info: I have 3 logical volumes)

Then the installation started installing packages for a while, and suddenly turned red saying "Debootstrap warning. Warning: Failure while configuring base packages. This will be attempted 5 times". After failing 5 times, it said "Installation step failed. The failing step is: Configure the package manager"

I could find this kind of errors in /var/log/syslog:

debootstrap: Errors were encoutered while processing: console-setup volumeid dmsetup udev ubuntu-minimal pcmciautils
...
apt-install: locale: Cannot set LC_MESSAGES to default locale: No such file or directory

The CD-check tool says the CD is valid.
Should I fill a separate bug for the second part of my story, after vgchange ?
Has this vgchange bug been fixed in Gusty ? I could give it a try tomorrow.
Nicolas.

Revision history for this message
Nicolas_Raoul (nicolas-raoul) wrote : Follow-up to my last message

I retried the exact same installation and this time I only had the first problem (vgchange sluggish) and not the second one (debootstrap warning). Well, not exactly the same, I left the default country/timezone to go faster, but that is the only difference.

So in the end, the installation just took 12 minutes more than usual. Not the end of the world, but the first time it happened I was really thinking it was frozen and rebooted.

Good luck for fixing this bug !
Nicolas.

description: updated
Revision history for this message
Steven Wagner (stevenwagner) wrote :

Verified here again, feisty server installer 386.
Also, I verified it is fixed on gusty server installer 386.

Revision history for this message
Steven Wagner (stevenwagner) wrote :

Closing since this is verified fixed in gutsy.

Changed in mdadm:
status: New → Fix Released
Changed in lvm2:
status: New → Fix Released
Revision history for this message
Lifu,zhang (gslzzlf) wrote :

his bug makes for a very disturbing user experience while trying to use the Ubuntu alternate installer with LVM (as shipped with 7.04). When activating a volume group or creating a new volume the installer hangs for 4-5 minutes on my machine.

This was properly diagnosed as an issue in Bug #105704 and was supposed to be fixed. Not sure when 7.04.1 is due out but updated alternate install CDs with the fix for this is probably not a bad idea as I imagine a lot of the people that use the alternate install disks do so primarily for LVM support.

Revision history for this message
Lifu,zhang (gslzzlf) wrote :

the installation just took 12 minutes more than usual. Not the end of the world, but the first time it happened I was really thinking it was frozen and rebooted.

Revision history for this message
William Grant (wgrant) wrote :

Ubuntu 7.10 was released almost 24 hours ago, with this fixed. I find it rather unlikely that a 7.04 point-release will be created.

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Indeed, we normally don't issue point releases for non-LTS stable releases -- except if there were some absolutely critical bug, which this isn't since it's mentioned in the release notes!

Revision history for this message
junk123 (junk123-deactivatedaccount-deactivatedaccount) wrote :

I am encountering this bug as well while installing 8.0.4.2 on VMware ESXi 3.5 update 5 while using guided LVM. I am downloading 8.0.4.3 but I expect that I will have the same problem.

Is there a workaround to this installation problem, should I try uses non-LVM or some other method?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers