PulseAudio requirement breaks Firefox on ALSA-only systems after 55.0.1 update

Bug #1710993 reported by Tiago Pimenta on 2017-08-15
56
This bug affects 7 people
Affects Status Importance Assigned to Milestone
indicator-sound-gtk2 (Ubuntu)
Critical
Unassigned
Xenial
Critical
Simon Quigley
lubuntu-default-settings (Ubuntu)
Critical
Unassigned
Xenial
Critical
Simon Quigley
lubuntu-meta (Ubuntu)
Critical
Unassigned
Xenial
Critical
Simon Quigley

Bug Description

[Impact]
Users of Lubuntu 16.04 LTS are left with no sound in the default web browser, Firefox. This is a regression. For users with no knowledge of what PulseAudio even is (and even for people who *do* know what it is), this is not good.

[Test Case]
 1. Go to a website that plays sound in Firefox on Lubuntu 16.04. This, for example: https://www.youtube.com/watch?v=_QfHhFlTUN8

Expected: Sound should play without having to install any additional software.

Result: No sound is played, and the user is given a message that they need to install PulseAudio.

[Regression Potential]
People might get mad that PulseAudio is now installed, without them asking (but it adds functionality, so in my opinion this update is needed, regardless). I see no technical regression potential, as it is simply adding a dependency.

[Original Description]
I am on Lubuntu, an ALSA-only system, after update Firefox to version 55.0.1 it started to ask for PulseAudio when playing media.

Reference: https://i.imgur.com/5gEnaYv.png

I have initially stated the bug here: https://askubuntu.com/q/946568
This bug also happened with Firefox 52 and were fixed on 52.0.2, it seems it have had returned: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1671273

For lubuntu-default-settings and indicator-sound-gtk2:

[Impact]
Without this fix, users are still using alsamixer after the migration to PulseAudio, this isn't intended as they should be using pavucontrol.

[Test Case]
Go to the panel after installing the above lubuntu-meta fix, and right click on the volume icon, then select Volume Settings, and it goes to alsamixer. After installing these fixes, clicking the icon should display a Sound icon and Sound Settings should go to pavucontrol.

[Regression Potential]
Little to none, as this has been applied in all releases after Lubuntu 16.04 LTS. The only regression would occur when launching pavucontrol (as shown and fixed in bug 1708619, the fix is in indicator-sound-gtk2).

tags: added: regression-update
tags: added: xenial
description: updated
description: updated
description: updated
Tiago Pimenta (tiagoapimenta) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Simon Quigley (tsimonq2) wrote :

Tiago,

We care. ;)

I'll talk with the Lubuntu Team and see how we can handle it from this point on.

Thank you for taking the time to make Lubuntu better!

Changed in firefox (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Simon Quigley (tsimonq2)
Tiago Pimenta (tiagoapimenta) wrote :

Could someone please help me to fix that: https://askubuntu.com/q/947784

Tiago Pimenta (tiagoapimenta) wrote :

I am begging them to reconsider the decision, I am very sad about it:

https://support.mozilla.org/pt-BR/questions/1172578

Tiago Pimenta (tiagoapimenta) wrote :

Let us see how many time it will remain there until they consider it duplicated:
https://bugzilla.mozilla.org/show_bug.cgi?id=1393105

Gabriel Parrondo (v-sistemas) wrote :

Tiago: upstream (mozilla) has made it very clear they won't be changing anything on their end. All the bugs you linked are closed as WONTFIX.

This is up to the distribution to solve: either add pulseaudio to lubuntu, or compile firefox with alsa support (and maybe patch it if Mozilla drops alsa support completely in the future).

Simon: any progress on this? Anything we can help with? Thanks!

Simon Quigley (tsimonq2) on 2017-08-29
Changed in lubuntu-meta (Ubuntu):
status: New → In Progress
status: In Progress → Fix Released
Changed in lubuntu-meta (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → Simon Quigley (tsimonq2)
no longer affects: firefox (Ubuntu)
no longer affects: firefox (Ubuntu Xenial)
Changed in lubuntu-meta (Ubuntu):
importance: Undecided → Critical
Changed in lubuntu-meta (Ubuntu Xenial):
importance: Undecided → Critical
Simon Quigley (tsimonq2) on 2017-08-29
description: updated
Simon Quigley (tsimonq2) on 2017-08-29
Changed in lubuntu-meta (Ubuntu Xenial):
milestone: none → xenial-updates
Tiago Pimenta (tiagoapimenta) wrote :

Gabriel: That is the reason of my sadness.

Simon: I am using Chromium for now, I decided not to install PA in order to save resources, after all I am using Lubuntu instead of Xubuntu or MATE due to the lightweight way, but if the head gave up, what could I do.

Robie Basak (racb) wrote :

Wearing my ~ubuntu-sru hat:

This seems like a pretty radical change. There was some IRC discussion here: https://irclogs.ubuntu.com/2017/08/30/%23ubuntu-devel.html

My conclusion: +1 in principle (I have yet to review the change itself), for the following reasons:

This change impacts Lubuntu only, and I'm told that this has been discussed and agreed within the Lubuntu community and approved by an Lubuntu release manager.

Though fixing Firefox packaging to support ALSA is another option, I appreciate that this may be beyond feasible for Lubuntu in practice, and I think it's appropriate for Lubuntu to decide for themselves how they want to approach fixing this.

Clearly the Firefox update has broken user experience on Lubuntu, so I think a fix is justified under existing SRU policy. It's a grey area as to whether this is a "change to the environment" or a regression caused by the Firefox update, but either way I think the spirit of the SRU policy is that the SRU team have the remit to approve a fix. Especially because the regression is hitting users already.

Julien Lavergne (gilir) wrote :

Just to add my 2 cents, I'm still suprise that Firefox package doesn't add a depend on pulseaudio with this version. By adding pulseaudio to the seed, we make the impression that we want pulseaudio on Lubuntu for Xenial. We don't. We need to add it because Firefox is broken without it.

However, adjusting the seed is probably the quicker way to fix this critical issue, on a stable release, so let's go with this.

Hello Tiago, or anyone else affected,

Accepted lubuntu-meta into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lubuntu-meta/0.65.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lubuntu-meta (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Robie Basak (racb) wrote :

> Just to add my 2 cents, I'm still suprise that Firefox package doesn't add a depend on pulseaudio with this version.

It should only be a Recommends at the most I think, since Firefox is usable without sound hardware. Does Lubuntu install Recommends by default? Feel free to file a bug against the Firefox package for this, of course.

Simon Quigley (tsimonq2) wrote :

Lubuntu does not follow recommends.

Tiago Pimenta (tiagoapimenta) wrote :

After add the line on /etc/apt/sources.list, update and upgrade, I get my sound muted, I reboot and unmute but stayed playing no sound, I checked the volume it seemed ok but nothing goes out, volume icon still launch alsamixergui, but it displayed Card and Chip as being PulseAudio, and have Master and Capture control, the console alsamixer stayed displaying ALSA controls. Unfortunately I can not hold this situation for now, I have a meeting soon, so I reverted the version to 0.65.1.

Simon Quigley (tsimonq2) wrote :

Apologies for the delay on this, but I think I know why Tiago was having those issues...

There seems to be other pulse things pulled in when upgrading completely from -proposed, and so it seems there might be a regression there, but after updating *only* lubuntu-desktop, it works fine.

I would consider this a working lubuntu-meta, and I'll update the tags as such.

But, they do raise a good point about the volume icon still using alsamixer. I'll work to figure that out.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Simon Quigley (tsimonq2) wrote :

Seems like the usage of alsamixer resides in lubuntu-default-settings. I'll upload a new lubuntu-default-settings to Xenial that makes this change.

NOTE TO SRU TEAM: lubuntu-meta and lubuntu-default-settings should be released to xenial-updates at the same time.

no longer affects: lubuntu-meta (Ubuntu Xenial)
Changed in lubuntu-meta (Ubuntu Xenial):
importance: Undecided → Critical
Changed in lubuntu-default-settings (Ubuntu):
importance: Undecided → Critical
Changed in lubuntu-default-settings (Ubuntu Xenial):
importance: Undecided → Critical
assignee: nobody → Simon Quigley (tsimonq2)
Changed in lubuntu-meta (Ubuntu Xenial):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Fix Committed
Changed in lubuntu-default-settings (Ubuntu Xenial):
status: New → In Progress
Simon Quigley (tsimonq2) wrote :

I uploaded a fixed lubuntu-default-settings, and I tested locally that it successfully migrates over to using the correct applet after logging out and logging back in (I would call this verification-done-xenial).

I would prefer this approach because it is more uniform to what the later releases do.

Simon Quigley (tsimonq2) wrote :

Modified the bug description for lubuntu-default-settings and indicator-sound-gtk2 (indicator-sound-gtk2 needs the same fix as Zesty and Artful, bug 1708619 for reference).

description: updated
Simon Quigley (tsimonq2) on 2017-09-17
no longer affects: lubuntu-meta (Ubuntu Xenial)
no longer affects: lubuntu-default-settings (Ubuntu Xenial)
Changed in lubuntu-default-settings (Ubuntu):
status: New → Fix Released
Changed in indicator-sound-gtk2 (Ubuntu):
status: New → Fix Released
Changed in indicator-sound-gtk2 (Ubuntu Xenial):
status: New → Fix Committed
Changed in lubuntu-meta (Ubuntu Xenial):
status: New → Fix Committed
Changed in lubuntu-default-settings (Ubuntu Xenial):
status: New → Fix Committed
Changed in indicator-sound-gtk2 (Ubuntu):
importance: Undecided → Critical
Changed in indicator-sound-gtk2 (Ubuntu Xenial):
importance: Undecided → Critical
Changed in lubuntu-default-settings (Ubuntu Xenial):
assignee: nobody → Simon Quigley (tsimonq2)
Changed in indicator-sound-gtk2 (Ubuntu Xenial):
assignee: nobody → Simon Quigley (tsimonq2)
Changed in lubuntu-meta (Ubuntu Xenial):
assignee: nobody → Simon Quigley (tsimonq2)
Changed in lubuntu-default-settings (Ubuntu Xenial):
importance: Undecided → Critical
Changed in lubuntu-meta (Ubuntu Xenial):
importance: Undecided → Critical
Simon Quigley (tsimonq2) wrote :

Bump?

Łukasz Zemczak (sil2100) wrote :

Hello Tiago, or anyone else affected,

Accepted lubuntu-default-settings into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lubuntu-default-settings/0.46.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
removed: verification-done verification-done-xenial
Simon Quigley (tsimonq2) wrote :

The fix works as intended for me.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Tiago Pimenta (tiagoapimenta) wrote :

Ok, I was realy afraid to break my system, so I used qemu, this time the sound works on Firefox as expected after the proposed upgrade, and the sound icon on tray was almost correct: there is one master bar - working properly - and a link to Sound Settings, that I suppose should lead to more advanced settings, but it does nothing when clicked over, and still there wasn't the pavucontrol requirement, I installed it but the Sound Settings still do not launch nothing, it maybe misconfigured or there is a missing requirement.

I am sad to say the proposed update bring a plenty of useless stuff, as some unity packages, I am not sure it is safe to release these packages without a dependency review.

Moreover, I am deeply heartbroken about this situation, as it adds a pulseaudio process that keeps running forever, once more time the system paying the price of a corporation's misled decision.

Simon Quigley (tsimonq2) wrote :

I have personally done a dependency review and it looks fine to me...

Also, this exact thing was already done with 16.10 and on...

Lastly, indicator-sound-gtk2 was never accepted into xenial-proposed, which has been sitting in there *for over a month*. That fixes the problems Tiago described with the volume applet not opening pavucontrol, and *is not a regression in lubuntu-default-settings*.

To be honest, I'm a bit frustrated... I do not want to drag this on longer than it already has been. This is a high priority regression that needs to get an update promptly...

Robie Basak (racb) wrote :

You asked for lubuntu-meta and lubuntu-default-settings to move to xenial-updates at the same time. I can do that, but users aren't guaranteed to see that at the same time (for example with phased updates). If one breaks the other, then versioned Breaks clauses need to be used to ensure updating ordering. Please could you confirm if this is needed? What will happen if this doesn't happen?

Is the proposed upload to indicator-sound-gtk2 tied up in this too?

Robie Basak (racb) wrote :

Perhaps both lubuntu-default-settings and indicator-sound-gtk2 need to Breaks: lubuntu-meta (<< 0.65.2)? I'm not certain I've got that the right way round. The idea is that the tools won't change to use pavucontrol until lubuntu-meta has been updated and pulled in pulseaudio. Users without lubuntu-meta installed would be unaffected.

Robie Basak (racb) wrote :

Fix Committed is wrong - see SRU procedure documentation. I wonder if this is why it has been missed from review? I have looked at things either side of this item in the queue but I don't remember why I never considered this bug from the perspective of indicator-sound-gtk2 before.

Changed in indicator-sound-gtk2 (Ubuntu Xenial):
status: Fix Committed → In Progress
Simon Quigley (tsimonq2) wrote :

I had a discussion with Robie on IRC but see nothing was reflected here...

Would the SRU team like new uploads or not?

Robie Basak (racb) wrote :

Sorry, I saw your response scroll by on IRC but wasn't in a position to act on it at the time. Responding in the bug would have been useful!

For reference:

12:01 <rbasak> tsimonq2: around? I commented on the bug.
12:02 <rbasak> tsimonq2: since it's possible you might want to put the Breaks in indicator-sound-gtk2, I don't want to accept it as-is without your comment.
12:02 <rbasak> tsimonq2: if you do, then it'll want adding to lubuntu-default-settings too I guess?
12:05 <rbasak> tsimonq2: aside from that your upload for indicator-sound-gtk2 looks fine. Though I feel that the changelog message should probably mention the reason for the upload (Lubuntu's move to pulseaudio), I won't block on that.
12:06 <rbasak> tsimonq2: let me know what you want to do please.
15:50 <tsimonq2> rbasak: Breaks might be a good idea... but if any one lands before the other, as long as they all land within an hour or two it'll be fine
15:50 <tsimonq2> (well, within a few hours of each other)
15:52 <tsimonq2> rbasak: If you'd prefer Breaks I can upload some new packages in 6 or 7 hours
15:52 <tsimonq2> But yeah, good point.
15:56 <rbasak> tsimonq2: it can break if you have a user with the security pocket enabled but not updates for example.
16:00 <rbasak> tsimonq2: anyway, that's the potential consequence. I don't have a strong opinion here especially as the potential breakage isn't severe and is recoverable.
16:01 <rbasak> tsimonq2: if you want me to accept the current indicator-sound-gtk2 in the queue, I'd be happy to - just give me a +1 after you've considered the above please.
16:01 <rbasak> Since I think this should be your decision.
16:21 <tsimonq2> rbasak: Since I've been the one doing Lubuntu security updates for Universe packages, I'm willing to deal with the consequences if needed. +1, please accept.

Changed in indicator-sound-gtk2 (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-done verification-done-xenial
Robie Basak (racb) wrote :

Hello Tiago, or anyone else affected,

Accepted indicator-sound-gtk2 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/indicator-sound-gtk2/12.10.0.1-0ubuntu5.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Tiago Pimenta (tiagoapimenta) wrote :

Ok, let's go.

Performing just upgrade after proposed configuration gave me just lubuntu-core update:
https://pastebin.com/We1Af6eM

If i perform dist-upgrade it would bring the unity stuff I had said before, I simulate it here:
https://pastebin.com/LuJtgHXD

Unfortunately when I run install just for lubuntu-default-settings it brings this lots of stuff:
https://pastebin.com/mfVsU3fU

The indicator also bring a plenty of packages:
https://pastebin.com/4bpWJCCc

I do not know if lubuntu-desktop is also required to this fix, as part of lubuntu-meta, but it bring few dependencies, nothing to worry about.

As I am running on VM I did not care about it and I performed a full dist-upgrade, but I would care about it if I had to do it on my machine.

After reboot the machine the sound worked on Firefox but the indicator did not launched pavucontrol as I expected, it is due to no dependency relation between any package tha could lead to pacucontrol package installation. I still had to install it apart, after done that, the tray icon could launch the control as expected.

I see there is two things to be done:
* A dependency to be add to some package that could lead to the pacucontrol installation;
* A deep dependency review in order to clean up unity installation, as well as reduce as few as possible the dependencies

Simon Quigley (tsimonq2) wrote :

> Ok, let's go.
>
> Performing just upgrade after proposed configuration gave me just lubuntu-core update:
> https://pastebin.com/We1Af6eM
>
> If i perform dist-upgrade it would bring the unity stuff I had said before, I simulate it here:
> https://pastebin.com/LuJtgHXD
>
> Unfortunately when I run install just for lubuntu-default-settings it brings this lots of stuff:
> https://pastebin.com/mfVsU3fU
>
> The indicator also bring a plenty of packages:
> https://pastebin.com/4bpWJCCc

Not only is this expected, but these dependencies seem to exist on every Lubuntu release past Xenial. It's fine in my opinion, and really doesn't need much of a dependency review.

> After reboot the machine the sound worked on Firefox but the indicator did not launched pavucontrol as I expected, it is due to no dependency relation between any package tha could lead to pacucontrol package installation. I still had to install it apart, after done that, the tray icon could launch the control as expected.

You're right on this, my mistake. Great catch. I pushed an update to the seed (I now have access) and will push an update to lubuntu-meta shortly pulling this in. SRU team, please review this (this also has Breaks as discussed with rbasak on IRC, because this needs an upload anyways). But for now, indicator-sound-gtk2 is good, so I'm marking that as verification-done-xenial.

Hopefully we can *finally* get this solved. :)

Simon Quigley (tsimonq2) on 2017-11-01
tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound-gtk2 - 12.10.0.1-0ubuntu5.16.04.1

---------------
indicator-sound-gtk2 (12.10.0.1-0ubuntu5.16.04.1) xenial; urgency=medium

  * Add compatibility for Lubuntu (LP: #1710993).

 -- Simon Quigley <email address hidden> Fri, 04 Aug 2017 06:30:37 -0500

Changed in indicator-sound-gtk2 (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for indicator-sound-gtk2 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-meta - 0.65.2

---------------
lubuntu-meta (0.65.2) xenial; urgency=medium

  * Refreshed dependencies
  * Added pulseaudio to desktop (LP: #1710993)

 -- Simon Quigley <email address hidden> Tue, 29 Aug 2017 00:12:42 -0500

Changed in lubuntu-meta (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-default-settings - 0.46.1

---------------
lubuntu-default-settings (0.46.1) xenial; urgency=medium

  * Use the non-ALSA volume mixer (LP: #1710993).
    - Add a hard dependency on indicator-sound-gtk2 to get this to work.

 -- Simon Quigley <email address hidden> Sat, 16 Sep 2017 18:25:46 -0500

Changed in lubuntu-default-settings (Ubuntu Xenial):
status: Fix Committed → Fix Released
Tiago Pimenta (tiagoapimenta) wrote :

Hello,

Something went wrong today!

It seems all packages were upgraded as expected but pavucontrol:

$ dpkg-query -l | egrep 'lubuntu-(core|default-settings)|indicator-sound-gtk2|pavucontrol'
ii indicator-sound-gtk2 12.10.0.1-0ubuntu5.16.04.1 amd64 System sound indicator.
ii lubuntu-core 0.65.2 amd64 Lubuntu Desktop environment - minimal installation
ii lubuntu-default-settings 0.46.1 all default settings for Lubuntu

If only it was only pavucontrol the problem I would consider a minor problem, but I do not know why, despite all versions had matched the required, it still show the old sound control, and my sound got muted.

There is the pulseaudio process running, so I believe the mixer control is muted, but as I said it is not shown at tray icons, not the simpler one neither the pavucontrol, which was not even installed.

Tiago Pimenta (tiagoapimenta) wrote :

I managed to make my sound work installing pavucontrol, running it, and adjusting the sound volume and devices, but as I said I am still not able to do it via tray icon. And it is not expected the user known it is required to install anything apart after a upgrade.

Raycho Raykov (raycho-raykov) wrote :

Updating ubuntu-default-settings to 0.46.1 requires also to install these packages:

----------
  apg bluez-obexd cheese-common cups-pk-helper dconf-cli evolution-data-server evolution-data-server-common evolution-data-server-online-accounts geoclue
  geoclue-ubuntu-geoip gir1.2-ibus-1.0 gkbd-capplet gnome-bluetooth gnome-desktop3-data gnome-session-bin gnome-settings-daemon-schemas gnome-user-share
  gsettings-ubuntu-schemas gstreamer1.0-clutter-3.0 gstreamer1.0-x hwdata ibus indicator-bluetooth indicator-datetime indicator-keyboard indicator-power
  indicator-sound indicator-sound-gtk2 libaccounts-glib0 libaccounts-qt5-1 libcanberra-pulse libcheese-gtk25 libcheese8 libclutter-gst-3.0-0 libebackend-1.2-10
  libebook-1.2-16 libebook-contacts-1.2-2 libecal-1.2-19 libedata-book-1.2-25 libedata-cal-1.2-28 libedataserver-1.2-21 libfftw3-single3 libgee-0.8-2
  libgeocode-glib0 libgeonames0 libgnome-bluetooth13 libgnome-desktop-3-12 libgnomekbd-common libgnomekbd8 libgweather-3-6 libgweather-common libibus-1.0-5
  libido-0.1-0 libpulsedsp libsignon-extension1 libsignon-glib1 libsignon-plugins-common1 libsignon-qt5-1 libtimezonemap-data libtimezonemap1
  libunity-control-center1 libunity-settings-daemon1 liburl-dispatcher1 libwebrtc-audio-processing-0 mousetweaks nautilus-data pulseaudio pulseaudio-module-x11
  pulseaudio-utils rtkit session-migration signon-plugin-password signon-ui signon-ui-service signon-ui-x11 signond ubuntu-system-service ubuntu-touch-sounds
  unity-control-center unity-control-center-faces unity-settings-daemon
-------

I don't need these. Maybe you need to reconsider dependencies of this package. Why cheese or evolution packages are required to solve problem with alsa mixer or pulse audio.

I'm using currently ESR version of Firefox, which works fine with my audio.

Simon Quigley (tsimonq2) wrote :

> I don't need these.

These have already been installed by default on every future release, and are pulled in by pulseaudio.

> Maybe you need to reconsider dependencies of this package.

That's not our problem.

Raycho Raykov (raycho-raykov) wrote :

Thanks, Simon Quigley. How I dare to think it's your problem at first place. Shame on me.

The real question behind everything in my post you quoted is that you avoid: Why pulseaudio requires cheese and evolution. Do I (or anyone else) expect to hear a sound from the speakers of the computer without these programs? What about unity-control-center and other unity-*? Where are kde-control-center, cinnamon-control-center and whatever? Where are my beloved apple-control-center or windows-control-center packages? How may I hear anything without the Bill's smile on my screen?

One of reasons for me (and many others) to choose lubuntu instead of Ubuntu is low system requirements.

I write my previos post not to tell anyone what is his problems but to focus attention on something wrong in my point of view. So I don't understand why you need to point here what is not your problem. If it is God's (pulseaudio's) will, who am I to argue with?! Let it be!

Raycho Raykov (raycho-raykov) wrote :

Ok, my fault! Tiago Pimmenta already pointed on that problem on post #30.

Tiago Pimenta (tiagoapimenta) wrote :

I believe the problem is not with pulseaudio, and with indicator-sound-gtk2, as Simon stated, it is not lubuntu-meta problem:

apt-cache show lubuntu-core lubuntu-desktop lubuntu-default-settings | awk '$1 == "Version:" { version = $2 } $1 == "Package:" { package = $2 } $1 == "Depends:" || $1 == "Recommends:" { for (i = 2; i <= NF; i++) { sub(/,$/, "", $i); print $i >> "/tmp/" package "-" version } }'

diff -iuw /tmp/lubuntu-core-0.65 /tmp/lubuntu-core-0.65.2 # +xserver-xorg-video-intel nothing relevant
diff -iuw /tmp/lubuntu-desktop-0.65 /tmp/lubuntu-desktop-0.65.2 # +pulseaudio
diff -iuw /tmp/lubuntu-default-settings-0.46 /tmp/lubuntu-default-settings-0.46.1 # +indicator-sound-gtk2

As I said on post #30 when updating just lubuntu-core and lubuntu-desktop it brings few packages, so that is why I believe the problem is with indicator-sound-gtk2.

Tiago Pimenta (tiagoapimenta) wrote :

As I suspected I found the problem, indicator-sound-gtk2 recommends unity-control-center, as apt-get also install recommended packages it get installed, then it depends on libcheese8, and libcheese8 depends on cheese-common, and so the shit is done...

I filed the bug here:
https://bugs.launchpad.net/ubuntu/+source/indicator-sound-gtk2/+bug/1734100

Simon Quigley (tsimonq2) wrote :

I've had a think about this and will look into the dependency problem because I'm seriously wondering what the heck is going on...

All I can tell you right now is that it wouldn't be Recommends because Lubuntu doesn't pull those in.

I'll update this bug when I have something.

Tiago Pimenta (tiagoapimenta) wrote :

Simon, I am highly inclined to believe Lubuntu does indeed install recommends packages, otherwise we would'nt be having all these problems, I will do another clean installation on qemu to confirm that for you as soon as possible.

Tiago Pimenta (tiagoapimenta) wrote :

As I suspected, I was right, to reproduce what I get I did:

$ sudo apt-get update
$ sudo apt-mark hold lubuntu-default-settings
$ sudo apt-get dist-upgrade -s
# sudo apt-mark unhold lubuntu-default-settings
$ LANG= apt-get dist-upgrade -s > /tmp/normal-dist-upgrade-s
$ LANG= apt-get dist-upgrade -s --no-install-recommends > /tmp/dist-upgrade-s--no-install-recommends

Result running normal apt-get dist-upgrade:
https://pastebin.com/TvQ736xJ

Result running apt-get dist-upgrade with --no-install-recommends:
https://pastebin.com/scS5iATN

Tiago Pimenta (tiagoapimenta) wrote :

There was no /etc/apt/apt.conf file and none of the files on /etc/apt/apt.conf.d has any Install-Recommends configuration, so that I hope you could review the dependencies considering recommended packages as targets of being installed after a upgrade.

Tiago Pimenta (tiagoapimenta) wrote :

On the first dist-upgrade on post #46 where I put the argument -s consider being -y.

Chris Halse Rogers (raof) wrote :

Hm, what's happening here?

I see lubuntu-meta 0.65.3 in xenial-proposed claiming to fix this bug, but no record on this bug of a 0.65.3 upload. Is lubuntu-meta 0.65.3 the version that has been tested?

Changed in lubuntu-meta (Ubuntu Xenial):
status: Fix Released → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-meta - 0.65.3

---------------
lubuntu-meta (0.65.3) xenial; urgency=medium

  * Refreshed dependencies
  * Added pavucontrol to desktop (LP: #1710993)
  * Add Breaks to make sure this update lands at the same time as
    lubuntu-default-settings and indicator-sound-gtk2

 -- Simon Quigley <email address hidden> Tue, 31 Oct 2017 22:26:24 -0500

Changed in lubuntu-meta (Ubuntu Xenial):
status: Incomplete → Fix Released
Tiago Pimenta (tiagoapimenta) wrote :

Indeed, now it brings pavucontrol as expected, but there still are the dependency problem filed here:
https://bugs.launchpad.net/ubuntu/+source/indicator-sound-gtk2/+bug/1734100

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.