lubuntu and ubuntustudio are missing pool; can not install without internet connection

Bug #1633913 reported by Marco on 2016-10-16
94
This bug affects 15 people
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Critical
Simon Quigley
ubuntustudio-meta (Ubuntu)
Critical
Unassigned

Bug Description

Installing lubuntu 16.10. I'm getting an error. Grub installation failed.
The 'grub-efi-amd64-signed'package failed to install into / target/. without the GRUB bootloader, the installed system will not boot.

I do not have this problem with lubuntu 16.04

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: ubiquity 16.10.14 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
Uname: Linux 4.8.0-22-generic x86_64
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CasperVersion: 1.379
Date: Sun Oct 16 20:37:52 2016
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/lubuntu.seed boot=casper only-ubiquity quiet splash ---
LiveMediaBuild: Lubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.1)
ProcEnviron:
 TERM=unknown
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
 LC_NUMERIC=C.UTF-8
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Marco (lampje) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed
hakuna_matata (hakuna-matata) wrote :

Lubuntu 16.10 desktop ISO does not work without internet connection. The ISO does not contain /pool with additional packages.

If you compare http://cdimage.ubuntu.com/lubuntu/releases/16.10/release/lubuntu-16.10-desktop-amd64.list with http://releases.ubuntu.com/yakkety/ubuntu-16.10-desktop-amd64.list, e.g. /pool/main/g/grub2-signed/grub-efi-amd64-signed_1.74+2.02~beta2-36ubuntu11_amd64.deb is missing.

IMHO the advantage of a smaller ISO cannot compensate the drawback of a necessary internet connection. So it is not really a feature, it is a bug.

Phillip Susi (psusi) on 2016-10-31
summary: - failed to install grub-efi-amd64-signed
+ lubuntu image is missing pool; can not install without internet
+ connection
Changed in grub-installer (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Critical
affects: grub-installer (Ubuntu) → ubuntu
Phillip Susi (psusi) on 2017-03-03
summary: - lubuntu image is missing pool; can not install without internet
- connection
+ lubuntu and ubuntustudio are missing pool; can not install without
+ internet connection
Simon Quigley (tsimonq2) wrote :

Is this still an issue?

Phillip Susi (psusi) wrote :

Yes.

CombatWombat (cwombat) wrote :

Just wanna say this is still a very active bug. Just spent two days trying to get Lubuntu 17.04 64-bit installed and gave up. Tried 16.04 and went with 0 issues.

Dimitri John Ledkov (xnox) wrote :

Lubuntu Desktop images in the iso tracker lack "No Network" test cases; unlike e.g. Ubuntu Desktop.

The lubuntu tech-leads marked desktop images as ready for both yakkety and zesty releases.

I do not know why "No Network" test cases are not enabled for Lubuntu Desktop images. It would seem to me, as if this is an explicit goal to require network connectivity during installation.

Note that e.g. Lubuntu Alternate images do contain /pool/ with many files there.

Lack of ./pool/ on the image, would indicate a seed changes to explicitely exclude shipping deb files in the pool.

Lack of ./pool/ should not be fatal, as there are dists/ files still generated, and it is a valid apt repository; albeit without shipping any files.

Please contact Lubuntu developers for further clarification as to why ./pool files were removed from the desktop images; and "No Network" installation tests not enabled for Lubuntu desktop images.

affects: ubuntu → lubuntu-meta (Ubuntu)
Changed in lubuntu-meta (Ubuntu):
assignee: nobody → Lubuntu Developers Team (lubuntu-dev)
status: Triaged → New
importance: Critical → Undecided
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-meta (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1633913

tags: added: iso-testing
Simon Quigley (tsimonq2) wrote :

This is fixed as of Lubuntu Artful Aardvark Alpha 2.

Changed in lubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
Phillip Susi (psusi) wrote :

Sorry for the noise, meant that for a different bug.

no longer affects: lubuntu-next
Phillip Susi (psusi) wrote :

Lubuntu is still not installable offline on EFI based machines because the pool does not contain the grub-efi and grub-signed packages.

Changed in lubuntu-meta (Ubuntu):
status: Fix Released → Triaged
Simon Quigley (tsimonq2) on 2017-11-19
Changed in lubuntu-meta (Ubuntu):
assignee: Lubuntu Developers Team (lubuntu-dev) → Simon Quigley (tsimonq2)
importance: Undecided → Critical
status: Triaged → In Progress
Simon Quigley (tsimonq2) wrote :

I can confirm that this bug is now fixed in the Bionic daily.

Changed in lubuntu-meta (Ubuntu):
status: In Progress → Fix Released
Phillip Susi (psusi) wrote :

It looks like ubuntustudio 16.04.4 is still missing the pool.

Changed in ubuntustudio-meta:
importance: Undecided → Critical
status: New → Confirmed
Ross Gammon (rosco2) wrote :

Best to add the ubuntu "source" archive ubuntustudio-meta package instead of the upstream project, or it will get lost. At least I hadn't spotted it before :-)

affects: ubuntustudio-meta → ubuntustudio-meta (Ubuntu)
Ross Gammon (rosco2) wrote :

I don't see this on Ubuntu Studio 16.04.05 (at least in a VM). It installs and boots fine without a network connection. Can anyone else confirm?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers