Ubuntu

missing background theme definition

Reported by Rafael Laguna on 2012-02-29
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
lubuntu-artwork (Ubuntu)
High
Lubuntu Developers Team

Bug Description

Maybe not the right place, and possibly a duplicated bug, this:
https://bugs.launchpad.net/ubuntu/+source/lubuntu-artwork/+bug/938472

But now, since last update, Unico based themes show weird colours, dialogs are black and this make apps unreadable.

summary: - black backgrounds using unico engine
+ gtk3 draws black backgrounds with unico themes

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
tags: added: rls-mgr-p-tracking
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → High
tags: added: rls-p-tracking
Martin Pitt (pitti) wrote :

Andrea, does this ring a bell to you?

tags: removed: rls-p-tracking
Andrea Cimitan (cimi) wrote :

Issue is not in unico, neither Gtk+, but in the themes.

With updated Gtk+ 3.x, widgets must specify or inherit background colors, otherwise theming engines (unico or gtk default theming engine) won't render the background (cause the default background color is NULL, indeed).

All themes, like lubuntu or light-themes, must add a line like:

    background-color: @bg_color;

...n the widgets which are affected by this black background, because this black background means background-color is currently unset.
Set it to a color and unico or gtk+ will render with the background-color, black gone.

Cheers

Martin Pitt (pitti) wrote :

Thanks Andrea!

affects: gtk+3.0 (Ubuntu) → ubuntu
summary: - gtk3 draws black backgrounds with unico themes
+ missing background theme definition
affects: ubuntu → lubuntu-artwork (Ubuntu)
Changed in lubuntu-artwork (Ubuntu):
assignee: nobody → Lubuntu Developers Team (lubuntu-dev)
August Karlstrom (fusionfile) wrote :

Andrea, I see black backgrounds with the fallback theme (Raleigh) as well, see Bug 995844. Does that mean that there is a missing background color definition even in the GTK source code?

Julien Lavergne (gilir) wrote :

Set as "Fix released", it should be fixed since Lubuntu 12.04

Changed in lubuntu-artwork (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers