dialogs are barely readable-- grey on black????

Bug #938472 reported by Walter Lapchynski on 2012-02-22
68
This bug affects 14 people
Affects Status Importance Assigned to Milestone
lubuntu-artwork (Ubuntu)
Undecided
Unassigned

Bug Description

furthermore the buttons themselves only show text if moused over/focused.
Lubuntu Precise daily-live 20120221 fresh install on 12" 1.5GHz PowerBook G4 PPC
lubuntu-artwork 0.24

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: lubuntu-artwork 0.24
ProcVersionSignature: Ubuntu 3.2.0-17.26-powerpc 3.2.6
Uname: Linux 3.2.0-17-powerpc ppc
ApportVersion: 1.92-0ubuntu1
Architecture: powerpc
Date: Tue Feb 21 23:43:54 2012
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha powerpc (20120221)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lubuntu-artwork
UpgradeStatus: No upgrade log present (probably fresh install)

Walter Lapchynski (wxl) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/938472

tags: added: iso-testing
karl anliot (kanliot) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-artwork (Ubuntu):
status: New → Confirmed
Greg Faith (gregfaith) wrote :

I can confirm this bug also affects the precise-desktop-amd64.iso

From yesterday 20120221 daily-build: installation completed normal but very hard to read pages.
Post installation all in fine.

And today's 20120222 daily-build: installation aborted

I would agree the lubuntu-artwork is most probable cause.

karl anliot (kanliot) wrote :

it might be better for a developer to decide on what is the most probable cause of the black background. My first thought that it was a change in GTK+

Erick Brunzell (lbsolost) wrote :

I'm seeing this also with the Lubuntu 20120222 i386 image. I aborted at the screen shown in the attached screenshot because it was too difficult to read.

its affecting all gtk-applications here on an installed system

gedit, evolution, nm-applet, keyring-password-dialog, lxpanel

I have marked the other bugs as a duplicate of this bug

Just for the record, thats how my evolution is "designed" at the moment

http://alpha-unix.de/~iceroot/ubuntu/evolution-in-black.png

tags: added: amd64 i386

another info

firefiox/thunderbird are not affected by this
also chromium is not affected after changing the settings to (use default gtk-theme)

[00:58] wxl | anywho click the wrench on chromium
[00:58] wxl | then preferences > personal stuff > appearance > use gtk+ theme

Redwolf (viking.redwolf) wrote :

Yes, the problem should be on lubuntu-artwork affecting GTK3 apps. I have no issues with lxpanel. Weird. Anyway, I'm working on it. Thank you for advertising the bug.

Walter Lapchynski (wxl) wrote :

also there's a theme for firefox that apparently let's you use native
gtk+ theme:
https://addons.mozilla.org/en-US/firefox/addon/gtk-native/
but it was acting strange in the precise version of firefox (11). for
one, i couldn't add it due to compatibility (which i thought was no
longer an issue with v10?) but after editing the install.rdf in the .xpi
to allow it to force compatibility, i found it wasn't really working
right. i'd like to say this helped diagnose this, but i can't. unless
someone else has a different experience.

Redwolf (viking.redwolf) wrote :

Confirmed that a working theme version is showing that black colour. It has no sense. I'm starting to imagine something wrong with Unico engine. This theme works fine in Oneiric Ocelot.

karl anliot (kanliot) wrote :

On Sun, Feb 26, 2012 at 8:28 AM, 神癒礁湖 <email address hidden> wrote:
> Confirmed that a working theme version is showing that black colour. It
> has no sense. I'm starting to imagine something wrong with Unico engine.
> This theme works fine in Oneiric Ocelot.
>
> ** Attachment added: "Captura a 2012-02-26 14:24:14.png"
>   https://bugs.launchpad.net/ubuntu/+source/lubuntu-artwork/+bug/938472/+attachment/2785035/+files/Captura%20a%202012-02-26%2014%3A24%3A14.png
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (930719).
> https://bugs.launchpad.net/bugs/938472
>
> Title:
>  dialogs are barely readable-- grey on black????
>
> Status in “lubuntu-artwork” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  furthermore the buttons themselves only show text if moused over/focused.
>  Lubuntu Precise daily-live 20120221 fresh install on 12" 1.5GHz PowerBook G4 PPC
>  lubuntu-artwork 0.24
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 12.04
>  Package: lubuntu-artwork 0.24
>  ProcVersionSignature: Ubuntu 3.2.0-17.26-powerpc 3.2.6
>  Uname: Linux 3.2.0-17-powerpc ppc
>  ApportVersion: 1.92-0ubuntu1
>  Architecture: powerpc
>  Date: Tue Feb 21 23:43:54 2012
>  InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha powerpc (20120221)
>  PackageArchitecture: all
>  ProcEnviron:
>   TERM=xterm
>   PATH=(custom, no user)
>   LANG=en_US.UTF-8
>   SHELL=/bin/bash
>  SourcePackage: lubuntu-artwork
>  UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/lubuntu-artwork/+bug/938472/+subscriptions

Do a work-around. Even if it's very bad.
My feeling is that unico isn't maintained, or doesn't get bug-fixes.

If someone asks you why you did a terrible work-around. You can tell
them you had no time.

:)

Good luck
kanliot

Erick Brunzell (lbsolost) wrote :

This is still a problem with the 20120228 i386 live image, and also the installed DE. Two apps obviously effected are the Update Manager and Software Sources GUI's.

Too hard to see to try a manual partitioning install.

Greg Faith (gregfaith) wrote :

I had the same issue but I was able to make the install in the amd64 flavor. It is extremely difficult to see the selections. After installation the clearlooks theme seems to work best.

Redwolf (viking.redwolf) wrote :

@karl: Unico is maintained, but it was adapted by Ubuntu, as it's used as the base of Ambiance. Both packages are created by Cimi.

The problem of lubuntu-artwork are both GTK3 and Unico. I'm adapting the theme for the new (changed again) syntax. Somebody should tell Ubuntu devs not to change more things or we shoul never work on standards.

I'll publish the changes as soon as I get some success. My apologies for this annoyance.

Julien Lavergne (gilir) wrote :

@Rafael
At least, if you can have something usable, it's not a problem for the short-term if it's not pretty.
The last commit in lubuntu-artwork branch already contain a workaround for some black background, but it doesn't fix all backgrounds (like, the lsc one which is white, or the banner of the installer, still black).

tags: added: rls-mgr-p-tracking
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.25

---------------
lubuntu-artwork (0.25) precise; urgency=low

  * usr/share/themes/Lubuntu-default:
   - Update with the current unico on precise (LP: #938472)
 -- Julien Lavergne <email address hidden> Wed, 29 Feb 2012 23:27:51 +0100

Changed in lubuntu-artwork (Ubuntu):
status: Confirmed → Fix Released
Redwolf (viking.redwolf) wrote :

I just wanted you all to know that the problem is located at GTK3 libraries. I want to say sorry to Cimi for my post #18 on this bug, without any clue. That wasn't scientific at all. And I'm thank for getting his cooperation with this. So, I hope all together will solve this soon.

Greg Faith (gregfaith) wrote :

Updated my installed Lubuntu precise amd64 and the dark backgrounds are gone
reverted back to lubuntu-default themes and see nice white backgrounds. Will we
get a respin on the beta isos for testing?

Redwolf (viking.redwolf) wrote :

Thanks to the speed of gilir, the respin will be available :)

Phill Whiteside (phillw) wrote :

They are building as you send this. I will be sending an announcement email
out shortly.

skaet was true to their word and is watching over them as they build.

regards,

Phill.

On 1 March 2012 00:53, 神癒礁湖 <email address hidden> wrote:

> Thanks to the speed of gilir, the respin will be available :)
>
> --
> You received this bug notification because you are a member of Lubuntu
> Packages Team, which is subscribed to lubuntu-artwork in Ubuntu.
> https://bugs.launchpad.net/bugs/938472
>
> Title:
> dialogs are barely readable-- grey on black????
>
> Status in “lubuntu-artwork” package in Ubuntu:
> Fix Released
>
> Bug description:
> furthermore the buttons themselves only show text if moused over/focused.
> Lubuntu Precise daily-live 20120221 fresh install on 12" 1.5GHz PowerBook
> G4 PPC
> lubuntu-artwork 0.24
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: lubuntu-artwork 0.24
> ProcVersionSignature: Ubuntu 3.2.0-17.26-powerpc 3.2.6
> Uname: Linux 3.2.0-17-powerpc ppc
> ApportVersion: 1.92-0ubuntu1
> Architecture: powerpc
> Date: Tue Feb 21 23:43:54 2012
> InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha powerpc
> (20120221)
> PackageArchitecture: all
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: lubuntu-artwork
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/lubuntu-artwork/+bug/938472/+subscriptions
>

--
https://wiki.ubuntu.com/phillw

karl anliot (kanliot) wrote :

there's still a problem with abiword. so not 100% yet

I can confirm that abiword is still affected but gedit, nm-applet, nm-connection-manager, evolution are not affected anymore.

I just found abiword which is still affected.

Erick Brunzell (lbsolost) wrote :

I think we should file a new bug report regarding Abiword in Lubuntu. I use Abiword, have for a long time, so I'll make some comparisons between Abiword in Ubuntu and in Lubuntu.

Please feel free to subscribe me to the new bug report and I'll follow up ASAP, but I do have a couple of bigger fish to fry, like coming up with a "non-pae" installation guide, so be a bit patient.

Paul Gorski (pauliegras) wrote :

This bug has been reported as "fixed"? For the 20120301.1 Lubuntu precise-desktop-powerpc.iso the installer screen still comes up as being nearly all black with barely visible type. This on an eMac G4 800 MHz, ATI graphics. I filed a bug report.

ojordan (ojordan12345) wrote :

Yeah, this is unfortunately not fixed. I don't understand why there was no mention of it on the qa tracker - is it fixed for some graphics cards? I have a ati radeon card in my ppc ibook and ubiquity still has a black blackground. PowerPC has the same package numbers as i386 as far as I can tell. I created a duplicate bug 946278 before I found this bug. A slightly different symptom from not already mentioned here is I have yellow window titles when I turn KMS on.

Phill Whiteside (phillw) wrote :

I think the term 'fix released' is not quite correct, but they do not have
'a hurried work around to overcome the massive problem of not being able to
see anything' is not on the list options for bug status. The tracker gets
reset after the beta 1 go out. The full fix will still take a few more days
as it involves a pretty much full re-write of the theme.
Most likely it is not on the current tracker because testers were aware
that we only have a "work around" at present and have not re-issued the bug
to the tracker. For sake of clarity, please feel free to ticket it to the
Dailys tracker. I can assure you, however, that we are fully aware of the
bug & Rafael is working as hard as he can to get the new theme out as soon
as humanly possible.

On 4 March 2012 14:49, ojordan <email address hidden> wrote:

> Yeah, this is unfortunately not fixed. I don't understand why there was
> no mention of it on the qa tracker - is it fixed for some graphics
> cards? I have a ati radeon card in my ppc ibook and ubiquity still has
> a black blackground. PowerPC has the same package numbers as i386 as
> far as I can tell. I created a duplicate bug 946278 before I found this
> bug. A slightly different symptom from not already mentioned here is I
> have yellow window titles when I turn KMS on.
>
> --
> You received this bug notification because you are a member of Lubuntu
> Packages Team, which is subscribed to lubuntu-artwork in Ubuntu.
> https://bugs.launchpad.net/bugs/938472
>
> Title:
> dialogs are barely readable-- grey on black????
>
> Status in “lubuntu-artwork” package in Ubuntu:
> Fix Released
>
> Bug description:
> furthermore the buttons themselves only show text if moused over/focused.
> Lubuntu Precise daily-live 20120221 fresh install on 12" 1.5GHz PowerBook
> G4 PPC
> lubuntu-artwork 0.24
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: lubuntu-artwork 0.24
> ProcVersionSignature: Ubuntu 3.2.0-17.26-powerpc 3.2.6
> Uname: Linux 3.2.0-17-powerpc ppc
> ApportVersion: 1.92-0ubuntu1
> Architecture: powerpc
> Date: Tue Feb 21 23:43:54 2012
> InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha powerpc
> (20120221)
> PackageArchitecture: all
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: lubuntu-artwork
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/lubuntu-artwork/+bug/938472/+subscriptions
>

--
https://wiki.ubuntu.com/phillw

Serhiy Zahoriya (xintx-ua) wrote :

For me it's still not fixed in 12.04.2 with palimpsest (gnome-disk-utility). Deleting unico package doesn't change anything.

Serhiy Zahoriya (xintx-ua) wrote :

Sorry, the Raleigh theme was selected, it's really fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers