package plymouth 0.9.2-3ubuntu2 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 1

Bug #1524480 reported by Roy H Huddleston on 2015-12-09
56
This bug affects 6 people
Affects Status Importance Assigned to Milestone
lubuntu-artwork (Ubuntu)
High
Didier Roche
Xenial
High
Didier Roche

Bug Description

I was upgrading a daily build and this came up.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: plymouth 0.9.2-3ubuntu2
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
Uname: Linux 4.2.0-19-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.3-0ubuntu1
Architecture: amd64
Date: Wed Dec 9 13:11:39 2015
DefaultPlymouth: /usr/share/plymouth/themes/lubuntu-logo/lubuntu-logo.plymouth
DuplicateSignature:
 De-configuring plymouth-theme-lubuntu-logo (0.56) ...
 /var/lib/dpkg/info/plymouth-theme-lubuntu-logo.prerm called with unknown argument `deconfigure'
 dpkg: error processing archive /var/cache/apt/archives/plymouth_0.9.2-3ubuntu2_amd64.deb (--unpack):
  subprocess installed pre-removal script returned error exit status 1
ErrorMessage: subprocess installed pre-removal script returned error exit status 1
InstallationDate: Installed on 2015-11-06 (33 days ago)
InstallationMedia: Lubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151104)
MachineType: ASUS All Series
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-19-generic root=UUID=e8c4b504-b1e0-4007-b278-66478b356aac ro recovery nomodeset
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-19-generic root=UUID=e8c4b504-b1e0-4007-b278-66478b356aac ro recovery nomodeset
RelatedPackageVersions:
 dpkg 1.18.3ubuntu1
 apt 1.1.4
SourcePackage: plymouth
TextPlymouth: /usr/share/plymouth/themes/lubuntu-text/lubuntu-text.plymouth
Title: package plymouth 0.9.2-3ubuntu2 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 1
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/25/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0310
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: B85M-G R2.0
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0310:bd03/25/2014:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnB85M-GR2.0:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: All Series
dmi.product.version: System Version
dmi.sys.vendor: ASUS

Roy H Huddleston (archspader) wrote :
Steve Langasek (vorlon) wrote :

The error in the logs is:

De-configuring plymouth-theme-lubuntu-logo (0.56) ...
/var/lib/dpkg/info/plymouth-theme-lubuntu-logo.prerm called with unknown argument `deconfigure'
dpkg: error processing archive /var/cache/apt/archives/plymouth_0.9.2-3ubuntu2_amd64.deb (--unpack):
 subprocess installed pre-removal script returned error exit status 1

This is a grave bug in the plymouth-theme-lubuntu-logo package.

affects: plymouth (Ubuntu) → lubuntu-artwork (Ubuntu)
Steve Langasek (vorlon) wrote :

fixing this probably requires an SRU, to get a fixed version of plymouth-theme-lubuntu-logo onto the system *before* trying to upgrade to the new version of plymouth in 16.04.

Changed in lubuntu-artwork (Ubuntu):
importance: Undecided → High
status: New → Triaged
tags: removed: need-duplicate-check
Martin Pitt (pitti) wrote :

Alternatively we could drop the "Breaks: plymouth (<< 0.9.2-3ubuntu1~)" from plymouth-theme-lubuntu-logo. The "Replaces:" will still work for upgrades, the only thing that doesn't is a partial downgrade. But we don't care too much about that I think, it's at least way less important than ruining a lot of upgrades if SRUs don't get installed before.

Martin Pitt (pitti) wrote :
Download full text (5.0 KiB)

Discussed on IRC some more. Summary:
 - Dropping the Breaks: from the theme packages and using a versioned Depends: plymouth is semantically equivalent but should avoid the deconfigure (to be confirmed)
 - We should fix all the themes' prerm to accept "deconfigure" to fix future upgrades.
 - The above should avoid having to SRU all themes (as this wouldn't guarantee successful upgrades).

IRC discussion for the record:

08:15:03 pitti | didrocks: do you know, does that only affect lubuntu-logo for some reason, or a gazillion other themes too? I. e. the mutual Breaks:
08:15:16 pitti | mutual Breaks: forces "deconfigure", i. e. I wonder if we can avoid that somehow
08:17:07 didrocks | hey pitti! I'm afraid that's pretty much global, indeed
08:17:38 didrocks | pitti: as most of the themes seems to be copy and paste and they copied a wrong prerm
08:18:08 didrocks | yeah, the Breaks/Replaces is just about the moving files, to ensure we don't end up for partial upgrade with an non working theme
08:18:09 pitti | didrocks: oh, so that's not just plymouth's prerm, but *all* prerms of logo packages?
08:18:34 didrocks | pitti: yeah, plymouth prerm is fine (let me confirm in a minute), it's the ones in the logo packages for sure at least
08:18:42 didrocks | and most of them are copy/paste :/
08:18:47 pitti | didrocks: so instead of SRUing all logo packages and plymouth itseslf, it seems easier to me to just drop the Breaks: of the logo packages in xenial?
08:19:18 didrocks | yeah, that would be slightely incorrect, but there is nothing else anyway that should call deconfigure on those packages
08:19:21 pitti | didrocks: oh, ok, I misinterpreted the log, it's indeed not plymouth itself
08:19:32 pitti | didrocks: right, which is how it got unnoticed for so long
08:19:37 didrocks | we should still fix them in xenial though, so that this doesn't happen in the future
08:19:39 didrocks | well, years :p
08:19:52 didrocks | some packages were untouched since 2010/2011…
08:19:55 pitti | didrocks: curiously I had exactly the same case for ifupdown and udev two days ago (mutual Breaks:, missing deconfigure in udev.prerm)
08:20:22 pitti | didrocks: yes; so my proposal is to fix all the logo packages in xenial with (1) teaching prerm about deconfigure, and (2) dropping the Breaks: to fix upgrades
08:20:27 didrocks | I don't know why people are doing this *) echo "Call with unknown parameter; exit 1
08:20:41 pitti | didrocks: I had that too; I think that was in some standard templates
08:20:55 pitti | but that's a bit overzealous indeed
08:20:59 didrocks | pitti: as most cases are empty anyway, I would suggest we drop that
08:21:01 didrocks | yeah
08:21:22 didrocks | so yeah, we can workaround and avoid the SRU by removing the Breaks
08:21:28 didrocks | (in plymouth)
08:21:36 pitti | didrocks: oh, in plymouth, not in the logo packages?
08:21:45 didrocks | the Breaks in plymouth against logo packages
08:21:46 pitti | didrocks: you should drop it on the side which has the Replaces:, not the other one
08:21:58 didrocks | there is no Replaces
08:22:00 didrocks | just Breaks
08:22:25 didrocks | basically, n...

Read more...

Martin Pitt (pitti) on 2016-01-08
Changed in lubuntu-artwork (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Martin Pitt (pitti) wrote :

Simple/fast reproducer:
- start a wily schroot
- apt install plymouth-theme-lubuntu-logo
- update /etc/apt/sources.list to xenial
- apt update
- apt install plymouth-theme-lubuntu-logo

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.59

---------------
lubuntu-artwork (0.59) xenial; urgency=medium

  * plymouth theme: don't use a Break but a versioned dep to avoid end up
    unconfigured during wily -> xenial upgrade. wily's prerm is broken and
    doesn't handle deconfigure action. (LP: #1524480)
  * Fix maintainer scripts to not be restrictive on arguments passed to them
    for future upgrades.

 -- Didier Roche <email address hidden> Fri, 08 Jan 2016 09:03:24 +0100

Changed in lubuntu-artwork (Ubuntu Xenial):
status: Triaged → Fix Released
Alex Dueppen (adueppen) wrote :

Fix is confirmed in 20160108 daily build

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers