12.04 64bit beta-2 doesnt boot on Lenovo W520

Bug #969276 reported by Hans Bayle on 2012-03-30
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
High
Unassigned

Bug Description

Hi,

I installed 12.04 64bit beta-2 successfully on a Lenovo T420, after that
I tried to install on a Lenovo W520.

This gives problems, a boot with the splash disabled will hang and the
last visible message is:

11.716922 udevd[133]: Starting version 174.

On the same laptop I previously installed 11.10 and Mint 12 without problems.
The same Kubuntu 12.04 64bit beta-2 CDROM was used to succesfully install the system on a Lenovo T420.

To include output from the following commands etc. isn't yet possible at this point in the booting process, but I'm open for suggestions to provide other kinds of info.

regards
Hans

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/969276/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Fabio Marconi (fabiomarconi) wrote :

Hello
Can you run a live session on this pc ?
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ubuntu:
status: New → Incomplete

On 30-3-2012 20:57, Fabio Marconi wrote:
> Hello
> Can you run a live session on this pc ?
> Thanks
> Fabio
> ---
> Ubuntu Bug Squad volunteer triager
> http://wiki.ubuntu.com/BugSquad
>
> ** Changed in: ubuntu
> Status: New => Incomplete
>

What do you mean, a live session by irc on another PC or something like that?

Hans Bayle (hansb-i) wrote :

this laptop has a BIOS setting for the display, you can choose for integrated graphics or for discrete graphics (nVidia Quadro 1000M). When I boot the live CD with integrated graphics, the boot process becomes stable.

integrated graphics will disable all external VGA/DVI ports, so its no very useful for me.

So now I'm reinstalling without 3rd party software and try the discrete graphics settings with the nouveau driver.

Hans Bayle (hansb-i) wrote :

see also:

http://forums.lenovo.com/t5/Linux-Discussion/64-bit-Linux-W520-amp-nVidia/td-p/577789

with discrete graphics & nouveau the boot is also instable, did turn off VT-d in BIOS

Hans Bayle (hansb-i) wrote :

with the nvidia-current 295.33-0ubuntu1 and discrete graphics - the boot is more stable, but now kdm will hang during startup, I won't get a login prompt and/or mouse/keyboard are gone. still have to turn off VT-d to make it stable.

Using BIOS 1.34 / 2011-11-02

Hans Bayle (hansb-i) wrote :

Also for me with 12.04 64bit beta-2 with binary nvidia-current 295.33-0ubuntu1 on a Lenovo W520 with discrete graphics, with the nox2apic kernel option, VT-d can be enabled.

Linux xxx 3.2.0-21-generic #34-Ubuntu SMP Fri Mar 30 04:25:35 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Or else it is unstable / becomes unbootable.

Fabio Marconi (fabiomarconi) wrote :

ok, then this is an installed system.
Have you alredy tried the latest mainline kernel?
http://kernel.ubuntu.com/~kernel-ppa/mainline/
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Hans Bayle (hansb-i) wrote :

Looked at the CHANGES of Linux 3.2.13: no description of a fix for this, will keep an eye on newer versions.

Hans Bayle (hansb-i) wrote :

Linux xxxx 3.2.0-22-generic #35-Ubuntu SMP Tue Apr 3 18:33:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

problem persists.

Fabio Marconi (fabiomarconi) wrote :

Hello Hans
it would be good if you test the 3.4.0 rc 1 or better the last at the end of the column.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Hans Bayle (hansb-i) wrote :

BIOS 1.36, Linux xxxx 3.4.0-rc1-custom #1 SMP Thu Apr 5 23:53:16 CEST 2012 x86_64 x86_64 x86_64 GNU/Linux

Using oldconfig and defaults for the new features.

With VT-d & x2apic enabled, this kernel will also hang during boot on:

11.716922 udevd[133]: Starting version 174.

with the nox2apic kernel option, VT-d can be enabled and it boots into the desktop.

Could not create the nvidia 295.33 kernel module with this kernel, the module build will complain it can't find the kernel configuration.

Will report it on http://bugzilla.kernel.org

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 969276

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Hans Bayle (hansb-i) wrote :

Brad,

Error occurs while booting. Not possible to collect logfiles at that point.
However, I could run apport-collect but the collected info from that state would not reflect the error condition.

Please advise.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
status: Incomplete → Triaged
tags: added: kernel-bug-exists-upstream precise
Joseph Salisbury (jsalisbury) wrote :

Was there a precise kernel version where you were not having this particular problem? This will help determine if the problem you are seeing is the result of the introduction of a regression, and when this regression was introduced.

You report you can install Oneiric, so maybe you can boot some Precise kernels on Oneiric to try and find what version introduced the regression.

tags: added: regression-release
Hans Bayle (hansb-i) wrote :

Every kernel version until now has this particular problem.

https://bugzilla.kernel.org/show_bug.cgi?id=43054

It looks like a classic BIOS bug, however there's not much chance Lenovo will resolve it as long as it has no effect on the stability of Windows.

In the meantime documentation and/or blacklistig x2APIC on Lenovo W520 would be great because out-of-the box it won't boot and lots of naive users will blame it on the distro.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Robert Lewis (rrl125) wrote :

I have been having this issue on other distributions as well since kernel 3.2, and I have tried every release up to 3.6.2. The issue still exists. I have tried the latest bios for the w520 as well (1.39)

Some workarounds include:
1) Use integrated graphics only
2) Use optimus with bumblebee
3) Use 32-bit instead of 64-bit
3) Disable VT-D, but leave VT-X enabled. This still allows for fast VM's, as I do not think there is an implement of VT-D yet. VT-D is PCI pass-through, and should increase speed to some calls, however VirtualBox at this time only supports VT-X.
4)Pass in "intel_iommu=off" as a kernel parameter during boot time.

I was looking around further and some say this is a bios issue with the W520 (W530 too?) where the DMA tables are not exported properly for linux to do PCI pass-through, resulting in a lockup during boot time.

It would nice for the kernel devs to fix this (yes it is an annoying bios workaround, agreed), as this is the most annoying bug I have experienced in a long time. If the table is really not being exported properly, at least show an error and move on instead of locking up.

I was looking further around the net, and saw some documentation here http://www.mjmwired.net/kernel/Documentation/Intel-IOMMU.txt and saw another possible workaround "intel_iommu=igfx_off" as a kernel parameter. I have not tested this yet as I do not have linux installed, but if anyone can try it that would provide more information about the problem. The documentation there says to submit a bug if this fixes a problem in any situations.

Another possible workaround could be to bypass the bios (if it is truely a bios bug) and use UEFI instead. I have not tried this yet.

Sorry for the long text, I figured I would let people know my experiences for over a year now with this annoying bug. For now I workaround with VT-D disabled as nothing uses it anyway. If anyone can confirm if the "intel_iommu=igfx_off" option works during boot with Discrete, 64-bit, VT-X / VT-D enabled we can work on submitting a kernel but as suggested in the documentation.

Ted Kitch (tedkitch) wrote :

I'm using a W520 and the intel_iommu=igfx_off parameter does not work. The intel_iommu=off does work while VT-d is enabled in the BIOS.

I hit the same in the 64 bit version of 12.10. After a fresh install I was unable to boot. Adding nox2apic to the kernel options fixed it.

Hans Bayle, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in a working install from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, in your working install, could you please test the latest upstream kernel available (not the daily folder, but the one all the way at the bottom) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Mnemonic (mnemonic-get2net) wrote :

This is still a problem with Lenovo W520 on Ubuntu 14.04 64 bit.

Please give this bug some attention!

Mnemonic (mnemonic-get2net) wrote :

I will be able to test if it is needed.

Mnemonic, it will help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to your new report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.