Cannot connect to wireless network in 12.04

Bug #929244 reported by Stuart on 2012-02-09
90
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

My wireless network is listed in Network Manager, but upon entering the password it tries to connect and then re-prompts for a password. I can connect fine in Ubuntu 10.10/Fedora 16.

Steps to reproduce:
1. Select wireless network in Network Manager (802.11g with WPA2 in my case)
2. Watch the network icon animate while it tries to connect
3. Dialog box re-prompts for password

My wireless card details:

01:08.0 Network controller: Ralink corp. RT2561/RT61 802.11g PCI
 Subsystem: Linksys WMP54G v4.1
 Flags: bus master, slow devsel, latency 32, IRQ 18
 Memory at dbff8000 (32-bit, non-prefetchable) [size=32K]
 Capabilities: <access denied>
 Kernel driver in use: rt61pci
 Kernel modules: rt61pci

dmesg output immediately after connection failed:

[ 422.332069] wlan0: authenticate with 00:26:f2:05:ad:dc (try 1)
[ 422.334473] wlan0: authenticated
[ 422.348049] wlan0: associate with 00:26:f2:05:ad:dc (try 1)
[ 422.350844] wlan0: deauthenticated from 00:26:f2:05:ad:dc (Reason: 6)
[ 507.012093] wlan0: authenticate with 00:26:f2:05:ad:dc (try 1)
[ 507.015078] wlan0: authenticated
[ 507.017076] wlan0: failed to insert Dummy STA entry for the AP (error -17)

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/929244/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Stuart (aquaglow) on 2012-02-09
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 929244

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise

Since the suggested GUI apport tool requires an Internet connection to function, I ran "apport-cli linux" instead. Here's the output.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-15.24

I have no Internet connection, therefore can't use sudo apt-get update...

Out of curiosity I tested Ubuntu 11.10, and the same issue occurs. So the bug has existed for some months.

tags: added: bot-stop-nagging
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.3-rc2 fixed the issue, the tag would be: 'kernel-fixed-upstream-v3.3-rc2'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc2-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
tags: added: kernel-da-key
Stuart (aquaglow) wrote :

Just tested 3.3-rc2 as suggested, same issue occurs.

In addition to previous errors, after installing I get these messages (with both kernels) when booting up:

Waiting for network configuration...
Waiting up to 60 more seconds for network configuration...

tags: added: kernel-bug-exists-upstream
Stuart (aquaglow) on 2012-02-09
tags: removed: needs-upstream-testing

I have the same problem, but my card is a

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)
 Subsystem: Quanta Microsystems, Inc Device 0308
 Flags: bus master, fast devsel, latency 0, IRQ 16
 I/O ports at 3000 [size=256]
 Memory at b8100000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
 Capabilities: [70] Express Legacy Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Virtual Channel
 Capabilities: [160] Device Serial Number 88-55-22-fe-ff-4c-e0-00
 Kernel driver in use: rtl8192se
 Kernel modules: rtl8192se

normally I run the command "sudo modprobe -r rtl8192se && sudo modprobe rtl8192se" some times to connect to my AP. When it works it will connect in the first try.

The strange thing is that with other AP it always connect correclty. My AP is not using any authentication method, just a mac filter.

I have a second AP that connect to my app. At the beginning I have thinked that the problem is it, but the problem still occurs even after I configured the BSSID and in log only show the correct MAC of my AP.

The problem exists in 11.10, I have upgrade with hope that it has been fixed :(

Stuart (aquaglow) wrote :

Is this issue being investigated? Or should I report the problem upstream to the kernel developers?

Joseph Salisbury (jsalisbury) wrote :

Yes, this issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
RC Lages (rclages) wrote :
Download full text (10.4 KiB)

This bug have in Ubuntu 12.04 LTS beta1 and the log is...

tuxmatrix@USS-StarGazer:~$ tail -f /var/log/syslog
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) starting connection 'RWFCI01'
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0/wireless): access point 'RWFCI01' has security, but secrets are required.
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0/wireless): connection 'RWFCI01' has security, and secrets exist. No new secrets needed.
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Config: added 'ssid' value 'RWFCI01'
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Config: added 'scan_ssid' value '1'
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Config: added 'psk' value '<omitted>'
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Mar 15 12:36:05 USS-StarGazer NetworkManager[929]: <info> Config: set interface ap_scan to 1
Mar 15 12:36:05 USS-StarGazer kernel: [14353.609129] rtl8192c_common: Loading firmwar...

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Stuart (aquaglow) wrote :

No response from the Kernel bug tracker yet - are there any Ubuntu developers available to investigate this issue?

Brad Figg (brad-figg) on 2012-04-11
tags: added: kernel-wifi
Stuart (aquaglow) wrote :

I just tested in the stable release of Ubuntu 12.04 (was hoping a minor kernel update might have fixed it), and the issue still exists.

Ronald Teune (zeekoe) wrote :

Bug seems to affect me too, but I cannot see any networks at all.

zeekoe@zeekoe-d630:~$ sudo iwlist scan
[sudo] password for zeekoe:
wlan2 Interface doesn't support scanning : Device or resource busy

(now I disabled the device by hardware button)

zeekoe@zeekoe-d630:~$ sudo iwlist scan
wlan2 Interface doesn't support scanning : Network is down
zeekoe@zeekoe-d630:~$ sudo ifconfig wlan2 up
zeekoe@zeekoe-d630:~$ sudo iwlist scan
wlan2 No scan results

(and it stays like that. NetworkManager does not see any networks either)

...if that may help.

After that, I tried mainline Linux 3.4.0-030400rc4-generic-pae (as suggested in #989473, I picked pae because I might add some more memory soon), in which my wifi worked flawlessly. However, with that kernel, my laptop did not wake out of its sleep, at least not my monitor (perhaps because of dkms/nvidia issues?). Now I returned to:

zeekoe@zeekoe-d630:~$ uname -r
3.0.0-17-generic

...from oneiric/11.10, in which everything works perfectly.

lspci reports my card as:
0c:00.0 Network controller: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe

I'm not sure what card it actually is (it came with an Eee 901).

Not sure how I can add a tag? But, to repeat, this particular bug was fixed in mainline 3.4.0-030400rc4-generic-pae.

Ronald Teune (zeekoe) wrote :

to add (it seems I can't edit), in 3.0.0-17 lsmod reports this (which works perfectly):

zeekoe@zeekoe-d630:~$ lsmod |grep rt28
rt2800pci 18340 0
rt2800lib 48909 1 rt2800pci
crc_ccitt 12595 1 rt2800lib
rt2x00pci 14202 1 rt2800pci
rt2x00lib 48146 3 rt2800pci,rt2800lib,rt2x00pci
mac80211 393421 3 rt2800lib,rt2x00pci,rt2x00lib
eeprom_93cx6 12653 1 rt2800pci

bug persists with rtl8192se and 12.04 release

(genesis) ➜ ~ uname -r
3.2.0-24-generic-pae

ar (arjenmeijernl) wrote :
Download full text (13.7 KiB)

On my Thinkpad W701 Ubuntu 12.04 64 bits I can trigger this(?) bug by running on batteries. Running on mains is fine.

I do have to restart with power from the grid to solve this problem.

Log when starting on battery power:
19.773370] rtl8192se 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
19.773378] rtl8192se 0000:03:00.0: setting latency timer to 64
19.785134] rtl8192se: rtl8192ce: FW Power Save off (module option)
19.785347] rtl8192se: Driver for Realtek RTL8192SE/RTL8191SE
19.785347] Loading firmware rtlwifi/rtl8192sefw.bin
20.244480] cfg80211: Updating information on frequency 2412 MHz for a 20 MHz width channel with regulatory rule:
20.244485] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244488] cfg80211: Updating information on frequency 2417 MHz for a 20 MHz width channel with regulatory rule:
20.244491] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244494] cfg80211: Updating information on frequency 2422 MHz for a 20 MHz width channel with regulatory rule:
20.244497] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244500] cfg80211: Updating information on frequency 2427 MHz for a 20 MHz width channel with regulatory rule:
20.244503] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244505] cfg80211: Updating information on frequency 2432 MHz for a 20 MHz width channel with regulatory rule:
20.244508] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244511] cfg80211: Updating information on frequency 2437 MHz for a 20 MHz width channel with regulatory rule:
20.244514] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244517] cfg80211: Updating information on frequency 2442 MHz for a 20 MHz width channel with regulatory rule:
20.244520] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244522] cfg80211: Updating information on frequency 2447 MHz for a 20 MHz width channel with regulatory rule:
20.244525] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244528] cfg80211: Updating information on frequency 2452 MHz for a 20 MHz width channel with regulatory rule:
20.244531] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244533] cfg80211: Updating information on frequency 2457 MHz for a 20 MHz width channel with regulatory rule:
20.244537] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244539] cfg80211: Updating information on frequency 2462 MHz for a 20 MHz width channel with regulatory rule:
20.244542] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244545] cfg80211: Updating information on frequency 2467 MHz for a 20 MHz width channel with regulatory rule:
20.244548] cfg80211: 2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244550] cfg80211: Updating information on frequency 2472 MHz for a 20 MHz width channel with regulatory rule:
20.244554] cfg80211: 2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
20.244556] cfg80211: Disabling freq 2484 MHz as custom regd has no rule that fits a 20 MHz wide channel
20.244566] cfg80211: Pendin...

Pavel (pavel-ka) wrote :

Same problem. I see networks, sometimes i can connect! Sometimes can not. If i run few times this script, then i can connect, not every time. But it's better than nothing. Run as root or with sudo:

-------------------------------------------------
ifconfig wlan0 down
rmmod -f rt2800pci
modprobe rt2800pci nohwcrypt=1
ifconfig wlan0 up
------------------------------------------------

options rt2800pci nohwcrypt=1 probably not a special trick.

this bug is fixed by the mainline kernel

"linux-image-3.4.0-030400rc3-generic_3.4.0-030400rc3.201204152235_amd64.deb"

Rovanion (rovanion-luckey) wrote :

Since a working patch has apparently been found and 12.04 is going to be supported for five years I would, without any authority what so ever, recommend backporting it:

http://permalink.gmane.org/gmane.linux.kernel.wireless.general/84095

Title updated because the bug also affects the final version.

summary: - Cannot connect to wireless network in 12.04 Alpha 2
+ Cannot connect to wireless network in 12.04
Leonardo Borda (lborda) wrote :

Same issue on my side:

08:00.0 Network controller: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe
 Subsystem: Ralink corp. Device 2790
 Flags: bus master, fast devsel, latency 0, IRQ 19
 Memory at c8000000 (32-bit, non-prefetchable) [size=64K]
 Capabilities: <access denied>
 Kernel driver in use: rt2800pci
 Kernel modules: rt2800pci

$ uname -ri
3.2.0-31-generic x86_64

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

Stuart, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in 10.10 from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder, but the one all the way at the bottom) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-kernel-logs needs-upstream-testing
removed: kernel-request-3.2.0-15.24
tags: added: regression-release
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Stuart (aquaglow) wrote :

Thanks for getting back to me, but I'm no longer able to test as I switched from Ubuntu to OS X.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.